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Introduction
Welcome to the InDesign cs5 Visual 

QuickStart Guide, my eighth ver-
sion of the book. From its humble start, 
InDesign is now the primary application 
for desktop publishing and page layout. 
I feel very lucky to have been working 
with and teaching InDesign since its 
very fi rst beta. In fact, this is the only 
third-party book that has had editions 
for all versions of InDesign. 

Using This Book

If you have used any of the other Visual 
QuickStart Guides, you will fi nd this book 
to be similar. Each chapter is divided into 
diff erent sections that deal with a specifi c 
topic — usually a set of tools or similar com-
mands. For instance, the chapter on text has 
sections on creating text frames, typing text, 
selecting text, and so on.
Each of the sections contains numbered exer-
cises that show you how to perform a specifi c 
technique. As you work through the steps, 
you gain an under standing of the technique 
or feature. The illustrations help you judge if 
you are following the steps correctly.
I’ve also sprinkled sidebars, printed in gray 
boxes, throughout the chapters. Some of 
these sidebars give you a bit of history or 
background for a specifi c feature. Other 
times, I’ve written out humorous stories 
about desktop publishing. These sidebars are 
the same little stories and anecdotes I tell my 
students in the classes I teach.

Strictly speaking, you don’t have to work 
through the book in the same order as it 
is printed. If you want to learn more about 
imported images, you can skip right over to 
that chapter.
However, the book is organized in the same 
order that I run my InDesign beginner classes. 
We start with the document setup, then move 
to basic text, color, and so on. It’s just as if you 
were sitting in one of my classes. The only 
thing you won’t see is a lunch break.

Instructions

You will fi nd it easier to use this book once 
you understand the terms I am using. This is 
especially impor tant since some other com-
puter books use terms diff erently. Therefore, 
here are the terms I use in the book and 
explanations of what they mean.
Click refers to pressing down and releasing 
the mouse button on the Macintosh, or the 
left mouse button on Windows. You must 
release the mouse button or it is not a click.
Press means to hold down the mouse button, 
or a keyboard key.
Press and drag means to hold the mouse 
button down and then move the mouse. I 
also use the shorthand term drag.
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Menu Commands

InDesign has menu commands that you 
follow to open dialog boxes, change artwork, 
and initiate certain actions. These menu 
commands are listed in bold type. The typical 
direction to choose a menu command might 
be written as Object > Arrange > Bring to 
Front. This means that you should fi rst choose 
the Object menu, then choose the Arrange 
submenu, and then choose the Bring to Front 
command.

Modifier Keys

Modifi er keys are always listed with the 
Macintosh key fi rst and then the Windows key 
second. So the instruction “Hold the Cmd/Ctrl 
key” means hold the Cmd key on the Macin-
tosh platform or the Ctrl key on the Windows 
platform. When the key is the same on both 
computers, such as the Shift key, only one key 
is listed.

Keyboard Shortcuts

You’ll notice that I don’t usually provide 
the keyboard shortcut for commands. For 
instance, I’ll list the menu command for 
File > New, but not the keyboard shortcut 
Cmd/Ctrl-N.
While keyboard shortcuts help you work 
faster, you really don’t have to start using 
them right away. In fact, you will most likely 
learn more about InDesign by using the 
menus. As you look for one command, you 
may see another feature that you would like 
to explore.
So don’t worry about keyboard shortcuts as 
you start. Focus on the big picture.

Video Lessons

After years of creating a print-only book, 
the Visual QuickStart Guide series has gone 
multimedia!

In addition to these printed chapters, I’ve also 
created a series of short videos that will help 
you understand some of the features. For 
instance, instead of just writing out how to 
use a tool, you can watch a video of me using 
that tool in action. It’s a great way to under-
stand some of the more complicated features 
of the program.
And you get the best of both a printed book 
as well as video training! You can fi nd these 
videos at:
www.peachpit.com/indesigncs5vqs.

And Don’t Forget…

Whether you’re learning InDesign in a class 
or on your own, I hope this book helps you 
master the program. 
Just don’t forget to have fun!
Sandee Cohen
(Sandee@vectorbabe.com)
July, 2010

www.peachpit.com/indesigncs5vqs
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One of the reasons why InDesign has 
become so popular is that it uses 

many of the same tools, panels, and 
onscreen elements that are found in 
Adobe Photoshop and Adobe Illustra-
tor. This makes it very easy to use your 
knowlege of those programs to learn 
InDesign. With InDesign cs5, this syn-
ergy between all the programs is even 
stronger than ever before. 

However, with every version of the 
Creative Suite, there are slight changes 
in how to work with the software. This 
chapter should help you pick up some 
power shortcuts in working with the 
interface. 

Finally, this chapter contains a rundown 
of all the panels and tools in the pro-
gram. This is an excellent way to quickly 
familiarize yourself with all the features 
of InDesign. As you read the descrip-
tions of all the panels, you should get 
a better idea of the power of InDesign.
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Choosing Panels

Most of the commands and features that 
control InDesign are found in the onscreen 
panels. Each of the panels covers special 
features. Although they fi rst appear on your 
screen the way Adobe arranges them, we’ll 
tackle them in alphabetical order.

Align panel

The Align panel  A  (Window > Object & 
Layout > Align) aligns and distributes objects 
(see Chapter 4, “Working with Objects”).

Animation panel

The Animation panel  B  (Window > Interac-
tive > Animation) applies animation presets 
to objects (see the online Chapter 18, “Inter-
active & Multimedia”).

Application bar or frame

The Application bar  C  (Window > Application 
bar or Window > Application frame) contains 
controls for the application windows (see 
Chapter 2, “Document Setup”).

Assignments panel

The Assignments panel  D  (Window >
Editorial > Assignments) lets you control 
the editorial revisions of InCopy stories.

Attributes panel

The Attributes panel  E  (Window >
Attributes) allows you to set fi lls and strokes 
to overprint (see Chapter 5, “Working in 
Color”). It also lets you create nonprinting 
objects (see Chapter 19, “Output”).
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 A  Use the  Align panel  to align objects or 
distribute the space between objects.

 C  The  Application bar or frame  contains 
controls for opening Bridge, magnifi cation, 
and the display of windows and workspaces.

 E  The  Attributes panel  lets you set 
the overprinting controls for fi lls and 
strokes or set objects to not print.

 D  The  Assignments panel  lets you 
check stories in and out of an 
InDesign/InCopy workfl ow.

 B  The  Animation panel  lets you 
apply animations to objects.



Book panel

The Book panel  F  (File > New > Book) is 
created by the user and contains documents 
that can be managed using the Book features 
(see Chapter 10, “Pages and Books”).

Bookmarks panel

The Bookmarks panel  G  (Window > 
Interactive > Bookmarks) allows you to 
defi ne pages as bookmarks. These bookmarks 
are then used as navigation aids in PDFPDF docu-
ments (see the online Chapter 18, “Interac-
tive & Multimedia”).

Buttons panel

The Buttons panel  H  (Window > Interac-
tive > Buttons) is where you style and control 
the actions for interactive elements for export 
as PDFPDF or SWFSWF fi les (see the online Chapter 18, 
“Interactive & Multimedia”).

Cell Styles panel

The Cell Styles panel  I  (Window > Styles > 
Cell Styles) allows you to coordinate the 
appearance of cells in tables (see Chapter 13, 
“Tabs and Tables”).

Character panel

The Character panel  J  (Window > Type & 
Tables > Character or Type > Character) 
controls character-level attributes such as the 
typeface and point size (see Chapter 3, “Basic 
Text”).
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 I  The  Cell Styles panel  is used to format 
the appearance of cells in tables.

 J  Use the  Character panel  to format 
the appearance of text characters.

 H  The  Buttons panel  sets the appearance 
and actions for interactive elements.

 G  The  Bookmarks panel  lets you 
create navigation bookmarks that are 
used in Adobe PDF documents.

 F  The  Book panel  is created by the 
user. It synchronizes document styles 
and manages page numbering.



Character Styles panel

The Character Styles panel  A  (Window > 
Styles > Character Styles or Type > Character 
Styles) lets you defi ne and work with charac-
ter styles (see Chapter 14, “Automating Your 
Work”).

Color panel

The Color panel  B  (Window > Color) allows 
you to mix or apply colors (see Chapter 5, 
“Working in Color”).

Conditional Text panel

The Conditonal Text panel  C  (Window > Type 
& Tables > Conditional Text) allows you to 
apply electronic markers that show or hide 
text in a layout (see Chapter 10, “Pages and 
Books”).

Control panel

The Control panel  D  (Window > Control) 
changes its layout depending on the object 
selected on the page. If you are working with 
text, the Control panel shows a combination 
of the Paragraph and Character panels. If you 
are working with objects, the panel shows 
a combination of the Transform and Stroke 
panels. The Control panel is covered in 
Chapters 3, 4, and 13.

Cross-References panel

The Cross-References panel (Window > Type 
& Tables > Cross-References) is actually the 
bottom section of the Hyperlinks panel  E . 
(Both panels are covered in the online Chap-
ter 18, “Interactive & Multimedia.”)
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 B  The  Color panel  is used to mix colors 
to apply to text and objects.

 C  The  Conditional Text panel  is used to 
set certain text to be visible or hidden.

 D  The  Control panel  changes its options 
depending on the selected object. 
(Only a portion is shown here.)

 E  Use the  Cross-References area of the 
Hyperlinks panel  to create and store 
links to other pages in a document.

 A  Use the  Character Styles panel  to automate 
the formatting of text characters.



Data Merge panel

The Data Merge panel  F  (Window > 
Utilities > Data Merge) gives you the controls 
for merging information from databases into 
InDesign documents.

Eff ects panel

The Eff ects panel  G  (Window > Eff ects) 
contains the special opacity, blend mode, and 
other eff ects you can apply to elements in 
the layout (see Chapter 6, “Fills, Strokes, and 
Eff ects”).

Flattener Preview panel

The Flattener Preview panel  H  (Window > 
Output > Flattener Preview) lets you display 
the page as it would look after fl attening has 
been applied during the printing process (see 
Chapter 19, “Output”).

Glyphs panel

The Glyphs panel  I  (Window > Type & 
Tables > Glyphs or Type > Glyphs) lets you 
insert or replace characters from a font (see 
Chapter 3, “Basic Text”). The Glyphs panel 
also helps you work with OpenType features 
(see Chapter 16, “ Typography”).

Gradient panel

The Gradient panel  J  (Window > Color > 
Gradient) lets you defi ne and control the 
appearance of gradients or color blends (see 
Chapter 5, “Working in Color”).
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 F  The  Data Merge panel  lets you integrate 
data from spreadsheets into your layouts.

 G  The  Eff ects panel  lets you apply opacity 
and other eff ects to elements in a layout.

 H  The  Flattener Preview panel  shows how 
eff ects will aff ect objects and images.

 I  The  Glyphs panel  lets you insert 
characters from a font.

 J  The  Gradient panel  lets you 
create color blends.



Hyperlinks panel

The Hyperlinks panel  A  (Window > Interac-
tive > Hyperlinks) is used to create links 
and cross-references that let you easily 
navigate around PDF and HTMLHTML documents 
(see the online Chapter 18, “Interactive & 
Multimedia”).

Index panel

The Index panel  B  (Window > Type & 
Tables > Index) lets you create cross-refer-
enced index entries for a document or book 
(see Chapter 10, “Pages and Books”).

Info panel

The Info panel  C  (Window > Info) gives you 
feedback on the type of object selected, and 
the action taken on that object (see Chapter 4, 
“Working with Objects”).

Kuler panel

The Kuler (pronounced coo-ler) panel  D  
(Window > Extensions > Kuler) is an online 
service that allows you to access color themes 
(see Chapter 5, “Working in Color”).
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 A  Use the  Hyperlinks panel  to create 
and store links to other pages in a 
PDF document or on the Web.

 B  The  Index panel  lets you create 
and manage index entries for 
a document or book. 

 C  The  Info panel  shows the attributes 
of objects. These attributes change 
depending on the object chosen. 

 D  Use the  Kuler panel  to access the online 
service that displays and creates colors.



Layers panel

The Layers panel  E  (Window > Layers) 
controls the stacking order, editability, and 
visibility of diff erent layers (see Chapter 11, 
“Layers”).

Links panel

The Links panel  F  (Window > Links) 
controls the status of placed images (see 
Chapter 8, “Imported Graphics”).

Media panel

The Media panel  G  (Window > Interac-
tive > Media) lets you preview movies, 
animations, and sounds placed in a docu-
ment (see the online Chapter 18, “Interactive 
& Multimedia”).

Mini Bridge panel

The Mini Bridge panel  H  (Window > Exten-
sions > Mini Bridge) lets you work with assets 
such as Adobe Photoshop and Adobe Illustra-
tor fi les and place them onto InDesign pages 
(see Chapter 8, “Imported Graphics”).
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 E  Use the  Layers panel  to add layers 
and change their display.

 F  The  Links panel  displays a list of all the 
imported graphics and text fi les.

 G  The  Media panel  lets you preview and 
control placed movies, sounds, and 
animations. (Only a portion is shown here.)

 H  The  Mini Bridge panel  is a smaller version 
of Adobe Bridge that allows you to place 
images into InDesign documents.



Notes panel

The Notes panel  A  (Window > Edito-
rial > Notes) is used to insert queries and 
comments into text as part of an InDesign/
InCopy workfl ow.

Object States panel

The Object States panel  B  (Window > 
Interactive > Object States) lets you create 
multiple appearances for objects that can be 
displayed as part of a slideshow for PDF or SWF 
fi les (see the online Chapter 18, “Interactive 
& Multimedia”).

Object Styles panel

The Object Styles panel  C  (Window > 
Styles > Object Styles) lets you quickly apply 
complex formatting to text and graphic 
frames (see Chapter 14, “Automating Your 
Work”).

Page Transitions panel

The Page Transitions panel  D  (Window > 
Interactive > Page Transitions) allows you to 
apply the transition eff ects for how one page 
changes to another in PDF and SWFSWF documents  
(see the online Chapter 18, “Interactive & 
Multimedia”).
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 A  Use the Notes panel to insert 
comments into text stories.

 C  The  Object Styles panel  lets you create 
and apply object styles for frames.

 B  The  Object States panel  creates alternate 
views of objects for slide shows.

 D  The  Page Transitions panel  lets you 
change the appearance of how one page 
changes into another in PDF and SWFSWF fi les.



Pages panel

The Pages panel  E  (Window > Pages) lets you 
add and control pages and master pages, as 
well as move from one page to another (see 
Chapter 10, “Pages and Books”).

Paragraph panel

The Paragraph panel  F  (Window > Type & 
Tables > Paragraph) controls paragraph-level 
attributes such as the alignment and margin 
indents (see Chapter 3, “Basic Text”).

Paragraph Styles panel

The Paragraph Styles panel  G  (Window > 
Styles > Paragraph Styles) lets you defi ne 
and apply paragraph styles (see Chapter 14, 
“Automating Your Work”).

Pathfi nder panel

The Pathfi nder panel  H  (Window > Object & 
Layout > Pathfi nder) allows you to apply the 
Pathfi nder and Convert Shape commands 
that change the shapes of objects (see Chap-
ter 4, “Working with Objects”).
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 E  The  Pages panel  lets you add and 
delete pages, apply master pages, 
and move through the document.

 F  The  Paragraph panel  contains all the 
formatting controls for text paragraphs.

 G  The  Paragraph Styles panel  makes it easy 
to apply complex formatting to paragraphs.

 H  The  Pathfi nder panel  allows you to 
easily change the shape of objects.



Prefl ight panel

The Prefl ight panel  A  (Window > Object & 
Layout > Pathfi nder) lets you check to see if 
any items in the document violate the rules 
for how the document should be set up for 
printing (see Chapter 19, “Output”).

Preview panel

The Preview panel  B  (Window > Interac-
tive > Preview) lets you see how movies, but-
tons, and other elements act when exported 
as interactive documents (see the online 
Chapter 18, “Interactive & Multimedia”).

Sample Buttons panel

The Sample Buttons panel  C  (Window > 
Sample Buttons) is a library document, cre-
ated by Adobe, that ships with InDesign. The 
items in the sample buttons library can be 
used to create interactive elements for PDFPDF 
and SWF output (see the online Chapter 18, 
“Interactive & Multimedia”).

Script Label panel

The Script Label panel  D  (Window >
Utilities > Script Label) lets you edit labels 
that are applied to objects as part of scripts.
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 A  The  Prefl ight panel  shows you 
possible printing issues and other 
problems in a document.

 B  The  Preview panel  lets you see 
how the interactive elements in 
a document will respond.

 C  The  Sample Buttons panel  contains 
a library of items that can be used 
for interactive documents.

 D  The  Script Label panel  allows you to edit 
the labels applied to objects in a script.



Scripts panel

The Scripts panel  E  (Window > Utili-
ties > Scripts) displays the scripts that have 
been placed inside the Scripts folder. These 
scripts can be run directly from within 
InDesign (see Chapter 14, “Automating Your 
Work”).

Separations Preview panel

The Separations Preview panel  F  (Window > 
Output > Separations Preview) lets you 
change the display for the color plates in the 
document. This lets you see the individual 
color separations (see Chapter 19, “Output”).

Story panel

The Story panel  G  (Window > Type & Tables > 
Story) lets you change the regular alignment 
of the text to an optical margin alignment 
that adjusts the position of punctuation and 
serifs (see Chapter 14, “Automating Your 
Work”).

Stroke panel

The Stroke panel  H  (Window > Stroke) con-
trols attributes such as stroke width, dashes, 
and end arrows and symbols (see Chapter 6, 
“Fills, Strokes, and Eff ects”).

Swatches panel

The Swatches panel  I  (Window > Color > 
Swatches) stores the colors and gradients 
used in a document (see Chapter 5, “Working 
in Color”).

 I  The  Swatches panel  stores 
colors and gradients.
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 E  The  Scripts panel  allows you to run 
scripts directly within InDesign.

 F  The  Separations Preview panel  lets you 
see the color plates that are in a document.

 G  Use the  Story panel  to control the optical 
margin alignment for hanging punctuation.

 H  The  Stroke panel  controls the appearance 
of rules and lines around objects.



Table panel

The Table panel  A  (Window > Type & 
Tables > Table) contains the formatting 
controls for creating tables within text frames 
(see Chapter 13, “Tabs and Tables”).

Table Styles panel

The Table Styles panel  B  (Window > 
Styles > Table Styles) allows you to easily 
apply and modify the appearance of tables 
(see Chapter 13, “Tabs and Tables”).

Tabs panel

The Tabs panel  C  (Type > Tabs) controls the 
position of the tab stops for text (see Chapter 
13, “Tabs and Tables”).

Tags panel

The Tags panel  D  (Window > Utilities > Tags) 
lets you apply and control XML XML (extensible 
markup language) tags in a document. 
Working with tags is beyond the scope of 
this book. For more information on using 
XML tags, see A Designer’s Guide to Adobe 
InDesign and XMLXML by James J. Maivald and 
Cathy Palmer, published by Adobe Press.

Text Wrap panel

The Text Wrap panel  E  (Window > Text Wrap) 
controls how text wraps around objects and 
placed images (see Chapter 9, “Text Eff ects”).

 A  Use the  Table panel  to format 
tables and table cells.

 B  Use the  Table Styles panel  to 
modify the appearance of tables.

 C  The  Tabs panel  lets you position 
and format tabs within text.

 D  Use the  Tags panel  to control 
tags in a document.

 E  Use the  Text Wrap  panel to control how 
text wraps around objects and images.
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Timing panel

The Timing panel  F  (Window > Interac-
tive > Timing) lets you control how long and 
under what conditions animations occur (see 
Chapter 4, “Working with Objects”).

Tool Hints panel

The Tool Hints panel  G  (Window > Utili-
ties > Tool Hints) provides information on 
how to use the currently selected tool (see 
page 19).

Transform panel

The Transform panel  H  (Window > Object 
& Layout > Transform) lets you see the size 
and position of objects. You can also use the 
Transform panel to apply transformations 
such as scaling and rotation (see Chapter 4, 
“Working with Objects”).

Trap Presets panel

The Trap Presets panel  I  (Window >
Output > Trap Presets) is used to store dif-
ferent settings for how colors are trapped 
between one object and another. Setting 
traps is not covered in this book. Talk to the 
print shop that will output your fi le before 
you attempt to set traps in InDesign.

 H  The  Transform panel  lets you control 
the position and size of objects.

 F  The  Timing panel  controls how 
individual objects are animated.

 G  The  Tool Hints panel  shows how to use 
the tool that is currently selected.

 I  The  Trap Presets panel  lets you store 
and apply trapping settings.
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Working with Panels

If you don’t see a panel onscreen, you can 
open it by choosing the command in the 
Window menu.

To open a panel:

Choose the name of the panel from the 
Window menu or submenu. For instance, 
to open the Character panel go to the 
Window menu, then to the Type & Tables 
listing, and then choose Character from 
the submenu.

To close a panel:

Click the close control in the panel’s title 
bar. The close control for Windows panels 
is on the right of the title bar  A . The close 
control for Macintosh panels is on the left 
of the title bar  B .

You can also minimize a panel so that it only 
displays the panel tab  C . This takes up less 
screen space.

To minimize a panel display:

Click the minimize icon  B  to collapse the 
panel.

TIP Some panels need more than one click to 
minimize the display completely.

TIP If a panel does not contain all its controls, 
click the minimize icon to expand the panel. 
This can also be done by choosing the Show 
Options command from the panel menu.

Panels can also be displayed in an icon view. 
This view takes up less screen real estate.

To collapse a panel to the icon view:

Click the top gray bar of the panel to 
collapse the panel to the icon view  D .

TIP Click the gray bar again to expand the panel 
out of the icon view.

 C  A  minimized panel  .

 D  A  panel in the icon display  .

 E   Drag a panel in the icon view  to the left or 
right to show or hide the name of the panel. 

 B  The  controls  for Macintosh panels.

Close Minimize Collapse to icon

Panel menu

 A  The  controls  for Windows panels.

CloseMinimize

Panel menu

Collapse to icon
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To control the icon view of a panel:

Drag the icon panel to the left to display 
just the icon of the panel  E . Or drag the 
icon panel to the right to display both the 
icon and the name of the panel.

The icon view allows you to open the panel in 
the full panel display.

To reveal the full panel from the icon view:

Click the name or the icon of the panel. 
The full panel appears next to the icon 
panel  F .

TIPTIP Click the icon panel name again, or another 
panel, to retract the full panel display.

Most panels contain a menu with additional 
commands.

To display the panel menus:

1. Click the panel menu icon to open the 
panel menu  G .

2. Choose a command from the menu.

Another way to save screen space is to move 
one panel so that it is located within the 
boundaries of another. This is called nesting.

To nest panels:

1. Position the cursor over the panel tab.
2. Drag the tab so that the outline is inside 

another panel. A rectangular highlight 
inside the panel indicates that the two 
panels will be nested  H .

3. Release the mouse button. The panel 
appears next to the other item.

To unnest panels:

1. Drag the panel tab so that the outline is 
completely outside the other panel.

2. Release the mouse button. The panel 
appears as a separate onscreen item.

 H  Drag the panel tab into another 
panel area to  nest panels .

 F  Click the name of the panel or icon 
to open the  full panel display  .

 G  Click the  panel menu icon  to 
display the menu for a panel.
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Using Workspaces

I don’t know any two InDesign users who 
agree as to how to arrange their panels. 
Although my panels may start out neatly 
arranged, within a short time I’ve got them 
scattered all over my screen — especially if I 
am demonstrating in front of a class.
Fortunately, you can arrange and save your 
panel arrangements into workspaces that you 
can call up at any time.

To save a custom workspace:

1. Arrange your panels as you want them to 
appear on the screen.

2. Choose Window > Workspace > New 
Workspace. The New Workspace dialog 
box appears  A .

3. Enter a name for the workspace.
4. Select the Capture options:

 • Panel locations remembers the 
positions of the panels.

 • Menu Customisation remembers the 
display of menus. (See Chapter 21, 
“Customizing.”)

5. Click OK. The workspace appears 
alphabetically at the top of the Workspace 
menu.

To delete a workspace:

1. Choose Window > Workspace >
Delete Workspace. The Delete Workspace 
dialog box appears  B .

2. Use the pop-up menu to choose the 
workspace you want to delete. Or choose 
All to delete all the custom workspaces.

3. Click the Delete button.

TIP You cannot delete any of the workspaces in 
brackets. These are the workspaces that ship 
with the application.

 A  The  New Workspace dialog box  lets you 
set a custom workspace confi guration.

 B  The  Delete Workspace dialog box  lets you 
choose the workspace you want to delete.
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There is no direct route to edit a workspace, 
but you can modify it.

To modify a workspace:

1. Make the changes in the workspace.
2. Choose Window > Workspace >

New Workspace. The New Workspace 
dialog box appears.

3. Name this new arrangement with the 
same name as the workspace you want to 
modify.

4. When asked if you want to replace the 
original workspace, say Yes.

Once you set up your workspaces, it is a joy to 
apply them as you work.

To apply a workspace:

Choose a workspace from the 
Window > Workspace menu  C . The 
panels fly around into their designated 
spots.

TIPTIP You can also apply workspaces using 
keyboard shortcuts. You can use the Keyboard 
Shortcuts dialog box (Edit > Keyboard 
Shortcuts) to set shortcuts for the first nine 
default workspaces and the first nine custom 
workspaces. (See Chapter 21, “Customizing.”)

If you move items in a workspace, you have 
actually created a new version of that work-
space. To go back to the original setting of the 
workspace, you need to reset the workspace.

To reset a workspace:

Choose Window > Reset [name of 
workspace]. This resets the captured 
elements of the workspace to the way 
they were when you first defined the 
workspace.

Suggestions for Using Workspaces

Workspaces save all the attributes, appearances, 
and positions of the panels. This means that you 
can have a workspace that closes all the panels 
except one or two that you want to use.

You can have workspaces that show just the 
panels that apply colors, gradients, and other 
object attributes. You can have other workspaces 
that show only the panels that you use for text. 
You can even have a workspace that puts all the 
panels on the left for left-handed users.

You can apply workspaces at any time as you 
are working — even with a document open. It’s 
very soothing to see all your panels rearrange 
into orderly groups.

 C  The  Workspace menu  with the custom 
workspaces and default workspaces.

Custom 
workspaces

Default 
workspaces
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Using the Tools Panel

The Tools panel contains the tools for working 
in InDesign, as well as controls for applying 
the colors of fi lls and strokes. Some of the 
tools have fl y-out panels that let you access 
the other tools in the category.

To choose a tool:

Click the tool in the Tools panel  A . Or tap 
one of the keyboard shortcuts for each of 
the tools.

TIP Double-click the title bar on the Tools panel 
to change the Tools panel from single column 
to double column or horizontal column.

Tools and controls in the Tools panel that 
have a small triangle in their slot have other 
tools hidden in a fl y-out panel.

To open the tools in the fl y-out panels:

1. Press the fly-out triangle on the tool slot. 
The fly-out panel appears  B .

2. Choose one of the tools listed in the fly-
out panel.

To see the tool keyboard shortcuts:

Pause the cursor over the tool. The name 
of the tool and the keyboard shortcut 
appear  C .

TIP If you don’t see the tool tip after pausing for 
a moment, make sure the Tool Tips control is 
turned on in the application preferences (see 
Chapter 21, “Customizing”).

TIP You can change or add keyboard shortcuts 
for tools using the keyboard shortcut controls 
(see Chapter 21, “Customizing”).

 

 B  The  fl y-out panel  for the Type tools

 C  Pause over a tool to see its  tool tip .

 A  The  Tools panel  at its default tool display.

Title bar
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Using the Tools Hints Panel

If Tool Tips aren’t enough information on a 
certain tool, use the Tools Hints panel for 
more details without a trip to the Help menu.

 Using the Tool Hints panel:

1. Select a tool in the Tools panel. 
2. Choose Window > Utilities > Tool Hints 

to open the Tool Hints panel  C . The panel 
displays the following:
 • The tool icon and name.
 • A description of the function.
 • Any modifier keys and how they affect 

the tool behavior.
 • The keyboard shortcut that accesses 

the tool.

TIPTIP Move the mouse cursor over the Tool Hints 
panel to highlight the text in the panel. Right-
click to copy the text from the panel. The text 
can be pasted into documents. (But that’s not 
how I wrote this book.) 

 C  Open the  Tool Hints panel  to read 
short descriptions of the functions 
and features of the selected tool.
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Using Contextual Menus

Contextual menus are menus that change 
depending on the type of object selected or 
where the mouse is positioned  A . The benefi t 
is that you don’t have to move all the way up 
to the menu bar to invoke a command.

To display contextual menus:

(Mac and Win) Click the right mouse 
button.
or
(Mac) Hold the Control key and click the 
mouse button.

TIP Watch for the Macintosh contextual menu 
cursor, which appears next to the arrow as 
you press the Control key.

Contextual cursor

 A  The  contextual menu  changes depending 
on what type of object is selected.
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Document Setup
Billions of years ago, when dinosaurs 

ruled the earth — or about 25 
years ago, before the start of desktop 
publishing — people prepared docu-
ments for printing using pieces of stiff  
board. They marked up the boards with 
special blue pencils to indicate the 
edges of the pages. They drew marks 
that specifi ed where the margins and 
columns should be and how the pages 
should be trimmed. This board, called a 
mechanical, was used as the layout for 
the document.

Unlike the board mechanicals of the 
past, InDesign documents are elec-
tronic layouts. Just as with the board 
mechan icals, you need to set the page 
sizes,  margins, and column widths. 
But because you are using a computer 
rather than a pencil, you have addi-
tional controls for how the document is 
laid out.

Of course, changing an electronic layout 
takes far less time than it did with the 
board mechanicals that old dinosaurs 
like me used to use.
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The Welcome Screen

How nice of InDesign to welcome you when 
you fi rst launch the application. Rather than 
just close the Welcome Screen, take a look at 
its features because there are things that may 
be useful.

Using the Welcome Screen:

1. The Welcome Screen automatically 
appears when you first launch InDesign  A .

2. You can click one of the Welcome Screen 
features:
 • To create new documents or open 

sample templates, click one of the 
Create New commands  B .

 • Use the Recent Items area to open 
InDesign documents that you have 
recently opened and saved  C .

 • Click one of the choices in the 
Community area to open a Web 
browser and visit a site where you can 
get more information or support for 
working with InDesign  D .

TIP Click the Don’t Show Again checkbox to keep 
the Welcome Screen from opening.

Most people I know click the Don’t Show 
Again box and never look at the Welcome 
Screen again. However, one day you may 
decide that you would like to investigate the 
Welcome Screen resources. Here’s how to get 
the Welcome Screen back.

To reopen the Welcome Screen:

Choose Help > Welcome Screen. The 
Welcome Screen opens.

 A  The  Welcome Screen  appears 
when you fi rst launch InDesign.

 B  The  Create New  commands 
in the Welcome Screen.

 C  The  Open a Recent Item  lists 
InDesign documents you have 
recently opened and saved.

 D  The  Community area  sends you 
to Web sites where you can get 
more information on InDesign.
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Setting Up Documents

When you create a new document, you have 
the opportunity to set many options in the 
New Document dialog box.

To set the basic options for a new 
document:

1. Choose File > New > Document. This 
opens the New Document dialog box  E .

2. Set each of the document options below 
(For details see “Setting the Layout Options” 
on page 25.):
 • Choose the Intent of Print or Web. 
 • Enter the number of pages in the 

Number of Pages field.
 • Choose at what page number the 

document should start.
 • Check Facing Pages to set your 

document with left-hand and right-
hand pages. 

 • Check Master Text Frame to make 
it easy to flow text onto pages. (See 
Chapter 10, “Pages and Books,” for more 
infor ma tion on master text frames.)

 • Use the Page Size pop-up list to set the 
size of your page. 

 • Set the Orientation to portrait or 
landscape. 

 • Enter the size of the margins in the 
Margins fields. 

 • Set the number of columns and the 
gutter width in the Columns Number 
and Gutter fields. 

3. Click OK. The document appears in the 
window  F .

TIPTIP The pages are sur rounded by an area called 
the pasteboard. Like a drawing table, you 
can set items there for later use. Items on the 
pasteboard do not print.

 E  The  New Document dialog box  
set for the basic layout options.

 F  Each  document page  is surrounded by 
the nonprinting pasteboard area where 
you can store objects for later use.

Pasteboard area Document page
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You can also set the advanced options for a 
document. The fi rst is the area around the 
page, called a bleed. When you set a bleed, 
you defi ne an area outside the trim of the 
page where objects will still print. The second 
area is called a slug. This is an area outside 
the page that may or may not print. Slugs 
are often used by advertising agencies to list 
insertion dates and the name of the product, 
manufacturer, and ad agency.

To set the advanced options for a new 
document:

1. Click the More Options button in the New 
Document dialog box. The advanced 
options for Bleed and Slug dimensions 
appear at the bottom of the dialog box.

2. Set the amounts for the size of the bleed 
area around the document  A . 

3. Set the amounts for the size of the slug 
area around the document. The slug area 
is displayed outside the document trim  B .

TIP Click the Fewer Options button to hide the 
Bleed and Slug dimensions.

TIP Click the Make Same Size icon  C  for the 
Bleed or Slug to automatically set all the 
dimensions to the same size.

 A  Click the More Options button to 
reveal the  Bleed and Slug fi elds. 

 C  The  Make Same Size icon  forces all 
the fi elds to the same amount.

Applied Not applied

 B  A document with  bleed and slug areas .

Document trim

Bleed area

Slug area

You paid for the program. You might as well use it!

The More Options button in the New Document dialog box is just one of many buttons that provide additional 
features for InDesign. There are others all around the dialog boxes.

Once you find one of these buttons, click it!

You’d be surprised at what great features are hidden behind these “secret doors.”

My feeling is that as long as you’ve already paid for the whole program, you might as well get the most out of it!
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 Setting the Layout Options

As you enter your settings in the New Docu-
ment dialog box, you are actually making 
decisions as to the layout of your document.

The Intent menu refers to the fi nal output of 
a document. The choices are Print, for ink on 
paper, or Web, for online output. 

Setting the output intent:

Choose Print or Web from the Intent 
menu. The Web intent changes the units 
of measurement into pixels and changes 
colors in the document from CMYKCMYK to RGB.

Setting the number of pages:

Enter the total number of pages in the 
Number of Pages field. This doesn’t mean 
you can’t add or delete pages later. It just 
saves a step of adding them later on.

Setting the start page:

Use the Start Page # field to enter the 
number at which your document should 
start. For instance, because this chapter 
starts on page 21, I can enter that number 
in the Start Page # field when I select the 
Facing Pages option.

Facing pages refers to documents such as a 
book where pages on one side of its spine 
face the pages on the other side. (This is also 
called a spread.) Single pages, such as adver-
tisements, have facing pages turned off .

To set facing pages:

With the Document Setup dialog box 
open, select the Facing Pages option. This 
changes the document from single page 
to facing pages  D  and  E .

TIPTIP When a document is set for facing pages, 
the names in the dialog box for the Left and 
Right margins change to Inside and Outside 
margins.

 D  The  left and right margins  
on nonfacing pages. 

Left margin Right margin

 E  The  outside and inside 
margins  on facing pages. 

Outside margin Inside margins Outside margin
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The page size is the size of the individual 
pages of the document.

To set the size of the page:

Choose one of the choices from the Page 
Size menu  A :

TIP The A4, A3, A5, and B5 sizes are used primarily 
outside of the United States.

TIP The online sizes 600 x 300, 640 x 460, and so 
on are set in pixel dimensions.

TIP If you change the values in the Width or the 
Height field, the Page Size auto matically 
switches to the Custom setting.

The term orientation refers to how the 
page is positioned, either up and down or 
sideways.

To set the orientation:

Click the Portrait orientation to create a 
document where the width is always less 
than the height  B .
Click the Landscape orientation to create 
a document where the width is always 
greater than the height  B .

To set the margins:

1. Enter an amount for the Top and Bottom 
fields  C .

2. If the document is set for facing pages, 
enter an amount for the Inside and 
Outside fields.
If the document is not set for facing 
pages, enter an amount for the Left and 
Right margins  D .

TIP When you finish typing in one of the fields, 
press the Tab key to jump to the next field.

TIP Click the Make Same Size icon in the Margins 
area to make all the margins the same size. 
When the icon displays a broken link, you can 
enter different sizes for each margin.

 A  The  Page Size menu  off ers standard 
print and online page sizes, as well 
as customization controls.

 C  The margin settings for a 
document with  facing pages .

 D  The margin settings for a document 
with  nonfacing pages .

 B  The  Orientation controls  let you 
set the position of the page.

Portrait Landscape
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You can also set visible guides for columns 
and the gutters (or spaces) between the 
columns.

To set the columns and gutters:

1. Click the field arrows or enter an amount 
for the number of columns  E .

2. Click the field arrows or enter an amount 
for the gutter.

TIPTIP The columns and gutters act as guidelines 
on your page  F . You can still place text or 
graphics across or outside the columns or 
gutters.

TIPTIP InDesign remembers the last new document 
settings and uses it for a new document.

You can also create the default setting for new 
documents. 

To set the document defaults:

1. Close all InDesign documents, leaving just 
the application open.

2. Choose File > Document Setup. The 
Document Setup dialog box appears.

3. Make whatever changes you want to 
the options in the Document Setup 
dialog box.

4. Click OK. The settings you have chosen 
become the default for any new 
documents.

TIPTIP Hold the Opt/Alt key as you open a new 
document to override the previously 
created document and go back to the 
default new document setting.

 E  The  column settings  let you set the 
number of columns and the amount of 
space for the gutter between the columns.

 F  A  two-column document  with margin, 
column, and gutter guidelines.

Margin guide

Column guide

Gutter

Setting Other Defaults

As you work in InDesign, you will discover other 
areas where you would like to set defaults. Per-
haps you’d like certain colors to appear (or not 
appear) in each new document. Or you would 
like certain text options to appear automatically. 

Just as you can set the Document Setup options 
with no document open, you can also set other 
defaults.

With no document open, go to the panels or 
preferences and set the controls to what you 
would like to have as a default. 
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 Changing Layout Options

When you start a new document, all the 
settings appear in one dialog box. However, 
after you begin working on the document 
you must use two separate controls to make 
changes to the document.

To change the document setup:

1. Choose File > Document Setup to open 
the Document Setup dialog box  A .

2. Make whatever changes you want to the 
settings.

3. Click OK to apply the changes.

Although most of the layout options are in 
the Document Setup dialog box, the margins 
and columns are set separately.

To change the margins and columns:

1. Choose Layout > Margins and Columns 
to open the Margins and Columns dialog 
box  B .

2. Make whatever changes you want to the 
following settings:
 • Margins
 • Number of columns
 • Gutter (the width of the space 

between the columns)
3. Check Enable Layout Adjustment to have 

text frames and other objects move as 
the margins change. (See Chapter 14, 
“Automating Your Work” for information on 
the Enable Layout Adjustment command.) 

4. Click OK to apply the changes.

TIP Changing the margins and columns while 
on a page or spread changes the settings 
only for that page or spread. To change the 
settings for all the pages, you need to work 
with the master page. (See Chapter 10, “Pages 
and Books,” for more information on master 
pages.)

 A  The  Document Setup dialog box  
for an existing document.

 B  The  Margins and Columns dialog 
box  for an existing document.
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Using the Document Presets

You may want to save all the settings for 
certain types of documents so they can easily 
be applied when you start new documents. 
For instance, my Visual QuickStart books 
require diff erent settings from the handouts I 
use when teaching. Document presets make 
it easy to apply the diff erent settings when I 
create new documents.
You can also use the Document Presets 
dialog box to create document presets 
without going through the New Document 
dialog box.

To create a new document preset:

1. Choose File > Document 
Presets > Define. This opens the 
Document Presets dialog box  C .

2. Click the New button to open the New 
Document Presets dialog box.

3. Use the dialog box to name and set the 
options for the new preset.

4. Click OK to save the preset.

To delete a document preset:

1. Choose File > Document 
Presets > Define. This opens the 
Document Presets dialog box.

2. Choose the document preset that you 
want to delete.

3. Click the Delete button.

To apply a document preset:

Choose the document preset from the 
Document Preset menu in the New 
Document dialog box  D . 
Or choose File > Document Presets and 
then choose one of the presets listed in 
the menu. This opens the New Document 
dialog box with that preset chosen.

 D  You can apply presets using the 
Document Preset menu  in the 
New Document dialog box.

 C  The  Document Presets dialog 
box  lets you edit, delete, and 
create new document presets.
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To edit a document preset:

1. Choose File > Document 
Presets > Define. This opens the 
Document Presets dialog box.

2. Select the document preset that you want 
to edit.

3. Click the Edit button. This opens the Edit 
Document Preset dialog box  A .

4. Make whatever changes you want. Click 
OK to save the changes in the preset.

TIP You can edit the [Default] present, but you 
can’t delete it.

You can also export document presets into a 
fi le that can be shared with others.

To export document presets:

1. Click the Save button in the Document 
Presets dialog box.

2. Name and save the document preset file.

You can also import document presets from 
others.

To import document presets:

1. Click the Load button in the Document 
Presets dialog box.

2. Navigate to find the document preset file.
3. Click the Open button. The document 

presets are imported into InDesign.

 A  Use the  Edit Document Preset 
dialog box  to make changes to the 
existing document presets.
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Using Document Rulers

Designers need to measure things on pages. 
Rather than hold a ruler up to your monitor, 
you can use InDesign’s electronic rulers.

To show and hide the document rulers:

To see the rulers along the top and left 
edges of the document window, choose 
View > Show Rulers  B .
or
Choose View > Hide Rulers.

You can change the rulers to display diff erent 
units of measurement. This is helpful if you 
receive instructions written in measurements 
with which you are not familiar.

To change the unit of measurement:

1. Choose Edit > Preferences > Units 
& Increments (Win) or InDesign > 
Preferences > Units & Increments (Mac).  
This opens the Preferences Units & 
Increments dialog box.

2. For the Horizontal and Vertical settings, 
choose one of the measurements from 
the pop-up lists  C .

3. If you choose Custom, enter the number 
of points for each unit on the ruler.

TIPTIP You can also change the units with the ruler 
contextual menus  D . 

TIPTIP The Units & Increments preferences also let 
you set your own value for the number of 
points per inch.

 B  The  horizontal and vertical rulers .

Vertical ruler Horizontal ruler

 C  The choices for the ruler’s 
 units of measurement .

 D  The contextual menu choices for the 
ruler’s  units of measurement .
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The rulers start numbering at the top-left 
corner of the page. You may want to move 
this point, called a zero point, to a diff erent 
position. This can help you judge how much 
space you have from one spot of the page to 
another.

To reposition the zero point:

1. Position the cursor over the zero point 
crosshairs at the upper-left corner of the 
rulers  A .

2. Drag the zero point to the new position 
on the page  B .

3. Release the mouse button to position the 
zero point.

TIP Double-click the zero point crosshairs in the 
corner of the rulers to reset the zero point to 
the upper-left corner.

If you are working on a project such as an 
advertising spread, it may be easier to posi-
tion objects if the rulers continue across 
the spine of the pages. (The spine is where 
the pages of a book or magazine are bound 
together.)

To set the origin of the rulers:

1. Choose Edit > Preferences > Units 
& Increments (Win) or InDesign > 
Preferences > Units & Increments (Mac). 

2. Set the Ruler Units Origin menu to one of 
the following:
 • Ruler Per Page sets individual rulers for 

each page.
 • Ruler Per Spread sets one ruler that 

crosses the spine.
 • Ruler Per Spine sets the ruler in 

negative numbers to the left of the 
spine and positive numbers to the right 
of the spine  C .

TIP You can choose the same settings from the 
ruler contextual menu.

 B  You set the ruler’s  zero point  by 
dragging the zero point indicator 
to a new position on the page.

 C  You can control  whether the rulers reset 
for each spine or each page . They can 
also be set to stay across a spread.

Page

Spread

Spine

 A  The  zero point indicator  of the rulers.
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Using the Page Tool

Pages don’t have to be the same size in a 
single document. Once you have created 
a page, you can use the Page tool to make 
that page a diff erent size from the rest of the 
pages in the document. This makes it possible 
to combine the layouts for diff erent sized 
items into a single document.

To change the size of a page:

1. Choose the Page tool from the Tools 
panel D.

2. Click the page or pages that you want 
to customize. Use the Shift key to select 
pages in more than one spread.

3. Use the width and height fields in the 
Control panel to adjust the size of the 
pages or choose a size from the pull-
down menu  E .

4. Check Enable Layout Adjustment to have 
objects rearrange their position as you 
change the size of the page. (See Chapter 
14, “Automating Your Work,” for information 
on the Enable Layout Adjustment 
command.)

5. Check Show Master Page Overlay to see 
the prefix and name of the master applied 
to a page F. (See Chapter 10, “Pages and 
Books,” for how to work with master pages.)

6. Check Objects Move with Page to have 
items on the page move as you rearrange 
pages. (See the next exercise on how to 
move pages in a layout.)

TIPTIP You can also select pages in the Pages panel 
with the Page tool.

 D  The  Page tool  in the Tools panel.

 E  The  Page tool controls  in the Control panel.

 F  The  Master overlay  can be displayed 
when the Page tool selects a page.
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You can also use the Page tool to move pages 
up or down in a spread.

To move pages in a spread:

1. Select the Page tool from the Tools panel.
2. Postion the Page tool over the page you 

want to move and drag up or down.

TIP The vertical area of the pasteboard expands 
as you drag a page beyond the top or bottom 
of the other page  A .

TIP Custom-sized pages appear as different 
sizes on the artboard  B . However, they do 
not appear with the same relationship in the 
Pages panel  C .

 A   Moving a page up or down  
next to another page.

 B  Two diff erent sized pages as they 
appear on the artboard.

 C  Two diff erent sized pages as they 
appear in the Pages panel.
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Working with Guides

Guides are nonprinting lines that help you 
position objects. InDesign has many diff erent 
types of guides that you can work with  D . 

 • Ruler Guides can be positioned 
anywhere on the page or pasteboard.

 • Margin Guides show the settings of 
the margins for the document.

 • Column Guides show the column 
settings for a page or master page.

 • Bleed Guides show the bleed area for 
the document.

 • Slug Guides show the slug area for the 
document.

 • Smart Guides appear as you create 
and move objects around a page. (See 
the next section for working with Smart 
Guides.)

InDesign gives you options for how to work 
with guides.

To change the guide preferences:

1. Choose Edit > Preferences > Guides & 
Pasteboard (Win) or InDesign > 
Preferences > Guides & Pasteboard 
(Mac) to open the Guides & Pasteboard 
Preferences  E .

2. Use each of the menus to set the colors of 
the guides.

3. Check Guides in Back to position the 
guides behind text and graphics on the 
page  F .

4. Enter an amount in the Snap to Zone 
field. This is the distance, in pixels, for how 
close an object must be before it will snap 
or jump to align with a guide.

 E  The dialog box for the  guides preferences .

 F  The  Guides in Back command  changes 
how guides are displayed as they 
pass through text and artwork.

Guides in Back 
turned on

Guides in Back 
turned off

 D  Examples of the various types 
of  guides on a page .

Bleed

Margin

Column

Ruler

Slug
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To show or hide guides:

To see the margin, column, and ruler 
guides, choose View > Grids & Guides > 
Show Guides.
or
To hide the guides, choose View > Grids & 
Guides > Hide Guides.

Objects can be set to automatically snap to 
guides as you move them. This makes it easier 
to align objects to guides.

To make objects snap to guides:

Choose View > Grids & Guides > Snap to 
Guides.

TIP Choose the command again to turn off the 
feature.

There may be times when you want to move 
a column guide manually. This results in a 
custom guide setting.

To unlock and move column guides:

1. If View > Grids & Guides > Lock Column 
Guides is checked, choose the command 
to unlock the column guides.

2. Position the cursor over the guide you 
want to move.

3. Press the mouse button. The cursor turns 
into a two-headed arrow that indicates 
that the column has been selected  A .

4. Drag the column guide to the new 
position.

TIP You cannot change the width of the gutter 
space between the columns by moving a 
column guide. But you can change it in the 
Margins and Columns dialog box.

 A  The  two-headed arrow  
indicates that a column 
guide can be moved.
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Ruler guides are more fl exible than margin 
or column guides and can be positioned 
anywhere on the page to help with object 
placement. 

To create ruler guides:

1. Position the cursor over the horizontal or 
vertical ruler. 

2. Press the mouse button. The cursor turns 
into a two-headed arrow.

3. Drag to pull the guide out onto the 
page  B .

Rather than pulling guides out one at a time, 
you can also create a series of ruler guides in 
rows and columns. 

To create rows and columns using guides:

1. Choose Layout > Create Guides. This 
opens the Create Guides dialog box  C .

2. Enter the number of rows (horizontal 
guides) in the Rows Number field.

3. Enter the amount for the space between 
the rows in the Rows Gutter field.

4. Enter the number of columns (vertical 
guides) in the Columns Number field.

5. Enter the amount for the space between 
the columns in the Columns Gutter field.

6. Choose between Fit Guides to Margins or 
Fit Guides to Page  D .

7. Check Remove Existing Ruler Guides 
to delete all the ruler guides that were 
previously on the page.

8. Click OK to apply the guides.

TIPTIP Check Preview to see the guides on the page 
change as you enter the values within the 
dialog box.

TIPTIP If you set the Number fields to zero for both 
the Rows and Columns, the Remove Existing 
Ruler Guides option deletes all the ruler 
guides on the page.

 C  The  Create Guides dialog box  lets you 
automatically add many guides on a page.

 D  Fit Guides to Margins spaces the guides 
equally inside the page margins. Fit 
Guides to Page spaces the guides 
equally inside the page trim.

Fit to margins

Fit to page

 B  You can  drag ruler guides  out from 
the horizontal ruler or vertical ruler.



38 Chapter 2 Document Setup

To reposition ruler guides:

1. Position the cursor over the guide you 
want to move.

2. Press the mouse button. The cursor turns 
into a two-headed arrow and the guide 
changes color. This indicates that the 
guide has been selected.

3. Drag the ruler guide to a new position.

You can manually move or delete guides.

To move existing ruler guides:

Use either of the Selection tools to drag 
the ruler guide to a new position  A .

To delete selected ruler guides:

1. Click the ruler guide with one of the 
Selection tools.

2. Press the Delete/Backspace key.

You can lock ruler guides so they don’t move.

To lock guides:

Choose View > Grids & Guides > Lock 
Guides.

TIP Choose the command again to unlock the 
guides.

You can change the color of guides and set 
when they are visible.

To change the appearance of ruler guides:

1. Choose Layout > Ruler Guides to open the 
dialog box  B .

2. Use the Color pop-up list to pick the color 
for the ruler guides.

3. Set a percentage for the View Threshold. 
This sets the magnification below which 
the guides are not displayed  C .

TIP Increase the View Threshold if you have many 
guides on the page. This hides the guides at 
low magnifications and shows them at 
higher ones. 

 B  Use the  Ruler Guides dialog box  to change 
the color of the ruler guides. You can also 
set the threshold to determine at what 
magnifi cation the guides are visible.

 A  Use  either of the Selection 
tools  to select a ruler guide.

 C  A view threshold of 200% means 
the guides are visible only when the 
magnifi cation is 200% or higher.

200%

75%
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Using Smart Guides

Ruler guides are static elements that are 
always on the page. Smart Guides are 
dynamic elements that appear and disappear 
depending on what you are doing on the 
page. Smart Guides make it very easy to align 
objects to the center of a page.

To show or hide Smart Guides:

Choose Window > Grids & 
Guides > Smart Guides. This turns the 
Smart Guides on or off.

To align and center to the page using 
Smart Guides:

Drag the object near to where the center 
of the page is. A Smart Guide appears 
when the center of the object or edge of 
the object is centered to the page  D .

Smart Guides also appear when one object is 
near the center or edge of another.

To align and center to an object using 
Smart Guides:

Drag the object near to where the center 
or edge of another object is. A Smart 
Guide appears when the center of the 
object or edge of the object is centered to 
the other object  E .

 Viewing Transformation Values

Transformation Values provide additional 
feedback as to the position and size of 
objects.

To view transformation values:

1. Choose Preferences > Interface.
2. Turn on Show Transformation Values. This 

adds an information label that provides 
the size or position of objects as they are 
moved or created  F .

 D  Two  Smart Guides  appear as an object 
is positioned at the center of a page.

 E  Smart Guides appear when an object is 
near the  edge or center of other objects .

 F  The  Transformation Values  appear when an 
object is created (top) or moved (bottom).
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Working with Document Grids

Ruler guides aren’t the only way to align 
objects. The document grid can also be used 
as a structure for designing pages. The base-
line grid is used to keep lines of text even.

To display the grids:

Choose View > Grids & Guides > Show 
Document Grid  A  or View > Grids & 
Guides > Show Baseline Grid.

To hide the grids:

Choose View > Grids & Guides > Hide 
Document Grid or > Hide Baseline Grid.

To change the grid appearance:

1. Choose Edit > Preferences > Grids (Win) 
or InDesign > Preferences > Grids (Mac) 
to open the preferences dialog box  B . 

2. Use the Color list to change the grid color.
3. Enter an amount in the Horizontal and 

Vertical Gridline Every fields to set the 
distance between the main gridlines.

4. Enter an amount in the Subdivisions field 
to create lighter gridlines between the 
main gridlines.

5. Enter an amount in the Start field to set 
where the baseline grid should start.

6. Use the Relative To list to position the 
start of the grid relative to the top of the 
page or the top margin.

7. Enter a percentage in the View Threshold 
field. This sets the lowest magnification at 
which the grid is visible.

8. Check Grids in Back to position the 
gridlines behind objects on the page.

To turn on Snap to Grid:

Choose View > Grids & Guides > Snap 
to Document Grid. If Snap to Document 
Grid is checked, the feature is already 
turned on.

 A  Choose  Show Document Grid  to see 
the horizontal and vertical gridlines.

 B  The  Grids Preferences dialog box  
lets you control the display and 
arrangement of the document grid.



InDesign CS5 Visual Quickstart Guide 41

Changing the Magnification

Magnifi cation refers to the size of the docu-
ment as it appears on your screen. InDesign 
gives you many ways to change the magni-
fi cation setting. Some of the quickest and 
easiest ways to change the magnifi ca tion 
settings are to use View commands.

TIPTIP A small monitor forces you to use small 
magnifications to see the entire page. 
A larger monitor allows you to set its 
resolution so that it shows the entire page 
at magnifications that are easier to read.

To zoom with the View commands:

1. To increase the magnification, choose 
View > Zoom In. 

2. To decrease the magnification, choose 
View > Zoom Out. 

3. To see all of the current page, choose 
View > Fit Page In Window. This changes 
the magnification setting to whatever 
amount is necessary to see the entire 
page.

4. To see all of the current spread, choose 
View > Fit Spread in Window. 

5. To see the document at 100% 
magnification, choose View > Actual Size.

6. To see the entire pasteboard area, choose 
View > Entire Pasteboard  C .

 C  The  Entire Pasteboard command  shows 
the page as well as the pasteboard.

InDesign’s “Smart” View Commands

If you have not used other page layout pro-
grams, you may not realize how smart some of 
InDesign’s View commands are. These are the 
commands Fit Page in Window, Fit Spread in 
Window, and Entire Pasteboard.

In most other programs, if you choose the Fit 
Page in Window command, the magnification 
changes to show the entire page. If you then 
change the size of the window, the magnifica-
tion is no longer the correct size to show the 
entire page.

InDesign, however, is much smarter. When you 
choose those three View commands, InDesign 
continues to display the entire page, spread, 
or pasteboard even if you resize the window. 
The magnification dynamically changes as you 
change the size of the window.

The command will stay active until you choose 
a new view or manually change the magnifica-
tion. That’s pretty smart!
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InDesign lets you view the page with a wide 
range of magnifi cation settings. You can 
select a specifi c magnifi cation amount from 
the magnifi cation list. 

To use the magnifi cation list:

1. Click the control in the Application bar to 
display the magnification list  A .

2. Choose one of the magnifications in 
the list.

You can also view specifi c magnifi cations not 
in the list.

To enter a specifi c magnifi cation amount:

1. Double-click or drag across the 
magnification shown in the 
Application bar.

2. Type a number between 5 and 4000.

TIP It is not necessary to type the % sign.

3. Press Return or Enter to apply the setting.

 A  The  magni fi ca tion list  in 
the Application bar.

Magnification Shortcuts

Because the View commands are used so often, 
the keyboard shortcuts are listed here. You can 
also find these shortcuts displayed on the View 
menu.

Mac Commands

Zoom In Cmd-=

Zoom Out Cmd-hyphen

Fit Page in Window Cmd-0

Fit Spread in Window  Cmd-Opt-0

Actual Size  Cmd-1

Windows Commands

Zoom In Ctrl-=

Zoom Out Ctrl-hyphen

Fit Page in Window Ctrl-0

Fit Spread in Window  Ctrl-Alt-0

Actual Size  Ctrl-1
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 View and Pasteboard Controls

As you work, you may want to view your 
document in diff erent ways. The fi ve view 
modes provide diff erent ways of looking at 
your document.

To choose the fi ve view modes:

Choose one of the view modes from the 
fly-out panel at the bottom of the Tools 
panel  B .
 • Normal mode is the default view 

and shows you all the guides in the 
document as well as the pasteboard, 
bleed, and slug areas  C .

 • Preview mode shows only the area 
inside the page boundaries. All guides 
are automatically hidden. A gray 
background hides any objects on the 
pasteboard  C .

 • Bleed mode adds the area inside the 
bleed to the Preview Mode  C .

 • Slug mode adds the area inside the 
slug to the Preview Mode  C .

 • Presentation mode is similar to 
the Preview Mode except that the 
background is black. Also, you can use 
keyboard shortcuts to move through 
the document as a slide show  C . (See 
the online Chapter 18, “Interactive & 
Multimedia”.)

TIPTIP The view controls are also in the 
Application bar.

 B  Choose  one of the view modes  to see 
specifi c areas in a Preview Mode.

 C  The diff erent  view modes  of a document.

Slug

Normal

Bleed

Preview

Presentation
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The area above and below the document is 
controlled by the Minimum Vertical Off set. 
You can make that area larger.

To change the Minimum Vertical Off set:

1. Choose Edit > Preferences > Guides &
Pasteboard (Win) or InDesign > 
Preferences > Guides & Pasteboard 
(Mac) to open the Guides & Pasteboard 
Preferences.

2. Enter an amount in the Minimum 
Vertical Offset field  A . This increases the 
pasteboard above and below the page  B .

 A  Use the  Minimum Vertical Off set fi eld  
to increase the size of the pasteboard 
above and below the document.

 B  The eff ects of increasing the size of 
the Minimum Vertical Off set.
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Using the Zoom and Hand 

Tools

The Zoom tool lets you jump to a specific 
magnification and position on the page. The 
Hand tool moves the view to a new position.

To use the Zoom tool:

1. Click the Zoom tool in the Tools panel  C . 
The cursor turns into a magnifying glass.

2. Click the Zoom tool on the area you want 
to zoom in on. Click as many times as is 
necessary to change the magnification.

TIPTIP Press Cmd/Ctrl and Spacebar to access the 
Zoom tool without leaving the tool that is 
currently selected.

TIPTIP Each click of the Zoom tool changes the 
magnification to the next setting in the 
magnification list.

TIPTIP Press the Opt/Alt key while in the Zoom tool 
to decrease magnification. The icon changes 
from a plus sign (+) to a minus sign (–).

TIPTIP Double-click the Zoom tool in the Tools panel 
to set the view to the actual size (100%).

A marquee zoom allows you to zoom quickly 
to a certain magnifi cation and position.

To create a marquee zoom:

Drag the Zoom tool diagonally across the 
area you want to see. Release the mouse 
button to zoom in  D  and  E .

 C  Use the  Zoom tool  to change 
the magnifi cation of the page.

 E  The selected area fi lls the window 
after you release the mouse button.

 D   Drag the Zoom tool diagonally  to 
magnify a specifi c area. The marquee 
indicates the area to be selected.
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You can also use the Hand tool (sometimes 
called the Grabber tool) to move around 
within the area of the document. This is more 
fl exible than using the scrollbars, which only 
go up and down or left and right.

To use the Hand tool:

1. Click the Hand tool in the Tools panel  A .
2. Drag the Hand tool to move around the 

page.

TIP Double-click the Hand tool in the Tools panel 
to fit the entire page in the window.

A power zoom allows you to zoom out, 
move around, and then zoom back in on a 
document.

To create a power zoom:

1. With the Hand tool active, press down 
on the mouse button until you see two 
triangles appear inside the Hand. The 
screen zooms out and displays a red 
rectangle  B .

2. With the mouse button still pressed, 
move the rectangle to a new position in 
the document.

3. Release the mouse button. The view 
snaps back to the original magnification 
before the power zoom.

If you want to become a true InDesign power 
user, you need to use keyboard shortcuts. 
One of the primary shortcuts you should 
learn is how to temporarily access the Hand 
tool without leaving the current tool. 

To temporarily access the Hand tool:

Press the Opt/Alt plus Spacebar keys. This 
gives you the Hand tool in all situations.

TIP You can also access the Hand tool by pressing 
just the Opt/Alt key if you are working in a 
text frame. 

 A  Use the  Hand tool  to move the 
page around the window.

 B  Use a  power zoom  to quickly zoom 
out, navigate around, and then 
zoom back in on a document.

Playing the Keyboard “Bass Notes”

I confess! I haven’t chosen the Zoom or Hand 
tools in years. Rather than move the mouse 
all the way over to the Tools panel, I use the 
keyboard shortcuts.

On the Mac, I keep my fingers lightly resting on 
the Cmd, Opt, and Spacebar keys. By changing 
which keys are pressed, I alternate between the 
Zoom In, Zoom Out, and Hand tools.

On Windows, I do the same thing with the Ctrl, 
Alt, and Spacebar keys.

So, as my right hand moves the mouse around 
and taps other keys on the keyboard, my left 
hand is always playing the three bass notes of 
the keyboard.
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Controlling Windows

The window commands let you view one 
document in two windows and control the 
display of multiple windows.

To see a document in two windows:

Choose Window > Arrange > New 
Window. This creates a second window 
containing the document.

If you have many documents open, you can 
quickly arrange them neatly.

To arrange multiple document windows:

Choose Window > Arrange > Tile. This 
changes the size of the windows and 
positions them so that all the documents 
are visible  C .
or
Choose Window > Arrange > Cascade. 
This stacks all the open windows so that 
their title bars are visible.

In the Macintosh operating system, some of 
the windows for InDesign documents may 
be obscured by other application windows. 
Fortunately there is a command that lets you 
move all the InDesign windows to be seen at 
the front of the screen.

To control the order of documents (Mac):

Choose Window > Arrange > Bring All 
To Front. This moves all the InDesign 
documents to the front of the stacking 
order of all other applications.

 C  Two views of the same document set to  Tile .
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Using the Application bar

Another useful tool for working with docu-
ments is the Application bar.

To work with the Application bar:

On the Macintosh, choose Window > 
Application bar. The Application bar 
appears as one of the panels  A .
or
On Windows the Application bar is always 
visible. The Application bar on Windows 
contains the menus for the application  B .

The best part of the Application bar is that it 
combines many commands and features into 
a single area. Although these features are 
found elsewhere, having them in the Applica-
tion bar makes them more convenient.

To open Adobe Bridge from the 
Application bar:

Click the Bridge icon to go to the Adobe 
Bridge application  C .

To change the magnifi cation from the 
Application bar:

Click the Magnification menu in the 
Application bar  D . 

To change the view options with the 
Application bar:

Click the View Options menu icon to hide 
or display any of the following  E :
 • Frame Edges
 • Rulers
 • Guides
 • Smart Guides
 • Baseline Grid
 • Hidden Characters

 A  The  Application bar for the Macintosh .

 D  The  Magnifi cation fi eld  in 
the Application bar.

 E  The  View Options menu  in 
the Application bar.

 C  The  Bridge icon  in the Application bar.

 B  The  Application bar for Windows .
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To change the view mode from the 
Application bar:

1. Click the Screen Mode menu in the 
Application bar  F . 

2. Choose to display the view mode options 
as described on page 43.

If you have many documents open, your 
screen may get cluttered. You can quickly 
arrange all the open documents using the 
Application bar.

To tile documents using the 
Application bar:

1. Click the Arrange Documents menu in the 
Application bar  G . 

2. Choose one of the tile options as shown 
by the graphic in the menu.

You can also change the workspace via the 
Application bar.

To change the workspace using the 
Application bar:

1. Click the Workspace menu in the 
Application bar  H . 

2. Choose one of the workspaces in the 
menu.

The Application bar also has an online con-
nection to Adobe.com. This makes it easy to 
search for technical documents, support fi les, 
and other information.

To search Adobe.com using the 
Application bar:

1. Enter a search term in the Search field  I . 
2. Press Enter or Return. This opens the 

default browser and takes you to the 
Adobe.com Web site.

 F  The  Screen Mode menu  in 
the Application bar.

 G  The  Arrange Documents menu  
in the Application bar.

 I  The  Search fi eld  in the Application bar.

 H  The  Workspace menu  in 
the Application bar.
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File Maintenance

After you work on a document for even a 
little while, you must save your work to a hard 
drive or disk. This is vital so that you don’t lose 
important information should your computer 
crash in a blackout or you do something 
stupid like pull the power plug.

TIP You have a choice to save files as an InDesign 
document (.indd) or template (.indt). The 
template format saves the file so that each 
time it is opened, it opens as an untitled 
document. This protects the document from 
inadvertent changes.

To save and name a fi le (Win):

1. Choose File > Save or File > Save As. This 
opens the Save As dialog box  A .

2. Use the Save In field to choose a 
destination disk and folder for the file.

3. Use the File Name field to name the file.
4. Use the Save As Type field to choose 

between an InDesign document and an 
InDesign template.

5. Click Save to save the file and close the 
dialog box.

To save and name a fi le (Mac):

1. Choose File > Save or File > Save As. This 
opens the Save As dialog box  B .

2. Use the Macintosh navigational elements 
to choose a destination disk and folder for 
the file.

3. Use the Name field to name the file.
4. Use the Format pop-up list to choose 

between an InDesign document and an 
InDesign template.

5. Click Save to save the file and close the 
dialog box.

 B  The  Save As dialog box  (Mac).

 A  The  Save As dialog box  (Win).
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As you work, you may want to spin off  a copy 
of your document under another name. The 
Save a Copy command makes this easy to do.

To create a copy of a document:

1. Choose File > Save a Copy. This opens the 
Save As dialog box.

2. Use the same steps as described in the 
two previous exercises to save the file.

3. Click Save. The copy of the document is 
saved while you can continue to work on 
your current file.

There may be times when you want to revert 
to the previously saved version of a document 
without saving any changes.

To go back to the saved version of a 
document:

Choose File > Revert. The file closes and 
then reopens to where it was when last 
saved.

To undo the steps you have done:

Choose Edit > Undo [Action].

TIPTIP Repeat this command as often as necessary.

To redo the steps you have done:

Choose Edit > Redo [Action].

To close a document:

Choose File > Close.
or
Click the Close box or button in the 
document window.

The Three Different Save Commands

The first time you look under the File menu you 
may be a little confused by the three different 
commands for saving documents. What are the 
differences between Save, Save As, and Save a 
Copy?

The first time you save an untitled document, 
there is no difference between choosing 
File > Save and File > Save As. Both commands 
bring up the Save As dialog box.

Once you have named a file, the Save command 
adds new work to the file without changing the 
file’s name. The Save As command will always 
open the dialog box where you can change the 
file’s name or location.

I use the Save command almost all the time. 
That way I only have to remember one keystroke 
combination: Cmd/Ctrl-S. The only time I use 
the Save As command is if I want to change the 
name of a document or save it somewhere else.

The File > Save a Copy command is different. 
When you save a copy, you can save the file 
under a new name. However, unlike the Save As 
command, you continue to work on the file you 
were working on.

I use the Save a Copy command when I am about 
to do something strange or bizarre to my work. 
The Save a Copy command lets me create a 
version of the file that I know I can fall back on.
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It happens — someday, somehow your 
computer will crash, a blackout will hit the 
city, or you will be forced to restart the com-
puter without saving your work. Fortunately, 
InDesign has an automatic recovery option 
that can save your work.

To recover a fi le:

1. Restart the computer after the crash or 
data loss.

2. Start InDesign. Any files that were 
open when the crash occurred will be 
automatically opened.

3. Choose File > Save As to save the file with 
a new name and destination.

TITIPP The restored data is a temporary version of 
the file and must be saved in order to ensure 
the integrity of the data.

InDesign gives you options for opening and 
closing fi les.

To open a fi le within InDesign:

1. Choose File > Open.
2. Use the navigation controls to select the 

file you want to open.

TIP You can also open a document by double-
clicking its icon.

To open recently saved documents:

Choose File > Open Recent and then 
choose one of the files listed in the 
submenu.

TITIPP InDesign lists the ten last-opened documents 
in the submenu.

Opening QuarkXPress or 
PageMaker Files

InDesign can convert documents and tem-
plates from QuarkXPress 3.3 or 4.0, and Adobe 
PageMaker 6.5 (or later). Simply choose 
File > Open and choose the file. InDesign 
converts the file into a new InDesign document.

How good is the conversion? It’s great for tem-
plates that consist of the layout without any text. 
All the master pages are converted along with 
the style sheets and colors. This lets you use your 
old templates to produce new work in InDesign.

Graphics that were pasted via the clipboard into 
QuarkXPress or PageMaker — and not placed 
using the Place or Get Picture commands — are 
not converted.

The conversion may change documents with 
lots of text. For instance, InDesign arranges type 
with a very sophisticated composition engine. 
This means that text could move to new lines 
when it appears in the InDesign document.

If you need to make just one or two small 
changes to an old document, you’re better off 
opening the file in QuarkXPress or PageMaker 
and making the changes to the original files.

However, if you need to completely redo a 
document, export the text from the file, and 
then use InDesign to convert the template into 
an InDesign file. You can then use that template 
for all new documents.

What if you need to open QuarkXPress files 
greater than version 5 in InDesign? I suggest you 
investigate the product Q2ID from Markzware. 
It provides a conversion for those versions of 
QuarkXPress files. 
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Basic Text
When I started in advertising, back 

in the late seventies, setting type 
was a complicated process. First, the 
writer typed out the text on paper. The 
art director or typographer then marked 
up the copy with a red (sometimes blue) 
pencil to indicate the typeface, point 
size, leading, and so on.

Then, the copy was sent to a typesetting 
house where a typesetter retyped the 
text into a special typesetting machine. 
The text was printed onto special pho-
tographic paper and sent back the next 
morning. The copywriter then had to 
proof the text to make sure that there 
were no errors.

She might also have to cut some lines of 
text to fi t the layout. Depending on how 
much text had to be cut, the art direc-
tor would use a razor blade to delete the 
text, or the copy would be sent back to 
the typesetter.

That’s why I am amazed every time I use 
a program such as InDesign to set text. 
I don’t type the copy onto a piece of 
paper; I type to fi t right onto my actual 
layout. I don’t have to send the copy out 
overnight; it’s right there on my com-
puter screen. And I know that the only 
mistakes are the ones I make myself!
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Creating Text Frames

InDesign holds text in objects called frames. 
Before you can start typing text, you need to 
create a text frame. The easiest way to do this 
is with the Type tool.

TIP You can resize or reshape text frames like you 
can other objects. (See Chapter 4, “Working 
with Objects,” for more details on creating and 
working with objects.)

To create a text frame with the Type tool:

1. Click the Type tool in the Tools panel  A .
2. Move the cursor to the page. The cursor 

changes to the Type tool cursor  B .
3. Drag diagonally to create the frame  C .

TIP The frame starts from the horizontal line that 
intersects the text frame cursor.

4. Release the mouse button. The text frame 
appears with an insertion point that 
indicates you can type in the frame.

The Type tool will always create rectangular 
frames. However, you can use the frame tools 
to create other geometric shapes such as 
ellipses and polygons to hold text.

TIP The frame tools also let you use numerical 
settings to specify the exact dimensions of 
a frame.

To draw an elliptical frame:

1. Click the Ellipse tool in the Tools panel  D .
2. Drag diagonally to create the ellipse  E .
3. Release the mouse button when the 

ellipse is the correct size.
4. Click the Type tool inside the frame to 

convert it to a text frame.

 A  Choose the  Type tool  in the 
Tools panel to work with text.

 B  The cursor set to create a text frame.

 D  The Ellipse tool in the Tools panel.

 E  Drag diagonally to 
create an ellipse.

 C  Drag diagonally 
with the Type 
tool to create 
a text frame.

Where are the Transformation 
Values Labels?

When you drag to create objects, you will see 
transformation values labels that appear next to 
the cursor (see page 39).

Rather than show them in this chapter, I’ve 
turned the feature off so you can concentrate 
just on the objects being drawn.
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The Polygon tool also lets you draw stars as 
well as ordinary polygons.

To draw a polygon frame:

1. Double-click the Polygon tool in the Tools 
panel  F . This opens the Polygon Settings 
dialog box  G .

2. Enter a number in the field for the 
number of sides.

3. Leave the Star Inset amount as 0%. If you 
increase the star inset, you create a star. 
(See the next exercise.)

4. Drag across the page to create the 
polygon  H .

TIPTIP Press the up or down arrow keys as you drag 
to increase or decrease the number of sides of 
the polygon.

5. Release the mouse button when the 
polygon or star is the correct size.

6. Click the Type tool inside the frame to 
convert it to a text frame.

To create a star frame:

1. Double-click the Polygon tool in the Tools 
panel to open the Polygon Settings dialog 
box  G .

2. Enter a number in the Number of Sides 
field for the number of outer points.

3. Enter a value for the Star Inset amount. 
The greater the amount, the sharper the 
points will be.

4. Drag to create the star  H .

TIPTIP Press the up or down arrow keys as you drag 
to increase or decrease the number of points 
of the star.

TIPTIP Press the left or right arrow keys as you drag 
to increase or decrease the star inset.

5. Release the mouse button when the star 
is the correct size.

6. Click the Type tool inside the frame to 
convert it to a text frame.

 F  The  Polygon tool  in 
the Tools panel.

 G  Use the  Polygon Settings dialog 
box  to change the shape and the 
number of sides of a polygon.

Unassigned Frames

The Ellipse, Polygon, and Rectangle tools create 
frames that are unassigned. This means they 
hold neither text nor graphics. But don’t let the 
unassigned designation mislead you. It doesn’t 
really matter if a frame is unassigned or not.

You can convert unassigned frames to hold text 
or you can convert unassigned frames to hold 
graphics.

 H  Drag diagon-
ally to create 
polygons 
or stars.
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You can also create rectangular frames using 
the Rectangle tool.

To draw a rectangular frame:

1. Click the Rectangle tool in the Tools 
panel  A .

2. Drag diagonally to create the rectangle  B .
3. Release the mouse button when the 

rectangle is the correct size.
4. Click the Type tool inside the frame to 

convert it to a text frame.
The Ellipse tool and the Rectangle tool let you 
numerically specify the frame size.

To set the size of a frame numerically:

1. Choose the Ellipse or Rectangle tool from 
the Tools panel.

2. Position the cursor where you want to 
create the frame.

3. Click. A dialog box appears  C .
4. Set the Width and Height of the frame.
5. Click OK. The frame appears with its 

upper-left point where you first clicked.

TIP Hold the Opt/Alt key as you click to position 
the centerpoint of the frame at that point.

Frames created with the Ellipse, Polygon, and 
Rectangle tools must be converted before 
they can be used as text frames. 

To convert unassigned frames:

1. Select the frame you want to convert.
2. Choose the Type tool and click inside the 

frame.
or
Choose Object > Content > Text. An 
insertion point appears indicating that 
you can begin typing.

 A  The  Rectangle tool  in 
the Tools panel.

Tips for Drawing Frames

There are several keyboard shortcuts you can 
press as you draw frames:

 • Hold the Shift key to constrain the frame 
to a square, circle, or uniform polygon.

 • Hold the Opt/Alt key to draw the frame 
from the center outward.

 • Hold the Spacebar to reposition the 
frame as you draw.

 C  The  Ellipse and Rectangle dialog 
boxes  let you specify the width 
and height of a frame.

 B  Drag diagonally to 
create a rectangle.
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Typing Text

The two most important parts of working 
with text are typing the text and then select-
ing it to make changes.

To type text:

1. Click with the Type tool in a frame.
2. Begin typing.
3. Press Return to begin a new paragraph.

or
Press Shift-Return to begin a new line 
without starting a new paragraph. 
InDesign calls this a Forced Line Break. 
Others call it a soft return.

TIPTIP InDesign automatically wraps text within the 
text frame.

TIPTIP If the text frame is too small to display all the 
text, an overset symbol appears D. You can 
reshape the text frame or flow the text into 
a new frame to convert the overset text into 
visible text.

To add text into a passage you have already 
typed, you move the insertion point to where 
you want to place the new material. The point 
blinks to help you fi nd it  E . 

To move the insertion point:

1. Position the Type tool cursor where you 
want the insertion point.

2. Click to set the insertion point.

To move the point using the keyboard:

1. Use the arrow keys to move the insertion 
point left or right one character at a time 
or up and down one line at a time.

2. Use the Cmd/Ctrl key with the arrow keys 
to move the insertion point one word or 
one paragraph at a time.

 D  The  overset symbol  indicates that there 
is more text than will fi t in the frame.

 E  The  blinking insertion point  indicates 
where text will be added.
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Selecting Text

The simplest way to select text is to use the 
mouse.

To select text using the mouse:

Press and drag across the text. The 
highlight indicates which text is being 
selected.

TIP You don’t have to drag from left to 
right to select multiple lines. Simply 
drag down.

Like other programs, InDesign has special 
techniques to select words, lines, and para-
graphs with the mouse. 

To select a single word:

Double-click within a word to select it  A .

TIP Although only the word is selected, if you hit 
the Delete key, the word and the space after it 
will be deleted.

To select a single line:

Triple-click within the line  B .

TIP Turn on Triple Click to Select a Line in the 
Type preferences.

To select a paragraph:

If Triple Click to Select a Line is turned 
off, triple-click within the paragraph  C .
or
If Triple Click to Select a Line is turned 
on, quadruple-click in the paragraph.

To select all the text in a frame or story:

If Triple Click to Select a Line is turned 
off, quadruple-click within any paragraph.
or
If Triple Click to Select a Line is turned 
on, quintuple-click in any paragraph.

 A   Double-click to select a single 
word , which is then highlighted.

 B  A  triple-click selects a single 
line  in a paragraph.

 C  An example of how a  triple-click or 
quadruple-click can select a paragraph .
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If you spend a lot of time typing and modi-
fying text, you should learn the following 
techniques for selecting text.

To select text using keyboard shortcuts:

1. Use the following keyboard commands to 
select text using the keyboard:

Keystroke Selects

Shift key and tap the 
left or right arrow key 

Single character.

Shift key and tap the 
up or down arrow key

One line of text. Repeat 
to select additional 
lines.

Cmd/Ctrl+Shift keys 
and tap the left or right 
arrow key 

One word and the 
space following it.

Cmd/Ctrl+Shift keys 
and tap the up or down 
arrow key 

Paragraph.

Shift key and tap the 
Home or End key 

All the text to the 
beginning or end of 
a line.

Cmd/Ctrl+Shift keys 
and tap the Home or 
End key 

All the text to the 
beginning or end of a 
text frame or story.

Cmd/Ctrl+A All the text within an 
entire text frame or 
story.

2. Repeat any of the above commands to 
select additional text.

TIPTIP You can switch commands to first select a line 
and then the following word.

TIPTIP You can quickly edit text by double-clicking 
a text frame with either selection tool. This 
switches to the Type tool and places an 
insertion point where you double-clicked.

TIPTIP Press the Escape (esc) key to switch out of the 
text editing mode and then select the frame 
as an object.

Keyboard, Mouse, or Menu?

One of the hot topics in working with software 
is the keyboard- versus-mouse debate. If you are 
a fast typist, you will work faster using keyboard 
shortcuts. There are times when you may con-
sider using a mouse.

If my hands are already on the keyboard, I try 
to keep them there to select text or apply a 
formatting change.

But if my hands are on the mouse, I try to use it. 
So if I’ve just finished moving a text frame to a 
new position, I can easily highlight the text with 
the mouse.

Menu commands are another matter entirely. 
I try whenever possible to learn the keyboard 
shortcuts for menu commands.

That way I don’t have to move the mouse all 
the way up to the top of the page to choose a 
command such as Cut, Copy, or Paste.

Quick Guide to the Shortcuts

Here are some easy ways to understand the 
selection shortcuts:

 • The up, down, left, and right arrow keys 
all jump around the text.

 • Add the Cmd/Ctrl keys to make the 
bigger jumps. Instead of a character, 
you jump a word. Instead of a line, you 
jump a paragraph. (Remember: you have 
more power when you take Command or 
Control!)

 • Adding the Shift key lets you select the 
text. The S in Shift stands for Select.



60 Chapter 3 Basic Text

Moving and Deleting Text

You can copy or move text from one place 
and then paste it into another. Text that 
is copied or cut is stored on the computer 
clipboard. (See the sidebar on this page for an 
explanation of how the  clipboard works.) 

To copy and paste text:

1. Select the text or text frame  A .
2. Choose Edit > Copy or Cut.

TIP If you choose Cut, the highlighted text 
disappears and the remaining text reflows.

3. Position the insertion point where you 
want to put the copied or cut text  B .

4. Choose Edit > Paste. The text is inserted 
into the new position  C .
or
Choose Edit > Paste Without 

Formatting to paste the text so that 
its formatting (point size, typeface, 
style, etc.) matches the text it is being 
pasted into.

TIP The Paste Without Formatting command is 
very helpful if you want the text from one 
place to be pasted into a paragraph that has 
different formatting.

TIP You can select text before pasting to replace 
the selected text with the copied text.

What Is the Computer Clipboard?

The Copy command places the copied objects 
into an area of the computer memory called 
the clipboard. The contents of the clipboard 
stay within the memory until a new copy or cut 
command is executed or until the computer is 
turned off.

The clipboard can hold only one set of informa-
tion at a time. So if you copy one sentence, you 
will lose it from the clipboard if you copy or cut 
something else later on.

 C  The  Paste command  inserts the copied 
or cut text at the insertion point.

 A  Select text in order to copy or cut it 
from one position to another.

 B  Click to put the insertion point where you 
want to insert the copied or cut text.
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You can also use the mouse to drag text from 
one place to another.

TIPTIP Use the Preferences to set the options for 
drag-and-drop text to be active in the Story 
Editor and/or the Layout View. 

To drag text from one place to another:

1. Select the text so that it is highlighted 
within the frame.

2. Position the cursor inside the highlighted 
text. The cursor changes to a curved 
arrow with the letter T next to it  D .

3. Press with the mouse and drag to the new 
position. An insertion point appears at 
the new location  E .

4. Release the mouse to move the text to 
the new position  F .

TIPTIP Hold the Opt/Alt key as you drag text to 
create a copy of the original text in the new 
location.

TIPTIP Hold the Shift key as you drag text to force 
the text to inherit the formatting of the 
destination. This works for text dragged 
within InDesign as well as from external 
applications.

The Duplicate command copies and pastes a 
text frame all in in one step. 

To duplicate text:

1. Select the text or text frame.
2. Choose Edit > Duplicate. The copied text 

is duplicated as follows:
 • A text frame is created slightly offset 

from the original object.
 • Text inside a frame is pasted 

immediately following the original text.

TIPTIP The Duplicate command does not replace the 
contents of the clipboard.

 D  Press on the highlighted text to display 
the  Drag-and-Drop Text cursor .

 E  Drag to display the  destination insertion 
point  for drag-and-drop text.

 F  Release the mouse button to drop 
the text into its new position.
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Using the Character Panel

Character formatting refers to attributes that 
can be applied to a single character or glyph 
in a paragraph without applying that format-
ting to the entire paragraph. The Character 
panel controls character attributes.

TIP As you work with text frames, the Control 
panel changes to display most of the controls 
found in the Character panel. This lets you 
style text using just the Control panel.

To work with the Character panel:

1. If the Character panel is not visible, 
choose Window > Type & Tables > 
Character or Type > Character. This 
opens the Character panel  A .
or
Click the Character panel tab to move it to 
the front of a set of nested panels.

2. Click the panel tab to reveal all the panel 
options.
or
Choose Show Options from the Character 
panel menu  B .

TIP The Character panel menu also contains 
additional controls for formatting text.

 A  The  Character panel  lets you 
change the character attributes.

 B  The  Character panel menu  contains 
additional controls for formatting text.

Setting the Text Defaults

When you first open InDesign, text frames are 
set with the fonts that the Adobe folks thought 
you’d like to work with. You don’t have to live 
with those settings.

Deselect all objects and change the text settings 
to whatever you like. Those settings will become 
the defaults for that document. You can also set 
the defaults for all new documents by changing 
the settings with no document open.
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Setting the Typeface and 

Point Size

The design of type is called the typeface. 
The typeface you are reading now is called 
Myriad Pro SemiCondensed. The typeface of 
the subhead below is called Myriad Pro Bold 
Condensed.

To choose a font (typeface):

1. Choose Type > Font and then choose the 
typeface from the font menu. The font 
menu can be set to preview the typefaces. 
or
In the Character panel, choose a typeface 
from the font menu  C .

2. If necessary, choose the styling for the 
font from the style menu next to the 
name of the font.
or
Use the style list in the Character panel to 
choose the styling  D .

TIPTIP The style list changes depending on the 
typeface and the fonts you have installed. If 
you do not have the bold version of a font, for 
example, it will not be listed.

TIPTIP You can use the keyboard commands to apply 
styling such as regular, bold, italic, and bold 
italic.

The size of type is measured using a system 
called points. There are 72 points per inch. The 
point size of this text is 10.25.

To change the point size:

Choose Type > Size and then choose a 
point size from the list.
or
Use the point size field controls to enter a 
custom point size  E .

 E  The  point size fi eld in the Character 
panel  lets you choose common point 
sizes or enter a specifi c size in the fi eld.

 D  The  style menu in the Character 
panel  lets you choose the proper 
style choices for a typeface.

 C  The  font menu in the Character panel  
lets you choose the typeface for text. 
The style menu next to each font 
name displays the style choices.
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Styling Text

InDesign also lets you apply electronic styling 
such as All Caps, Small Caps, Subscript, and 
Superscript.

To apply electronic styles:

Choose one of the styles listed in the 
Character panel menu  A . The text 
changes to the style chosen  B .
 • All Caps converts lowercase letters to 

all capital letters.
 • Small Caps converts lowercase letters 

to reduced capitals.
 • Superscript reduces and raises the 

text above the baseline.
 • Subscript reduces and lowers the text 

below the baseline.
 • Underline draws a line under the text. 
 • Strikethrough draws a line through 

the text. 
 • Ligatures automatically substitutes 

the combined letterforms for 
characters such as fi and fl  C .

TIP The All Caps style has no effect on text typed 
with the Caps Lock or Shift key held down.

TIP The sizes of the Small Caps, Subscript, 
and Superscript are controlled in the text 
preferences.

Dorothy and TOTO

L. FRANK BAUM

Emerald City®

H20

Cowardly Lion

Tin Woodman

 B  Examples of the electronic 
styles applied to text.

All caps

Small caps

Superscript

Subscript

Underline

Strikethrough

 A  The  electronic style options  in 
the Character panel menu.

 C  Applying the  Ligatures command  to 
the top text replaces specifi c pairs of 
letters with combination letterforms 
such as those on the bottom.
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You can change the appearance of the Under-
line and Strikethrough eff ects.

To customize Underline and Strikethrough 
Options:

1. Select the text.
2. Choose Underline Options or Strike-

through Options from the Character 
panel menu. The Underline Options 
or Strikethrough Options dialog box 
appears  D .

3. Click Underline On or Strikethrough On to 
turn on the effect.

TIPTIP The effect will already be on if it was applied 
in the Character panel menu.

4. Use the Weight controls to set the 
thickness of the line.

5. Use the Offset controls to move the line 
as follows:
 • Positive underline numbers move 

the line below the baseline.
 • Positive strikethrough numbers 

move the line above the baseline.
6. Choose one of the rules from the Type list.
7. Choose a color and tint from the Color 

and Tint lists.
8. If your line type has a gap, such as in a 

dashed line, use the Gap Color and Gap 
Tint lists to color the gap.

9. If desired, check the Overprint Stroke and 
Overprint Gap options. (See Chapter 5, 
“Working in Color,” for more information on 
overprinting colors.)

 D  The  Underline Options and 
Strikethrough Options dialog boxes  
let you customize the appearance of the 
Underline and Strikethrough eff ects.

Underlines as Highlights!

One of the most exciting uses for the custom 
underlines and strikethrough effects is to use 
them as highlights for individual lines or words 
of text. This is something designers have wanted 
to do for years.

All you have to do is set the weight of the line to 
slightly thicker than the text point size. And use 
the offset to position the line around the text. 
You can then apply these custom underlines as 
highlights for text. You can also combine the 
underline and strikethrough lines above and 
below the text  E .

 E  An example of how custom underlines 
and strikethrough settings can be used 
for highlights and other special eff ects.
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Setting Line and Character 

Spacing

Leading is the space between lines of type 
within a paragraph  A . (It is pronounced led-
ding, because it refers to the lead metal for-
merly used to set type.) Leading is specifi ed 
as an absolute point size or as auto leading. 
The leading of this paragraph is 12 points.

To set the leading:

1. Select the paragraph of text.
2. Use the leading controls in the Character 

panel to enter an amount of leading  B .
or
Set the leading to Auto to have the 
leading automatically change to an 
amount based on the point size.

TIP The amount of the auto leading is set in the 
Paragraph panel’s Justification menu.

Kerning is the space between two letters. It is 
applied so letters fi t snugly together  C .

To set kerning:

1. Select the text you want to kern, or place 
an insertion point between the letters.

2. To use the kerning pairs in the typeface, 
choose Metrics from the kerning list  D .
or
Choose Optical to adjust the kerning 
using a visual representation of the text.

TIP Use optical kerning when there are no built-in 
font metrics (for instance, when you combine 
two different typefaces).

3. To apply a specific kerning amount, use 
the kerning controls or pop-up menu to 
apply a numerical amount.

TIP Positive numbers increase the space. 
Negative numbers decrease the space. Zero 
indicates no kerning is applied.

“Well in a few mi

be all melted an

have the castle a
“Well in a few m
be all melted an
have the castle a

l h b A  The 24-point leading (top) has more line 
space than the 16-point leading (bottom).

Avoid
Avoid 
Avoid 

 C  A comparison of the 
diff erent kerning 
settings: 0 (top), 
Metrics (middle), 
Optical (bottom).

 B  The  leading controls in the 
Character panel  let you change the 
amount of space between lines.

 D  The  kerning controls in the 
Character panel  change the 
space between characters.
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Tracking is similar to kerning; however, unlike 
kerning, which applies to letter pairs, tracking 
is applied to a range of letters  E . Tracking is 
very useful, because as you increase the space 
between the letters, you don’t lose the rela-
tive spacing that is applied by kerning.

To set tracking:

1. Select the text you want to track.
2. Use the tracking controls in the Character 

panel to set the amount of tracking  F .

TIPTIP Positive numbers increase the space between 
letters. Negative numbers decrease the space. 
Zero indicates no tracking is applied.

Baseline shift moves text up or down from 
the baseline, or the imaginary line that the 
letters sit on. Baseline shift is often applied to 
shift bullets or parentheses so they sit better 
next to text. It can also be used for special 
eff ects in display or headline text  G .

To set the baseline shift:

1. Select the text that you want to 
reposition.

2. Use the baseline shift controls in the 
Character panel to move the text away 
from the baseline  H .

TIPTIP Positive numbers move the text up. Negative 
numbers move the text down.

The Emerald City
The Emerald City

 E  Tracking of 100 increases the 
space along all the letters.

Wonderful Wizard
 G  A negative baseline shift lowers the capital 

letters from the rest of the characters.

 F  The  tracking controls  in the 
Character panel change the space 
across a sequence of letters.

 H  The  baseline shift controls  in the Character 
panel move text above or below the line.
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Applying Text Distortions

InDesign also lets you apply horizontal or 
vertical scaling to text. This distorts the text 
to increase its height or width  A . This changes 
the type from the original design of the 
characters. Typographic purists (such as this 
author) disdain distorting text. 

To apply horizontal scaling:

1. Select the text that you want to distort.
2. Use the horizontal scale field controls in 

the Character panel to change the width 
of the text  B .

To apply vertical scaling:

1. Select the text that you want to distort.
2. Use the vertical scale field controls in the 

Character panel  C .

Skewing allows you to slant or tilt text  D . This 
is also called false italic because it resembles 
the slant of italic text.

To skew text:

1. Select the text that you want to skew.
2. Enter an angle in the skew field in the 

Character panel to specify how much the 
text should be slanted  E .

TIP Positive numbers to 180 degrees tilt the text 
to the left. Negative numbers to 180 degrees 
tilt the text to the right.

DOROTHY
DOROTHY
DOROTHY
 A  The eff ects of applying either vertical 

scaling or horizontal scaling to text.

Vertical scale

Horizontal scale

Normal

C YCLONE!
 D  You can apply negative and positive 

skew to text to create a special eff ect.

 B  Use the  horizontal scale controls 
in the Character panel  to 
distort the width of text.

 C  The  vertical scale controls in the Character 
panel  let you distort text height.

 E  The  skew controls in the Character panel  
let you create fake oblique and slanted text.
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Setting the Language

You can also set the language. This ensures 
that foreign words as well as your native 
language are spell-checked and hyphen-
ated using the proper dictionary. (Sorry, but 
changing the language doesn’t translate the 
text.)

TIPTIP If you have [No Language] selected, InDesign 
can’t substitute typographer’s quotes (“curly” 
quotes) for the ordinary typewriter quotes 
(“straight” quotes).

To set the language:

1. Select the text that you want to set the 
language for.

2. Choose the language from the pop-up 
menu in the Character panel  F .

Electronic Styling: Myths and Realities

As you set type using programs such as InDesign, people may tell you never to style fonts electronically. So if 
you use the Roman version of a font (such as Minion), you should never press the  keyboard shortcut for italic. 
You should only choose the actual typeface (Minion Italic) from the font menu.

This rule emerged because some typefaces do not have an italic or bold version. The styling shows on the 
screen, but it doesn’t print. Techno or Zapf Dingbats are examples of fonts that shouldn’t be styled electroni-
cally. When people see their printed samples, they’re disappointed that there is no bold or italic appearance.

Fortunately, InDesign prevents you from making errors like that. If you apply the shortcut for italic, InDesign 
applies the actual italic version. If there is no version, InDesign does not change the font. So there is no harm 
styling electronically using InDesign.

I’ve also heard people advise to avoid all caps, subscript, small caps, and other electronic styles on type. 
In most cases, there is nothing wrong with applying those styles, and InDesign allows you to apply those 
electronic styles to text.

In some cases you’ll have better results with a small-caps version of a font than with the electronic style for 
small caps. However, a special small-caps font offers a subtle effect that few people will recognize. 

I personally hate the electronic styling for Vertical and Horizontal Scale. They distort the type horribly. The 
Skew command is even worse! However, I do accept that there might be times (grotesque Halloween cards?) 
where those distortions are acceptable.

 F  The  Language menu  lets you set the 
language used for spelling checks as 
well as for typographer’s quotes.
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Applying Paragraph 

Formatting

Paragraph formatting refers to the attributes 
that are applied to the paragraph as a whole. 
For instance, you cannot have half of the 
paragraph centered and the other half on the 
left side of the page. The alignment must be 
applied to the whole paragraph. InDesign 
paragraph formatting is applied using the 
Paragraph panel.

TIP As you work with text frames, the Control 
panel changes to display many of the text 
controls found in the Paragraph panel. This 
makes it possible to style text using just the 
Control panel. 

To work with the Paragraph panel:

1. If the Paragraph panel is not visible, 
choose Window > Type & Tables > 
Paragraph or Type > Paragraph. This 
opens the Paragraph panel  A .
or
Click the Paragraph panel tab to move it 
to the front of a set of tabbed panels.

2. To display all the paragraph formatting 
controls, choose Show Options from the 
Paragraph panel pop-up menu.

TIP The Paragraph panel menu also contains 
additional controls for formatting text  B . 

TIP The following techniques are useful when 
applying paragraph attributes:

 • To apply attributes to a single para graph, 
click to place an insertion point within the 
paragraph.

 • To apply attributes to more than one 
paragraph, select a portion of the first and 
last paragraphs and the paragraphs in 
between.

 A  The  Paragraph panel  controls attributes 
that are applied to the whole paragraph.

 B  The  Paragraph panel menu  contains 
additional controls for paragraph attributes.



InDesign CS5 Visual Quickstart Guide 71

Setting Alignment and Indents

In addition to the common paragraph align-
ment controls found in page layout or word 
processing programs, InDesign off ers some 
special controls for setting alignment.

To set paragraph alignment:

1. Select the paragraphs.
2. Click one of the Alignment buttons  C  to 

set the alignment as follows:

Alignment Icon Example Description

Flush Left

I have been wicked in my day but I never 
thought a little girl like you would be 
able to melt me. Sets the text to align at the left margin.

Centered

I have been wicked in my day but I never 
thought a little girl like you would be 

able to melt me.

Sets the text to align at the center of the para-
graph.

Flush Right

I have been wicked in my day but I never 
thought a little girl like you would be 

able to melt me. Sets the text to align at the right margin.

Justifi ed Last Left

I have been wicked in my day but I never 
thought a little girl like you would be able 
to melt me.

Sets the text to align at both the left and right 
margins, but aligns the last line fl ush left.

Justifi ed Last 
Centered

I have been wicked in my day but I never 
thought a little girl like you would be able 

to melt me.

Sets the text to align at both the left and right 
margins, but centers the last line.

Justifi ed Last 
Right

I have been wicked in my day but I never 
thought a little girl like you would be able 

to melt me.

Sets the text to align at both the left and right 
margins, but aligns the last line fl ush right.

Justifi ed All

I have been wicked in my day but 
I never thought a little girl like 
you would be able to melt me.

Sets the text to align at both the left and right 
margins.

Align Towards 
Spine

I have been wicked in my day but I never 
thought a little girl like you would be 
able to melt me.

Sets the text to align along the spine of the docu-
ment. This fl ips the alignment on recto and verso 
pages.

Align Away From 
Spine

I have been wicked in my day but I never 
thought a little girl like you would be 

able to melt me.

Sets the text to align toward the outside edge of 
the pages. This fl ips the alignment on recto and 
verso pages.

TIPTIP Look closely and you’ll see that the lines in 
the alignment buttons resemble how the 
alignment changes the position of the text.

 C  The  Alignment buttons  on the 
Paragraph panel control how the type 
is aligned to the frame edges.
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You might want to indent a paragraph so that 
it stands from the rest of the text. 

To set the margin indents:

1. Select the paragraphs.
2. Use the margin indent controls  A  to move 

the text as follows  B :
 • Left Indent moves the left side of the 

para graph away from the left side of 
the text frame.

 • First Line Left Indent moves the first 
line of the paragraph away from the 
left edge of the rest of the paragraph.

 • Right Indent moves the right side of 
the para graph away from the right side 
of the text frame.

 • Last Line Right Indent moves the 
last line of the paragraph away from 
the right side of the text frame.

Ahang indent sets elements on the fi rst line 
outside the rest of the paragraph  C .

TIP You can use these steps to create bulleted 
and numbered paragraphs. Or you can 
create those automatically (as covered in 
Chapter 14).

To create a hanging bullet or 
numbered list:

1. Select the paragraphs.
2. Set the Left indent to the amount that 

the body of the paragraph should be 
indented.

3. Set the First Line indent to a negative 
amount.

4. Insert a tab character to separate the 
bullet or number from the rest of the line.

TIP The order of these steps is important because 
the First Line indent can’t have a negative 
amount until the Left indent has been 
created.

Well in a few minutes I shall be all 
melted and you shall have the castle 
all to yourself. I have been wicked in 
my day but I never thought a little 
girl like you would be able to melt 
me and end my life. 

 B  The eff ect of applying margin indents 
to text inside a text frame.

First line indent

Left indent

Right indent

• Take balloon out of storage and 
inflate.

• Wind clock and set the correct 
time.

 C  The  margin indent settings for a 
hanging bullet . Notice that the First 
Line indent has a negative value.

Left indent (1p6)

First line indent (-1p6)

 A  The  margin indent fi elds  control 
the space around a paragraph 
and the fi rst and last lines.

Right IndentLeft Indent
First Line Left 
Indent

Last Line 
Right Indent
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Inserting a Manual Indent

The Indent to Here character allows you to set 
an indent command that is tied to the posi-
tion of the character.

TIPTIP The Indent to Here character makes it easy 
to set a hanging indent for a drop cap or 
bulleted list.

To use the Indent to Here character:

1. Click inside a text frame where you would 
like the indent to occur.

TIPTIP The insertion point is placed not in the lines 
that you want to indent, but inside the line 
that serves as the model. This is usually the 
first line of text.

2. Type Cmd/Ctrl-\ (backslash).
or
Choose Type > Insert Special Character > 
Other > Indent to Here. This inserts a 
character that creates an indent at that 
point  D .

TIPTIP The Indent to Here character is indicated 
by a cross symbol when the Show Hidden 
Characters command is chosen.

To remove the Indent to Here character:

1. Place the insertion point to the right of 
the Indent to Here character.

2. Press the Delete/Backspace key. 

The Pros and Cons of Using
the Indent to Here Character

When should you use the Indent to Here charac-
ter? When should you use the paragraph margin 
indents?

The Indent to Here character is an excellent 
solution for setting off a drop cap. Because it is 
not set by a measurement, it doesn’t need to be 
adjusted if you change the drop cap letter from a 
wide letter such as M to a thin one such as I or J.

However, the Indent to Here character is not 
a good solution for long documents with out-
dented characters. Margin indents applied to 
style sheets are more useful for those situations. 
For instance, all the numbered lists, bulleted 
lists, and tip characters in this book have been 
formatted using margin indents — not the 
Indent to Here character.

 D  The  Indent to Here character  is indicated 
by the small dagger symbol. It automatically 
creates a hanging indent for the drop cap.
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Setting Paragraph Effects

The paragraph effects are available when 
Show Options is chosen in the Paragraph 
panel menu. One of the paragraph effects is 
to add space above and below a paragraph  A . 
For instance, the space between this para-
graph and the one following is controlled by 
adding space below.

To add space between paragraphs:

1. Select the paragraphs that you want to 
add space above or below.

2. Use the Space Before field controls to add 
space before the paragraphs  B .

3. Use the Space After field controls to add 
space after the paragraphs  B .

TIP Never insert paragraph returns to add 
space between paragraphs. That can cause 
problems later if text reflows!

Drop caps increase the size of the fi rst char-
acter or characters and positions them so 
that they drop down into the rest of the para-
graph  C . The opening page for each chapter 
of this book contains a paragraph that has a 
drop cap applied.

To create drop caps:

1. Select the paragraph you want to set with 
a drop cap.

2. Use the Drop Cap Number of Lines field 
to set the number of lines that the letter 
should occupy  D .

3. Use the Drop Cap Number of Characters 
field to set how many characters of the 
text should have the drop cap applied  D .

Dorothy lived in the midst of 
the great Kansas prairies, 
with Uncle Henry, who was a 

farmer, and Aunt Em, who was the 
farmer’s wife.
 C  An example of a  drop cap  set for 

one character and three lines.

“At the East, not far from here,” said one, 
“there is a great desert, and none could 
live to cross it.”

“It is the same at the South,” said another, 
“for I have been there and seen it. The 
South is the country of the Quadlings.”

“I am told,” said the third man, “that it is the 
same at the West and that country, where 
the Winkies live, is ruled by the Wicked 
Witch of the West, who would make you 
her slave if you passed her way.”

 A  An example of  adding space 
between paragraphs .

Paragraph space

 B   Use the  Paragraph Space controls  to 
add space before or after a paragraph.

Space afterSpace before

 D  Use the Drop Cap controls to change the 
appearance of a paragraph drop cap.

Number of CharactersNumber of Lines
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The Control panel contains only the basic 
options for drop caps. There are additional 
controls for refi ning the appearance of drop 
cap characters.

 To set the additional drop cap attributes:

1. Choose Drop Caps and Nested Styles from 
the Control panel menu or the Paragraph 
panel menu. This opens the Drop Caps 
and Nested Styles dialog box  E . 

2. Check the Align Left Edge option to force 
the drop cap character to align flush to 
the left side of the paragraph  F .

3. Check the Scale for Descenders option to 
reduce the size of the drop cap letters to 
keep character descenders from touching 
lines of text  G .

4. Use the Character Style menu to apply 
a different typeface or other character 
attribute to the drop cap. (See Chapter 15, 
“Styles,” for information on how to create a 
character style.)

You can also control whether the text within a 
paragraph is hyphenated or not.

To turn on hyphenation:

1. Select the paragraphs you want to set the 
hyphenation for.

2. To turn on hyphenation, click the 
Hyphenate checkbox in the Paragraph 
panel  H  . Depending on what words are 
hyphenated, the text may reflow. (See 
Chapter 16, “Typography,” for information 
on controlling the number of hyphens in a 
paragraph.)

 E  The  Drop Caps and Nested Styles 
dialog box  allows you to refi ne 
the settings for drop caps.

F  An example of how  Align Left Edge 
forces the drop cap character to 
align to the left margin edge.

 G  An example of how  Scale for 
Descenders  changes the size of the 
drop cap so that descenders don’t 
touch the other lines of text.

 H  Use the  Hyphenate checkbox  to 
hyphenate words at the ends of lines.
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Working with Hidden 

Characters

Every time you tap the Spacebar, Tab key, 
Return key, or Enter key, you create a non-
printing character in the text. These hidden 
characters (sometimes called invisibles) can 
be turned on to let you see where the spaces, 
tab characters, and paragraph returns fall in 
the text.

To show or hide hidden characters:

Choose Type > Show Hidden 

Characters. This displays the characters 
in the same color as the highlight for the 
layer  A .
or
Choose Type > Hide Hidden 

Characters to hide the hidden 
characters.

TIP Hidden characters are also hidden when 
you turn on the Preview mode or Overprint 
Preview.

TIP You can change the color of the hidden 
characters by changing the color of the Layer 
in the Layers panel.

The following is a chart of the various hidden 
characters.

Tab Right Indent Tab Indent To Here End Nested Style

Non-joiner Em Space En Space Anchored Object

Nonbreaking Space
Nonbreaking Space 
(Fixed Width)

Hair Space Sixth Space

Thin Space Quarter Space Third Space Punctuation Space

Figure Space Flush Space Column Break Frame Break

Page Break Odd Page Break Even Page Break Paragraph Return

Forced Line Break Discretionary Line Break End Of Story

 A  An  assortment of the hidden 
characters  displayed within text.

Tab Space

New line

End of paragraph

End of story
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Using the Glyphs Panel

Quick — what’s the keystroke for a trademark 
character? The Euro or Japanese Yen charac-
ters? The pointing hand in Zapf Dingbats? If 
you can’t remember the keystrokes for all the 
characters you use, then you need to open 
the Glyphs panel. The Glyphs panel lets you 
easily see all the characters in a typeface. You 
can also use the panel to display the alternate 
letterforms in OpenType fonts.

To insert characters: 

1. Place the insertion point where you 
would like the character to be inserted.

2. Choose Type > Glyphs. This opens the 
Glyphs panel  B .

3. Choose the typeface and style of the 
character you want to insert.

4. Scroll through the Preview area to find 
the character you want to insert.

TIPTIP Use the Preview Size controls to increase or 
decrease the size of the preview.

5. Double-click the character you want to 
insert.

6. Repeat step 5 to insert any additional 
characters.

TIPTIP The Glyphs panel allows you to insert 
characters that are not usually available 
for certain operating systems. For instance, 
Macintosh users can insert fractions and 
Windows users can insert ligatures.

To access alternative characters:

1. Place your insertion point where you 
want to insert the alternative characters.

2. Press the small triangle next to the glyph 
in the Glyphs panel  C . This opens the 
alternative letterforms for that character.

3. Choose the alternative character. This 
inserts the character into the text.

 C   Press the triangle under the glyph  to 
display the alternatives for the glyph.

 B   Use the  Glyphs panel  to insert 
characters from fonts.

Increase preview 
size

Decrease 
preview size
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As you hunt through the Glyphs panel, you 
may fi nd there are too many glyphs to look 
through. You can access the recently used 
glyphs or you can create your own custom 
glyph sets.

To access the recently used glyphs:

1. Make sure Show Options is chosen in the 
Glyphs panel menu.

2. Double-click one of the glyphs in the 
Recently Used area. This adds the glyph to 
your document.

To create a custom glyph set:

1. Choose New Glyph Set from the Glyphs 
panel menu.

2. Name the set in the New Glyph Set dialog 
box  A .

3. Choose where you want new additions to 
the set to appear.

4. Click OK to add the set.

TIP You can have many different glyph sets. 
Organize them however you want.

Once you have created a glyph set, you can 
add your favorite characters from any font 
into the glyph set.

To add characters to a glyph set:

1. Use the Glyphs panel to select the 
character you want to add to an existing 
glyph set.

2. Choose Add to Glyph Set > [Set Name] 
from the Glyphs panel menu. The 
character appears in the glyph set.

3. Choose what order you want the glyphs 
to appear in the set from the Insert Order 
list  B .

4. Click OK to create the glyph set.

 A  The  New Glyph Set dialog box  lets 
you name the new glyph set.

 B  The  Insert Order list  lets you control 
how glyphs are added to a set.
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To insert characters in a glyph set:

1. Choose the glyph set from the Glyph Set 
menu in the Glyphs panel.

2. Double-click to insert the glyph.

Once you have created a glyph set, you can 
edit the items in the set.

To edit the characters in a glyph set:

1. Choose Edit Glyph Set > [Set Name] from 
the Glyphs panel menu. The Edit Glyph 
Set dialog box appears  C .

2. Select the glyph item that you want 
to edit.

3. Use the Insert Order list to change where 
new glyphs are added.

4. Choose Remember Font with Glyph to set 
the glyph to a specific font. This means 
the glyph does not change to match the 
font in the text it’s inserted into.
or
Deselect Remember Font with Glyph to 
use the Unicode value of the current font. 
This option lets you match a character 
such as the Euro symbol to the text it is 
inserted into.

5. If you have selected Remember Font with 
Glyph, you can change the typeface and 
style in the Edit Glyph dialog box.

6. Click the Delete from Set button to delete 
a glyph from a set.

7. Click OK to apply the changes to the set.

 C  The  Edit Glyph Set dialog box  
lets you delete or modify the 
glyphs in a custom glyph set.

So What’s a Glyph?

If you’re like me, you’re probably wondering 
about the word glyph. Why use that word? Why 
not call it the Character panel?

The answer has to do with being precise. You 
know what a letter is: a, b, c, X, Y, or Z. You 
wouldn’t call things like 1, @, ?, or $ letters, 
though. They’re characters.

Well, glyphs are the proper name for everything 
including letters, characters, and alternative let-
terforms for things like ligatures and swashes.

So rather than call it the Insert Letters/Charac-
ters/Alternative Letterforms panel, Adobe calls 
it the Glyphs panel.

I could have sworn that the word glyph was 
some special Adobe typographic term; but then 
one of my students reminded me of Egyptian 
hieroglyphics. And then I remembered the 
Hawaiian petroglyphs. 

So glyph really isn’t as strange a word as I origi-
nally thought.
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Working with Text Flow

As mentioned earlier in this chapter, if text is 
too long to fi t in its text frame, you can link 
the text into another frame.

To link text between frames:

1. Click the overset text symbol. The cursor 
changes to the load text cursor  A .

2. Move the cursor over to the frame you 
want to flow the text into. The cursor 
changes to the link text cursor  B .

TIP Unlike with QuarkXPress, the second text 
frame does not have to be empty.

3. Click in the text frame. The link indicators 
show that the text in the frame flows to or 
from another frame  C .

TIP You can use the same steps to link empty text 
frames. This makes it easy to flow text into 
the layout later.

To change the link between frames:

1. Click the link indicator in the frame where 
you want to break the link. The cursor 
turns into a link text cursor.

2. Click in a new text frame to flow the 
text into a new frame.
or
Click inside the text frame to keep all the 
text within that frame. (The overset text 
symbol appears.)

InDesign also displays text threads, which 
show you the links between text frames.

To show the links between frames:

1. Select the text frame that you want to see 
the links for.

2. Choose View > Show Text Threads. This 
displays lines that show which frames are 
linked together  D .

 A  The  load text cursor  indicates that you can 
continue the overset text in another frame.

 B  The  link text cursor  indicates you can 
click to fi ll the next frame with text.

 C  The  link indicators  show that the text 
fl ows into and out of the text frame.

 D  The  text threads  show the 
links between frames.
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Setting Text Frame General 

Controls

Once you create a text frame, you can still 
control the fl ow of text within the frame. This 
is similar to creating a mini-layout within the 
text frame.

To change text frame options:

1. Select the text frame.
2. Choose Object > Text Frame Options. 

This opens the Text Frame Options dialog 
box  E .

3. Click the General tab.
4. Make whatever changes you want to the 

settings.

TIPTIP As you modify the text frame options, click 
the Preview checkbox to see the effects of 
your changes.

You can create columns within a text frame.

To create text frame columns:

Set the following options in the Columns 
area  F :
 • Number sets the number of columns.
 • Width sets the column width.
 • Gutter controls the space between the 

columns.

 E  The  Text Frame Options dialog box  
controls the fl ow of text within a frame.

 F  The  Columns settings  for the Text 
Frame Options dialog box.
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InDesign also has a powerful feature that 
helps you maintain a fi xed column width 
when working with a text frame. This is very 
helpful for magazine and news paper layouts 
where all text is in the same column width.

To use Fixed Column Width:

1. Click Fixed Column Width in the Text 
Frame Options dialog box.

2. Drag to resize the frame width. The width 
automatically jumps to whatever size can 
accommodate an additional column  A .

You can also add space between the text and 
the frame. This is called the inset spacing.

To control the frame inset:

1. Select the text frame and open the Text 
Frame Options dialog box.

2. Enter the values in the Inset Spacing fields 
to control the amount of space between 
the text and the top, bottom, left, and 
right edges of the frame  B .

3. Click OK to apply the changes to the 
column  C .

TIP If you have applied a stroke to a frame, 
you will most likely want to create an inset 
spacing so that the text does not touch the 
stroke.

 A  Applying  Fixed Column Width  
ensures that the columns in a text 
frame are always the same size.

Frame dragged to here
Automatically 
snaps to here

 B  The Inset Spacing settings for the 
Text Frame Options dialog box.

“At the East, not far from here,” said one, “there is a 
great desert, and none could live to cross it.”
“It is the same at the South,” said another, “for I have 
been there and seen it. The South is the country of 
the Quadlings.”
“I am told,” said the third man, “that it is the same at 

 C  A  text frame with inset spacing  has space 
between the text frame and the text.
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The vertical justifi cation of a text frame con-
trols where the text is positioned from the top 
to the bottom of the frame.

To set the vertical justification:

1. Select the text frame and open the Text 
Frame Options dialog box.

2. Choose one of the four options in the 
Vertical Justification Align pop-up list  D :
 • Top positions the text so that the first 

line sits at the top of the frame  E .
 • Center positions the text so it is 

centered between the top and bottom 
of the frame  E .

 • Bottom positions the text so that 
the last line sits at the bottom of the 
frame  E .

 • Justify positions the text so that it fills 
the entire frame from top to bottom  E .

TIPTIP The vertical justification options are only 
available for rectangular text frames. If the 
frame is another shape or has corner effects 
applied, the vertical justification options are 
dimmed out.

When you set the vertical alignment to 
Justify, you can set how the space between 
paragraphs is applied.

To set the paragraph spacing limit:

1. Set the Vertical Justification Align list to 
Justify.

2. Set an amount in the Paragraph Spacing 
Limit field  F . The higher the number, the 
more space between paragraphs and 
the less likely the leading between the 
lines will be affected by justifying the text 
vertically.

TIPTIP Set an amount equal to the height of the 
text frame to add space only between the 
paragraphs, not between the lines  G .

 D  The  Vertical Justifi cation Align 
menu  lets you choose where 
text is positioned vertically.

“The Wonderful 
Wizard of Oz”

by L. Frank Baum
Chapter One, The Cyclone

“The Wonderful 
Wizard of Oz”

by L. Frank Baum
Chapter One, The Cyclone

“The Wonderful 
Wizard of Oz”

by L. Frank Baum
Chapter One, The Cyclone

“The Wonderful 

Wizard of Oz”

by L. Frank Baum

Chapter One, The Cyclone

 E  The four vertical alignment settings change 
the position of text within a frame.

Top Center

Bottom Justify

 F  The  Paragraph Spacing Limit  for justifi ed 
vertical alignment controls how much 
space will exist between paragraphs 
before the leading is increased.

“The Wonderful 

Wizard of Oz”

by L. Frank Baum

Chapter One, The Cyclone

“The Wonderful 
Wizard of Oz”

by L. Frank Baum

Chapter One, The Cyclone

 G  A paragraph spacing limit of 0p 
causes the leading to increase. A 
limit of 1p only adds space between 
the paragraphs, not the leading.

0p paragraph spacing 1p paragraph spacing
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Spanning and Splitting 

Columns

Ordinarily, text stays within the boundaries 
of a column. However, you may want the 
headline for a story to stretch across (span) 
the columns in a text frame  A .

To set text to span columns:

1. Select the text and choose Span Columns 
from the Paragraph panel menu. The 
Span Columns dialog box appears  B .

2. Choose Span Columns from the 
Paragraph Layout choices.

3. Use the Span Columns field to control 
how many columns you want the text to 
span  C .

4. Use the Space Before Span or Space After 
Span to add space above or below 
the text.

Another way to customize text within a 
column is to split the text into sub-columns. 
This is called a split column and is very popu-
lar for highlighting text in a story  D .

To set text to split within a column:

1. Choose Split Columns from the Paragraph 
Layout choices.

2. Use the Sub-columns field to control how 
many columns you want to split the text 
into  E .

3. Use the Space Before Split or Space After 
Split field to add space above or below 
the split text  E .

4. Use the Inside Gutter field to add space 
between the split columns. This is similar 
to the gutter space within text frames.

5. Use the Outside Gutter field to add space 
between the outside edge of the text and 
the column.

 A  An example of headline text that 
 spans across columns.

 D  An example of text that has 
been set to  split columns .

 B  The  Paragraph Layout choices  of 
the Span Columns dialog box.

 E  The controls to set text to 
split within a column.

 C  The controls to set text to 
span across columns.
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Using the Control Panel for 

Text

The Control panel changes its settings 
depending on the type of object selected. For 
example, when a text object is selected, the 
Control panel displays a combination of the 
Character and Paragraph panel controls.

To use the Control panel for character 
settings:

1. Use the Type tool to create an insertion 
point within a text frame. The Control 
panel displays the text options.

2. Click the Character icon to display the 
character attributes in the first position 
in the Control panel  F . The paragraph 
attributes follow.

TIPTIP Cmd-Opt-7 (Mac) or Ctrl-Alt-7 (Win) switches 
the focus between the Character and 
Paragraph settings in the Control panel.

To use the Control panel for paragraph 
settings:

1. Use the Type tool to create an insertion 
point within a text frame. The Control 
panel displays the text options.

2. Click the Paragraph icon to display the 
paragraph attributes in the first position 
in the Control panel  G . The character 
attributes follow.

 G  Click the  Paragraph icon  to move 
the paragraph attributes to the fi rst 
position in the Control panel.

Paragraph icon

 F  Click the  Character icon  to move 
the character attributes to the fi rst 
position in the Control panel.

Character icon



86 Chapter 3 Basic Text

Using Special Text Characters

Text does not consist of just alphanumeric 
characters. There are special characters and 
spaces that are used as part of professional 
typography. InDesign lets you insert those 
characters into your documents.

To insert special characters:

1. Place the insertion point where you want 
to insert the special character.

2. Choose Type > Insert Special Character.
or
Control-click (Mac) or right-click (Win) 
and choose Insert Special Character from 
the contextual menu.

3. Choose a character from the submenu.

You can insert white space characters, which 
are fi xed spaces such as em and en spaces. 
You can also insert a nonbreaking space that 
forces two words to stay together.

TIP See the sidebar on the right for descriptions 
of the size of the white spaces.

 To insert special space characters:

1. Place the insertion point where you want 
to insert the special character.

TIP You can highlight a regular space to replace it 
with a white space character.

2. Choose Type > Insert White Space.
or
Control-click (Mac) or right-click (Win) 
and choose Insert White Space from the 
contextual menu.

3. Choose a white space character listing 
from the submenu.

How Wide are the Spaces?

Although some of the white space character 
widths are obvious, others need some definition.

 • An em space is the size of the letter M 
at that point size. In traditional typeset-
ting, an em space was often used as the 
indent for a paragraph.

 • An en space is one-half of an em space. 
An en space is often used as a fixed-
width space between bullets and the 
next character of text.

 • A hair space is one-twenty-fourth of an 
em space. A hair space is used when 
extremely small spaces are needed.

 • A sixth space is one-sixth of an em space.

 • A thin space is one-eighth of an em 
space. I use a thin space on either side of 
an em dash or the greater than (>) sign 
in menu commands such as File > New.

 • A quarter space is one-quarter of an em 
space.

 • A third space is one-third of an em space.

 • A punctuation space is the width of a 
period or comma.

 • A figure space is the width of a number 
in the same typeface. This is used to help 
align numbers in financial tables.

 • A flush space is a variable space that 
is used with the Justify All paragraph 
alignment setting. When flush space is 
inserted, the space between the charac-
ters will automatically expand so that the 
line of text fills the entire column width. 
A flush space character ensures that the 
justification of the text comes from the 
word spacing and not letter spacing.
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Working With Objects
Back in the old days of board 

mechanicals, advertising agencies 
and design studios had a production 
area called the bullpen. It was the 
people in the bullpen — called bullpen 
artists — who actually created the 
mechanical. Most of them were kids just 
out of design school; the bullpen was 
usually their fi rst step up the ladder in 
advertising or design.

The kids in the bullpen were amazing. 
Although not professional illustrators, 
they could create all sorts of artwork for 
the layout.

The same is true when working with 
InDesign. Although InDesign is not a 
full-fl edged drawing program such as 
Adobe Illustrator, you can use InDesign’s 
tools to create a wide variety of eff ects 
by distorting, moving, resizing, dupli-
cating, and aligning objects. It’s your 
electronic bullpen.
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Types of Frames

Frames are the containers in which you place 
graphics or text. Frames can also be used 
as graphic shapes. There are three types of 
frames you can create: unassigned, graphic, 
and text.

Unassigned frames

Unassigned frames are created with the 
Rectangle, Ellipse, and Polygon tools  A . These 
frames are useful for adding color to your 
layout or a stroke around an area without 
inserting a graphic or text.

Graphic frames

Graphic frames are created with the Rectan-
gle Frame, Ellipse Frame, and Polygon Frame 
tools. When you create a graphic frame, 
diagonal lines inside the frame indicate that 
you can insert a graphic inside the frame  A .

TIP Although most people insert images inside 
graphic frames, there is nothing to prevent 
you from flowing text inside a graphic frame.

Text frames

Text frames are created using the Text tool or 
by converting frames. When you create a text 
frame, two link boxes appear on the sides of 
the frame in addition to the bounding box 
handles. Text frames also display a blinking 
insertion point when they are selected  A .

 A  The  three diff erent types of frames : 
unassigned, graphic, and text.

Unassigned 
frame

Graphic 
frame

Text 
frame

Diagonal Lines in Graphic Frames?

The diagonal lines inside a graphic frame come 
from a convention that was used in traditional 
pasteboard mechanicals.

When pasteboard artists drew the lines on 
mechanicals, they would often block off an area 
with diagonal lines to indicate that a picture or 
graphic was to go there.

Electronic page-layout programs such as 
Adobe InDesign and QuarkXPress use the same 
convention. The diagonal lines indicate where 
photos or graphics need to be inserted.

However, there is absolutely no rule that says 
you can only place images in graphic frames. 
You can place text in graphic frames or images 
in unassigned frames. The choice is yours. 
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Creating Basic Shapes

You use the rectangle, ellipse, and polygon 
frame tools to create graphic frames into 
which you place images.

TIPTIP If another tool is visible, press the corner 
triangle to reveal the toolset.

To create a rectangular graphic frame:

1. Click the Rectangle Frame tool in the 
Tools panel  B .

2. Drag across the page to create the 
rectangle.

TIPTIP Hold the Opt/Alt key to draw the object from 
the center.

3. Release the mouse button when the 
rectangle is the correct size.

TIPTIP Hold the Shift key to constrain the rectangle 
into a square.

To create an elliptical graphic frame:

1. Click the Ellipse Frame tool in the Tools 
panel  C .

2. Drag across the page to create the ellipse.

TIPTIP Hold the Opt/Alt key to draw the object from 
the center.

3. Release the mouse button when the 
ellipse is the correct size.

TIPTIP Hold the Shift key to constrain the ellipse into 
a circle.

You can also create rectangles and ellipses by 
specifying their size numerically.

To create objects numerically:

1. Click with either the Rectangle or Ellipse 
Frame tools. A dialog box appears  D .

2. Enter the width and height amounts.
3. Click OK. The frame appears where the 

mouse was clicked.

Using the Transformation Values?

You may notice that there is a label that appears 
when you drag or create objects that contains 
feedback as to the position, size, or angle of the 
object. This is the Transformation Values cursor.

Rather than clutter the illustrations in this chap-
ter, I’ve turned off the Transformation Values.

But you should get in the habit of using those 
labels to work more precisely.

 B  The  Rectangle Frame tool 
in the Tools panel  creates 
rectangular graphic frames.

 C  The  Ellipse Frame tool in 
the Tools panel  creates 
elliptical graphic frames.

 D  The  Ellipse and Rectangle dialog 
boxes  let you create frames with 
precise width and height.
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To create a polygon graphic frame:

1. Double-click the Polygon Frame tool in 
the Tools panel  A . This opens the Polygon 
Settings dialog box  B .

2. Enter a number in the field for the 
Number of Sides to the polygon.

3. To create a star, change the amount in 
the Star Inset field from 0% to a higher 
number.

TIP A star inset of 0% creates a basic polygon. As 
you increase the percentage, the points of the 
star become more pronounced.

4. Drag across the page to create the 
polygon or star.

TIP Hold the Opt/Alt key to draw the object from 
the center.

TIP Hold the Shift key to constrain the width and 
height of the object to the same amount.

5. Release the mouse button when the 
polygon or star is the correct size.

InDesign is defi nitely the program for anyone 
who says they can’t even draw a straight line. 
The Line tool makes it easy.

To create straight lines:

1. Click the Line tool in the Tools panel  C .
2. Position the cursor where you want the 

line to start.

TIP Hold the Opt/Alt key to draw the line from its 
centerpoint.

3. Drag to create a line.
4. Release the mouse button where you 

want the line to end.

TIP Hold the Shift key to constrain the line to 
45-degree angles.

 C  The  Line tool in the Tools 
panel  creates straight lines.

 B  The  Polygon Settings dialog box  
creates either polygons or stars.

 A  Use the  Polygon Frame 
tool  to create polygon and 
star graphic frames.

Converting Shapes

So what if you’ve created a circle and later on 
realize you need a rectangle? What do you do?

Simple, you can use the Pathfinder Convert 
Shape commands to change an object from 
one shape to another. (See Chapter 7, “Points and 
Paths,” for more information on the Pathfinder 
commands.)
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Selecting Objects

Once you’ve created objects, you can use dif-
ferent techniques to select them.

To select by clicking:

1. Choose the Selection tool (black arrow) in 
the Tools panel  D .

2. Click the object you want to select.
3. Hold the Shift key to select any additional 

objects.

TIPTIP Hold the Shift key and click on a selected 
object to deselect that object.

TIPTIP To select objects behind others, hold the 
Cmd/Ctrl key as you click the mouse button.

TIPTIP Double-click on a graphic frame to toggle 
between the Selection and Direct Selection 
tools.

You can also select an object by dragging an 
area, or marquee, around the object.

To select by dragging a marquee:

1. Choose the Selection tool.
2. Drag along a diagonal angle to create a 

marquee around the objects you want to 
select  E .

TIPTIP You do not need to marquee the entire object 
to select it. Objects are selected if any portion 
is within the marquee.

TIPTIP Hold the Shift key and drag around another 
area to add to a selection.

You can also use a menu command to select 
all the objects on a page.

To select all the objects on a page:

Choose Edit > Select All.

TIPTIP This command works only if you do not have 
an insertion point blinking inside a text 
frame.

 E  Drag to create a marquee to select objects.

What Are the Differences 
Between the Selection Tools?

Perhaps the most confusing part of InDesign is 
the difference between the Selection tool (black 
arrow) and the Direct Selection tool (white 
arrow)  D .

The Selection tool will always select the object 
as a whole. Use this tool when you want to 
manipulate the entire object.

The Direct Selection tool will always select the 
points or segments that make up a frame. Use 
the Direct Selection tool to reshape a path.

Both tools can select placed images within 
a frame as covered in Chapter 8, “Imported 
Graphics.”

If you’ve ever worked with Adobe Illustrator, 
you’ll instantly recognize the two selection tools 
as identical to their Illustrator cousins.

 D  The  Selection tool in the Tools panel  
selects entire objects. The Direct Selection 
tool selects a point on an object.

Selection tool Direct Selection tool
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Moving Objects

The simplest way to position an object on a 
page is to drag it to a new position, but you 
can also move objects by using menu and 
keyboard commands, or by typing specifi c 
numerical locations into a dialog box, as you’ll 
learn later in this chapter.

To move an object by dragging:

1. Choose the Selection tool in the Tools 
panel.

2. Click the object you want to move. A 
bounding box with eight handles appears 
around the object. This indicates the 
object is selected.

3. Position the Selection tool on the edges 
of the bounding box (but not on the 
handles of the bounding box).

TIP If an object has a fill color, gradient, or image 
inside it, you can drag with the Selection tool 
directly inside the object. Otherwise, you 
must drag by the stroke or bounding box.

4. Drag to move the object. If you drag 
quickly, you will see only a bounding box 
preview of the object being moved  A .
or
Press and pause for a moment before 
you drag the object. The pause gives 
InDesign enough time to let you see a 
preview of the object as you move it  B .

 A  Quickly drag to see the bounding 
box of the object being moved.

 B  Pause before you drag to see a preview 
of the object being moved.
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You can also move an object more precisely. 
One way to do this is with the Move com-
mand in the Transform menu.

To use the Move command:

1. Select the object or objects.
2. Choose Object > Transform > Move. This 

opens the Move dialog box  C .

TIPTIP This command is also available in a 
contextual menu or by double-clicking the 
Selection or Direct Selection tools.

TIPTIP Select the Preview checkbox to see the results 
of your actions as you enter numbers in the 
dialog box.

3. Use the Horizontal and Vertical fields to 
move the object along those axes.

4. Use the Distance field to move the object 
an absolute distance.

5. Use the Angle field to set the angle along 
which the object moves.

6. Click OK to move the original object.
or
Click Copy to create a duplicate of the 
object in the new position.

To copy an object as you drag:

1. Hold the Opt/Alt key before you start the 
move.

2. Move the object as described on the 
opposite page. A double-headed arrow 
indicates that a copy is being created  D .

3. Release the mouse button. The copy 
appears in the new position.

 C  The  Move dialog box  gives you 
numerical controls for moving objects.

 D  The  double-headed arrow  indicates that a 
copy is being created of the moved object.
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Replicating Objects

There are several commands you can use to 
create duplicates of objects. Use the Copy 
command when you want to put the object 
on the clipboard so you can paste it some-
where else.

To copy objects:

1. Select an object to copy.
2. Choose Edit > Copy.

Use the Cut command to remove the object 
from the page so it can be pasted elsewhere.

To cut objects:

1. Select an object to cut.
2. Choose Edit > Cut.

Use the Paste command to see the contents 
of the clipboard.

To paste objects:

Choose Edit > Paste. The contents of the 
clipboard appear in the center of the 
window area  A .
or
Choose Edit > Paste in Place. The 
contents of the clipboard appear in the 
same location on the page as when they 
were originally selected.

The Duplicate command makes a copy with-
out changing the contents of the clipboard.

To duplicate objects:

1. Choose the object to duplicate.
2. Choose Edit > Duplicate. The selected 

object appears on the page slightly offset 
from the original  B .

 B  The  Duplicate 
command  places the 
object slightly off set 
from the original.

Original object

Duplicated object

 A  The  Paste command  
places the object in 
the center of the page.

Copied object

Pasted object

Using Paste in Place

I always wondered just how useful the Paste in 
Place command is. After all, if you already have 
a copy of an object in one place, why would you 
need a second copy right over it?

That’s not the point of Paste in Place. The power 
of the command is that you can paste an object 
in the same place on different pages. You can 
even paste in the same place in different docu-
ments.
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InDesign makes it easy to create a grid of an 
object as you drag to create it. This is known 
as the gridify feature.

To create a grid as you draw an object:

1. Select the tool and start the drag to draw 
the object.

2. Without releasing the mouse button, 
press the up/down or left/right arrows. 
This creates rows and columns that 
duplicate the object as follows:
 • The up and down arrows increase and 

decrease the number of rows.
 • The left and right arrows increase and 

decrease the number of columns. 
3. Release the mouse button when you have 

as many objects you you need  C .

The gridify feature is useful as you draw an 
object. However, it doesn’t give you numeri-
cal control over the space between the rows 
and columns. That’s when you want to use 
the Step and Repeat command.

To duplicate multiple objects:

1. With an object selected, choose Edit > 
Step and Repeat. The Step and Repeat 
dialog box appears  D .

2. In the Repeat Count field, enter the 
number of duplicates that you want to 
create in the top row.

3. In the Horizontal Offset field, enter a 
distance for the horizontal space between 
duplicates.

4. In the Vertical Offset field, enter a distance 
for the vertical space between duplicates.

5. If desired, select the Preview box to see 
how your settings affect the objects.

6. Click OK. The selected object is duplicated 
in the desired positions  E .

TIPTIP Use the Step and Repeat command again to 
create a grid of the objects  F .

 D  Use the  Step and Repeat dialog 
box  to make multiple copies of 
an object positioned at specifi c 
horizontal and vertical intervals.

 C  Press the up/down or left/right 
arrows as you drag with a tool to 
create a grid  of the objects.

 E  The  Step and Repeat command  
created fi ve copies of the fi rst circle.

 F  An example of how to use the Step and 
Repeat command to create a grid of objects.

Objects created in step 1

Objects created in step 2
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Resizing Objects

Very often things need to be made bigger or 
smaller. InDesign gives you several diff erent 
ways to scale objects. You can also use the 
bounding box handles to change the dimen-
sions of the object visually. This is the easiest 
way to quickly resize an object.

To resize using the bounding box handles:

1. Choose the Selection tool.
2. Choose which handle to drag based on 

the following options  A :
 • Drag the corner handles to change 

both the width and height.
 • Drag the top or bottom handles to 

change the height only.
 • Drag the left or right handles to change 

the width only.
3. Drag the handle. If you drag quickly, you 

will see only the bounding box of the 
object  B .
or
Press and hold for a moment and then 
drag the handle. This shows a preview 
of the object as you resize the bounding 
box  C .

TIP Hold down the Shift key as you drag a corner 
to keep the original proportions of the width 
and height.

TIP Hold the Cmd/Ctrl key as you drag to scale 
the frame as well as any text and images 
inside the object.

4. Release the mouse button when the 
object is the correct size.

 A  Use the  bounding 
box handles  to 
resize an object.

 B  If you  drag 
quickly , you only 
see a box as you 
resize an object.

 C  If you  press and 
pause a moment , 
you see an actual 
preview as you 
resize an object.

Resizing or Scaling?

Although you and I might feel the words are the 
same, InDesign treats them differently. When 
you resize an object, you change its width or 
height. The amount of scaling stays the same in 
the Control panel or the Transform panel. You 
have to resize the object again to get it back to 
its original size.

When you scale an object, the width and height 
change, and the amount of scaling applied to 
the object is shown in the Scale fields in the Con-
trol panel or Transform panel. You can convert 
the object back to its original size by setting the 
scaling to 100%.
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Using the Transform Tools

The transform tools resize and distort objects. 
You can transform the object itself (also called 
the container) or the object as well as any 
content. How you select objects changes the 
eff ect of the transform tools.

To control the eff ect of the transform tools:

Select the object using the Selection 
tool. This type of selection causes the 
transform tools to affect both the 
container and any text or images 
inside it  D .
or
Hold the Opt/Alt key as you click the 
frame with the Direct Selection tool. This 
causes the transformation to affect only 
the container, not any text or images 
contained in the frame  E .

TIPTIP The plus (+) sign next to the Direct Selection 
tool indicates that the tool is now the Group 
Selection tool.

All the transformations take place in relation 
to a reference point. Each object has a default 
reference point, but you can change it if 
necessary.

To control the reference point:

1. Select the object to be transformed.
2. Choose one of the transform tools. A 

reference point appears inside the object.
3. Move the cursor near the reference point. 

A small icon appears next to the cursor 
that indicates you can move the reference 
point  F .

4. Drag the reference point to a new 
position.
or
Click to position the reference point in a 
new position.

 E   Objects selected with the Group 
Selection tool have only the object 
transformed  by the transform tools.

 D Objects selected with the Selection tool 
have both the object and its content 
transformed  by the transform tools.

 F  The indicator that 
the reference point 
can be moved to 
a new position.
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The Scale tool lets you increase or decrease 
the size of objects.

To scale objects visually using the Scale 
tool:

1. Select the object or objects.
2. Choose the Scale tool in the Tools panel  A .
3. If necessary, change the position of the 

reference point.
4. Move the cursor away from the reference 

point, and drag to scale the object  B .

TIP Hold down the Shift key to constrain the tool 
to horizontal, vertical, or proportional scaling.

TIP To see a preview of the image as you scale, 
press and hold the mouse button for a 
moment before you start to drag.

TIP Hold down the Opt/Alt key to copy the object 
as you scale it.

If you prefer, you can resize objects numeri-
cally using the Scale command.

To scale objects using the Scale command:

1. Select the object or objects.
2. Choose Object > Transform > Scale. This 

opens the Scale dialog box  C .
3. Enter an amount for the Scale X 

(horizontal) field.
4. Enter an amount for the Scale Y (vertical) 

field.

TIP If the chain icon is selected, the X and Y fields 
scale the same amounts.

5. Select the Preview checkbox to see the 
effects of entering the amounts.

6. Click OKOK to scale the object or click Copy to 
create a scaled copy of the object.

 A  The  Scale tool in the Tools 
panel  is used to change 
the size of objects.

 B  The arrowhead 
appears while 
scaling an object.

 C  The  Scale dialog box  lets you scale 
objects using numerical values.

Making Copies as You 
Scale, Rotate, and Shear

As you use the Scale, Rotate, and Shear tools, 
you can duplicate the object as you transform it.

Drag, as usual, to start the transformation, but 
then add the Opt/Alt key after you start the 
drag. You will see the double-headed arrow that 
indicates you are duplicating the object.

Release the mouse button first, and then the 
Opt/Alt key to finish the transformation and 
duplication.
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To scale objects numerically using the 
Scale tool:

1. Select the object or objects.
2. Choose the Scale tool in the Tools panel.
3. Hold the Opt/Alt key and click to desig-

nate the position of the reference point. 
This opens the Scale dialog box  C .

4. Set the dialog box controls as described in 
the previous exercise. 

The Rotate tool changes the orientation, or 
angle, of the object on the page.

To rotate objects visually using the 
Rotate tool:

1. Select the object or objects.
2. Click the Rotate tool in the Tools panel  D .
3. If necessary, change the default reference 

point.
4. Move the cursor away from the reference 

point, and drag to rotate the object  E .

TIPTIP Hold down the Shift key to constrain the 
rotation to 45-degree increments.

To rotate objects using the Rotate 
command:

1. Select the object or objects.
2. Choose Object > Transform > Rotate. This 

opens the Rotate dialog box  F .
3. Use the Angle field to set how much the 

object should rotate.
4. Select the Preview command to see the 

effects of entering the angle.
5. Click OK to rotate the object or click Copy 

to create a copy as you rotate the object.

 D  The  Rotate tool in the Tools 
panel  is used to change the 
orientation of objects.

 E  Rotating an 
object around its 
reference point.

 F  The  Rotate dialog box  lets you rotate 
objects using numerical values.
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To rotate objects numerically using the 
Rotate tool:

1. Select the object or objects.
2. Choose the Rotate tool in the Tools panel.
3. Hold the Opt/Alt key and click to set the 

position of the reference point. This opens 
the Rotate dialog box.

4. Set the dialog box controls as described in 
the previous exercise. 

The Shear tool distorts the shape of objects.

To shear objects visually using the 
Shear tool:

1. Select the object or objects.
2. Click the Shear tool in the Tools panel  A .
3. If necessary, change the reference point 

by dragging it to a new position. The 
cursor indicates the reference point can 
be moved.

4. Move the cursor away from the reference 
point, and drag to shear the object  B .

To shear objects using the Shear command:

1. Select the object or objects.
2. Choose Object > Transform > Shear. This 

opens the Shear dialog box  C .
3. Use the Shear Angle field to set the 

amount of distortion.
4. Select one of the Axis options:

 • Horizontal shears along the 
horizontal axis.

 • Vertical shears along the vertical axis.
5. Select the Preview command to see the 

effects of entering the shear angle and 
choosing the axis.

6. Click OK to shear the object.
or
Click Copy to create a sheared copy of the 
object.

 A  Use the  Shear tool in the Tools 
panel  to distort objects.

 B  Shearing an 
object around the 
reference point.

 C  The  Shear dialog box  lets you distort 
objects using numerical values.
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To shear objects numerically using the 
Shear tool:

1. Select the object or objects.
2. Choose the Shear tool in the Tools panel.
3. Hold the Opt/Alt key and click to set the 

position of the reference point. This opens 
the Shear dialog box  C .

4. Set the dialog box controls as described in 
the previous exercise. 

Rather than switching between the Scale, 
Rotate, and Shear tools, you can use the Free 
Transform tool to scale, rotate, or shear an 
object.

To use the Free Transform tool:

1. Select the object or objects.
2. Click the Free Transform tool in the Tools 

panel  D . A bounding box appears around 
the object.

3. To scale the object, place the cursor over 
one of the handles. The cursor changes to 
a double-headed arrow  E .
or
Place the cursor outside one of the 
handles of the bounding box. The cursor 
changes to a curved double-headed 
arrow  F .
or
Drag one of the handles and then hold 
the Cmd/Ctrl key after you have started 
the drag. The cursor does not change 
appearance, but the object will be 
sheared.

4. Release the mouse button to apply the 
transformation.

 D  Choose the  Free Trans form 
tool in the Tools panel  to scale, 
rotate, and shear objects.

 E  The double-headed arrow indicates that the 
Free Transform tool is in the scale mode.

 F  The curved double-headed arrow 
indicates that the Free Transform 
tool is in the rotation mode.
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Using the Transform Panel

The Transform panel allows you to move, 
scale, rotate, and shear objects precisely, 
using numerical values.

TIP When you have objects selected, the Control 
panel displays many of the controls that are 
found in the Transform panel.

To open the Transform panel:

Choose Window > Object & Layout > 
Transform to open the panel  A .
or
If the Transform panel is behind other 
panels, click the Transform panel tab.

As you work with the Transform panel, it is 
important to know its reference point on the 
object. This is the same as the reference point 
used with the transform tools.

To set the Transform panel reference point:

1. Select the object or objects that you want 
to transform.

2. Click the reference point control on the 
Transform panel to choose the point 
around which the object moves  B .

 A  The  Transform panel  is a command center 
for positioning and transforming objects.

 B  The  reference point  controls where in 
the object the transformation occurs.

Bottom 
left

Top left

Left side

Top right

Right side

Bottom right

Top center

Bottom center

Center
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You can use the Transform panel to move 
objects numerically.

To move an object with the Transform 
panel:

1. Select the object or objects that you want 
to move.

2. To move the object horizontally, enter an 
amount in the X field  C .

TIPTIP As you increase the numbers, the object 
moves to the right.

3. To move the object vertically, enter an 
amount in the Y field  C .

TIPTIP As you increase the numbers, the object 
moves down.

4. Press Enter or Return to apply the 
changes.

You can use the Transform panel to resize an 
object numerically.

To resize with the Transform panel:

1. Select the object or objects.
2. If necessary, change the reference point 

as explained on the preceding page.
3. To change the width of the object, enter 

an amount in the W field  D .
4. To change the height of the object, enter 

an amount in the H field  D .
5. Press Enter or Return to resize the object.

You can resize proportionally even if you 
know the size for only one side of the object.

To resize proportionally:

1. Select the object or objects.
2. Enter the new size in the W field or H 

field  D .
3. Hold Cmd/Ctrl as you press Enter or 

Return. The amount in both the W and H 
fields changes proportionally.

 C  The  X and Y fi elds in the Transform 
panel control  the position of an object.

 D  The  W and H fi elds in the Transform panel  
control the width and height of objects.
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You can also scale using the Trans form panel.

To scale with the Transform panel:

1. Select the object or objects.

TIP Use the Selection tool to scale the object and 
its contents. Use the Direct Selection tool to 
scale only the object.

2. If necessary, change the reference point.
3. To change the horizontal size, enter a 

percentage in the Scale X field  A .
4. To change the height of the object, enter 

a percentage in the Scale Y field  A .

TIP The Scale X and Y fields also have pop-up lists 
from which to choose the amount of scaling.

5. Press Enter or Return to apply the 
changes.

TIP You can also scale text within a text frame 
by dragging on the edge of the frame while 
holding the Cmd/Ctrl key. Hold Cmd/Ctrl-
Shift and drag by a corner point to scale 
proportionally. This also applies to text 
frames in groups.

To scale proportionally with the Transform 
panel:

1. Select an object or objects.
2. If the Link icon is in the open state, click to 

close it  B .
3. Enter an amount in either the Scale X or 

Scale Y fields. You do not have to enter 
an amount in both fields. The closed Link 
icon forces both fields to display the same 
amount.

4. Press Enter or Return to apply the 
changes.

TIP Hold the Cmd/Ctrl key as you press the Enter 
or Return key to scale proportionally even if 
the Link icon is in the open state.

 B  The  Link icon in the closed state  
forces both the Scale X and the Scale Y 
fi elds to the same amount. In the open 
state, you can enter diff erent amounts 
for the Scale X and Scale Y fi elds.

Closed state Open state

Scale X Scale Y

 A  The  Scale X and Y fi elds in the 
Transform panel  let you apply 
percentage amounts to scale objects.
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You can also rotate objects using the 
 Transform panel.

To rotate with the Transform panel:

1. Select the object or objects.

TIPTIP Use the Selection tool to rotate the object 
and its contents. Use the Direct Selection tool 
to rotate only the object.

2. If necessary, change the reference point.
3. Enter the amount of rotation in the 

Rotation field  C .

TIPTIP The Rotation field also has a pop-up list from 
which to choose the amount of rotation.

4. Press Enter or Return to apply the 
changes  D .

You can also shear objects using the Trans-
form panel.

To shear with the Transform panel:

1. Select the object or objects.

TIPTIP Use the Selection tool to shear the object and 
its contents. Use the Direct Selection tool to 
shear only the object.

2. If necessary, change the reference point.
3. Enter the amount of distortion in the 

Shear field  E .

TIPTIP The Shear field also has a pop-up list from 
which to choose the amount of shearing.

4. Press Enter or Return to apply the 
changes  F .

The Cyclone
 F  The diff erence between shearing an object 

or shearing an object and its content.

Object sheared

Object and content sheared

The Cyclone

 C  The Rotation fi eld in the Transform panel 
lets you change the angle of objects.

 E  The Shear fi eld in the Transform panel 
lets you distort the shape of objects.
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 D  The diff erence between rotating an object 
or rotating an object and its content.

Object rotated Object and content rotated
The 

Munchkins 
immediately 

took out their 
handkerchiefs 

and

Object rotated
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Using the Transform 

Commands

In addition to the transform tools and 
transform fi elds, there are a whole bunch of 
transform commands you can use on objects. 
These commands make it easy to perform 
commonly used transformations, such as 
rotating and fl ipping objects.

To rotate with the transform commands:

1. Select an object or objects.
2. Click to open the Transformation 

panel menu.
or
Choose Object > Transform.

3. Choose one of the rotation settings as 
follows  A :
 • Rotate 90° CW (clockwise).
 • Rotate 90° CCW (counter-clockwise).
 • Rotate 180°.

To fl ip objects using the transform 
commands:

1. Select an object or objects.
2. Click to open the Transform panel menu.

or
Choose Object > Transform.

3. Choose one of the flip settings as 
follows  B :
 • Flip Horizontal.
 • Flip Vertical.

The Cyclone

The Cyclone

The Cyclone

 B  The  eff ects of fl ipping objects  
using the Transform submenu.

Original

Flip Horizontal

Flip Vertical

The Cyclone

The Cyclone T
he C

yclone

T
he

 C
yc

lo
ne

 A  The  eff ects of rotating objects 
 using the Transform submenu.

Rotate 
90° CW

Rotate 
90° CCW

Rotate 180°

Original

The Cyclone

The Cyclone
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When you perform a transformation on 
an object, that transformation is stored in 
InDesign’s memory. You can then perform 
the same transformation again on another 
object — even in another document! This is 
similar to Illustrator’s Transform Again 
command.

To repeat transformations:

1. Use any of the transform commands on a 
selection.

2. Select a different object or objects.
3. Choose one of the following from the 

Object > Transform Again submenu.
 • Transform Again applies the last single 

transform command to the selection as 
a whole  C .

 • Transform Again Individually applies 
the last single transform command to 
each object in the selection  D .

 • Transform Sequence Again applies the 
last set of transformation commands to 
the selection as a whole. 

 • Transform Sequence Again 
Individually applies the last set of 
transformation commands to each 
object in the selection.

TIPTIP InDesign remembers all the transformation 
commands until you select a different object 
or perform a different task.

TIPTIP InDesign can even remember an Opt/Alt-drag 
transformation that duplicated an object.

 C  The  Transform Again command  
allows you to duplicate transformation 
commands applied to objects.

Circle moved to new 
position

Transform Again 
command applied to 
triangle

 D  The diff erences between the Transform 
Again command and the Transform 
Again Individually command when 
applied to multiple objects.

Rotation applied to 
single triangle

Transform Again 
applied to two 
triangles

Transform Again 
Individually applied to 
two triangles
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Using the Arrange Commands

Objects in InDesign are layered on top of one 
another in the same order they were created. 
(This is sometimes called the stacking order.) 
The fi rst object created is behind the second, 
the second behind the third, and so on. 
Though you may not see the layering when 
objects are side by side, it is apparent when 
they overlap  A .

TIP The layering of objects is not the same as the 
layers of a document. (See Chapter 11, “Layers,” 
for more information on working with layers.)

The Arrange commands allow you to move 
objects through the stacking order.

To move up or down one level in a stack:

1. Select the object you want to move.
2. Choose Object > Arrange > Bring 

Forward to move the object in front of 
the next object in the stacking order  B .
or
Choose Object > Arrange > Send 
Backward to move the object behind the 
next object in the stacking order  C .

To move up or down the entire stack:

1. Select an object you want to move.
2. Choose Object > Arrange > Bring to 

Front to move the object in front of all 
the others in its layer  D .
or
Choose Object > Arrange > Send to Back 
to move the object behind all the others 
in its layer  E .

 A  When two objects overlap, it is obvious 
which object is in front of the other.

 B  Eff ects of the Bring Forward command.

Bring Forward appliedStar in back

 C  Eff ects of the Send Backward command.

Send Backward appliedStar in front

 D  Eff ects of the Bring to Front command.

Bring to Front appliedStar in back

 E  Eff ects of the Send to Back command.

Send to Back appliedStar in front
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Aligning Objects

The Align panel provides commands that 
align objects or distribute them evenly along 
a horizon tal or vertical axis.

To work with the Align panel:

1. Choose Window > Object & Layout >  
Align. This opens the Align panel  F .

2. Choose Show Options from the Align 
panel menu to see all the com mands in 
the panel.

To align objects:

1. Select two or more objects.
2. Use the Alignment menu to choose to 

what items the objects should align  G .
 • Align to Selection uses the objects 

themselves for alignment.
 • Align to Margins uses the margins for 

alignment.
 • Align to Page uses the page trim for 

alignment.
 • Align to Spread uses the size of the 

spread for alignment.
3. Click an alignment icon as follows:

 • Click a vertical alignment icon to move 
the objects into left, centered, or right 
alignment  H .

 • Click a horizontal alignment icon to 
move the objects into top, centered, or 
bottom alignment  I .

TIPTIP The align commands move objects based on 
the best representation of the controls. For 
instance, the Align Left command uses the 
leftmost object; Align Top uses the topmost 
object, and so on.

TIPTIP You can use the Lock command (covered later 
in this chapter) to force one object to be the 
reference object for others.

 F  Use the  Align panel  to arrange 
objects in an orderly fashion.

Original 
objects

Align 
Left

Align 
Centered

 Align 
Right

 H  Eff ects of the  vertical alignment icons . 

Original objects Align Top

Align Centered Align Bottom

 I  Eff ects of the  horizontal alignment icons. 

 G  The  Alignment menu  lets you choose 
how the objects should be aligned.
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You can also move objects so the spaces 
between certain points of the objects are 
equal. This is called distributing objects.

To distribute objects:

1. Select three or more objects.
2. Click a distribute icon as follows:

 • Click a vertical distribute icon to move 
the objects so that their tops, centers, 
or bottoms are equally distributed  A .

 • Click a horizontal distribute icon to 
move the objects so that their left 
edges, centers, or right edges are 
equally distributed  B .

You can also distribute objects based on their  
size. This ensures that the space between the 
objects is equal.

To distribute the space between objects:

1. Select three or more objects.
2. Click a distribute space icon as follows:

 • Click the vertical space icon to move 
objects so the vertical spaces between 
them are equal  C .

 • Click the horizontal space icon to 
move objects so the horizontal spaces 
between them are equal  D .

Original 
objects

Distribute 
tops

Distribute 
centers

Distribute 
bottoms

 A  Eff ects of the  vertical distribute icons . 
Notice that the middle object changes 
position to create an even distribution.

Original 
objects

Distribute left 
edges

Distribute 
centers

Distribute 
right edges

 B  Eff ects of the  horizontal distribute icons . 
Notice that the middle object changes 
position to create an even distribution.

Original 
objects

Distribute 
vertical space

 C  Eff ect of the  vertical distribute space icon. 

Original 
objects

Distribute 
horizontal space

 D  The eff ect of the  horizontal 
distribute space command . 
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The Align panel also has controls to space 
objects numerically. You can apply a numeri-
cal distance between the tops, centers, bot-
toms, or sides of objects.

To use spacing to distribute objects:

1. Select two or more objects.
2. Select Use Spacing in the Distribute 

Objects section of the Align panel  E .
3. Enter the numerical distance in the Use 

Spacing field.
4. Click one of the Distribute Objects icons. 

Now the objects are separated by a 
specific space inserted between the tops, 
centers, bottoms, or sides of the objects.

TIPTIP If a positive number moves the objects in the 
wrong direction, use a negative number.

You can also set a specifi c numerical distance 
between the objects themselves. This is very 
useful when you want the same amount of 
space between objects, but the objects them-
selves have diff erent sizes.

To set the spacing between objects:

1. Select two or more objects.
2. Select Use Spacing in the Distribute 

Spacing section of the Align panel  F .
3. Enter the numerical distance in the Use 

Spacing field.
4. Click one of the Distribute Spacing icons. 

Now a specific amount of space is added 
between the objects horizontally or 
vertically.

TIPTIP If a positive number moves the objects in the 
wrong direction, use a negative number.

 E  The  Use Spacing option for Distribute 
Objects  lets you set a specifi c 
distance between the tops, centers, 
bottoms, or sides of objects.

 F  The  Use Spacing option for 
Distribute Spacing  lets you set a 
specifi c distance between objects.

Setting the Anchor Object 
for Alignment

The Align to Selection option in the Align panel 
doesn’t let you designate which object in the 
selection should be used as the reference object 
for the alignment commands. So what if you 
want to designate a specific object to be used 
as the alignment reference object? 

First change the preference that prevents 
the locked object from being selected. (See page 
121.)

Select the object you want to use and apply the 
Object > Lock Position command. Then select 
all the objects and apply the alignment.

The locked object remains stationary and forces 
the other objects to align to it. Then if you need 
to, choose Object > Unlock All on Spread to 
move it and the others.
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Smart Dimensions; Smart 

Spacing

Just as Smart Guides can align to margins and 
objects, they also give you feedback that can 
help you create an object that is the same size 
as another object on the page.

To show or hide Smart Guides:

Choose Window > Grids & Guides > 
Smart Guides. This turns the Smart 
Guides on or off.

One of the options for Smart Guides is the 
Smart Dimensions features. This helps you 
create objects that have the same width or 
height.

To create objects with the same 
dimensions:

1. Create one object that has a certain width 
or height.

2. Drag to create a new object. As you drag, 
watch for a dimension arrow that appears 
next to the width or height  A . This is the 
Smart Dimension indicator that says the 
two objects have the same dimension.

Onother option for Smart Guides is the Smart 
Spacing feature. This make it easy to evenly 
distribute objects so that the spaces between 
them are equal.

To position objects with the same spacing:

1. Create two objects that have a certain 
space between them.

2. Position a third object on the page. As you 
drag, watch for Smart Spacing indicators 
that appear between the objects  B . These 
are the Smart Spacing indicators that say 
the three objects are spaced evenly.

 A  The  Smart Dimension indicators  
appear when an object is the same 
width or height as another.

 B  The  Smart Spacing indicators  appear 
when an object is the same distance away 
from one object as it is from another.
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Using the Gap Tool

Gaps are the spaces between objects. There 
may be times when you want to change 
the size of two objects, but keep the same 
amount of space (gap) between them. The 
Gap tool makes it very easy to change the 
width or height of the objects without aff ect-
ing the size of the gap between them.

TIPTIP The Gap tool can work on either horizontal or 
vertical gaps.

To use the Gap tool to resize objects:

1. Select the Gap tool in the Tools panel  C .
2. Move the cursor inside the space between 

two objects. A gray highlight and double-
headed gap cursor appear. This indicates 
that the gap space has been selected.

3. Drag the cursor up and down for 
horizontal gaps or left and right for 
vertical gaps. The gap remains constant 
while the sizes of the objects change  D .

4. Use the following modifiers to change 
how the Gap tool works:
 • Hold the Shift key to apply the effects 

of the Gap tool to only the two objects 
closest to the cursor  E .

 • Hold the Cmd/Ctrl key to resize the gap 
instead of moving it. 

 • Hold the Opt/Alt key to move the 
objects and the gap without changing 
their sizes. 

 • Hold the Cmd+Opt/Ctrl+Alt keys to 
resize the gap and move the objects. 

TIPTIP The Gap tool can be applied even if there is 
no space between two objects. The Gap tool 
then modifies the size of the objects without 
opening any space between them.

 D  As the Gap tool drags between two objects, 
the  size of the objects changes while 
the size of the gap remains constant.

 C  The  Gap tool in the Tools panel  
changes the size of objects 
without aff ecting the size of the 
space between the objects.

 E  When the Shift key is pressed, the 
Gap tool eff ect is applied only to the 
two objects closest to the cursor.

With 
Shift key

Without 
Shift key
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Grouping and Pasting Into 

Objects

You can group objects so you can easily select 
and modify them as a unit.

To group objects:

1. Select the objects you want to group.
2. Choose Object > Group. A dotted-line 

bounding box encloses all the objects  A .

You can also create groups within groups. This 
is called nesting.

To nest groups:

1. Select the grouped objects.
2. Hold the Shift key and select another 

object or group.
3. Choose Object > Group.

Once you have grouped objects, you can 
select individual objects within the group.

To select groups or objects within groups:

Click once on any item in the group. The 
group is selected as a whole.
or
Double-click to select a specific item in 
the group  B .

TIP The first double-click may act like the Direct 
Selection tool. If so, double-click again to 
select the entire item. 

 A  When selected with the Selection tool, 
 grouped items display a bounding 
box around the entire group .

Ungrouped 
items

Grouped 
items

 B  When selected with the Direct 
Selection tool,  a single item in a 
group is displayed on its own .

Group 
selected

Single item 
selected
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To use commands to select objects within 
groups:

1. Use the Selection tool to select the group.
2. Choose Object > Select > Content. This 

selects the topmost object in the group.
3. Choose Object > Select > Previous 

Object. This selects the object that is 
layered below the selected object.
or
Choose Object > Select > Next Object. 
This selects the object that is directly 
above the selected object.

To ungroup objects:

1. Select the group.
2. Choose Object > Ungroup.
3. If you have nested groups, continue to 

ungroup the objects as necessary.

You can also paste an object into a frame. 
InDesign refers to the object that is pasted as 
the content. It refers to the frame that holds 
the object as the container. 

To paste an object into another:

1. Select the first object and position it over 
the second object  C .

2. Choose Edit > Cut to place the first object 
on the computer clipboard.

3. Select the second object and choose 
Edit > Paste Into. The content appears 
within the borders of the container  D .

TIPTIP To paste multiple objects, group the objects 
together.

To remove pasted-in content:

1. Use the Direct Selection tool to select the 
pasted-in content.

2. Choose Edit > Cut.

TIPTIP The pasted-in content can be placed back on 
the page by choosing Edit > Paste.

 C  An object to be pasted into another 
should be positioned over the other.

 D  The  Paste Into command  displays 
the content only within the 
borders of the container.
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There are some special techniques for 
selecting just the container or the content of 
pasted-in objects.

To select just the container object:

Click on the frame that holds the content 
with the Direct Selection tool to select the 
container  A .
or
Click with the Selection tool and then 
choose Object > Select > Container.

To select just the content object:

Click inside the container with the Direct 
Selection tool to select the content  B .
or
Click with the Selection tool and then 
choose Object > Select > Content.

You use a special technique to move the 
content inside the container.

To move only the content object:

1. Select the content object.
2. Position the Selection tool inside the 

content. A “doughnut” circle appears 
along with the Hand tool. This indicates 
that you can move the content within the 
object.

3. Drag the doughnut circle  C . The content 
moves within the container.

To move only the container:

1. Select the container object.
2. Use the Direct Selection tool to drag 

the container by its center point. The 
container moves without disturbing the 
content.

 A  Click with the Direct Selection tool 
to select just the container.

 B  Click inside the container with the Direct 
Selection tool to select the content.

 C  Use the  selection “doughnut”  
inside the object to move the items 
pasted into the container.
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Using the Control Panel for 

Objects

The Control panel is context sensitive. This 
means it displays diff erent commands 
depending on the number of objects 
selected, or if the objects are grouped or 
pasted-in.

To use the Control panel with a single 
object:

Select an object, grouped object, or 
several objects. The Control panel displays 
the following options  D :
 • Transform panel commands
 • Flip commands
 • Select container, content, next object, 

and previous object
 • Stroke options for width and stroke 

style
 • Effects
 • Text wrap
 • Object styles
 • Alignment controls

 D  The  Control panel  when an object is selected.
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Using the Measure Tool

There are many places where you can fi nd the 
numerical sizes of items. But what if you want 
to measure the distance to another item? 
That’s where the Measure tool is so helpful.

To measure distances using the 
Measure tool:

1. Choose Window > Info to open the Info 
panel.

TIP All amounts measured by the Measure tool 
are displayed in the Info panel.

2. Click the Measure tool in the Tools 
panel  A .

3. Place the Measure tool on the start point 
and drag to the end point. A measuring 
line appears on the page  B . The Info panel 
displays the following attributes  C :
 • Horizontal position displays the X 

coordinate of the first point in the line 
or whichever point is then moved.

 • Vertical position displays the Y 
coordinate of the first point in the line 
or whichever point is then moved.

 • Distance shows the length of the line.
 • Width shows the width of the 

bounding box that would enclose 
the line.

 • Height shows the height of the 
bounding box that would enclose 
the line.

 • Angle shows the angle on which the 
line was drawn.

 A  The  Measure tool in 
the Tools panel .

 B   Drag the Measure 
tool  to measure the 
distance between 
two points.

 C  The  measurements displayed in 
the Info panel  for the measuring 
line drawn with the Measure tool.

Horizontal position

Vertical 
position

Distance

Width

Height
Angle
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Once you have drawn a measuring line, you 
can move it to other areas of the page.

To move a measuring line:

1. With the Measure tool still selected, 
position the cursor over the 
measuring line.

2. Drag the line to a new position  D .

TIPTIP Do not position the cursor over the start or 
end points of the measuring line.

You can also change the start or end points of 
the measuring line.

To reposition the points of the 
measuring line:

1. With the Measure tool still selected, 
position the cursor over either point in 
the measuring line.

2. Drag the point to a new position.

You can also extend a second line out from 
the origin of the measuring line to create an 
electronic protractor to measure angles.

To measure angles:

1. Drag the first line with the Measure tool.
2. Hold the Opt/Alt key and move the 

Measure tool back to the origin of the first 
line. An angle cursor appears  E .

3. Drag to create a second line extending 
out from the origin point  F . The Info 
panel displays the distance of the second 
line, as well as the angle between the 
measuring lines  G .

TIPTIP No bounding box is displayed when two 
measuring lines are created.

 D  Drag the line 
segment of the 
measuring line 
to move it to a 
new position.

 E  The  angle cursor  indicates 
that you are about to create 
a second measuring line.

 F  Two measuring lines 
let you measure 
angles with the 
Measure tool.

 G  The  Info panel display for 
two measuring lines .

Distance 1

Distance 2

Angle
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Using the Info Panel with 

Objects

The Info panel also gives you information 
about the document, text, and placed images.

To see the document information:

Deselect any objects on the page. The 
Info panel displays the following  A :
 • Location of the file on the computer.
 • Last Modified date and time.
 • Author as entered in the File Info 

(File > File Info) dialog box.
 • File size.

To see the text information:

Place your insertion point inside a text 
frame or highlight the text in the frame. 
The Info panel displays the following  B :
 • Characters in the frame or selection.
 • Words in the frame or selection.
 • Lines in the frame or selection.
 • Paragraphs in the frame or selection.

TIP If there is any overset text, it is displayed as a 
number with a plus sign.

To see the placed object information:

 Select a frame that contains a placed 
image, or the placed image itself. The Info 
panel displays the following  C :
 • Type of placed image.
 • Actual ppi (points per inch) resolution 

of the image.
 • Effective ppi resolution of the image if 

you have scaled it in InDesign.
 • Color Space of the image.
 • ICC Profile (if applicable) may also be 

shown.

 A  With no objects selected, the Info panel 
displays  document information .

 B  With text selected, the Info panel 
displays  text information .

 C  With a placed image selected, the Info 
panel displays  placed image information .
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  Locking Objects

You can also lock objects so they cannot be 
moved or modifi ed. This prevents people 
from inadvertently destroying your layout.

To lock the position of an object:

With the object you want to lock selected, 
choose Object > Lock Position. A small 
padlock appears if you try to move or 
modify the object  D .

To unlock objects:

Choose Object > Unlock All on Spread. 
This unlocks the objects and leaves them 
selected on the page.

TIPTIP In previous versions of InDesign, locked 
objects were locked only for position. You 
could still select and change the colors and 
contents of locked objects  E . If you want 
InDesign to work this older way, choose 
Preferences > General and deselect the option 
 Prevent Selection of Locked Objects  F .

 D  The  Padlock cursor  
indicates that 
the Lock Position 
command has 
been applied.

 E  An object that is 
locked and that has 
also been selected.

 F  Deselect the preference  Prevent 
Selection of Locked Objects  to be 
able to select locked objects.
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Selecting Frames

Use this chart as a guide to let you know what 
type of object you have selected and which 
parts of the object can be selected using the 
Selection tool or the Direct Selection tool.

Unassigned frames

Not selected. Selected with Selection tool. 
Notice the bounding box around 
the object.

Selected with Direct Selection tool. 
Notice there is no bounding box.

One point selected with Direct 
Selection tool.

Text frames

Not selected. Notice there is no 
indication that this is a text frame.

Selected with Selection tool.
Notice the bounding box and the 
text in and out ports.

Selected with Direct Selection tool. 
Notice there is no bounding box but 
the text in and out ports are visible.

One point selected with Direct 
Selection tool.

Graphic frames

Not selected. Notice diagonal lines 
that indicate it is a graphic frame.

Selected with Selection tool. Notice 
the bounding box.

Selected with Direct Selection tool. 
Notice there is no bounding box.

One point selected with Direct 
Selection tool.

Graphic frames with a placed image

For more information on working with placed images, see Chapter 8, “Imported Graphics.”
Not selected. Frame selected with Selection 

tool. Notice the bounding box for 
the frame.

Frame selected with Direct 
Selection tool. Notice there is no 
bounding box but the points are 
selected.

Content selected with Direct 
Selection tool. Notice that the color 
of the bounding box for the placed 
image is the inverse of the color of 
the frame’s bounding box.
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5
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Working in Color
When I fi rst started in advertising, 

only the senior creative teams 
could work in color. The junior teams 
were assigned only black-and-white ads. 
Later on they might be able to work on 
a two-color job, but the four-color work 
was handled by senior art directors. 

Fortunately, you’re not limited by such 
constraints. InDesign gives you, right 
from the fi rst day you use it, all the 
color controls you could ever wish for. 
However, with that power comes some 
responsibility.

When you defi ne colors and use them 
on your pages, you are wearing two 
hats. Your fi rst hat is that of a designer 
who looks at the aesthetics of the page 
and then applies colors. This is where 
you have fun with your creativity.

Your second hat is that of production 
manager. Wearing that hat you need 
to understand some of the principles 
of color and printing color documents. 
You also need to make sure your colors 
are defi ned so they print correctly.



124 Chapter 5 Working in Color

 

 

Type of 
color How it is used How it is created Comments

CMYK CMYKCMYK stands for the cyan, magenta, 
yellow, and black inks that are 
combined to create other colors. 
Also called process color, this is 
the primary type of color used in 
color printing. Most magazines and 
brochures are printed using the 
four process color inks.

Use the Color panel 
set to CMYKCMYK or the New 
Color Swatch dialog 
box set to CMYKCMYK or the 
Color Picker in the CMYKCMYK 
mode.

Color images are 
saved in the CMYKCMYK 
mode before they 
are imported into 
InDesign.

RGB RGB stands for the red, green, and 
blue lights that are used in com-
puter monitors to display colors. 
Because RGBRGB colors are based 
on light waves, not inks, there 
will always be a slight diff erence 
between colors defi ned as RGBRGB and 
those defi ned as CMYKCMYK.
RGB colors can be used to defi ne 
colors for documents that will be 
displayed onscreen. But you should 
not use them for print work.

Use the Color panel set 
to RGBRGB or the New Color 
Swatch dialog box 
set to RGB or the Color 
Picker in the RGB mode.

Most digital cameras 
and scanners save 
images as RGBRGB fi les. You 
must use a program 
such as Adobe Photo-
shop to convert those 
images to CMYKCMYK.

LABLAB LABLAB is another light-based color 
model that uses luminance (L) 
combined with the green to red (A) 
plus yellow to blue (B). As with RGB, 
you should not defi ne print colors 
using this system.

Use the Color panel set 
to LABLAB or the New Color 
Swatch dialog box set 
to LABLAB or the Color 
Picker in the LABLAB mode.

The Basics of Color

Here’s a quick primer to help you understand 
what happens when you defi ne and apply 
colors in your InDesign layout, as well as 
other programs.
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Type of 
color How it is used How it is created Comments

Spot 

colors

Spot colors are specialty colors that 
are printed without using the four 
process color inks. For instance, 
a metallic gold in a brochure is 
printed using metallic gold ink, not 
a combination of CMYKCMYK colors.
Spot colors can be mixed to display 
colors that could not be created 
using simple CMYKCMYK colors.

Use the New Color 
Swatch dialog box set 
to Spot.

Spot colors can be 
defi ned by the user 
or you can use the 
commercial spot color 
libraries produced by 
companies such as 
Pantone and Dicolor 
and Toyo.
Other names for spot 
colors are specialty, 
second color, fi fth 
or sixth color, or fl at 
colors.

Tints Tints are colors that have been 
screened so that only a percentage 
of their color appears on the page. 

Tints can be created 
from named colors 
using the New Tint 
dialog box. 

Mixed 

inks

Mixed inks are combinations of at 
least one spot color and another 
spot or process color. 

Mixed inks can be 
created using the 
Swatches panel menu. 
One spot color must 
also have been previ-
ously defi ned.

Mixed Ink Groups are 
combinations of dif-
ferent percentages for 
Mixed ink colors.



126 Chapter 5 Working in Color

Using the Color Panel

There are three diff erent models for defi ning 
colors: CMYK, RGB, and LABLAB. Each model is used 
for diff erent purposes. You choose the color 
mode and mix colors in the Color panel. (See 
Chapter 6, “Fills, Strokes, and Eff ects,” for how to 
apply colors to objects and text.)

To choose the options in the Color panel:

1. If the Color panel is not visible, choose 
Window > Color > Color to open the 
panel  A .

2. If the color sliders are not visible, click the 
panel tab or choose Show Options from 
the Color panel menu  B .

TIP Hold the Shift key as you drag one slider to 
have the others move along with it.

The CMYK color model is used primarily for 
print work. CMYKCMYK colors are mixed using 
percentages of the four inks used in process 
printing: cyan, magenta, yellow, and black.

To defi ne CMYKCMYK colors:

1. Choose CMYKCMYK from the Color panel menu. 
This opens the panel in the CMYKCMYK mode  C .

2. Choose one of the following methods 
to define the amount of cyan, magenta, 
yellow, or black ink in the color:
 • Type a value from 0 to 100 in each of 

the four color fields.
 • Drag the sliders for each of the four 

color fields.
 • Click a color in the CMYKCMYK spectrum area.

TIP Click the solid white or black rectangles to the 
right end of the spectrum to quickly get 100 
percent black or white.

 A  The  Color panel  with the options 
hidden shows only the spectrum 
or ramp for choosing colors.

 B  The  Color panel menu  lets you choose 
among the three color models.

 C  The  Color panel with the CMYKCMYK  (cyan, 
magenta, yellow, and black) color controls.

The Black Color Panel

If your Color panel displays a single slider 
for Black, it is because the Black color in the 
Swatches panel is your default color. Simply 
change it to CMYKCMYK to get the full set of CMYKCMYK color 
sliders.
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The RGBRGB color model is used primarily for 
onscreen work such as presentations and 
Web sites. The RGB colors — red, green, and 
blue — are mixed using representations of 
the three colors of light. This is what you see 
on television screens and computer monitors. 
RGB colors have a wider range of colors than 
CMYKCMYK colors.

To mix RGBRGB colors:

1. Choose RGB from the Color panel menu. 
This opens the panel in the RGB mode  D .

2. Choose one of the following methods to 
define the amount of red, green, or blue 
in the color:
 • Type the value from 0 to 255 in each of 

the three color fields.
 • Drag the sliders for each of the three 

color fields.
 • Click a color in the RGBRGB spectrum area.

 D  The  Color panel set for mixing RGBRGB  
(red, green, blue) color controls for 
onscreen display such as Web sites.

Understanding CMYKCMYK Color

Each of the colors in CMYKCMYK corresponds to one of the inks used in typical four-color printing. Cyan is a shade of 
blue. Magenta is a shade of red. Yellow is … well, yellow. And black is black — I want my baby back.

If you are creating print documents, you will want to define your colors using CMYKCMYK colors. Not only is the CMYKCMYK 
system overwhelmingly used for print work, it is the system you are most familiar with, whether you’re aware 
of it or not. Yellow and cyan make green; magenta and yellow make orange, and so on.

In theory, you shouldn’t need more than three colors for printing. If you mix cyan, magenta, and yellow 
together, you should get a solid black color. In reality, however, those inks are not pure enough to create solid 
black; instead they create a dark brown.

That’s why process printing uses four colors. In addition to cyan, magenta, and yellow, a fourth key color — black, 
indicated by the letter K — is added to create the really black areas. That’s where the term CMYKCMYK comes from.

Mixing Colors in RGBRGB

Maybe some Web designers and video engineers 
can think in RGBRGB, but I confess, I can’t. With the 
RGB sliders, red plus green creates yellow; green 
plus blue creates a shade of cyan, and all three 
colors together create white. To create black, you 
set all three colors to zero. It’s the exact opposite 
of CMYKCMYK where the four colors combine to create 
black.
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The LABLAB color model defi nes colors accord-
ing to a luminance (lightness) component, 
and two color components, A and B. The A 
component defi nes green to red values. The B 
component defi nes blue to yellow values. LABLAB 
colors are device-independent so that colors 
don’t change from one source to another.

TIP The proper name for LABLAB is L*A*B and is 
pronounced by spelling out the name (el-ay-
bee), not by saying the word “LABLAB.”

To mix LABLAB colors:

1. Choose LABLAB from the Color panel menu. 
This opens the panel in the LABLAB mode  A .

2. Choose one of the following methods to 
define the three components of the color:
 • Type the value from 0 to 100 in the L 

field or type the value from -128 to 127 
in the A or B field.

 • Drag the sliders for each of the fields.
 • Click a color in the LABLAB spectrum area.

The out-of-gamut symbol appears if you 
choose an RGBRGB or LABLAB color that cannot be 
printed using process inks  B .

To convert out-of-gamut colors:

Click the small square next to the out-of-
gamut symbol. This converts the color to 
the closest process-color equivalent.

You can use the Color panel to apply colors to 
selected objects.

TIP This technique, although convenient to use, 
creates unnamed colors or colors that are not 
listed in the Swatches panel. (See the sidebar 
“Avoiding Unnamed Colors” for why creating 
unnamed colors can be a problem.)

 A  The  LABLAB Color panel  mixes colors that 
look consistent no matter whether you 
print them or display them onscreen.

Out-of-gamut symbol

Color conversion square

 B  The  out-of-gamut symbol  for RGBRGB 
or LABLAB colors indicates that the color 
shown on screen will not print as 
seen using process color inks.
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To apply colors to a fi ll or stroke:

With an object or text selected, use the 
Color panel to define a fill color. This 
applies the unnamed color to the fill of 
the object or text. 
or
With an object or text selected, use the 
Color panel to define a stroke color. This 
applies the unnamed color to the stroke 
of the object or text. 

TIPTIP You can choose colors by clicking the ramp 
section of the Color panel  C .

TIPTIP You can also drag a color directly from the 
Color panel onto objects  D . This also creates 
unnamed colors.

TIPTIP A square dot appears next to the cursor when 
you drag a swatch color onto objects. This 
indicates you are dragging a fill color onto the 
object.

You can add colors from the Color panel to 
the Swatches panel so you can easily reuse 
them. 

To transfer colors from the Color panel:

1. Define the color in the Color panel.
2. Choose Add to Swatches from the Color 

panel menu. The color appears as a new 
color swatch in the Swatches panel.

 C  With an object selected,  click the 
color ramp in the Color panel  to 
apply a color to an object.

 D   Drag a color from the Color panel  
to apply a color to an object.
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Defining and Storing Swatches

Although it is very quick to create a color 
using the Color panel, you will fi nd it more 
effi  cient to create color swatches. A swatch is 
a color that has been defi ned and is stored in 
the Swatches panel. 

TIP Unnamed colors are not available for all 
places where you use colors. For instance, 
only named color swatches can be used as 
part of text styles. So it is helpful to define 
colors as swatches before you do too much 
work later.

To work with the Swatches panel:

1. If the Swatches panel is not visible, 
choose Window > Color > Swatches to 
open the panel  A .

2. To see the different types of swatches, 
click the icons at the bottom of the panel 
as follows:
 • Show All Swatches displays both the 

color and the gradient swatches.
 • Show Color Swatches displays only 

the color swatches.
 • Show Gradient Swatches displays 

only the gradient swatches.
3. To change the display of the swatches in 

the panel, choose the following from the 
Swatches panel menu:
 • Name displays a list of the swatch 

names in a large typeface.
 • Small Name uses a more compact 

typeface to display the swatch names.
 • Small Swatch displays only the square 

of the swatch color or gradient.
 • Large Swatch displays a larger square 

of the swatch color or gradient.

The Color “Paper”

The swatch labeled [Paper] in the Swatches 
panel allows you to change the background 
color of the pages in your document. This can be 
helpful if your document will be printed on col-
ored paper, specialty paper, or even newsprint 
that is not completely white. You can modify the 
paper color to help judge how your images will 
look when printed.

 A  The  controls for the Swatches panel .

All Swatches

Colors

Gradients

New Swatch

Delete Swatch
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Although you can apply colors to objects 
and text directly from the Color panel, this is 
not considered a good production workfl ow. 
Instead, use the Swatches panel to add the 
color currently defi ned in the Color panel. 

TIPTIP If you apply colors from the Color panel, they 
are called unnamed colors. Unnamed colors 
can cause production problems later on and 
should be avoided. 

To add a color to the Swatches panel:

1. Use the Color panel to define a color.
2. Click the New Swatch icon at the bottom 

of the panel. The new color, named with 
the color values, is automatically added to 
the Swatches panel.

TIPTIP You can also add colors to the Swatches panel 
using the Color Picker.

InDesign also lets you drag colors from the 
Color panel into the Swatches panel.

To drag colors into the Swatches panel:

1. Create the color in the Color panel.
2. Drag the color from the Color panel fill or 

stroke box to the bottom of or between 
two colors in the Swatches panel.

3. Release the mouse button when a black 
line appears in the Swatches panel  B . The 
new color is added and automatically 
takes its name from the color values.

TIPTIP The cursor displays a plus sign as you drag 
the color into the Color panel. On the Mac the 
cursor is the image of a fist. On Windows the 
cursor is an arrow.

 B  You can  drag colors from the Color 
panel  into the Swatches panel.

The Registration Color

“Registration” is a color that is set to print on all 
plates of a document. For instance, if your docu-
ment will be printed using process colors, you 
might want to create a note or mark that should 
be seen on all four plates. Rather than make the 
note in a combination of cyan, magenta, yellow, 
and black, you can apply the color Registration 
to the text for the note. This prints the note as a 
combination of all four inks.
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You can defi ne and add new colors to your 
document using only the Swatches panel. 

To defi ne a new color swatch:

1. Choose New Color Swatch from the 
Swatches panel menu. This opens the 
New Color Swatch dialog box  A .
or
Opt/Alt-click the New Swatch icon at the 
bottom of the Swatches panel.

2. To name the color swatch yourself, 
deselect the checkbox for Name with 
Color Value and then type a name in the 
Swatch Name field.
or
Leave the setting selected to name the 
color swatch using the values that define 
the color. This option is not available for 
spot colors.

3. Choose Process or Spot from the Color 
Type pop-up list  B . 

4. Choose LABLAB, CMYKCMYK, or RGBRGB from the Color 
Mode menu  C .
or
Choose one of the Swatch Libraries at the 
bottom of the Color Mode menu  C . 

5. If you have chosen LABLAB, CMYKCMYK, or RGB, use 
the sliders to change the values from the 
ones originally defined.

6. Click OK. This adds the swatch and closes 
the dialog box.
or
Click Add to add the swatch without 
closing the dialog box. This allows you to 
define additional colors.

 A  Use the  New Color Swatch dialog 
box  to defi ne colors to be added 
to the Swatches panel.

 C  The  Color Mode menu  in the 
New Swatch dialog box.

 B  Use the  Color Type menu  to choose 
either process or spot colors.
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The colors that appear in the Swatches 
panel are displayed with icons that give you 
information about the type of color, the color 
mode, and other attributes  D . Of course, once 
you have defi ned a color swatch, you can 
modify its color defi nition. This changes the 
appearance of all text and objects that use 
that color, even if they are not selected.

TIPTIP The color Black is protected and cannot be 
modified. If you need a variation of Black, 
create a new color swatch.

To modify a color swatch:

1. Select the swatch and choose Swatch 
Options from the Swatches panel menu. 
This opens the Swatch Options dialog 
box  E . These are the same controls as in 
the New Color Swatch dialog box.
or
Double-click the swatch in the panel.

2. Make changes to the color.

TIPTIP Select the Preview checkbox to see how the 
changes affect the colors applied to objects in 
the document.

3. Click OK to apply the changes.

TIPTIP The Swatch Options dialog box does not 
have an Add button. This is because you 
use this dialog box only to modify existing 
colors — not to add new ones.

 D  The  icons in the Swatches panel  
identify the diff erent types of 
colors and color modes.

Spot

RGB

CMYKCMYK

LABLAB

Mixed Ink

Protected

Process

Process or Spot?

Process colors are those printed using small dots of the four process inks: cyan, magenta, yellow, and black. 
Spot colors are printed using special inks. For example, if you look at the process-color green printed in a 
magazine, that color is actually a combination of cyan and yellow printed together in a series of dots. However, 
a spot-color green is printed by using actual green ink. 

One benefit of spot colors is that you can exactly match a special color or use specialty colors such as fluores-
cents or metallics that could never be created using process inks. You can also use a spot color together with 
black as a two-color job. This is cheaper than printing four-color process colors. The benefit of process colors 
is that you use just four inks to create thousands of different color combinations. 

 E  Once you defi ne a swatch, you modify 
it in the  Swatch Options dialog box .



134 Chapter 5 Working in Color

Once you create color swatches, you can 
apply them via the Fill and Stroke controls.

To apply a swatch color:

1. Create the object or text that you want to 
color.

2. Select either the Fill or Stroke icons in the 
Color panel, Tools panel, or Control panel. 
(See Chapter 6, “Fills, Strokes, and Effects,” 
for more information on using the Fill and 
Stroke icons.)

3. Click the color in the Swatches panel. This 
applies the swatch to the object.

To delete swatches:

1. Select the color you want to delete.

TIP To select a series of adjacent swatches, select 
the first swatch and then hold the Shift key 
and select the last swatch in the series. This 
highlights the first and last swatch and all the 
swatches in between.

TIP Hold the Cmd/Ctrl key to select nonadjacent 
swatches.

2. Click the Delete Swatch icon  A  or choose 
Delete Swatch from the Swatches menu.

3. If the swatch is used within the 
document, the Delete Swatch dialog box 
appears, asking how you want to replace 
the deleted swatch  B :
 • To swap the color with one from the 

Swatches panel, choose Defined 
Swatch and then pick a swatch from 
the pop-up list.

 • To leave the color as an unnamed color 
applied to the object, choose Unnamed 
Swatch.

TIP The default swatches None, Paper, Black, and 
Registration cannot be deleted.

 B  The  Delete Swatch dialog box controls  
what happens to colors when they 
are deleted from a document.

 A  Click the  Delete Swatch icon  to 
delete the selected swatches.
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If you have many colors in your document 
that you are not using, you may want to 
delete them to avoid confusion when the fi le 
is sent to a print shop.

To delete all unused swatches:

1. Choose Select All Unused in the Swatches 
panel menu  C .

2. Click the Delete Swatch icon or use the 
Delete Swatch command in the Swatches 
panel menu.

You can also select several swatches and 
merge them into one color.

TIPTIP The Merge Swatches command makes it 
easy to globally replace all instances of one 
defined color with another. 

To merge swatches:

1. Click to select the first color. This is the 
final color that you want the other colors 
to change to.

2. Hold the Cmd/Ctrl key and click to select 
another swatch. This is the color that you 
want to delete.
or
Hold the Shift key and click to select a 
range of swatches. These are the swatches 
you want to delete.

3. Choose Merge Swatches from the 
Swatches panel menu  C . This deletes all 
the swatches except the swatch that was 
first selected. That swatch is applied to 
all text and objects that used the deleted 
swatches. 

 C  The  Swatches panel menu  contains the 
commands for working with color swatches.
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The position that swatches occupy in the 
panel comes from the order in which they 
were created. You can easily change the order 
of the swatches.

To move swatches to new positions:

1. Select a swatch in the panel.
2. Drag the swatch to a new position. A 

black line indicates where the swatch will 
be located  A .

3. Release the mouse button.

You may fi nd it easier to duplicate a swatch 
and modify it than to start from scratch.

To duplicate a swatch:

Select the swatch and choose Duplicate 
Swatch from the Swatches panel menu.
or
Select the swatch and click the New 
Swatch icon.
or
Drag the swatch onto the New Swatch 
icon.

You can save a selection of swatches for use 
in other InDesign documents, or in Adobe 
Illustrator or Adobe Photoshop documents.

To save selected swatches:

1. Select the swatches in the Swatches panel 
that you want to save.

2. Choose Save Swatches For Exchange from 
the Swatches panel menu.

3. Use the operating system dialog box to 
save the swatches as an Adobe Swatch 
Exchange (.ase) file.

 A   Drag a swatch  to move it from 
one position to another.

The Cost of Unused Colors

Why is it important to delete unused colors?

One reason is if you are going to send your 
documents to a service bureau or print shop for 
final output. It can be confusing to the people 
who are going to open your file if they see many 
colors in a document that’s supposed to be 
printed in black and white.

At the very least, they’re going to wonder if 
they’ve received the right instructions. At the 
worst, they’ll delay printing the file until they 
talk to someone to make sure.

Also, it may seem like a little thing, but every 
color adds to the size of the file. Even in these 
days of huge hard drives, it’s always better to 
keep your files as lean as possible. 
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You can import the swatches from one 
InDesign document into another. You can also 
import the swatches from an Adobe Swatch 
Exchange fi le.

To import swatches from other documents:

1. Choose Load Swatches from the Swatches 
panel menu. The operating system dialog 
box appears.

2. Navigate to find the document or Adobe 
Swatch Exchange file you want to import 
swatches from.

3. Click Open. The swatches are imported 
into the current document.

Unnamed colors are colors that are applied 
to objects directly from the Color panel or the 
Color Picker instead of through the Swatches 
panel. It is a good idea not to have unnamed 
colors fl oating around your document. Fortu-
nately, you can easily convert unnamed colors 
into named colors.

To name unnamed colors:

Choose Add Unnamed Colors from the 
Swatches panel menu. All unnamed 
colors are added to the panel named with 
their percentage values.

You can create colors that are available as the 
default colors for all new documents.

To create default colors:

1. Close all documents but leave InDesign 
running.

2. Use any of the methods in this section, 
“Defining and Storing Swatches,” to define 
and store a color in the Swatches panel. 
The color will appear in the Swatches 
panel of all new InDesign documents.

Avoiding Unnamed Colors

Why do I warn you against creating unnamed 
colors? Why may your service bureau warn you 
not to create unnamed colors? 

Your job will most certainly print, even with 
unnamed colors. The problem comes when 
someone checks to make sure all your colors 
are defined correctly.

Because the unnamed colors don’t appear in the 
Swatches panel, there is no way for someone to 
easily find or make a universal change to the 
colors in your document. So the checker will 
have to search, page by page, to see if there are 
any unnamed colors.

So although there is nothing actually wrong 
with unnamed colors, it is better to always use 
the Swatches panel to apply colors. That way 
you’ll have more control over the colors in your 
document.
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Using Swatch Libraries

Rather than defi ning your own color mix-
tures, you can use the swatch libraries for 
professional color systems from companies 
such as Pantone or Trumatch. These color 
libraries usually have printed samples that 
you can refer to in order to see how the color 
will appear when printed.

To add colors from swatch libraries:

1. Open the New Color Swatch dialog box or 
the Swatch Options dialog box.

2. Choose one of the swatch libraries listed 
in the Color Mode list  A . This displays the 
colors in the library  B .

3. Scroll through the library to select the 
color you want to add to your document.
or
Instead of scrolling through a long list, 
type the name or number associated with 
the color in the Swatch Library field.You 
can use the swatch libraries to open color 
panels from other InDesign documents 
and Adobe Illustrator documents.

Every InDesign document acts like its own 
color library. You can then open the colors in 
an InDesign document just as you do when 
opening a commercial color library.

To import swatches from other documents:

1. Choose Other Library from the Color 
Mode list  A .

2. Navigate to select the InDesign document 
that contains the colors you want to use.

3. Press OK. The colors appear in the 
Swatches panel.

 A  The  swatch libraries  in the Color Mode list.

 B  An example of the window that 
displays  a swatch library , such as 
the Pantone Solid Coated colors.

Swatch Library field



InDesign CS5 Visual Quickstart Guide 139

Creating Mixed Inks

Mixed inks is the term InDesign uses for a 
color that combines a spot color with other 
spot colors or process colors. Mixed inks give 
you more fl exibility in creating colors, espe-
cially for two-color jobs.

TIPTIP The command to create mixed inks is not 
available unless you have first defined a spot 
color in the Swatches panel.

To create a single Mixed Ink swatch:

1. Choose New Mixed Ink Swatch from the 
Swatches panel menu. This opens the 
New Mixed Ink Swatch dialog box  C .

2. Enter a name for the mixed ink swatch.
3. Click the ink controls to select the colors 

in the mixed ink swatch. You must choose 
two inks, and one of them must be a spot 
color ink  D .

4. Use the sliders or fields to set the amount 
of each ink in the swatch.

5. Click the OK button to create the mixed 
ink swatch.
or
Click the Add button to create the mixed 
ink swatch and then use the dialog box to 
define a new mixed ink swatch.

 C  The  New Mixed Ink Swatch dialog 
box  allows you to combine a 
spot color with other colors.

Ink option Ink namesPreview Sliders Fields

Active inkNonactive ink

 D  Use the  ink controls  to defi ne the 
colors in the mixed ink swatch.

Using Mixed Ink Swatches

Mixed ink swatches have a variety of uses. Perhaps the most common use is to define a mixed ink as a single 
spot color plus a percentage of process black. This allows you to create a slightly darker version of a spot color. 
I find this extremely helpful when working on two-color jobs where I need to darken my spot color.

You can also use mixed ink swatches to combine two spot colors. For instance, you can combine a spot yellow 
with a spot blue to create a green mixed ink swatch. However, be careful when you try to mix spot colors. The 
color in the preview box is only a very rough representation of the actual color on press.

Finally, you can use mixed inks to combine varnishes with process colors. This is a sophisticated technique 
and you should consult with your print shop.
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You might want to create a collection of 
mixed inks that combine colors in an increas-
ing series of mixtures. InDesign calls this a 
Mixed Ink Group and makes it easy to auto-
matically create the mixtures of colors.

TIP A Mixed Ink Group makes it easy to create 
a variety of mixed inks that can be quickly 
applied as you work. 

To create a Mixed Ink Group:

1. Choose New Mixed Ink Group from the 
Swatches panel menu. The New Mixed Ink 
Group dialog box appears  A .

2. Enter a name for the group in the Name 
field.

3. Click the Inks controls to select the colors 
in the mixed ink swatch. You must choose 
at least two inks and one of them must be 
a spot color ink.

4. Use the Initial field to define the amount 
of color that the first instance of an ink 
has  B .

5. Use the Repeat field to set how many new 
mixed inks will be created with the color.

TIP Set the Repeat to zero to keep that color 
constant throughout the mixed ink group.

6. Use the Increment field to set the color 
increases for each new mixed ink.

7. Click OK to create the Mixed Ink Group. 
The group appears in the Swatches panel.

 A  The  New Mixed Ink Group dialog 
box  allows you to automatically 
create a series of mixed inks.

 B  Use the Inks controls to set the mixed ink 
colors, the initial amounts, the repetitions, 
and the increments by which they change.
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Once you have created a mixed ink group, 
you can make changes to the entire group or 
the individual swatches in the group.

To modify all the swatches in a mixed ink 
group:

1. Select the mixed ink group in the 
Swatches panel and choose Swatch 
Options from the Swatches panel menu.
or
Double-click the name of the mixed ink 
group in the Swatches panel. The Mixed 
Ink Group Options dialog box appears  C .

2. Use the Name field to change the name of 
the group.

3. Use the Inks controls to delete inks from 
the mixed ink group.

TIPTIP Although you can delete inks from the group, 
you cannot add inks. So a two-ink group can’t 
be changed to a three-ink group.

4. Use the Inks list to swap one ink for 
another  D . The list shows both the 
process and spot colors in the document.

5. If desired, select Convert Mixed Ink 
Swatches to Process. This changes all the 
colors in the mixed ink swatches to their 
process color equivalents.

TIPTIP The option to convert the colors to process is 
permanent and cannot be changed except as 
part of InDesign’s undo chain.

6. Click OK. The changes are applied to the 
inks used in the mixed ink swatches that 
you originally created.

TIPTIP Watch out! Once you have deleted inks from 
the mixed ink group, you can’t go back and 
add them to the mixed ink group. You’ll have 
to regenerate the entire mixed ink group.

 C  Use the  Mixed Ink Group Options 
dialog box  to make changes to the 
inks used in a mixed ink group.

 D  Use the  Inks list  to change the 
colors used in a mixed ink group.
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Creating Tints

Tints are screened, or lighter, versions of 
colors. Spot color tints create screens of the 
base color. Process color tints reduce the 
amounts of the process inks that defi ne 
the color.

To create a tint swatch:

1. Select the base color, that is, the swatch 
color that you want to tint.

2. Use the Tint field in the Swatches panel to 
create a screen of the swatch color  A .

3. Click the New Swatch icon to store 
the tint percentage as a swatch in the 
Swatches panel.

TIP The tint swatch appears in the Swatches 
panel with the same name as the base color 
but with the tint percentage listed  B .

TIP The tint field percentage continues to tint 
other swatches in the panel until you reset 
the field to 100%.

As you select a color swatch as a base color, 
the Color panel displays a slider and a ramp of 
the color.

To tint a swatch using the Color panel:

1. Select the swatch color that you want 
to tint.

2. In the Color panel, use the slider or click 
in the ramp to create a percentage of the 
base color  C .

3. Click the New Swatch icon to create a tint 
swatch of the percentage you defined.

 C  The Color panel displays  a slider and 
tint ramp  when a base color is chosen.

 A  Use the  Tint fi eld  to create a screened 
version of a swatch color.

 B  A  tint swatch  is listed with the same name 
as the base color and the tint percentage.
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You can also create a tint swatch using the 
Swatches panel menu.

To store a tint swatch of a color:

1. In the Swatches panel, select the base 
color, that is, the color you want to tint.

2. Choose New Tint Swatch from the 
Swatches panel menu. The New Tint 
Swatch dialog box appears  D .

3. Adjust the tint slider to a percentage.
4. Click OK. The tint swatch appears in the 

Swatches panel with the same name 
as the base color but with the tint 
percentage listed.
or
Click Add to add the tint to the Swatches 
panel and then create additional tints.

Once you store a tint swatch, you can modify 
the tint percentage. This updates all the 
objects that use that tint swatch. 

To modify tint swatches:

1. Double-click the name of the tint swatch 
in the Swatches panel. This opens the 
Swatch Options dialog box for tints.

2. To change the tint value, adjust the Tint 
slider at the bottom of the dialog box.

3. Click OK to apply the changes.

TIPTIP Anytime you modify the swatch used as 
a base color, all tints of that color update 
automatically.

 D  The  New Tint Swatch dialog box  lets 
you set the percentage of a tint.
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Using the Color Picker

If you have used Photoshop, you are prob-
ably familiar with Photoshop’s Color Picker, 
which is accessed through the foreground 
or background color icons in the Tools panel. 
InDesign also has a Color Picker, which is 
opened through the Tools panel.

To defi ne a color using the Color Picker:

1. Double-click either the Fill icon or the 
Stroke icon in the Tools panel  A . This 
opens the Color Picker.

2. Use the RGB, LABLAB, or CMYKCMYK fields ( B ,  C , 
and  D ) to define the color.

3. Click OK to apply the color to the current 
fill or stroke.

TIP When you click the RGBRGB or LABLAB controls, the 
Color Space area at the left of the dialog box 
displays one of those color controls. When 
you click the CMYKCMYK controls, however, the 
Color Space area does not display the CMYK 
color controls.

To defi ne a color swatch using the Color 
Picker:

1. Double-click either the Fill icon or the 
Stroke icon in the Tools panel to open the 
Color Picker.

2. Use the RGB, LABLAB, or CMYKCMYK fields to define 
the color.

3. Click the Add [RGBRGB, LABLAB, or CMYKCMYK] Swatch 
button to add the color to the Swatches 
panel.

4. Click OK to close the Color Picker.

 B  The  Color Picker in the RGBRGB mode  lets 
you defi ne and store RGBRGB colors.

RGB controls

 C  The  Color Picker in the LABLAB mode  lets 
you defi ne and store LABLAB colors.

LABLAB controls

 D  The  CMYKCMYK controls  let you defi ne 
and store CMYKCMYK colors.

CMYKCMYK controls

 A  The  Fill and Stroke icons  let 
you open the Color Picker.
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Creating Gradient Swatches

Gradients are blends that change from one 
color into another. InDesign creates gradi-
ents as swatches that can then be applied 
to objects. (See Chapter 6, “Fills, Strokes, and 
Effects,” for information on applying gradients.)

To defi ne a gradient:

1. Choose New Gradient Swatch from the 
Swatches panel menu. The New Gradient 
Swatch dialog box appears  E .

2. Enter a name for the gradient in the 
Swatch Name field.

3. Choose Linear or Radial in the Type 
field  F .

4. Click a color stop on the gradient ramp to 
define a color in the gradient  G .

5. Choose the type of color for the selected 
stop from the Stop Color list  H :
 • Swatches shows you the list of colors in 

the Swatches panel.
 • LABLAB, CMYKCMYK, or RGB displays the sliders 

that let you define the color using the 
LABLAB, CMYKCMYK, or RGB values. 

6. Click the other gradient stop to define a 
color for it.

7. Adjust the midpoint control to change 
the position where the two colors blend 
equally.

8. Click OK to add the gradient to the 
Swatches panel  I .
or
Click the Add button to add the current 
gradient to the Swatches panel and 
continue defining additional gradients.

TIPTIP If you don’t see the gradient listed in the 
Swatches panel, click either the Show All 
Swatches or Show Gradient Swatches icon at 
the bottom of the Swatches panel.

 E  Use the  New Gradient Swatch dialog box  
to defi ne a gradient of blended colors.

 G  Use the color stops and midpoint 
controls along the gradient 
ramp to modify a gradient.

Color stop Midpoint control

 F  A linear gradient changes colors 
along a line. A radial gradient changes 
colors in a circular pattern.

Linear gradient Radial gradient

 H  Use the  Stop Color menu  to 
choose the format for the colors 
used for the color stops.

 I  Gradients are stored in the  Swatches panel .
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All gradients must have at least two colors. 
However, you can easily add more colors to a 
gradient by using the color stops.

To add gradient color stops:

1. Open the New Gradient Swatch 
dialog box.
or 
Select a gradient and choose Swatch 
Options from the Swatches panel menu.

2. Click the area below the gradient ramp. 
This adds a color stop to the ramp area  A .

3. Make whatever changes you want to the 
color stop.

4. If necessary, move the color stop to a new 
position.

5. Click OK to apply the changes to the 
gradient swatch.

To delete a gradient color stop:

Drag the color stop away from the ramp 
area and release the mouse button  B . The 
gradient reblends according to the colors 
that remain.

To modify a gradient swatch:

1. Select the gradient swatch and choose 
Swatch Options from the Swatches panel 
menu. This opens the Gradient Options 
dialog box.
or
Double-click the gradient in the panel.

TIP Use the Preview checkbox to see how 
the changes affect the gradients in the 
document.

2. Adjust the midpoint, color stops, or 
gradient type.

3. Click OK to apply the changes.

 A   Click under the gradient ramp  to 
add a color stop to the gradient.

 B   Drag a color stop off  the gradient ramp  
to delete that color from the gradient.
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Just as you can create colors on the fl y, you 
can also create gradients without using the 
Swatches panel. These gradients are created 
only within the Gradient panel and are not 
stored in the Swatches panel.

To work with the Gradient panel:

1. Choose Window > Gradient to open the 
Gradient panel  C .

2. Choose Show Options from the Gradient 
panel menu to see all the controls.

To create gradients from the Gradient 
panel:

1. Use the Type pop-up list to choose 
between Linear and Radial.

2. Select a color stop and adjust the sliders 
in the Color panel to define the color at 
that position.
or
Hold the Opt/Alt key and click the name 
of a swatch in the Swatches panel.

3. Select another color stop and use the 
sliders in the Color panel to define the 
color at that position. 

4. Set the angle of the gradient in the Angle 
field.

5. Click the Reverse icon to reverse the 
positions of the color stops.

Once you have a defi ned a gradient in the 
Gradient panel, you can store it as a swatch.

To store an unnamed gradient:

1. Create the gradient in the Gradient panel.
2. Click the New Swatch icon in the 

Swatches panel.
or
Drag the preview of the gradient from the 
Gradient panel into the Swatches panel.

3. Double-click the name of the gradient in 
the Swatches panel to rename it.

 C  Use the  Gradient panel  to 
create on-the-fl y gradients.

Process and Spot Colors in Gradients

A gradient that’s defined using process colors is 
separated onto CMYKCMYK plates.

A gradient that contains two tints of the same 
spot color will be separated onto the single spot 
color plate. If you want the gradient to fade to 
white, create a gradient between the spot color 
and a 0% tint of the spot color. 

You can create a gradient between two spot 
colors. However, to avoid moiré patterns in 
the gradient, you must assign different screen 
angles to those spot colors in the Inks dialog box.

For instance, if you had a gradient of spot red to 
spot yellow, you would want to make sure each 
color had a screen angle that was 45 degrees 
different from the other. Ask your print shop 
for details on setting the screen angles for spot 
colors.

A gradient that contains both spot and process 
colors will be separated onto both the spot and 
process color plates.
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Using the Eyedropper

The Eyedropper tool lets you sample colors 
from graphics that are placed in your docu-
ment. (See Chapter 8, “Imported Graphics,” for 
more information on placing graphics.)

To sample and store colors from placed 
graphics:

1. Click the Eyedropper tool in the Tools 
panel  A .

2. Move the Eyedropper cursor over the 
color of a placed graphic  B .

3. Click to sample the color.

TIP If you have already used the Eyedropper 
to sample a color, hold the Opt/Alt key to 
sample a new color.

4. Click the New Swatch icon in the 
Swatches panel. The sampled color is 
stored as a color swatch.

TIP The Eyedropper samples the color in the 
same color mode as the placed graphic. So 
RGB images yield RGBRGB colors, and CMYK images 
yield CMYK colors.

TIP The Eyedropper can also sample and apply 
fills, strokes, and transparency attributes of 
objects and text formatting. (See Chapter 6, 
“Fills, Strokes, and Effects,” and Chapter 14, 
“Automating Your Work.”)

 B  Click with the  Eyedropper tool  over an 
area of an image that you want to sample.

 A  The  Eyedropper tool  
lets you sample colors 
from placed images.
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Using the Kuler Panel

The Kuler (pronounced coo-ler) panel is both 
a part of the InDesign application for generat-
ing colors as well as an online service that lets 
you download color palettes from others. I’m 
going to limit this section to just the part that 
works within InDesign.

To open the Kuler panel:

1. Choose Window > Extensions > Kuler.
2. If the panel opens to the About or Browse 

tabs, click the Create tab. This is the 
part of the panel that works without an 
internet connection  C .

Although the Kuler panel may seem com-
plicated, it is easy to use when you break it 
down into simple steps. The most important 
step is to fi rst create a base color.

To create a base color in the Kuler panel:

Use one of the following techniques to 
choose a base color:
 • Click the Add Current Fill Color icon to 

use the fill color in the document  D .
 • Click the Add Current Stroke Color 

icon to use the stroke color in the 
document  D .

 • Use the color sliders to generate a 
color  D .

 • Enter a value in the Hex field  D .
The base color swatch is indicated in the 
Kuler panel  E .

TIPTIP Unfortunately, the Kuler panel only creates 
RGB colors. If you do use the panel to create 
swatches in InDesign, you must then select 
those swatches and use the Swatch Options 
dialog box to convert them to CMYK and 
change the naming convention. I sincerely 
hope Adobe fixes this feature in future 
versions of Kuler.

 C  The  Kuler panel  set to the Create tab.

 E  The  Base Color  in the Kuler panel.

 D  Use the  color controls  to set a 
base color in the Kuler panel.

Add Current Fill Color Add Current Stroke Color

Color sliders

Hex field
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Once you have a base color, you can use 
the Kuler color rules to create harmonious 
themes.

To choose a color harmony rule:

Use the Select Rule menu to choose one 
of the following color harmony rules  A :
 • Analogous
 • Monochromatic
 • Triad
 • Complementary
 • Compound
 • Shades

or
Choose Custom to set your own color 
harmony.

You’re not limited to just the original base 
color harmonies. You can easily change the 
colors using the interactive color wheel.

To use the Kuler interactive color wheel:

1. Drag any one of the color indicators in the 
color wheel to a new position. The other 
indicators move according to the color 
rule in place  B .

2. Use the Brightness slider to add or 
remove black from the selected color.

TIP With certain color rules, you will not be able 
to separate the color indicators from the 
others.

Why Dave Awl Loves Kuler

I’m more of a production person so generating 
color palettes using Kuler is not important to 
me. But here’s an example of how you may enjoy 
using Kuler. Dave Awl, who helps me update my 
books, uses Kuler as follows.

First he samples a color in an image using 
InDesign’s Eyedropper tool. Then he uses the 
Kuler panel to generate a palette of compli-
mentary colors.

Dave says it’s faster and easier to rely on Kuler’s 
harmonies than to guess which colors belong 
together.

 A  The  Select Rule menu  in the Kuler panel.

Brightness 
slider

 B  Dragging a color in the  Interactive 
Color Wheel  in the Kuler panel.



InDesign CS5 Visual Quickstart Guide 151

Overprinting Colors

Overprinting is a technique that allows you 
to set the color of one object to mix with 
any colors underneath. For instance, without 
overprinting, a yellow object placed over a 
blue background knocks out the blue and 
prints as yellow. But with overprinting turned 
on, the yellow object mixes with the blue 
background to create green.

To set a fi ll or stroke to overprint:

1. Select the object.
2. If the Attributes panel is not visible, 

choose Window > Output > Attributes 
to open the panel  C .

3. Select Overprint Fill to set the object’s fill 
color to overprint.

4. Select Overprint Stroke to set the object’s 
stroke color to overprint.

5. Select Overprint Gap to set the color 
of the gap applied to stroke effects to 
overprint.

TIPTIP Select Nonprinting in the Attributes panel to 
set an object not to print. This is helpful if you 
want to add comments for production use 
that aren’t meant to be seen in the finished 
piece.

InDesign lets you see a simulation of over-
printing onscreen.

To turn on the overprint preview:

Choose View > Overprint Preview. 
InDesign shows the effects of those colors 
set to overprint  D .

 C  Use the  Attributes panel  to set the 
colors of an object to overprint.

 D  Turn on the  Overprint Preview command  
to see the eff ects of overprinting onscreen.

On

Off
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Fills, Strokes, and Effects
Here’s where you get a chance to 

express your creativity. Styling refers 
to applying fi lls, strokes, gradients, and 
eff ects to frames, lines, and text. If you’re 
bored with plain black text on a white 
background, InDesign lets you change 
the text and background colors to almost 
anything you can imagine.

Most other graphics programs let you 
style objects and text with fi lls, strokes, 
and gradients. InDesign certainly does 
that also.

However, InDesign off ers a plethora of 
amazing eff ects such as transparency, 
drop shadows, and glows. Although 
it has always been possible to create 
these eff ects in programs like Adobe 
Photoshop, having them in a page 
layout program makes it very conve-
nient to apply those eff ects on the fl y.

Meanwhile, it is not true that the Adobe 
End User Licensing Agreement (EULA) 
requires you to apply a drop shadow to 
every job you do in InDesign. 



154 Chapter 6 Fills, Strokes, and Effects

Applying Fills

Fills are the eff ects applied to objects, which 
can be the interior of frames or text within a 
frame. So you can apply one color fi ll to the 
text inside a frame and another color fi ll to 
the frame itself. A fi ll can be a solid color or a 
gradient.

To apply a fi ll to an object:

1. Select an object.
2. Make sure the Container icon is chosen in 

the Tools panel or the Swatches or Color 
panel  A . This indicates that the object will 
be modified.

3. Click the Fill icon in the Tools panel or in 
the Swatches or Color panel  B .

4. Choose a color or gradient in the Color, 
Gradient, or Swatches panel.

You don’t have to select an object to apply a 
fi ll. You can just drag a swatch onto any object 
to apply a color or a gradient.

To drag fi ll eff ects onto objects:

1. Drag a gradient or color swatch from 
the Tools panel or the Color, Gradient, or 
Swatches panel onto the object  C .

2. Release the mouse button when the 
swatch is inside the object. A square dot 
appears to indicate you are inside the 
object.

TIP If you release the mouse button when the 
swatch is on the edge of the object, you will 
apply the effect to the object’s stroke instead 
of the fill.

Tools panel Color panel Swatches panel

 A  The  Container icons  indicate an eff ect 
will be applied to an object, not text.

Tools panel Color panel Swatches panel

 B  The  Fill icons  indicate an eff ect will 
be applied inside an object.

 C  You can drag a swatch inside 
an object to apply a fi ll.
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You can also apply fi ll colors to selected text 
in a text frame.

To apply a fi ll to selected text:

1. Use the Text tool to highlight the text.
2. Click the Fill icon in the Tools panel or the 

Swatches or Color panel.
3. Choose a swatch in the Color, Gradient, or 

Swatches panel  D .

TIPTIP When text is highlighted, the color of the text 
is inverted. Deselect to see the actual text 
color.

You can also apply a fi ll to all the text in a 
frame with just the frame selected.

To apply a fi ll to all the text in a frame:

1. Select the text frame that contains the 
text to which you want to apply the fill.

2. Click the Fill icon in the Tools panel or the 
Swatches or Color panel.

3. Click the Text icon in the Tools panel or 
the Swatches or Color panel  E .

TIPTIP The T inside the Fill icon indicates the text will 
be affected, not the frame  F .

4. Choose a swatch in the Color, Gradient, or 
Swatches panel.

You can also apply a gradient to text or 
objects.

To apply a gradient fi ll:

1. Click the Fill icon in the Tools panel or 
the Swatches or Color panel with the 
container or text icons selected.

2. Click the Gradient icon in the Tools 
panel  G .
or
Click a gradient in the Swatches or 
Gradient panel. The gradient is displayed 
in the Fill box  H .

 D  Choose a swatch to apply the color 
or gradient to selected text.

Tools panel Color panel Swatches panel

 E  The  Text icons  (circled) set an eff ect to be 
applied to all the text within a frame.

 G  The  Gradient icon in the 
Tools panel  indicates 
that a color or gradient 
will be applied.

 H  The  gradient in the 
Fill box  indicates that 
the gradient will be 
applied as a fi ll.

Color panel Swatches panel

 F  The  T inside the Fill icon  (circled) 
indicates that text is going to be styled.

Tools panel
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Once you have applied a gradient to an 
object or text, you can modify how it is 
applied using the Gradient tool.

To adjust a gradient fi ll:

1. Select the object that contains the 
gradient you want to modify.

2. Choose the Gradient tool in the Tools 
panel  A .

3. Drag the Gradient tool along the angle 
that the linear gradient should follow  B .
or
Drag the Gradient tool to define the start 
and end points of a radial gradient  C .

TIP The start of the drag positions the first color. 
The end of the drag positions the final color.

 C  Drag with the Gradient tool to set the 
start and end points of a radial gradient.

Gradient start

Gradient end

 A  The  Gradient tool in the Tools 
panel  lets you modify the 
appearance of gradients.

 B  Drag the Gradient tool to set 
the start and end points and the 
angle of a linear gradient.

Gradient start

Gradient end

Angle of gradient
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You can also apply a fi ll of None to an object. 
This makes the background of the object 
transparent  D .

To apply a fi ll of None:

1. Select the object.
2. Click the None icon in the Tools panel or 

the Swatches or Color panel  E .

TIPTIP If the object is not in front of others, you may 
not see a difference between a white and a 
none fill. Check the icon to be sure  F .

Another way to style objects is to create a 
compound path. A compound path allows 
one path to punch a hole in another. This 
makes the inside path trans parent while the 
outside path is solid  G .

To create a compound path:

1. Select two paths that overlap.
2. Choose Object > Paths > Make 

Compound Path.

TIPTIP If the second object is not completely 
contained inside the first, the hole appears 
only where the objects overlap.

TIPTIP Compound paths must contain the same fill 
and stroke effects.

You can release a compound path back to 
separate objects to restore the inside path to 
a solid color.

To release a compound path:

1. Select the compound path.
2. Choose Object > Paths > Release 

Compound Paths.

THE CYCLONE!

THE CYCLONE!

 D  The diff erence between a text frame 
with a white fi ll and a none fi ll.

White fill

None fill

Tools panel Color panel Swatches panel

 E  The  None icons  (circled) apply 
no color to an object.

 F  The  None symbol in the Fill icon  
(circled) indicates there is no color 
for the fi ll applied to the object.

Color panel Swatches panelTools panel

THE CYCLONE!

THE CYCLONE!

 G  An example of how a compound 
path creates a hole in an object.

Before

After
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Applying Stroke Effects

Strokes are the eff ects applied to the edge of 
objects and text, or along lines.

To apply a stroke to an object:

1. Select the object.
2. Make sure the Container icon is chosen in 

the Tools panel or the Swatches or Color 
panel. This indicates that the object will 
be modified.

3. Click the Stroke icon in the Tools panel or 
the Swatches or Color panel  A .

4. Choose a swatch in the Color, Gradient, or 
Swatches panel. 

You can also apply a stroke color by dragging 
a swatch onto the edge of any object on the 
page.

To drag stroke eff ects onto objects:

1. Drag a gradient or color swatch from 
the Tools panel or the Color, Gradient, 
or Swatches panel onto the edge of the 
object.

2. Release the mouse button when you see 
a small line appear next to the mouse 
cursor  B . This applies the color or gradient 
to the stroke.

TIP If you release the mouse button when the 
swatch is inside the object, you apply the 
effect to the object’s fill instead of the stroke.

InDesign makes it easy to swap the fi ll and 
stroke colors applied to an object.

To swap the fi ll and stroke settings:

Click the double-headed arrow in the 
Tools panel  C . This switches the colors of 
the fill and stroke applied to the object.

Tools panel Color panel Swatches panel

 A  The  Stroke icons  (circled) set an eff ect to be 
applied to the outside of an object or text.

 B  Drag a swatch onto the edge to 
apply a stroke eff ect to an object.

 C  Click the Swap Fill and 
Stroke icon in the Tools 
panel to switch the settings.
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You can also add a color or gradient stroke 
to the outside edges of text with a color or 
gradient  D .

To apply a stroke to selected text:

1. Use the Text tool to highlight the text.
2. Click the Stroke icon in the Tools panel or 

Color panel  E .
3. Choose a swatch in the Color, Gradient, or 

Swatches panel.

To apply a stroke to all the text in a frame:

1. Select the text frame that contains the 
text to which you want to apply the 
stroke.

2. Click the Text button in the Tools panel or 
Color panel.

3. Click the Stroke icon in the Tools panel or 
Color panel.

4. Choose a swatch in the Color, Gradient, or 
Swatches panel.

You can also apply a gradient as a stroke to 
text or objects.

To apply a gradient stroke:

1. Click the Stroke icon in the Tools panel or 
the Swatches or Color panel.

2. Click the Gradient icon in the Tools panel 
or the Swatches or Gradient panel.

3. Use the Gradient tool to modify the angle 
or length of the gradient applied to a 
stroke.

TIPTIP A linear gradient applied as a stroke creates a 
beveled effect. This may be combined with a 
solid or gradient fill for a three-dimensional 
effect.

Dorothy
DorothyDorothy

 D  A stroke eff ect applied to text.

Stroke Text Gently

If you have worked with desktop publishing 
programs, you may have seen that strokes on 
text deform the shape of the characters. This 
happens because the stroke is applied on both 
the outside and the inside of the text. As a result, 
most teachers like me warned our students 
never to add a stroke to text — not in headlines 
and never in body copy.

Although InDesign does put its strokes only on 
the outside of text, it does stroke the inside of 
bowls such as the holes in a lower case p. This 
results in a slight deformity in the text.

So, try to avoid adding a stroke to text. And if 
you absolutely must, keep the size of the stroke 
to a minimum.

Tools panel Color panel Swatches panel

 E  The outlined T in the Stroke icon 
(circled) indicates that a stroke 
has been applied to text.
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Color is only one aspect of a stroke eff ect. The 
Stroke panel controls the rest of the stroke 
attributes.

To work with the Stroke panel:

If the Stroke panel is not visible, choose 
Window > Stroke to view it  A .
or
If the Stroke panel is behind other panels, 
click the Stroke panel tab.

One of the most important attributes of a 
stroke is its thickness. This is controlled by 
changing the stroke weight  B . 

To set the stroke weight (thickness):

1. Select the object.
2. Use the Weight field controls to set the 

thickness of the stroke  C .

TIP The stroke can be positioned on the outside, 
in the center, or inside the path using the 
Align Stroke controls.

 A  The Stroke panel with all its 
options displayed.

 B  Diff erent stroke weights.

.5 point 1 point 2 point 6 point 8 point

 C  The Weight controls let you 
change the stroke thickness.
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A stroke’s style is also controlled by the 
end caps and joins, which form points and 
corners.

To set the caps and joins:

1. Select an object that has a stroke applied 
to it.

2. In the Stroke panel, use the Cap icons  D  to 
change the way the ends of open paths 
are treated  E :
 • Butt ends the stroke in a square. This is 

the default setting for a plain stroke.
 • Round ends the stroke in a semi-circle.
 • Projecting ends the stroke in a square 

that extends out from the end point.

TIPTIP The Cap settings have no effect on closed 
paths such as rectangles, ellipses, and 
polygons.

3. Use the Join buttons  F  to change the 
way two segments of a path meet at 
corners  G :
 • Miter joins the segments at an angle.
 • Round joins the segments with a curve.
 • Bevel joins the segments with a line 

between the segments.

Sometimes a mitered join becomes too long 
and pointed. Fortunately, you can stop the 
point from becoming too long by setting the 
miter limit.

To set the miter limit:

1. Select an object with a mitered join.
2. In the Stroke panel, increase the amount 

in the Miter Limit field to control the size 
of the angle between the segments  H .

TIPTIP If the size of the angle exceeds the miter limit, 
a bevel is substituted  G . It does not mean a 
shorter point is substituted.

 D  The Cap icons 
control the end 
points of strokes.

Butt
Round

Projecting

 E  The three Cap settings applied to strokes.

Butt

Round

Projecting

 F  The Join buttons 
control how the 
corners of strokes 
are displayed.

Miter
Round

Bevel

 G  The three Join settings applied to strokes.

Miter Round Bevel

 H  The Miter Limit fi eld controls how 
long a miter point may extend.
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In traditional drawing programs, a stroke is 
distributed evenly on the outside and inside 
of its path. InDesign lets you choose the 
alignment of the stroke on the path  A .

TIP This is different from the position of a stroke 
applied to text.

To set the alignment of a stroke:

1. Apply a stroke to an object.
2. Choose one of the three alignment 

options for the stroke as follows  B :
 • Center aligns the stroke so that half 

the stroke weight is inside the path and 
half is outside the path.

 • Inside aligns the stroke so that the 
entire thickness of the stroke weight is 
inside the path.

 • Outside aligns the stroke so that the 
entire thickness of the stroke weight is 
outside the path.

 A  Set the Align Stroke controls to set the 
position of the stroke along the path.

Center

Inside

Outside

Uses for the Stroke Alignment

Most people will find they don’t ever need to change the alignment options for a stroke. They use the tradi-
tional Center alignment all the time. However, for many others, the ability to specify where the stroke aligns 
on the path is a real benefit.

Say you have a placed image inside a frame. After you import the graphic, you may want to add a stroke to 
its frame, but you don’t want the stroke to cover any part of the placed image. 

If you applied a stroke with the traditional Center alignment, you would then have to enlarge the size of the 
frame by half the size of the stroke. By setting the stroke alignment to Outside, you ensure that the stroke 
does not cover any part of the image.

Or say you want to apply a stroke to an object without increasing its size. With the Center alignment, every 
time you change the stroke weight, the size of the object would increase or decrease. By setting the stroke 
alignment to Inside, the stroke only appears inside the object and doesn’t add to the size of the object.

 B  Examples of how the Align Stroke 
controls change the position 
of the stroke on the path.

Center Inside Outside



InDesign CS5 Visual Quickstart Guide 163

The default setting for strokes is a solid line. 
However, you can choose one of the specialty 
strokes such as stripes, dashes, hashes, dots, 
or diamonds. You can even pick a stroke that 
curves up and down along the path.

To apply stroke styles to strokes:

1. Apply a stroke to an object.
2. Choose one of the styles from the Stroke 

Type menu  C .

The color of a stroke comes from choosing 
the Stroke icon and then picking a color. This 
method only colors the solid portion of a 
stroke. For strokes such as stripes and dashes, 
you can also color the gap, or the clear area 
between the solid colors of the stroke.

TIPTIP This is the same technique used to set the 
gap color for the underline and strikethrough 
effects.

To set a stroke gap color:

1. Choose one of the specialty strokes that 
have both solid and clear areas.

2. Use the Gap Color menu to choose the 
color for the clear areas of the stroke  D .

TIPTIP This list contains the same colors and 
gradients as the Swatches panel.

3. If necessary, use the Gap Tint controls to 
set a screen for the gap color  E .

 C  The 18 default strokes in the Stroke 
Type menu in the Stroke panel.

 D  Use the Gap Color menu in the Stroke panel 
to set the color of the clear areas of a stroke.

 E  Use the Gap Tint controls to set 
a screen for the gap color.
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The stroke list contains a dashed stroke that 
you can customize to set the size of the 
dashes and the gaps between them.

To create custom dashed strokes:

1. Apply a stroke to an object.
2. Choose Dashed from the Stroke Type pop-

up menu. The dashed settings appear at 
the bottom of the Stroke panel  A .

TIP The dashed settings only appear when you 
select the stroke style named Dashed and not 
the ones labeled Dashed (3 and 2) or Dashed 
(4 and 4).

3. Enter an amount in the first dash field for 
the length of all of the dashes in the line.

4. Enter an amount in the first gap field for 
the size of the space between all of the 
dashes.

5. To create a series of dashes and gaps with 
irregular lengths, enter other values in the 
rest of the dash and gap fields.

6. If necessary, use the Corners list  B  to 
adjust the dashes and gaps  C :
 • None leaves the dashes and gaps as 

they are. This can cause unequal dashes 
at the corners.

 • Adjust dashes changes the stroke so 
that the corner dashes are equal.

 • Adjust gaps changes the stroke so that 
the gap lengths are equal.

 • Adjust dashes and gaps changes the 
stroke to make the best fit so that both 
the corner dashes and gaps are equal.

 • Dash (3 and 2) creates a dash that is 3 
times the stroke weight with a gap that 
is 2 times the stroke weight  D .

 • Dash (4 and 4) creates dashes and gaps 
that are 4 times the stroke weight  D .

 A  The Dashed settings at the bottom of the 
Stroke panel. These only appear when 
the Dashed stroke type is chosen.

 B  Use the Corners menu to adjust how dashes 
and gaps are distributed on a stroke.

 C  Examples of how the Corners settings 
affect the appearance of a dashed stroke.

None Adjust dashes Adjust gaps 
Adjust dashes 
and gaps 

 D  The effects of the two preset dash 
styles on 3-point strokes.

3 and 2

4 and 4
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Creating Custom Stroke Styles

Stroke styles allow you to create custom 
stripes, dashes, and dots that you can add to 
your Strokes panel for reuse.

To create custom styles for strokes:

1. Choose Stroke Styles from the Stroke 
panel menu. The Stroke Styles dialog box 
appears  E .

TIPTIP This dialog box contains the seven default 
stripe styles. You can’t edit these default 
stripes, but you can use them as the basis for 
new stripe styles.

2. Click the New button to open the New 
Stroke Style dialog box  F .
or
Choose one of the default stripes and 
then click the New button. This opens 
the New Stroke Style dialog box with the 
stripe style already set as the starting 
pattern.

3. Use the Name field to enter a name for 
the custom stroke style.

4. Choose the type of stroke style from the 
Type menu as follows  G :
 • Stripe allows you to create multiple 

lines that run parallel to each other 
along the stroked path.

 • Dotted creates a series of dots 
repeated along the path. 

 • Dash creates a single line that is broken 
into a series of individual elements.

5. The dialog box changes its controls 
according to the stroke style chosen in 
the Type menu. 

6. When you have finished setting the stroke 
style, click OK OK to create the style.
or
Click the Add button to create the style 
and then define additional styles.

 E  The Stroke Styles dialog box lets you create, 
edit, and manage custom stroke styles.

 F  The New Stroke Style dialog box is where 
you defi ne the pattern for a custom stroke.

 G  Use the Type menu to choose the 
type of custom stroke style.
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To create a custom stripe stroke style:

1. Choose Stripe from the Type menu of the 
New Stroke Style dialog box. The stripe 
controls appear  A .

2. Click inside the Stripe area to add a stripe 
to the stroke.

TIP New stripes appear in the Stripe area with 
no width and need to be adjusted in order to 
appear as part of the finished stroke.

3. Drag the Start control triangle on the 
percentage ruler or enter an amount in 
the Start field to set the initial position for 
the stripe on the stroke  B .

TIP A setting of 0% positions the stripe to start at 
the very top of the stroke width.

4. Drag the Width control triangle on the 
percentage ruler or enter an amount in 
the Width field to set the width of the 
stripe  B .

TIP The width of the stripe is a percentage of the 
final stroke weight of the stroke. For example, 
a stripe width of 50% applied to a 4-point 
stroke creates a 2-point stripe.

5. Drag the stripe itself up or down in 
the Stripe area to position it without 
changing its width.

6. If you need to delete a stripe, drag it up or 
down so that it is off the Stripe area.

7. Use the Preview control to increase or 
decrease the size of the preview for the 
stroke style  C .

TIP A larger preview helps you see small 
elements added to the custom stroke style. 
However, it does not change the appearance 
of the stroke used in the document.

 A  The New Stroke Style dialog box 
set for the Stripe controls.

 C  Use the Preview display and Preview Weight 
to see what the stripe style will look like.

 B  The Stripe controls in the New 
Stroke Style dialog box.

Start 
controller

Width 
controller

Stripe 
area
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To create a custom dashed stroke style:

1. Choose Dash from the Type menu of the 
New Stroke Style dialog box. The dash 
controls appear  D .

2. Click inside the Dash area to add a dash to 
the stroke  E .

TIPTIP New dashes appear in the Dash area with no 
length and need to be adjusted in order to 
appear as part of the finished stroke.

3. Drag the Start control triangle on the 
percentage ruler or enter an amount in 
the Start field to set the initial position for 
the dash  E .

TIPTIP Unlike the Stripe controls, the length of a 
dash is set as an absolute amount, not a 
percentage of the stroke width.

4. Drag the dash itself to move it without 
changing its width.

5. Use the Pattern Length field to increase 
the length of the space that the dashes 
repeat within  E .

6. If you need to delete a dash, drag it up or 
down so that it is off the Dash area.

7. Use the Corners list to choose how the 
dashes should be arranged around 
corners  F .

8. Choose a Cap style to set how the dashes 
appear on the stroke.

9. Use the Preview control to increase or 
decrease the size of the preview for the 
stroke style.

 D  The New Stroke Style dialog box 
set for the Dash controls.

 F  Use the Corners list to choose how 
dashes are distributed along a stroke.

 E  The Dash controls in the New 
Stroke Style dialog box.

Start controller Length controllerDash area
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To create a custom dotted stroke style:

1. Choose Dotted from the Type menu of the 
New Stroke Style dialog box. The dotted 
controls appear  A .

2. Click inside the Dotted area to add a dot 
to the stroke  B .

3. Drag the Center controller triangle on the 
ruler or enter an amount in the Center 
field to set the initial position for the 
dot  B .

4. Use the Pattern Length field to increase 
the length of the space that the dots 
repeat within  B .

5. If you need to delete a dot, drag it up or 
down so that it is off the Dotted area.

6. Use the Corners list to choose how 
the dots should be arranged around 
corners  C . 

TIP Unlike the choices for dashes, the Corners list 
for dots only allows you to adjust gaps, as the 
dots themselves cannot change their length.

7. Use the Preview control to increase or 
decrease the size of the preview for the 
stroke style  D .

To edit a stroke style:

1. Select the custom stroke style in the 
Stroke Styles dialog box and choose Edit. 
The Edit Stroke Style dialog box appears.

2. Click OK to apply the changes.

TIP The Edit Stroke Style dialog box is the same as 
the New Stroke Style dialog box, except that 
there is a Preview checkbox to help you see 
what your changes do to the stroke  E . Also, 
the Edit Stroke Style dialog box does not have 
an Add button.

 A  The New Stroke Style dialog box 
set for the Dotted controls.

 B  The Dotted controls in the New 
Stroke Style dialog box.

Center controller

 C  Use the Corners menu to control how 
dotted styles are applied to corners.
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Once you have defi ned a stroke style, it 
appears in the Type menu of the Stroke panel 
for that document. You may want to transfer 
strokes from one document to another. You 
do so using the Stroke Styles dialog box  F .

To save strokes for use in another 
document:

1. Choose Stroke Styles from the Stroke 
panel menu.

2. Select the custom strokes that you want 
to transfer to another document.

TIPTIP Hold the Shift key to select a range of strokes.

TIPTIP Hold the Cmd/Ctrl key and click to select 
noncontiguous strokes.

3. Click the Save button. A dialog box 
appears where you can save the strokes 
as an .inst file, which contains the custom 
stroke definitions.

To transfer strokes from another 
document:

1. Choose Stroke Styles from the Stroke 
panel menu.

2. Click Load from the Stroke Styles 
dialog box.

3. Navigate to find the .inst file that contains 
the custom stroke definitions.

4. Click the Open button to add the strokes 
to the document.

TIPTIP You can also add custom strokes by copying 
and pasting objects from one document to 
another.

To delete a stroke from a document:

1. Choose Stroke Styles from the Stroke 
panel menu.

2. Select the stroke or strokes you want to 
delete.

3. Click the Delete button.

TIPTIP You can’t delete the seven default strokes.

 D  Use the Preview display and Preview Weight 
to see what a dotted style will look like.

 F  The Stroke Styles dialog box lets you create, 
edit, and manage custom stroke styles.

 E  Click the Preview checkbox to see how the 
stroke edits appear when applied to objects.
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Adding Arrows

You can add arrowheads and other shapes 
to the open-ended objects that have strokes 
applied to them  A .

To add arrowheads and end shapes:

1. Select an object with open ends.
2. Add a graphic to the beginning of the 

object by choosing a shape from the Start 
menu in the Stroke panel  B .

3. Add a graphic to the end of the object by 
choosing a shape from the End menu.

Corner Options

You can modify the corners of objects so that 
they have special shapes. These eff ects are 
called corner options.

To apply corner options to objects:

1. Select an object with at least one corner 
point.

2. Choose Corner Options from the Object 
menu. The Corner Options dialog box 
appears  C .

3. Choose one of the corner shapes from the 
menu list.

4. Use the size fields to set the size of the 
corner option.

5. Click OK to apply the settings  D .

TIP If the link icon is in the locked position, all the 
corners will have the same size and shape. 
In the unlocked position, you can assign 
individual shapes and sizes to each corner.

TIP Corner options can be applied to any type 
of object. For instance, you can change a 
star’s points to curves by applying a rounded 
corner effect. Or you can convert an L-shaped 
line into a soft curve.

 B  Choose an arrowhead style from the 
Start or End menu in the Stroke panel.

 D  Choose size and shape options for 
each corner of your object.

 C  The Corner options dialog box lets you 
apply diff erent corners to objects.

 A  The 12 diff erent types of 
arrowhead styles for paths.

Bar

Square

Circle

Barbed

Triangle

Simple

SquareSolid

CircleSolid

Curved

TriangleWide

SimpleWide

None
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You can also set the size and shape of corner 
options directly to an object without opening 
the Corner Options dialog box using the Live 
Corner Options controls.

To use the Live Corner Options controls:

1. Use the Selection tool to select an object 
with corner points.

2. Click the yellow square to display the 
diamond corner option control handles  E .

3. Drag the diamond handles to increase or 
decrease the size of the corner option  F .

TIPTIP As you drag the diamond handles, you are 
also changing the size of the numbers in the 
corner option fields.

4. If you want to modify the size of a single 
corner, hold the Shift key as you drag one 
of the diamond control handles  G .

5. If you want to change the shape of the 
corners, hold the Opt/Alt key as you click 
one of the diamond control handles.

6. If you want to change the shape of just 
one of the corners, hold the Opt/Alt+Shift 
key as you click one of the diamond 
control handles.

 E  Click the  yellow corner options square  
to open the corner options controls.

Yellow square

 F  Drag one of the  yellow diamond 
control handles  to change the 
size of the corner options.

Yellow diamond corner 
options control handle

 G  Hold the Shift key to adjust the size 
of the individual corner options.
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Opacity and Blend Mode 

Effects

What I call transparency (the ability to see 
through objects, images, or text), InDesign 
calls opacity.

To apply opacity eff ects to an object:

1. Choose Window > Effects to open the 
Effects panel  A .
or
Click the Opacity slider in the Control 
panel.
or
Choose Objects > Effects > Transparency 
to open the Effects dialog box set to the 
Transparency option  B .
or
Choose Transparency from the Effects 
panel menu.

2. Drag the Opacity slider or enter an 
amount in the Opacity field  C . The lower 
the opacity percentage, the more you can 
see through the object.

TIP Once you have activated the Opacity field or 
slider, you can use the up and down arrow 
keys on the keyboard to increase or decrease 
the amount of opacity. 

TIP Place a text frame filled with the color Paper 
at a reduced opacity over an image to “ghost” 
that area in the image  D . 

 A  The  Eff ects panel .

 D  An example of how a white text 
frame with the fi ll set to 50% opacity 
creates a ghost area in the image.

 C  The  Opacity slider in the Eff ects panel  
lowers the visibility of objects.

 B  The  Transparency controls  in 
the Eff ects dialog box.
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Blend mode eff ects allow the colors and 
shades in one object to interact with the 
objects beneath  E .

To add a blend mode eff ect:

1. Select the object.
2. Choose a blend mode from the list in the 

Effects panel or from the Transparency 
controls in the Effects dialog box.
 • Normal applies no change to the 

objects.
 • Multiply multiplies the bottom color 

with the top color. 
 • Screen is the inverse of Multiply.
 • Overlay preserves the highlights and 

shadows of the base color while mixing 
in the top color. 

 • Soft Light is similar to shining a 
diffused spotlight on the artwork. 

 • Hard Light is similar to shining a harsh 
spotlight on the artwork. 

 • Color Dodge lightens the bottom color 
to reflect the top color.

 • Color Burn darkens the bottom color 
to reflect the top color. 

 • Darken displays either the bottom or 
top color — whichever is darker. 

 • Lighten displays the bottom or top 
color — whichever is lighter. 

 • Difference subtracts one color from 
another depending on brightness.

 • Exclusion is similar to Difference but is 
lower in contrast.

 • Hue replaces the hue of the bottom 
object with the hue of the top one.

 • Saturation replaces the saturation of 
the bottom object with the top.

 • Color colorizes the bottom object with 
the top color.

 • Luminosity changes the bottom 
object’s luminance with the top.

 E  An example of how the 16 blend modes 
interact when placed over an image.

Normal

Multiply

Screen

Overlay

Soft Light

Hard Light

Color Dodge

Color Burn

Darken

Lighten

Difference

Exclusion

Hue

Saturation

Color

Luminosity
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As you apply a blend mode or an opacity 
setting, you may need to control how the 
transparency is applied. One such control 
is called a knockout group. Objects in a 
knockout group display their blend modes 
or opacity settings on other objects, but not 
with each other  A .

To create a knockout group:

1. Apply a blend mode or opacity setting to 
an object.

2. Repeat for any additional objects.

TIP Each object can have its own blend mode or 
opacity setting, or they all can have the same 
settings.

3. Use the Selection tool to select the 
objects. These are the objects you don’t 
want to have interact with each other.

4. Choose Object > Group. 
5. With the group selected, click the 

Knockout Group checkbox in the Effects 
panel  B  or the Transparency controls in 
the Effects dialog box.

 A  With the Knockout Group turned 
on, blended objects do not 
interact with each other.

Knockout 
Group off

Knockout 
Group on

 B  The  Knockout Group checkbox  
in the Eff ects panel.
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The Isolate Blending command creates the 
opposite eff ect of a Knockout group. With this 
command, the objects in the group display 
their blend modes with each other, but not 
with objects outside the group  C .

To isolate the blending in objects:

1. Apply a blend mode to as many objects as 
you want.

2. Use the Selection tool to select the 
objects that have the blend mode. 

3. Choose Object > Group. 
4. Keep the group selected, click the Isolate 

Blending checkbox in the Effects panel  D  
or the Transparency options in the Effects 
dialog box. 

You can also specify where the opacity or 
blend mode is applied.

To specify to which attributes the eff ect is 
applied:

Use the Settings for menu in the Effects 
dialog box  E  to choose one of the 
following:
 • Object sets the effect to the entire 

object.
 • Fill sets the effect to just the fill.
 • Stroke sets the effect to just the stroke.
 • Text sets the effect to just the text.

or
Click to target the object attribute in the 
Effects panel  F .

TIPTIP Use this technique when working with the 
other effects—such as shadows, glows, bevel 
and emboss effects, satin, and feathers—
covered in the next sections.

 E  Use the  Settings for  list to choose 
to which parts of the object the 
opacity or blend mode is applied.

 F  Select the object attribute in the Eff ects 
panel to apply the opacity or blend 
mode to just one part of the object.

 C  With the Isolate Blending command 
turned on, blended objects only interact 
with each other, not the objects below.

Isolate 
Blending 
off

Isolate 
Blending 
on

 D  The  Isolate Blending checkbox  
in the Eff ects panel.
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Working with Effects

In addition to opacity and blend modes, you 
can also apply special eff ects such as shad-
ows, glows, and feathers to objects. All these 
eff ects are controlled from the Eff ects dialog 
box  A .

To open the Eff ects dialog box:

Click the fx icon in the Effects panel or the 
Control panel to choose an effect from 
the menu  B .
or
Choose Object > Effects and then one of 
the effects in the submenu.
or
Choose one of the effects in the Effects 
panel menu.

To remove eff ects:

Deselect the effect in the Effects 
dialog box.
or
Select the effect in the Effects panel and 
then click the Delete Effect icon in the 
Effects panel  C .
or
Click the Clear All Transparency icon in 
the Effects panel to remove all effects 
as well as any opacity and blend mode 
settings  D .
or
Choose Clear Effects from the Effects 
panel menu or Object > Effects submenu.
or
Choose Clear All Transparency from the 
Effects panel menu or Object > Effects 
submenu. This removes all effects as well 
as any opacity and blend mode settings.

 B  The  fx icon in the Eff ects panel  
lets you apply special eff ects.

 A  The  Eff ects dialog box  lets you choose 
eff ects as well as change their appearance.

 C  The  Delete Eff ect icon  in the Eff ects 
panel removes eff ects from selections.

 D  The  Clear All Transparency icon  in 
the Eff ects panel removes all eff ects 
and makes the object opaque.
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Shadow Effects

One of the most popular eff ects is a drop 
shadow set behind objects, text, or images  E .

To add a drop shadow:

1. Select the object.
2. Open the Effects dialog box as described 

previously.
3. Select the Drop Shadow checkbox. 
4. Set the Drop Shadow controls as 

follows  F :
 • The Blending area controls the color 

and opacity of the shadow and how it 
interacts with other objects.

 • The Position area controls the 
placement of the shadow in 
relationship to the object.

 • The Options area controls the size and 
other attributes of the shadow.

5. Click OK to apply the shadow.

An inner shadow creates the appearance that 
the object is cut out of the page it is on  G .

To add an inner shadow:

1. Select the object.
2. Open the Effects dialog box as described 

previously.
3. Select the Inner Shadow checkbox. 
4. Set the Inner Shadow controls as 

follows  H :
 • The Blending area controls the color 

and opacity of the shadow as well as 
how the shadow interacts with other 
objects.

 • The Position area controls the 
placement of the shadow in 
relationship to the object.

 • The Options area controls the size and 
other attributes of the shadow.

5. Click OK to apply the shadow.

EFFECTIVE
EFFECTS
 E  A  drop shadow  applied to text.

 F  The  Drop Shadow controls  in 
the Eff ects dialog box.

EFFECTIVE
EFFECTS
 G  An  inner shadow  applied to text.

 H  The Inner Shadow controls in 
the Eff ects dialog box.
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Glow Effects

You can also add an outer glow around 
objects or an inner glow inside an 
object  A  –  D .

To add an outer glow:

1. Select the object.
2. Open the Effects dialog box as described 

previously.
3. Select the Outer Glow checkbox. 
4. Set the Outer Glow controls as follows  B :

 • The Blending area controls the color 
and opacity of the glow as well as how 
the glow interacts with other objects.

 • The Options area controls the size and 
other attributes of the glow.

5. Click OK to apply the glow.

To add an inner glow:

1. Select the object.
2. Open the Effects dialog box as described 

previously.
3. Select the Inner Glow checkbox. 
4. Set the Inner Glow controls as follows  D :

 • The Blending area controls the color 
and opacity of the shadow as well as 
how the glow interacts with the inside 
of the object.

 • The Options area controls the size and 
other attributes of the glow.

5. Click OK to apply the glow.

EFFECTIVE
EFFECTS

 A  An  outer glow  applied to text.

 B  The  Outer Glow controls  in 
the Eff ects dialog box.

EFFECTIVE
EFFECTS
 C  An  inner glow  applied to text.

 D  The  Inner Glow controls  in 
the Eff ects dialog box.
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Bevel and Emboss Effects

A great way to add dimension to objects is 
with the bevel and emboss eff ects  E .

TIPTIP Bevel and emboss effects are simply 
variations in the style of one effect.

To add a bevel or emboss:

1. Select the object.
2. Open the Effects dialog box as described 

previously.
3. Select the Bevel and Emboss checkbox  F . 
4. Set the controls as follows:

 • The Structure area controls the style of 
the bevel or emboss as well as the size 
and other attributes.

 • The Shading area controls what 
colors are used for the highlights and 
shadows of the effect as well as the 
direction of the light that creates the 
effects.

5. Click OK to apply the bevel or emboss.

Satin Effect

The satin eff ect gives the appearance of a 
fabric texture applied to the object  G  .

To add a satin eff ect:

1. Select the object.
2. Open the Effects dialog box as described 

previously.
3. Select the Satin checkbox. 
4. Set the Satin controls as follows  H :

 • The Structure area controls how the 
satin texture is applied as well as the 
size, angle, and other attributes.

 • Choose Invert to reverse the 
appearance of the satin effect with the 
object’s color.

5. Click OK to apply the satin effect.

EFFECTIVE
EFFECTS
 E  A  bevel eff ect  applied to text.

 F  The  Bevel and Emboss controls  
in the Eff ects dialog box.

EFFECTIVE
EFFECTS

 G  A  satin eff ect  applied to text.

 H  The  Satin controls  in the Eff ects dialog box.
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Feather Effects

Feather refers to softening the edge of 
an object so that it fades to transparent. 
InDesign gives you three diff erent types of 
feather eff ects. The Basic Feather creates a 
soft edge around the outside of objects  A .

To add a basic feather eff ect:

1. Select the object.
2. Open the Effects dialog box as described 

previously.
3. Select the Basic Feather checkbox. 
4. Use the Options area to control the size 

and other attributes of the feather  B .
5. Click OK to apply the feather.

A Directional Feather allows you to specify 
diff erent amounts of softening for the top, 
bottom, left, and right sides of the object  C .

 To add a directional feather:

1. Select the object.
2. Open the Effects dialog box as described 

previously.
3. Select the Directional Feather checkbox. 
4. Set the Directional Feather controls as 

follows  D :
 • The Feather widths area controls the 

size of the feather for the four sides of 
the object.

 • The Options area controls the size and 
other attributes of the feather.

5. Click OK to apply the feather.

 A  A  basic feather  applied to text.

 B  The  Basic Feather controls  in 
the Eff ects dialog box.

 C  A  directional feather  applied to text.

 D  The  Directional Feather controls  
in the Eff ects dialog box.
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The Gradient Feather eff ect allows you to 
create a color that fades in and out of opacity. 
So instead of a gradient that changes color, a 
gradient feather changes opacity for each of 
the gradient stops (transition points)  E .

TIPTIP The Gradient Feather effect only changes the 
opacity of the gradient. If you need to change 
the color of the gradient, you need to create a 
separate color gradient.

 To add a gradient feather:

1. Select the object.
2. Open the Effects dialog box as described 

previously.
3. Select the Gradient Feather checkbox. 
4. Set the Gradient Feather controls as 

follows  F :
 • The Gradient Stops area allows you to 

set the opacity and location for each of 
the gradient transition points.

 • The Options area controls the type of 
gradient (linear or radial) and the angle 
of the gradient.

5. Click OK to apply the feather.

Setting the Global Light

The Global Light setting allows you to set an 
angle and position of the electronic “light” 
that creates shadows and other dimensional 
eff ects. You can use the Global Light controls 
to coordinate the appearance of the eff ects.

To set the Global Light:

1. Choose Global Light from the Effects 
panel menu or the Object > Effects 
submenu.

2. Use the Global Light dialog box to set the 
angle and altitude of the global light  G .

 E  A  gradient feather  applied to text.

 F  The  Gradient Feather controls  
in the Eff ects dialog box.

 G  The  Global Light dialog box . 
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Using the Pathfinder 

Commands

I can’t draw. So rather than struggle to create 
certain shapes, I use the Pathfi nder com-
mands to use multiple objects to create 
diff erent shapes.

To use the Pathfi nder commands:

1. Select the objects that you want to have 
interact with each other. You must select 
at least two objects.

2. Click one of the Pathfinder icons in the 
Pathfinder panel  A  (Window > Object 
& Layout > Pathfinder) or choose 
one of the following from the 
Object > Pathfinder submenu:
 • Add combines the outer edges of the 

objects in a single shape  B .
 • Subtract uses the frontmost object as a 

cookie cutter that changes the shape of 
the backmost object  B .

 • Intersect creates a new shape based on 
the area intersected by the objects  B .

 • Exclude Overlap creates a hole where 
the objects overlap  B .

 • Minus Back uses the backmost objects 
as cookie cutters that change the shape 
of the frontmost object  B .

The pathfi nder commands may create a 
compound path. To separate the objects, you 
need to release the compound path:

To separate the results of the Pathfi nder 
commands:

1. Select the objects created by the 
Pathfinder command.

2. Choose Object > Paths > Release 
Compound Paths.

3. Deselect the objects and then move each 
one to new positions  C .

Command Objects before Objects after

Add

Subtract

Intersect

Exclude 
Overlap

Minus Back

 B  Examples of how the  Pathfi nder 
commands  change selected objects.

 C  An example of how the  Exclude Overlap 
command  creates separate objects 
when the Compound Path is released.

Before After

 A  Click the  Pathfi nder icons  in 
the Pathfi nder panel.

Add Subtract Intersect Exclude Overlap Minus Back
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You can use the Convert Shape commands to 
change objects from one shape to another.

To change the shape of objects:

1. Select the object that you want to 
convert.

2. Click one of the Convert Shape icons in 
the Pathfinder panel  D  and  E .
or
Choose one of the following from the 
Object > Convert Shape menu:
 • Rectangle converts to a rectangle.
 • Rounded Rectangle converts to a 

rectangle with rounded corners.
 • Beveled Rectangle converts to a 

rectangle with flat, angled corners.
 • Inverse Rounded Rectangle converts 

to a rectangle with inverted rounded 
corners.

 • Ellipse converts the object to an 
ellipse.

 • Triangle converts to a triangle.
 • Polygon converts to a polygon using 

the current settings for the Polygon 
tool.

 • Line converts the object to a line. The 
length is the diagonal of the bounding 
box of the object.

 • Orthogonal Line converts the object 
to a line. The length is the width or 
height of the bounding box, whichever 
is greater.

TIPTIP The size of the corner options comes from the 
current corner radius setting in the Corner 
options.

 D  The  Convert Shape icons  in the 
Pathfi nder panel allow you to 
change the shape of objects.

Icon Function

Rectangle

Rounded Rectangle

Beveled Rectangle

Inverse Rounded Rectangle

Ellipse

Triangle

Polygon

Line

Orthogonal Line

 E  The  Convert Shape icons  
and their functions.
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The Pathfi nder panel also contains the path 
modifi cation commands.

To modify paths:

1. Select the object that you want to modify.
2. Click one of the Paths icons in the 

Pathfinder panel  A  and  B .
or
Choose one of the following from the 
Object > Paths submenu:
 • Join Path joins the selected endpoints 

of two open paths or the selected 
endpoints of a single path.

 • Open Path opens a closed path at a 
point.

 • Close Path creates a segment between 
the end points of a path.

 • Reverse Path changes the direction of 
a path.

TIP Apply the Close Path command to expand 
the electronic corner options into actual 
points on the path. This is similar to applying 
Illustrator’s Object > Expand command.

 A  The  Paths icons  in the Pathfi nder panel 
allow you to modify individual paths.

Icon Function

Join Path

Open Path

Close Path

Reverse Path Direction

 B  The  Paths icons  and their functions.
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Using the Eyedropper

Imagine you’ve fi nished styling an object with 
exactly the right combination of fi ll, stroke, 
and eff ects. And now you’d like to apply those 
same settings to a diff erent object. That’s 
where the Eyedropper tool comes to the 
rescue.

To set the eyedropper options:

1. Double-click the Eyedropper tool in the 
Tools panel  C . This opens the Eyedropper 
Options dialog box  D .

2. Click the triangles to open each of the 
attribute categories.

TIPTIP The object settings categories are Fill, Stroke, 
and Transparency. 

3. Use the checkboxes to choose which 
attributes you want the Eyedropper tool 
to sample.

4. Click OK to set the options.

Once you set the eyedropper options, you can 
sample and apply object attributes.

To sample and apply object attributes:

1. Choose the Eyedropper tool.
2. Click with the white eyedropper cursor 

inside the object that you want to 
sample  E . The cursor changes from white 
to black.

TIPTIP If an object has a stroke, but no fill, click the 
object’s outline to sample its stroke.

3. Click the black eyedropper cursor inside 
the object that you want to change  F . This 
applies the first object’s attributes to the 
second.

4. Click the eyedropper inside any other 
objects that you want to change.

 C  The  Eyedropper tool  in 
the Tools panel lets you 
sample object attributes.

 D  Use the  Eyedropper Options dialog 
box  to set which attributes the 
Eyedropper will sample and apply.

 E  The  white eyedropper  lets you 
sample the object attributes.

 F  The  black eyedropper  applies object 
attributes from one object to another.
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As you work with the Eyedropper tool, you 
may change your mind and want to unload 
one set of attributes to sample new ones.

To sample new attributes:

1. Hold the Opt/Alt key. The eyedropper 
cursor changes to the white sample 
mode.

2. Click the cursor inside a new object that 
you want to sample.

3. Release the Opt/Alt key to apply the new 
attributes to objects.

You may not want to sample all the attributes 
in an object — just the fi ll or stroke. That’s 
when you can use the Eyedropper tool in its 
precision mode. The precision mode allows 
you to sample and apply just the color to 
either a fi ll or a stroke.

To use the precision eyedropper:

1. Choose the Eyedropper tool. Hold the 
Shift key. A plus sign appears next to 
the white eyedropper cursor  A . This 
indicates that the Eyedropper tool is in 
the precision mode.

2. Click the precision white eyedropper 
cursor on the fill or stroke color you wish 
to sample. The cursor turns into the 
precision black eyedropper  B .

3. Click the precision eyedropper on either 
a fill or a stroke of the object that you 
want to change. Only the fill or stroke is 
changed.

TIP As handy as the Eyedropper tool is, it doesn’t 
come close to the power of object styles 
(covered in Chapter 15, “Styles”).

 A  The  white precision 
eyedropper  allows 
you to sample a 
specifi c color.

 B   The  black precision 
eyedropper  lets 
you apply a specifi c 
color to either the 
fi ll or a stroke. 
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 C  Click the  Default Fill and 
Stroke icon  in the Tools 
panel to set the fi ll to 
none and stroke to black.

Setting Object Defaults

You can make any of the object settings the 
default for any new objects you create. You 
can set the object defaults for the current 
document or globally for all new documents.

To set current document defaults:

1. With a document open, deselect any 
objects.

2. Make whatever changes you want in the 
Stroke panel or other panels. This sets the 
defaults for the open document.

3. Set whatever amounts you want for the 
Effects or Corner options dialog boxes.

To set global defaults:

With no document open, make what ever 
changes you want in the Stroke or other 
panels. This sets the global defaults for all 
new documents.

InDesign also has its own default fi ll and 
stroke setting of a black stroke and no fi ll. 
These are separate from the defaults you set 
yourself. This can be easily applied to objects.

To apply the InDesign fi ll and stroke 
defaults:

Click the Default Fill and Stroke icon in the 
Tools panel  C .
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Points and Paths
I remember the fi rst time I tried to 

use the Pen tool in a computer gra-
phics program. I clicked the tool and 
dragged across the screen in the way 
I thought would create a simple curve. 
Instead, I got a wild series of lines that 
shot out in diff erent directions. When I 
tried to change the shape of the curves, 
things got even worse. I was so startled 
I immediately closed up the program 
and didn’t use the Pen tool for a long, 
long time.

However, I really wanted to use the Pen 
tool, as I knew it was the best way to 
create curved shapes. So I forced myself 
to try the tool again. It took a lot of trial 
and error but eventually I was able to 
understand the Pen and Bezier controls. 
Later on, working with tools such as the 
Pencil and Eraser made it even easier to 
work with Bezier curves.

Once I got it, I realized the principles are 
simple. Even better, if you have used the 
Pen tool in Adobe Illustrator or Adobe 
Photoshop, you will fi nd InDesign’s Pen 
tool almost the same.

I wish someone had written out easy-to-
understand, step-by-step instructions 
on how to use the Pen tool. So think of 
this chapter as the instruc tions for the 
Pen tool that I wish I had had back then.

Look for the Videos

Working with the Pen tool is all about clicking, 
dragging, pulling, and pushing — all topics that 
are not easy to translate into print.

In addition to the exercises and illustrations in 
this chapter, I’ve created a series of videos that 
better illustrate the process of creating paths 
with the Pen tool.

Look for these videos on the Peachpit Web site 
at: www.peachpit.com/indesigncs5vqs

www.peachpit.com/indesigncs5vqs
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Pen Points

One of the most important tools in any 
graphics program is the Pen tool. Fortu nately 
InDesign has a Pen tool that lets you create 
much more sophisticated shapes in your 
layout than can be created with the basic 
shape tools. (See Chapter 4, “Working with 
Objects,” for more information on creating 
basic shapes.)

TIP If you are familiar with the Pen tool in Adobe 
Illustrator, Adobe Photoshop, or Adobe Flash, 
you will find it very easy to master the Pen in 
InDesign.

If you’ve never used a Pen tool in any graphics 
program, you will understand more if you fi rst 
become familiar with the elements of paths.

Elements of Paths

Paths are defi ned by points and line seg-
ments. When you draw with the Pen tool you 
create the following:

 • Anchor points, which define a path 
at points where the path changes  A . 
These can be plain corner points, 
smooth curve points, and corner curve 
points, as explained on the following 
pages.

 • Segments, which are the paths that 
connect anchor points  A .

 • Control handles that extend out 
from anchor points; their length and 
direction control the shape of the 
segment’s curves  A .

Drawing in a Page Layout Program?

I limit using InDesign’s Pen tool to simple things. If I need some sort of curved or wavy line, I use InDesign’s 
Pen tool. For instance, all the curved arrows in this book were created with the Pen tool. However, if I want a 
perfect spiral, I use Illustrator’s Spiral tool. (See Chapter 8, “Imported Graphics,” for how to bring Illustrator 
paths into InDesign.)

If I need to jazz up some text, I stay within InDesign. But if I need a complete map of New York State with 
highways, rivers, and scenic attractions, I work in Illustrator.

The Father of Bezier Curves

Some people call the curves created by the 
Pen tool Bezier curves. This is in honor of Pierre 
Bézier (Bay-zee-ay), the French mathematician.

Monsieur Bézier created the system of math-
ematics that is used to define the relationship 
of the control handles to the shape of the curve.

Adobe Systems, Inc., adopted this mathemati cal 
system when it created the PostScript language, 
which is used as the basis of graphics programs. 
InDesign, along with many other programs, uses 
Bezier curves as the mathematics behind each 
curve.

 A  The elements of a path.

Selected anchor point

Control handle

Path segment

Deselected 
anchor point
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Drawing Lines

Diff erent types of anchor points create diff er-
ent line shapes. Straight lines are formed by 
creating plain corner points.

To create straight lines:

1. Click the Pen tool in the Tools panel  B .
2. Position the cursor where the path should 

start. A small X appears next to the Pen, 
which indicates that you are starting the 
path  C .

3. Click. A plain corner point appears as 
a colored square. The Pen cursor is 
displayed without any symbol next to 
it  D .

TIPTIP A small arrow next to the Pen  E  indicates 
it is aligned with one of the Smart Guides 
(covered in Chapter 2).

4. Position the cursor for the next point and 
click. This creates another plain corner 
point with a straight line that connects 
the first point to the second.

TIPTIP Hold the Shift key to constrain the straight 
lines to 45-degree angles.

5. Continue clicking until you have created 
all the straight-line sides of the object  F .

TIPTIP If you have not closed the path (see the next 
exercise), hold the Cmd/Ctrl key and click 
with the Selection tool. This deselects the 
path and allows you to start a new one.

To close a path with a straight line:

1. Move the Pen over the first point. A small 
circle appears next to the Pen  G . This 
indicates that you can close the path.

2. Click. This closes the path with a plain 
corner point and allows you to start a 
new path.

 B  Click the  Pen tool in the 
Tools panel  to create lines.

 C  The  start icon  for the Pen tool.

 D  Click with the Pen tool 
to create  a corner point , 
shown as a small square.

 E  The  hollow arrow  indicates the 
Pen is aligned with a Smart Guide.

 F  Straight lines extend 
between the plain 
corner points.

 G  The  small circle next 
to the Pen  cursor 
indicates that you 
will close the path.
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Drawing Curves

Smooth curve points create curves like the 
track a roller coaster follows. There are no 
abrupt changes from one curve to another.

To create smooth curves:

1. Drag the Pen tool where you want to start 
the curve. Handles extend out from the 
point.

TIP The length and angle of the handle control 
the curve’s height and direction.

2. Release the mouse button. 

TIP You do not see a curve until you create the 
next point of the path.

3. Move the cursor to where you want the 
next part of the curve. Drag to create the 
curved segment between the two smooth 
curve points  A .

4. Continue to create curved segments by 
repeating steps 2 and 3  B .

To close a path with a smooth curve:

1. Move the Pen over the first point. A small 
circle appears, indicating that you can 
close the path.

2. Drag backwards to close the path  C .

A corner curve point creates curves with an 
abrupt change in direction. The path of a 
bouncing ball illustrates a corner curve.

To create a corner curve:

1. With the Pen tool active, drag to create an 
anchor point with control handles.

2. Without releasing the mouse button, hold 
the Opt/Alt key and then drag to pivot the 
second handle  D .

3. Release the mouse button when the 
second handle is the correct length and 
direction.

 A  Drag with the Pen tool to 
create  smooth curves .

 D  Hold the Opt/
Alt key to pivot 
the handles, 
which creates a 
 corner curve .

 C  Dragging backwards closes a 
path with a smooth curve.

First drag

Second drag

Third drag
Final drag

Se

 B  A path with a series of curved segments.

Second segment Third segmentFirst segment
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Changing Curves and Corner 

Points

If you retract the handle that extends out 
from a curve point, the next segment 
becomes a straight line.

To retract a handle:

1. Drag to create a smooth curve point.
2. Move the Pen cursor back over the anchor 

point. A small angle symbol appears next 
to the cursor.

3. Click. The handle retracts back into the 
anchor point. The point is now a corner 
point with only one handle  E .

4. Continue the path with either a straight 
line or a curved line.

TIPTIP Click to make the next path segment straight. 
Drag to make the next path segment curved.

If you create a corner point with no control 
handles, you can extend a single handle out 
from that anchor point.

To extend a handle from a point:

1. Click to create a corner point with no 
handles.

2. Move the Pen cursor back over the anchor 
point you just created. A small angle 
symbol appears next to the cursor.

3. Drag to pull a single handle out from the 
anchor point  F .

4. Continue the path with a curved line.

General Pen Rules

As you work with the Pen tool, there are some 
rules you should follow:

 • Use the fewest number of points to 
define a path. Too many points add to 
the size of the file and make it difficult 
to edit the path later.

 • Try to limit the length of the control 
handles to one-third the length of the 
curve. This is sometimes called the One-
Third Rule. The One-Third Rule makes it 
easier to edit and control the shape of 
curves.

 E  Move the cursor back 
over a point and click 
to  retract a handle 
along a curve .

 F  Drag with the Pen tool 
over an existing anchor 
point to  extend a handle 
out from the point .
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Modifying Paths

Once you create a path, you can still change 
its shape and the position of the points. 
You can also split a path into two separate 
segments or join two segments together. 
When you move points, you use the Direct 
Selection tool.

To move individual points:

1. Click the Direct Selection tool in the Tools 
panel  A .

2. Position the tool over the point you want 
to move.

3. Drag the point to the new position.

To select and move multiple points:

1. Click the Direct Selection tool in the Tools 
panel.

2. Drag to create a rectangular marquee 
around the points you want to select  B . 
The selected points appear solid. The 
unselected points appear hollow.
or
Hold the Shift key as you click to select 
the points.

TITIPP You can select points in one path or multiple 
paths.

3. Drag the points to the new position.

The Direct Selection tool also lets you 
change the length and direction of the con-
trol handles.

To move control handles:

1. Click the Direct Selection tool in the Tools 
panel.

2. Click a point on the path. This displays the 
control handles for that point.

3. Position the Direct Selection tool over the 
end point of the handle.

4. Drag the handle to the new position  C .

 A  The  Direct Selection tool  in the 
Tools panel; use it to move points.

 B   Drag a marquee to 
select multiple points . 
The center point 
does not turn black.

 C  The Direct Selection 
tool changes the 
length and position 
of a control handle.
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You may want to separate one path into two 
parts. The Scissors tool makes it easy to split 
or break a path into segments.

To split paths:

1. With the path selected, click the Scissors 
tool in the Tools panel  D .

2. Position the cursor where you want to 
split the path.

3. Click to split the path at that point.

TIPTIP The Scissors tool creates two points, one on 
top of the other. Use the Direct Selection tool 
to move one point away from the other  E .

To open paths using a command:

Choose Object > Path > Open Path. This 
opens the path by creating two points, 
one on top of the other.

To close a path using a command:

Choose Object > Path > Close Path. This 
closes the path by creating a line segment 
between the end points of the path  F .

To join two paths together:

1. Use the Direct Selection tool to select two 
endpoints on separate paths.

2. Choose Object > Path > Join. This 
creates a line segment that joins the end 
points of the two paths  G .

The path direction comes from the order in 
which you draw the path. You can change the 
path direction.

To change the path direction:

1. Use the Direct Selection tool to select the 
path.

2. Choose Object > Path > Reverse Path. 
This switches the start and end points of 
the path  H .

 D  The  Scissors tool  in the 
Tools panel allows you 
to snip paths in two.

 E  The Scissors tool splits 
a path into two points, 
one on top of the other.

 H   The results of 
applying the 
 Reverse Path 
command  to 
a path with an 
arrowhead.

 F  The  Close Path command  joins 
the two end points of a path.

 G  The  Join command  joins the two 
end points of separate paths.



196 Chapter 7 Points and Paths

Modifying Points

So what happens if you create the wrong 
point with the Pen tool? Are you stuck? Does 
it mean you have to redraw the entire path? 
Thankfully, no—there are many ways to 
change the paths made with the Pen tool, 
as well as paths made with other tools. (See 
Chapter 4, “Working with Objects,” for more 
information on working with the basic 
shapes.)
A simple way to change a path is to add a 
point. This helps you turn one shape into 
another.

To add points to a path:

1. With the path selected, choose the Add 
Anchor Point tool in the Tools panel  A .

2. Click the path where you want to add the 
point.

TIP The Pen tool automatically changes to the 
Add Anchor Point tool when positioned over 
a selected path segment  B .

You can delete points from a path without 
causing a break in the path.

To delete points from a path:

1. With the path selected, choose the Delete 
Anchor Point tool in the Tools panel  C .

2. Click to delete the point from the path.

TIP The Pen tool changes to the Delete Anchor 
Point tool when positioned over a point on a 
selected path  D .

 A  The  Add Anchor Point 
tool  in the Tools panel.

 C  The Delete Anchor Point 
tool in the Tools panel.

 B  The Add Anchor 
Point tool displays 
 a plus sign over a 
path segment .

 D  The Delete Anchor 
Point tool displays 
 a minus sign 
over a point .
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You can also create an open path by deleting 
a segment or the point between two seg-
ments.

To delete a segment in a path:

1. Use the Direct Selection tool to select the 
segment that you want to delete.

2. Press the Delete key or choose Edit > 

Clear to delete the segment  E .

TIPTIP If you select a point with the Direct Selection 
tool, the two segments on either side of the 
point can be deleted  F .

You can also change the shape of segments 
by changing the type of anchor point.

To modify an anchor point:

1. Select the path.
2. Choose the Convert Direction Point tool 

in the Tools panel  G .
3. Use the tool as follows to change the 

anchor points:
 • Press and drag a corner point to 

create a smooth curve point with two 
handles  H .

 • Click a smooth curve point to create a 
corner point with no handles  I .

 • Drag a handle of a smooth curve point 
to create a corner curve point  J .

You can also use commands to change the 
control handles around a point.

To modify an anchor point:

Select the path and choose one of the 
following from the Object > Paths > 

Convert Point submenu:
 • Line End
 • Corner
 • Smooth
 • Smooth Symmetrical

 H   Drag the Convert 
Direction Point 
tool  to change 
a corner point 
into a smooth 
curve point.

 I   Click with the 
Convert Direction 
Point tool  to 
change a smooth 
curve point into 
a corner point.

 E  When you select and delete a 
segment, you keep the points on 
either side of the segment.

 F  When you select and delete a point, 
you delete both segments that 
were attached to the point.

 J   Drag a handle 
with the Convert 
Direction Point 
tool  to change 
a smooth 
curve point 
into a corner 
curve point.

 G  The Convert Direction Point 
tool in the Tools panel.
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Using the Pencil Tool

Unlike the Pen tool, which uses mathemati-
cal principles to draw paths, InDesign’s Pencil 
tool works more like a traditional pencil. 
However, the Pen tool is a little more precise 
than the Pencil.

TIP If you are familiar with the Pencil tool in 
Adobe Illustrator, you will find you already 
know how to work with InDesign’s Pencil tool.

To draw with the Pencil tool:

1. Click the Pencil tool in the Tools panel  A . 
A small cross next to the Pencil cursor 
indicates that you are about to start the 
path  B .

2. Press and drag with the Pencil  C .
3. To close the path, hold the Opt/Alt key. 

A small circle next to the cursor indicates 
that the path will be closed  D .

4. Release the mouse button to create the 
path.

The Pencil tool can also be used to edit exist-
ing paths and reshape paths.

To edit paths with the Pencil tool:

1. Select the path that you want to reshape.

TIP The Pencil tool can edit paths created by tools 
such as the Pen or the frame tools.

2. Move the Pencil tool near the selected 
path. The cross next to the cursor 
disappears. This indicates that you are 
about to edit the path.

3. Drag along the path. When you release 
the mouse button, the path is reshaped  E .

TIP If you don’t get the results you expect, drag 
the Pencil tool in the opposite direction.

 A  The  Pencil tool  in the Tools panel.

 C  Press and drag to 
create a path with 
the Pencil tool.

 D  The  circle next to the 
Pencil cursor  indicates 
that the Opt/Alt key 
will close the path.

 E  Drag the Pencil tool next to a selected 
path to reshape the path.

 B  The  cross next to the Pencil 
cursor  indicates that you are 
about to start a new path.
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You can change how the Pencil tool responds 
to the movements of the mouse as you drag. 
The preferences also control how the Pencil 
tool edits paths.

To set the preferences for the Pencil tool:

1. Double-click the Pencil tool in the 
Tools panel. This opens the Pencil Tool 
Preferences dialog box  F .

2. Set the amount of Fidelity using the slider 
or field. The lower the amount of Fidelity, 
the more the path will follow the motions 
of the mouse  G .

3. Set the amount of Smoothness using 
the slider or field. The higher the setting 
for Smoothness, the more the path will 
follow curved shapes  G .

4. Select Keep Selected to keep the path 
selected after you have drawn it. This 
makes it easier to reshape the path.

5. Select Edit Selected Paths to turn on the 
reshape option.

6. If the Edit Selected Paths option is turned 
on, use the slider or field to set how close 
the Pencil tool must come, in pixels, to the 
path you want to reshape.

TIPTIP If you want to restore the Pencil tool to its 
original settings, click the Defaults button  H .

 F  The  Pencil Tool Preferences 
dialog box  allows you to control 
the appearance of the path.

 H  Click the  Defaults button  in thePencil 
Tool Preferences dialog box to rests the 
settings to their original amounts.

 G  The  Pencil tool Fidelity and 
Smoothness settings  change 
the appearance of the path.

Fidelity 2.5 pixels
Smoothness 0%

Fidelity 11 pixels
Smoothness 0%

Fidelity 11 pixels
Smoothness 70%



200 Chapter 7 Points and Paths

Using the Smooth Tool

Once you have created a path, you may want 
to delete extra points so that the path is 
smoother.

TIP If you are familiar with Illustrator’s Smooth 
tool, you will find it easy to use the Smooth 
tool in InDesign.

To smooth paths with the Smooth tool:

1. Select the path that you want to smooth.
2. Click the Smooth tool in the Tools panel  A .
3. Press and drag the Smooth tool along the 

path.
4. Release the mouse button. The path is 

redrawn with fewer points  B .

You can change how the Smooth tool 
responds to the movements of the mouse 
as you drag.

To set the preferences for the Smooth tool:

1. Double-click the Smooth tool in the 
Tools panel to open the Smooth Tool 
Preferences dialog box  C .

2. Use the slider or field to set the Fidelity 
amount. The lower the amount, the more 
the new path will follow the original path.

3. Use the slider or field to set the 
Smoothness amount. The higher the 
setting, the more curved the path.

4. Select Keep Selected to keep the path 
selected after you have smoothed it. 
This makes it easier to increase the 
smoothness of the path.

TIP If you want to restore the Smooth tool to its 
original settings, click the Defaults button.

 A  The  Smooth tool  in 
the Tools panel.

 B  Drag the Smooth tool along a path 
to  remove points and eliminate 
small bumps and curves .

Original path After using the 
Smooth tool

 C  The  Smooth Tool Preferences  allow 
you to control how much the Smooth 
tool aff ects the appearance of paths.



InDesign CS5 Visual Quickstart Guide 201

Using the Erase Tool

You may want to delete parts of paths. Rather 
than selecting and deleting individual points, 
you can use the Erase tool to drag to delete 
parts of a path.

TIPTIP If you are familiar with the Erase tool in 
Adobe Illustrator, you will find it easy to use 
the Erase tool in InDesign.

To delete paths with the Erase tool:

1. Select the path that you want to delete 
parts of.

2. Choose the Erase tool in the Tools 
panel  D .

3. Press and drag the Erase tool along the 
path.

4. Release the mouse button to display the 
new path  E .

TIPTIP The Erase tool will always open a closed path.

TIPTIP If you drag the Erase tool over the middle of 
an open path, you create two separate open 
paths. Both open paths will be selected.

 D  The  Erase tool  in the Tools panel.

 E  The Erase tool deletes points as 
you drag it along a path.

Original path After using the Erase tool

Deleting or Removing Points: 
Which Tools or Commands Do What?

You may find yourself confused by all the dif-
ferent tools and commands for deleting or 
removing points and segments.

When does the action cause a break in a path? 
When does an action remove points without 
opening the path?

See the table on the next page for a review of 
how points are removed from paths, and the 
result.
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Adding or Deleting Points on 

Paths

The following table compares the diff erent 
tools and commands as to their eff ect when 
adding or deleting points on a path.

Tool or Command Action Result

Add Anchor Point tool Click a segment on the path Always adds a point to the path.

Delete Anchor Point 

tool

Click an existing point on the 
path

Deletes the point. The path 
reshapes without any break.

Erase tool Drag along a path Creates a break in the path.

Scissors tool Click a point or a segment Creates two end points at that 
position. 
The points can then be separated 
to create a break in the path.

Open Path command Applied to a path Creates two end points at the 
origin of the path. The points are 
indicated by selection.
The points can then be separated 
to create a break in the path.

Close Path command Applied to a path Creates a segment that joins two 
end points of a path.

Join command Applied to two endpoints of 
two separate paths selected 
with the Direct Selection tool

Creates a segment that joins the 
two separate paths into a single 
path.

Delete command Applied to points or segments 
selected with the Direct Selec-
tion tool

If applied to a selection in the 
middle of a path, the com-
mand breaks the path into two 
 segments.
If applied to a selection at the end 
of a path, the command shortens 
the path.
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Imported Graphics
One reason desktop publishing 

became so popular is how easy it 
made combining graphics such as pho-
tographs and illustrations with type for 
layouts.

In the years before designers began 
using personal com puters, spe cialized 
workers, toiling under the exotic name 
of strippers, manually trimmed away the 
blank areas around graphics so that text 
could be placed around the image. (The 
name stripper is derived from combin-
ing strips of fi lm together.)

Even more compli cated was placing 
text over an illustration. The image and 
text had to be combined by photogra-
phy and then stripped into the layout.

Certainly you expect InDesign to import 
images in the formats that are used 
by other page-layout programs. But 
because this is Adobe InDesign, you also 
get some special benefi ts when work-
ing with other Adobe products.

Here’s where you learn how to add 
imported artwork to your page layouts. 
It only takes a few clicks of a mouse to 
combine type and artwork together. 
It’s enough to make old-time strippers 
hang up their tassels!
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Placing Artwork

Most artwork that’s used in InDesign comes 
from other sources such as Adobe Photoshop, 
Adobe Illustra tor, or Adobe Acrobat. You can 
even place the contents of one InDesign 
fi le as a graphic into another. In all of these 
instances you use the Place command to add 
the artwork to your fi le.

To import artwork into InDesign:

1. Choose File > Place. This opens the Place 
dialog box  A .

2. Navigate to find the file you want to 
import. 

3. Select the Show Import Options checkbox 
to open the Import Options dialog box 
before you place the file. 

4. Click Open to load the graphic into an 
image cursor  B .

TIP Hold the Shift key as you click Open to open 
the Import Options dialog box, even if the 
option is not selected.

Once you have imported the artwork into an 
image cursor, there are choices as to how to 
add the graphic to the fi le.

To place the graphic at its actual size:

Click the cursor to place the graphic in a 
rectangular frame the same size as the 
artwork.

To place the graphic into an existing frame:

Position the cursor over an empty frame 
and click. Curves appear around the 
cursor indicating you are about to place 
the image within the frame  C .

TIP Hold the Opt/Alt key to place the image into a 
frame that already contains an image.

A  Use the  Place dialog box  to open a fi le you 
wish to place. Select Show Import Options 
to make refi nements to the imported fi le.

 B  The  loaded image 
cursor  appears 
when you prepare 
to place artwork.

 C  The  curved loaded 
image cursor  
appears when 
you position the 
loaded cursor over 
an existing frame.
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To place artwork into a custom-sized frame:

Drag the image cursor to define the size 
of the rectangular frame. The frame size is 
constrained to the correct proportion to 
hold the image  D .

TIPTIP Hold the Shift key as you drag to create the 
frame in any other proportion.

You can also place artwork directly into a 
selected frame. This is handy if you have set 
up empty frames as placeholders for graphics.

To place artwork into an existing frame:

1. Use one of the tools to create a rectang-
ular, elliptical, or polygonal frame.

TIPTIP You can use either the frame tools that 
create graphic frames or the tools that create 
unassigned frames.

2. Use either the Selection or Direct 
Selection tool to select the frame.

3. Choose File > Place and navigate to find 
the image you wish to place in the frame.

4. Click Open in the Place dialog box. The file 
automatically is inserted within the frame.

TIPTIP You can also use the Pen tool to create frame 
shapes.

To replace the artwork in an existing frame:

1. Use either Selection tool to select the 
frame that contains the artwork you want 
to replace.

2. Choose File > Place and navigate to find 
the image you wish to place.

3. Click Replace Selected Item in the Place 
dialog box.

4. Click Open in the Place dialog box. The 
new image automatically replaces the 
contents of the frame.

 D   Drag to create a custom-sized frame  
that contains a placed image.

File Formats

A wide variety of graphic formats can be added 
to InDesign documents. These formats are 
recommended for professional printing:

 • Adobe Illustrator (AIAI)

 • Adobe Photoshop (PSD)

 • Adobe InDesign (ID)

 • Encapsulated PostScript (EPSEPS)

 • Desktop Color Separation (DCSDCS)

 • Joint Photographic Experts Group (JPEGJPEG)

 • Portable Document Format (PDFPDF)

 • Portable Network Graphics (PNGPNG)

 • PostScript (PS)

 • Scitex Continuous Tone (SCT)

 • Tagged Image File Format (TIFFTIFF)

These formats should be used only for onscreen 
PDF review, or for printing to non-PostScript 
printers:

 • Enhanced Metafiles (EMF)

 • Macintosh Picture (PICTPICT)

 • Graphics Interchange Format (GIFGIF)

 • PC Paintbrush (PCX)

 • Windows Bitmap (BMPBMP)

 • Windows Metafile (WMF)
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To move or copy artwork between frames:

1. Use the Direct Selection tool to select the 
artwork you want to replace.

2. Choose Edit > Cut or Edit > Copy. This 
places the artwork on the clipboard.

3. Select the frame that you want to move 
the artwork into.

4. Choose Edit > Paste Into. The contents 
of the clipboard are pasted into the frame.

You can also select multiple items in the Place 
dialog box and then add all the items to your 
document. This way you don’t have to keep 
going back to the Place dialog box.

To place multiple items at once:

1. Choose File > Place to open the Place 
dialog box.

2. Use the Cmd/Ctrl key to select the items 
you want to place.
or
Use the Shift key to select a range of 
items.

3. Click the Open button. The cursor displays 
a preview of the placed file. A number 
next to the preview indicates there are 
multiple files  A .

4. Click or drag to place each item. The 
number reduces as you place each item.

TIP Use the up/down or left/right arrow keys to 
cycle through the placed items.

TIP Use the ESC key to delete an item from the 
loaded cursor.

TIP Use the Opt/Alt key to swap the item in a 
frame with the item in the loaded cursor.

TIP You don’t have to limit yourself to one kind of 
item. You can load the cursor with Photoshop, 
PDF, or other types of files. You can even mix 
text files with image files!

 A  The  numbered 
loaded cursor  
indicates you 
have more than 
one placed item.

What can you do with a loaded cursor?

Be careful when you’ve got a loaded cursor in 
your hand. Never point it at anyone unless you 
intend to use it.

Once you have the loaded cursor, what can you 
do without losing the placed items? Surpris-
ingly, there’s a lot you can do.

You can go to any menu, open panels, or even 
go to another document. Your cursor remains 
loaded when you come back to your document.

However, you will lose the items in a loaded 
cursor if you choose any tool in the Tools panel 
or press a key that chooses a tool.

Placing ID files into another ID file

There’s something very existential about it, but 
you can place an InDesign file as a graphic into 
another InDesign file. 

The placed file behaves exactly like a placed 
PDF document. When you modify the placed 
graphic, it updates in the InDesign layout. You 
can turn the layers on or off just like you can with 
PDF documents.
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This is fun! Once you have loaded multiple 
images, you can place them all at once on the 
page in a grid of frames.

To place imported graphics into a grid of 
frames:

1. Use steps 1–3 in the previous exercise to 
load the cursor with multiple items.

2. Hold the Cmd/Ctrl-Shift keys. The cursor 
changes to the grid icon  B .

3. Drag the mouse to create an area for the 
grid  C . As you drag you can release the 
Cmd/Ctrl-Shift keys.

4. Without releasing the mouse button, 
press the Shift key and use the following 
modifier keys to adjust the spaces 
between the frame grid:
 • Left arrow decreases the space 

between the columns.
 • Right arrow increases the space 

between the columns.
 • Down arrow decreases the space 

between the rows.
 • Up arrow increases the space between 

the rows.
5. Continue to drag the mouse and press 

the following modifier keys to adjust the 
number of frames inside the grid:
 • Left arrow decreases the number of 

columns.
 • Right arrow increases the number of 

columns.
 • Down arrow decreases the number of 

rows.
 • Up arrow increases the number 

of rows.
6. Release the mouse button when you have 

the correct size and number of frames in 
the grid  D .

TIPTIP Click to place the grid at the same size as 
the page. 

 B  The  grid icon  indicates you will place 
graphics in a grid on the page.

 C  Drag to create a  grid of frames  
for multiple placed images.

 D  A  grid of frames  for multiple images.
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Using Bridge and Mini Bridge

Adobe Bridge is a separate application that 
is installed automatically when you install 
InDesign. Bridge is a fi le browser that lets 
you organize, sort, and view artwork. It also 
lets you drag graphics directly onto InDesign 
pages.

To open Bridge:

Choose File > Browse in Bridge. The 
Bridge window appears. You can also click 
the Bridge icon in the Control panel  A .

To place artwork from Bridge:

1. Position the Bridge and InDesign 
windows so that both are visible.

2. Select one or more files in the Bridge 
window.

3. Drag the file or files from Bridge onto 
the InDesign page  B . Release the mouse 
button to place the item. 

4. If you have dragged multiple files, click 
or drag to place the additional images on 
the InDesign pages.

Bridge takes up a lot of screen space. Mini 
Bridge is a smaller version of the full Bridge 
that lets you preview and drag fi les into 
InDesign fi les.

TIPTIP Mini Bridge is also convenient to use as 
it always stays in front of the InDesign 
application window.

To open and use Mini Bridge:

1. Choose Window > Mini Bridge to open the 
Mini Bridge panel  C .

2. Drag images from the panel onto the 
InDesign pages.

 B   Drag an image from Adobe Bridge  
to place it onto an InDesign page.

A   Click the Bridge icon in the Control 
panel to open Adobe Bridge. 

 C   Mini Bridge  is a smaller version 
of the full Adobe Bridge.
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Specialty Frames

Frames don’t have to be single items drawn 
from scratch. You can join frames into one 
compound shape or you can convert text 
into frames that can hold images. You can 
also bring paths from other programs into 
InDesign to act as frames.
You can make multiple frames act as a single 
item by converting them to a compound 
shape. Frames combined into a compound 
shape display a single image across all the 
items in the compound.

To create a compound shape:

1. Select the frames you want to combine 
into a compound shape.

TIPTIP If the frames overlap, InDesign displays a 
transparent hole where they overlap.

2. Choose Object > Paths > Make 
Compound Path. If the frame is a graphic 
frame, the diagonal lines cross through all 
the frames in the compound  D  and  E .

To add an image to a compound shape:

1. Use either Selection tool to select the 
compound shape.

2. Use any of the techniques described on 
the previous pages to place the image in 
the selected frame. The image tiles across 
the spaces between the elements of the 
compound shape  F .

To split a compound shape:

1. Select the compound shape.
2. Choose Object > Paths > Release 

Compound Path. The image is shown 
only through the first frame; the rest of 
the compound frames are available to 
hold other images.

 E  A  compound shape displays the diagonal 
lines  across the entire set of frames.

 F  A  placed image is seen across all 
the items  in a compound shape.

 D  Individual frames that act independently 
display diagonal lines within each object.
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You can also create unique frame shapes by 
converting text to frames so graphics assume 
the shapes of letters.

TIP If you can’t draw for beans, you can convert 
the characters in dingbat or symbol fonts 
into graphic shapes such as hearts, arrows, 
snowflakes, and so on.

To convert text to frames:

1. Use the Selection tool to select the frame 
that contains the text.
or
Highlight the selected text within the 
frame.

2. Choose Type > Create Outlines. Each 
character of text is converted to paths 
that can be modified  A .

TIP You can also place images into the converted 
text paths just like you can with compound 
shapes  B .

TIP The converted paths are created as 
compound paths. If you want to place 
different images or colors in each of the 
frames, release the compound shape first.

TITIPP If you select only a portion of the text within 
the frame, the highlighted text is converted 
to inline graphics within the frame.

 A  The  Create Outlines command  converts 
text into paths that can then be modifi ed.

Frame

Paths

 B  Text converted to paths can also 
hold imported graphics.
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If you work with a vector-drawing program 
such as Adobe Illustrator or FreeHand, you 
can also convert the paths in those programs 
to InDesign frames.

TIPTIP In addition to Illustrator and FreeHand, 
this technique can be used with any other 
program that copies paths using the AICB 
(Adobe Illustrator Clipboard). Check your 
vector-drawing program manual for more 
information.

To import paths as frames:

1. Position the windows of the vector-
drawing program and InDesign so they 
are both visible onscreen.

2. Select the paths in the vector-drawing 
program with the appropriate tool in that 
application.

3. Drag the paths from the vector-drawing 
program onto the window of the 
InDesign document.

4. When a black line appears around the 
perimeter of the InDesign window, 
release the mouse button. The paths 
are converted to InDesign unassigned 
frames  C .

TIPTIP If you don’t have the screen space to see 
both windows at once, you can also use the 
clipboard to copy the paths from the vector 
program and paste them into InDesign.

TIPTIP Once the vector path has been converted to 
an InDesign frame, it can be used to hold an 
image or text  D .

 D  Graphics converted to frames 
can hold images or text.

Dragging from Illustrator

If you want to import paths from Adobe Illus-
trator, you need to make sure that Illustrator’s 
preferences are set correctly.

Choose File Handling And Clipboard in Illustra-
tor’s Preferences dialog box. Under the Clipboard 
section, select the AICBAICB (no transparency setting) 
option. Then click the Preserve Paths button.

If this is not done, the Illustrator paths will not 
be converted to frames.

C  Artwork can be dragged from a 
vector program and converted 
into InDesign frames.
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Setting the Image Import 

Options

When you import a graphic, you can use the 
Image Import Options dialog box to control 
how that image is placed.

TIP The following chart shows which types of 
import options are applied to pixel images.

Import Options for Placed Images

TIFF Image Import Options with 
controls for Image and Color

JPEG Image Import Options with 
controls for Image and Color

PSD Image Import Options with 
controls for Image, Color, and 
Layers

EPS EPSEPS Import Options

Illustrator PDFPDF Import Options with con-
trols for Layers

PDF PDFPDF Import Options with con-
trols for Layers

InDesign PDFPDF Import Options with con-
trols for Layers

To set the options for TIFFTIFF and JPEGJPEG images:

1. In the Place dialog box, select the Import 
Options checkbox.

2. Choose a TIFF or JPEGJPEG image and click 
Open. This opens the Image Import 
Options dialog box for TIFFTIFF or JPEG 
images  A .

3. Select the Image tab. If the image has 
a clipping path, you can choose Apply 
Photoshop Clipping path.

4. Select the Color tab. Use the controls to 
set the Color Management settings.

5. Click OK to place the image.

 A  The  Image Import Options dialog 
box for TIFFTIFF and JPEG images.

Best File Format from 
Adobe Illustrator?

If you work in Adobe Illustrator, you will notice 
that there are several file formats you can 
choose from when you save your work: native 
Illustrator, EPSEPS, or Adobe PDF. Which one works 
best with InDesign?

All three file formats can be placed into InDesign 
documents. However, native Illustrator files have 
the best preview.

You may have old Illustrator documents that 
were saved as EPSEPS files. There’s no need to resave 
them. You can place them into InDesign too.

However, you may see a white background 
behind artwork that has been saved on a 
Macintosh as an EPS. If that is a problem, use the 
Rasterize the PostScript option during import to 
eliminate the white background.
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To set the options for PSDPSD images:

1. In the Place dialog box, select the Show 
Import Options checkbox.

2. Choose a Photoshop image and click 
Open. This opens the Image Import 
Options dialog box for Photoshop files  B .

3. Choose Show Preview to see a preview of 
the file.

4. Select Image Settings. If the image has 
a clipping path, you can choose Apply 
Photoshop Clipping path.

5. Select the Color tab. Use the controls to 
set the Color Management settings.

6. Select Layers. If the image has layers or 
layer comps, you can choose which layers 
are visible in the InDesign layout.

7. Click OK to place the image.

To set the import options for EPSEPS images:

1. In the Place dialog box, select the Show 
Import Options checkbox.

2. Choose an EPS file. This opens the EPS 
Import Options dialog box  C .

3. Don’t select Read Embedded OPIOPI Image 
Links unless your service bureau has 
instructed you to have InDesign perform 
the image swapping.

4. If the image has a clipping path, you can 
choose Apply Photoshop Clipping Path.

5. Set the options in the Proxy Generation 
section to control the preview of the 
image:
 • Use TIFF or PICTPICT Preview uses the 

preview that was created with the file.
 • Rasterize the PostScript displays the 

actual PostScript data as a preview. This 
lets you see custom PostScript code 
such as is found in FreeHand.

6. Click OK to place the image.

 B  The  Image Import Options 
for Photoshop fi les . 

 C  The  EPSEPS Import Options dialog box  
lets you control imported EPS fi les. 

Working with Photoshop Layer Comps

A layer comp is a snapshot of a state of the Layers 
panel. Layer comps record the visibility, position 
and appearance of the layers in a Photoshop file.

You create layer comps in Photoshop. The 
names of the layer comps are then available 
within InDesign.

Using layer comps makes it possible to have sev-
eral variations of the same file within InDesign.
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InDesign also lets you place PDFPDF fi les as 
graphics.

To set the options for PDFPDF fi les:

1. In the Place dialog box, select the Show 
Import Options checkbox.

2. Choose a PDFPDF file. This opens the Place PDFPDF 
dialog box  A .

3. Choose Show Preview to see a preview of 
each page of the PDFPDF.

4. Use the page selectors to select the page 
you want to place  B . If you select multiple 
pages, use the following exercise to place 
the multiple pages.

5. Click the General tab to see those options.
6. Use the Crop To list to deter mine how 

the PDFPDF should be cropped within the 
frame  C . Choose the crop options:
 • Bounding Box crops to the active 

page elements, which includes printer 
marks.

 • Art crops to the area defined as 
placeable art.

 • Crop crops to only the printable area, 
not to the printer marks.

 • Trim crops to the area that is the final 
trim size.

 • Bleed crops to the area that is the total 
size of the image if a bleed area has 
been specified.

 • Media crops to the page size of the 
original document.

7. Choose Transparent Background to show 
only the elements of the page, without 
the opaque background  D .

TIPTIP If you choose Transparent Background, you 
can make it opaque by adding a fill color to 
the frame that contains the PDFPDF.

8. Click the Layers tab to set the layers for 
the PDFPDF.

9. Click OKOK to place the image.

 A  The  Place PDF dialog box  lets you preview 
and control the options for PDF fi les.

 C  The  Crop To menu  in the Place PDF dialog 
box controls the size of the placed artwork.

 D  The eff ect of the  Transparent 
Background  on a placed PDF image. 

Transparency off Transparency on

 B  The  page selectors  let you preview 
the pages of a multipage PDF.
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PDFPDF documents can contain more than one 
page. If you want, you can place those mul-
tiple pages all at once, without having to go 
back to the Place PDFPDF dialog box.

TIPTIP Illustrator CS5 allows you to save multiple 
artboards with a file. These import with the 
same controls as the multiple pages in PDFPDF 
files  E . 

To place multiple pages from a PDFPDF:

1. In the Place PDFPDF dialog box, choose one of 
the following:
 • Previewed Page selects whatever page 

is selected in the Preview area.
 • All selects all the pages in the 

document.
 • Range allows you to specify individual 

pages or a range of pages. Use commas 
to separate individual pages; use a 
hyphen to specify a range of pages.

2. Click OKOK to load the cursor.

TIPTIP The cursor for a PDFPDF displays a plus (+) sign 
when it is loaded with multiple pages  E . 

3. Click as many times as necessary to 
load all the pages. When the plus sign 
disappears from the cursor, you have 
reached the last page to be placed.

Placing Multiple PDF Pages from Bridge

Part of my job is not only to tell you what you 
can do in InDesign, but also to tell you what you 
can’t do. Sadly, this sidebar is to tell you what 
you can’t do when placing a PDFPDF file from Adobe 
Bridge into InDesign.

When you select a PDFPDF in Bridge, the Preview 
pane adds page controls that allow you to view 
the various pages in the PDFPDF.

I would have sworn that the Adobe engineers 
would have designed the program so that what-
ever page was displayed in the Bridge Preview 
would automatically be the page placed when 
you dragged from Bridge onto an InDesign 
page.

Nope, it doesn’t work that way. Even if you set 
the PDFPDF import option to place a specific page, 
dragging from Bridge places only the first page 
of the PDFPDF.

As much as I am a big fan of using Bridge in my 
workflow, this is an example of where Bridge is 
not as useful as working with the ordinary Place 
dialog box.

 E  The  plus sign (+) 
in the PDF cursor  
indicates that you 
can place multiple 
pages from the PDF.



216 Chapter 8 Imported Graphics

Working with Images Inside 

Frames

After you place an image, you may want to 
move or modify it. Which tool you use and 
where you click aff ects what will be selected.

To select and move both the frame and the 
image:

1. Use the Selection tool and click the frame 
holding the image. A bounding box 
appears that indicates that the frame and 
its content are selected  A .

2. Move the selection tool inside the 
bounding box and drag to move both the 
frame and the image  A .

TIP Do not drag the content grabber (the donut) 
or you will select and move the image inside 
the frame.

You can also use the Selection tool to move 
an image within a frame. This requires view-
ing and dragging the content grabber (the 
donut) within the frame. (Honest! Adobe calls 
this the donut.)

To select the image inside the frame:

1. Move the Selection tool inside the frame 
and position it over the content grabber. 
The grabber hand appears.

2. Click with the grabber hand. This selects 
the image within the frame  B .

To select and move the image inside the 
frame:

1. Move the Selection tool inside the frame 
and position it over the content grabber. 
The grabber hand appears.

2. Press and drag to move the image within 
the frame  C .

TIP You can also use the Direct Selection tool to 
select an image within a frame.

B   Click on the selection content grabber  
to select the image inside a frame.

C   Press and drag on the content grabber  
to move the image inside a frame.

A  The Selection tool  displays the 
content grabber (the donut)  when it 
comes into the area of the frame.

Outside frame Inside frame
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You can use the Selection tool to resize both 
the frame and the image as you drag.

To resize a frame and image by dragging:

1. Select the image to be resized.
2. Click the Auto-Fit command in the Control 

panel.
3. Drag one of the handles for the frame. 

The image and frame resize together.

TIPTIP You can also hold the Cmd/Ctrl key as you 
drag the frame to resize the image inside the 
frame.

When you apply transformations to frames 
that contain placed images, you have a choice 
as to which objects — the frame, the image, 
or both — are transformed. Here are some 
helpful guides.

TIPTIP If you pause before you drag with any of the 
transform tools, you will see a preview of the 
image as you transform it.

To transform both the frame and the placed 
image:

1. Use the Selection tool to select both the 
frame and the placed image.

2. Use any of the Transform panel fields or 
transform tools  D . 

To modify the content only:

1. Click the image grabber within a frame to 
select the artwork.

2. Use any of the Transform panel fields 
or transform tools to modify only the 
selected image  E . 

To modify the container frame only:

1. Use the Direct Selection tool to select the 
frame that contains the image.

2. Use any of the Transform panel fields 
or transform tools to modify only the 
selected frame  F . 

 D  An example of  a frame and image 
that have been transformed . 

F  An example of  a frame that has 
been transformed  without changing 
the image within the frame.

 E  An example of  an image that has 
been transformed  without changing 
the frame that holds the image .



218 Chapter 8 Imported Graphics

Fitting Graphics in Frames

Placed images don’t always fi t perfectly into 
preexisting frames. InDesign gives you several 
commands that let you quickly posi tion and 
resize artwork in frames.

To proportionally resize to the frame size:

1. Use either selection tool to select the 
frame or the graphic inside the frame.

2. Choose Object > Fitting > Fit Content 
Proportionally. This changes the size of 
the graphic to fit completely, and without 
distortion, within the frame  B .

TIP Use the Fit Frame to Content command to 
resize the frame to the size of the graphic. 

The Fit Content Proportionally command 
usually leaves some empty space between 
the graphic and the frame. What if you want 
to resize the image so that it fi lls the entire 
frame? That’s where the Fill Frame Propor-
tionally command comes to the rescue.

To resize the graphic to fi ll the frame:

1. Use either selection tool to select the 
frame or the graphic inside the frame.

2. Choose Object > Fitting > Fill Frame 
Proportionally. This changes the size of 
the graphic to fit completely, and without 
distortion, within the frame  C .

To resize the frame to the graphic size:

1. Use either selection tool to select the 
frame or the graphic inside the frame.

2. Choose Object > Fitting > Fit Frame 
to Content. This changes the size of the 
frame so that the artwork fits completely 
within the area of the frame  D .

 B  The eff ect of the  Fit Content 
Proportionally command .

Before After

“Why Does the Frame Say 100% 
Even Though I Resized the Image?”

Here’s something that confuses my students. 
They import an image into a frame, and then 
choose Fit Content Proportionally to shrink the 
image.

When they look at the Control panel the frame 
size is listed at 100%. That seems impossible; 
how can the image which has just been shrunk 
down still be listed as 100%? The answer is that 
the frame may be listed as 100%, but if you 
select the image with the Direct Selection tool, 
you’ll see the percentage that the image was 
scaled.

 C  The  Fit Content Proportionally command  
may leave a gap between the frame and 
the image. The Fill Frame Proportionally 
command always fi lls the frame.

Before
Fit Content 
Proportionally

Fill Frame 
Proportionally
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If a frame is larger than the content, you can 
resize the frame to the size of the graphic by 
clicking the frame handles.

To resize the frame by clicking the handles:

1. Use the Selection tool to select the frame.
2. Click the frame handles as follows:

 • Double-click a corner handle to resize 
both horizontally and vertically.

 • Double-click the left or right handles to 
resize either horizontally.

 • Double-click the top or bottom handles 
to resize vertically.

TIPTIP This works on both images and text.

Sometimes you need to put a graphic in the 
center of a frame. This is especially helpful 
if an image has been transformed so it is no 
longer visible within the frame.

To center the graphic within the frame:

1. Use either selection tool to select the 
frame or the graphic inside the frame.

2. Choose Object > Fitting > Center 
Content. This centers the graphic within 
the frame without changing the size of 
either the graphic or the frame  E .

TIPTIP The Fitting commands are also available on 
the Control panel  F .

 D  The eff ect of the  Fit Frame 
to Content command .

Before After

 E  The eff ect of the  Center Content command .

Before After

 F  Use the  Fit icons in the Control panel  
to modify placed images and frames.

Fit Content 
Proportionally

Center 
Content

Fit Frame 
to Content

Fit Content 
to Frame

Fill Frame 
Proportionally
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Many designers work with frames already in 
the layout to which they add images. What 
they want is their image to automatically be 
placed at the correct size — fi lling the frame, 
or scaled proportionally. InDesign lets you 
apply that setting to empty frames.

To apply the fi tting commands to empty 
frames:

1. Select the frame.
2. Choose Object > Fitting > Frame Fitting 

Options to open the Frame Fitting 
Options dialog box  A .

3. Use the Crop Amount to specify how 
much area of the image should be outside 
the frame.

4. Set the Align From reference point 
to choose how the image should be 
positioned when cropped or scaled.

5. Use the Fitting list to set how the image 
will be scaled when placed into an empty 
frame  B .
or
Choose None to leave the image unscaled 
when placed. 

 A  Use the  Frame Fitting Options 
dialog box  to set how images appear 
when placed into a frame.

 B  The  Fitting controls list  lets you choose 
the Fitting options for how an image is 
scaled when placed in an empty frame.



InDesign CS5 Visual Quickstart Guide 221

In addition to the commands that posi-
tion graphics, you can also position images 
numerically within frames using the X and Y 
coordinates in the Transform panel.

To numerically position graphics within 
frames:

1. Select Show Content Offset in the 
Transform panel menu.

2. Use the Direct Selection tool to select the 
graphic inside the frame.

3. Enter the X and Y coordinates in the 
Transform panel. The image moves to a 
new position relative to the frame  C . This 
is called the content offset.

TIPTIP Small plus signs (+) next to the X and Y 
coordinates in the Transform panel indicate 
that Show Content Offset is turned on  D .

To numerically position graphics on the 
page:

1. Deselect Show Content Offset from the 
Transform panel menu.

2. Use the Direct Selection tool to select the 
graphic inside the frame.

3. Set the X and Y coordinates in the Trans-
form panel. The image moves to a new 
position relative to the page rulers. This is 
called the absolute offset.

Of course you can use any of the transforma-
tion commands to scale, rotate, and shear 
objects within the frame. This allows you to 
scale images numerically within a frame.

To transform images within a frame:

1. Use the Direct Selection tool to select the 
graphic inside the frame.

2. Use any of the Transform tools or the 
Transform panel.

 C   Content off set  positions the graphic 
relative to the frame. Absolute off set 
positions the graphic relative to the page.

Content offset on Absolute offset

 D  The  plus signs (+) next to the X and Y 
coordinates  indicate that the position 
of the object is relative to the frame.
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Nesting Graphic Elements

Once you have an image in a frame, you can 
then paste it into another frame. This tech-
nique is called nesting elements and it allows 
you much more fl exibility in assembling vari-
ous images than other programs.

TIP For instance, you can use nested elements to 
put a placed image inside a circular frame, 
and then put that circular frame inside a 
rectangular frame. The top rectangular frame 
crops the circular frame while the circular 
frame crops the placed image. 

To create a nested frame:

1. Use the Selection tool to select the 
element to be nested inside the frame  A .

TIP A nested element can be a graphic or text 
frame.

2. Cut or copy the element to the clipboard.
3. Select the frame that is to hold the nested 

element.
4. Choose Edit > Paste Into. This pastes the 

element inside the frame  B .

TIP The Selection tool moves all the elements in 
the nest.

TIP Frames can hold multiple levels of nested 
frames. So you can have a frame within a 
frame within a frame, and so on.

TIP Use the Fit Content commands to 
automatically position the nested frame 
inside the parent frame.

 A  Before nesting, the circular frame with 
the placed image is a separate object.

 B  After nesting, the circular frame is the 
content inside the rectangular frame.
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Styling Placed Images

Once you have placed a graphic within a 
frame, you can employ many tech niques to 
style the frame or the image. For instance, 
you can change the color of the frame or the 
color of the image.

To color the frame fi ll or stroke:

1. Use the Selection tool to select the frame.
2. Click the Fill icon in the Tools panel or 

Color or Swatches panel.
or
Click the Stroke icon in the Tools panel or 
Color or Swatches panel.

3. Choose a color in the Swatches panel. If 
the Fill icon is chosen, you’ll see the fill 
color wherever the image doesn’t fill the 
frame  C .

If you import a grayscale image, you can add 
color to it, so you change the black values in 
the image.

To color a grayscale image:

1. Use the Direct Selection tool to select the 
grayscale image.

2. Choose the Fill icon in the Color panel or 
Tools panel.

TIPTIP The default fill color for grayscale images is 
black.

3. Change the tint value to lighten the 
image.
or
Choose a color in the Color or Swatches 
panel. The grayscale values change to a 
tint of the color chosen  D .

4. Use the steps in the previous exercise to 
change the fill color of the frame. This 
colorizes the white areas of the image.

Colorizing Grayscale Images

Your service bureau may tell you not to colorize 
grayscale images. Or you may get a warning 
from a preflight program that checks your docu-
ment before printing.

In theory there is nothing wrong with colorizing 
grayscale images, but individual production 
workflows may not be able to handle the images.

If you do get a warning, check with your print 
shop or service bureau to see whether or not it 
can handle them.

 C  When a frame is selected, 
choosing a fi ll color changes the 
background color of the frame.

 D  You can change the appearance of a 
grayscale image by changing the image 
color or the fi ll color of the frame.

Original

Image color tinted

Image color tinted and 
frame darkened
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Linking Graphics

When you place an image, you don’t actu-
ally place the image into the document. You 
place a screen preview of the image that links 
to the original graphic. In order to print the 
fi le, InDesign needs to follow that link to the 
original graphic.

TIP It is possible to link text files as well as 
graphics, but those are primarily used 
together with InCopy. 

To examine the links in a document:

1. Choose Window > Links. This opens the 
Links panel  A . The Links panel shows all 
the linked images in the document with 
their page numbers. Special icons indicate 
the status of the image  B .
 • Missing Link indicates that InDesign 

can’t find the original graphic.
 • Modified Link indicates that the 

graphic has changed and has a 
different modification date from when 
it was originally placed.

2. Click the page numbers to go to that 
instance of the link.

TIP When there is more than one instance of a 
link, the link name appears with an arrow 
that groups all instances of that link. Click the 
arrow to display all the instances.

 A  The  Links panel  displays the names of 
the placed images in the document.

 B  The  icons and page numbers next 
to a listing in the Links panel  tell 
you the status of a placed image.

Modified link

Missing link

Page number



InDesign CS5 Visual Quickstart Guide 225

The Missing or Modifi ed Links notice appears 
when you open a fi le whose link is missing or 
has been changed  C .

To relink graphics when you open a 
document:

1. Click the Update Links button in the 
Missing or Modified Links notice. All 
modified graphics are automatically 
updated.

2. If there are missing links, the operating 
system navigation dialog box opens. Use 
it to find each missing graphic.

You can use the Links panel to relink missing 
graphics to the screen preview.

To relink a missing graphic:

1. Select the missing link in the Links panel.

TIPTIP You can also select multiple links. Shift-click 
to select a range of links. Cmd/Ctrl-click to 
select noncontiguous links.

2. Click the Relink button. This opens the 
navigation dialog box, which you can use 
to find the missing file.
or
Choose Relink from the Links panel menu.

3. Navigate to find the missing file.
4. Select the Search for Missing Links in 

This Folder checkbox to relink all missing 
graphics that are in that folder  D .

5. Select the Show Import Options checkbox 
to open the Import Options dialog box 
before you relink the graphic.

6. Click Open to relink the graphic. 

 C  The  Missing or Modifi ed Links notice  
appears when you open an InDesign 
document that has a link to a graphics 
fi le that is missing or modifi ed.

 D  Select the  Search for Missing Links 
in This Folder option  to update all 
missing images in that folder.

Working With Missing Images

I often transfer an InDesign file from a storage 
CD onto my hard drive. When I do, InDesign 
notifies me that the links for the file are missing. 

I don’t often update those links because I know 
that as soon as I eject the CD, I’m going to get 
the notice that the images are missing.

I just work on the InDesign file and then update 
the links when I’m ready to send the finished file 
to my publisher. It doesn’t really matter to work 
on a file with missing links.

I just click the Don’t Update Links button.
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If a graphic has been modifi ed, you can use 
the controls at the bottom of the Links panel 
to update the link.

To update modifi ed links:

1. Select the modified link in the Links 
panel.

2. Click the Update Link button  A  or choose 
Update Link from the Links panel menu.

TIP Shift-click to select a range of links. Cmd/Ctrl-
click to select noncontiguous links.

The Links panel also lets you move quickly to 
a specifi c graphic.

To jump to a linked graphic in the 
document:

1. Select the link in the Links panel.
2. Click the Go to Link button  A  or choose 

Go to Link from the Links panel menu.

The Links panel can also be used to open and 
edit a graphic.

To edit a linked graphic:

1. Select the graphic you want to edit.
2. Choose Edit Original from the Links panel 

menu. The graphic opens in the program 
that created it.
or
Click the Edit Original icon in the Links 
panel  A . 

TIP To force a graphic to open in a certain 
program, choose Edit With and then choose a 
program from the Links panel menu.

TIP Hold the Opt/Alt key and double-click the 
graphic to edit the original.

Links for Text Files

InDesign also has a preference that automati-
cally creates a link for placed text files. With the 
preference turned on, if you modify the original 
text file that was placed in the InDesign docu-
ment, you see a notice when you open the file 
that links are missing or modified.

It might seem like a good idea to use the Update 
Link command to update the text within the 
InDesign document. If you do, you will lose any 
formatting or changes you have applied within 
InDesign.

In most cases it is not necessary to keep the link 
for text files. You are probably better off embed-
ding the text file within the document.

If you are working with InCopy or some other 
sort of workgroup software, you may not be able 
to embed text files within the document. In that 
case, check with your workgroup supervisor for 
the proper procedures.

 A  The  icon commands in the 
Links panel  allow you to access 
frequently used commands.

Relink

Go to Link

Update Link

Edit Original
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You may want to fi nd a placed image in 
the Macintosh Finder, Windows Explorer, or 
Bridge window.

To fi nd the linked fi le:

1. Select the graphic in the Links panel.
2. Choose one of the following in the Links 

panel menu:
 • Reveal in Finder (Mac) or Reveal in 

Explorer (Win) to select the file in the 
operating system directory.

 • Reveal in Bridge to select the file in the 
Bridge window.

The Link Information dialog box gives you 
information about an imported graphic.

To see the link information:

1. Select the graphic in the Links panel.
2. If the Link Info is not visible, click the Link 

Info toggle in the Links panel. This reveals 
the link information area  B .

3. Use the Next or Previous buttons to move 
to other graphics in the Links panel.

If all the information in the Link Info area is 
too much to handle, you can customize what 
items are displayed.

To customize the Link Info items:

1. Choose Panel Options from the Links 
panel.

2. Use the Row Size menu to make the list of 
linked items larger or smaller  C .

3. Click the options for Thumbnails to 
display them in the Name Column and/or 
the Link Info area.

4. Use the Show Column checkboxes to 
show information in the top of the Links 
panel.

5. Use the Show in Link Info checkbox to 
show information in the Link Info area. 

 C  The  Panel Options  for the Links panel.

 B  The  Link Info area  in the Links panel gives 
you information about a placed graphic.

Link Info toggle Previous Next
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Embedding Graphics

Usually, only the preview of a graphic is 
contained within an InDesign fi le. You 
can, however, embed a graphic within the 
InDesign fi le. This means that all the informa-
tion necessary to print the fi le is contained 
within the InDesign document.

TIP Embedded graphics will increase the size of 
the InDesign file. 

To embed placed images or text:

1. Select the placed image.
or
Select the frame that contains the 
imported text.

2. Choose Embed Link from the Links panel 
menu. If you have selected a graphic, the 
Embed icon appears next to the file name 
in the Links panel  A .
or
If you have selected text, the file name 
disappears from the Links panel.

TIP Embedded text files do not add to the size of 
the InDesign file.

TIP Once you embed a graphic, InDesign no 
longer needs to find the original file on your 
hard disk.

To unembed images:

1. Select the embedded image.
2. Choose Unembed Link from the Links 

panel menu. The Unembed alert box 
appears  B .

3. Click Yes to link the embedded graphic 
back to the original file that was placed 
into InDesign.
or
Click No. A dialog box appears asking you 
to choose the destination for a new file.

When to Embed Graphics

You may be tempted to embed many, if not all, 
of your graphics within the InDesign document. 
After all, it makes it much easier to send a file to 
the service bureau if you don’t have to remem-
ber to send the graphic files along with it.

Embedding graphics increases the size of the 
InDesign file. Just a few large graphics can make 
the InDesign file balloon in size. This means the 
file will take a long time to open or save.

You shouldn’t have problems, though, if you 
embed small graphics, such as logos. Just 
remember that each time you embed a small 
graphic, it adds to the file size. Page after page 
of small graphics adds up.

I always embed images that are part of snippets. 
That way I only have to drag the one snippet 
onto the InDesign page and I don’t worry about 
missing links.

 B  The  Unembed alert box  lets you 
choose to link back to the original 
fi le or create a new fi le.

A  The  Embed icon in the Links panel  
indicates that all the information 
necessary to print the graphic is 
stored in the InDesign fi le.
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Setting Layer Visibility

When you import Photoshop, Illustrator, 
InDesign, and PDFPDF fi les, you have the chance 
to set the visibility of the layers in those fi les.

To set the layer options as you import fi les:

1. Choose Show Import Options when you 
place a layered Photoshop, Illustrator, 
InDesign, or PDFPDF file.

2. Click the Layers option in the Show 
Import Options dialog box  C .

3. Click the visibility icon for each layer to 
show or hide that layer.

4. If you have chosen a Photoshop file with 
layer comps, use the Layer Comp list to 
choose the layer comp that you want to 
apply to the image  D .

TIPTIP The layer comp description appears in the 
field under the Layer Comp list.

5. Select one of the following from the 
When Updating Link list:
 • Use Photoshop’s/PDFPDF’s Layer Visibility 

resets any overrides you have made in 
InDesign to the settings of the original.

 • Keep Layer Visibility Overrides 
maintains any layer settings you have 
made in InDesign.

TIPTIP The Layer Overrides information in the Links 
panel indicates if you have set the layers 
differently from the saved state of the file  E .

Once you have imported a layered fi le, you 
can also change the visibility of the layers.

To edit the layer options of a placed fi le:

1. Select the placed image.
2. Choose Object > Object Layer Options.
3. Use the steps in the previous exercise to 

make any changes.

 C  The  Layers controls  of the 
Place PDF dialog box.

Show/Hide Layer Icons

 D  The  Layer Comp list of the Image 
Import Options  for a Photoshop fi le.

Layer Comp description

 E  The  Yes for Layer Overrides in 
the Links panel  indicates that the 
visibility of the layers is diff erent 
from the saved state of the fi le.
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Importing Transparent Images

InDesign off ers you a special advantage when 
you place native Photoshop (PSDPSD) or Illustra-
tor (AI) fi les. If there is any transparency in the 
placed image, InDesign displays the image 
with the same transparency as in the original 
fi le.

To use the transparency in a Photoshop fi le:

1. In Photoshop, use any of the tools to 
silhouette or fade the edges of the 
image. The Photoshop transparency grid 
indicates which parts of the image are 
transparent  A .

2. Save the file as a Photoshop (PSDPSD) file.
3. Choose File > Place to import the file into 

the InDesign document.
4. Click to place the file. The areas that 

were transparent in Photoshop will be 
transparent in InDesign  B .

TIP You can combine the use of a Photoshop 
silhouette together with transparency 
to create an image with a see-through 
transparency.

To use the transparency in an 
Illustrator fi le:

1. In Illustrator, use any of the commands to 
apply transparency to the artwork.

2. Save the file as an Illustrator (AI) file.
3. Make sure that the PDF Compatibility 

option is selected in the Save dialog box.
4. Import the file into the InDesign 

document. The areas that were 
transparent in Illustrator will be 
transparent in InDesign.

B  A  transparent Photoshop fi le placed 
into InDesign  lets you see through the 
glass to the text behind the image.

A  The transparency grid in Photoshop 
lets you see the  fully transparent and 
semi-opaque areas  of the image.
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Using Clipping Paths

Raster images saved as TIFFTIFF or EPS fi les are 
always rectangular. If you want to see only 
part of the image you import, you can create 
a clipping path that surrounds the part of 
the image that you want to see. The rest of 
the image becomes transparent. One way to 
create a clipping path is to use Adobe Photo-
shop to create paths for the fi le. 

To import a fi le with a clipping path:

1. In Photoshop, use any of the the Path 
tools to create a path around the image.

TIPTIP Although you will not see the clipping effect 
in Photoshop itself, the areas of the image 
inside the path will be visible in InDesign. The 
areas outside the path will be invisible.

2. Use Photoshop’s Paths panel menu to 
designate the path as a clipping path  C .

3. Save the file as a TIFFTIFF, EPS, or Photoshop 
file.

TIPTIP You can have many paths saved as part of 
a Photoshop file, but only one path can be 
designated as a clipping path.

4. In InDesign, choose File > Place and 
choose the file you have created.

5. In InDesign’s Import Options dialog box, 
select Apply Photoshop Clipping Path  D . 
The image is automatically clipped so that 
only the areas inside the path are visible 
in the layout  E .

 D  InDesign’s  Image Import Options 
dialog box  lets you choose to 
apply a clipping path to a fi le.

 E  An example of how a clipping path creates 
a transparent area around an image.

Clipping path 
around corn

Background 
gradient

C   Photoshop’s Paths panel  shows the 
paths saved with the fi le. Clipping 
paths are shown in outlined type.

Designated 
clipping path

Ordinary path

The End of the Clipping Path?

A clipping path acts like a knife that cuts out 
the background of an image. This is good if you 
need a really sharp edge on an image. However, 
soft edges (like curly hair) may need variations in 
transparency that a clipping path can’t provide.

That’s when you want to use the transparency 
options in placing Photoshop images.
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Once you have a clipping path applied to a 
graphic, you can change the shape of the 
path to hide or show more of the image.

To modify the shape of a clipping path:

1. Use the Direct Selection tool to select the 
placed image. If the image has a clipping 
path, the path appears as a series of 
points and path segments  A .

2. Use any of the path techniques to change 
the shape of the clipping path.

You can also turn a clipping path into a frame. 
This lets you apply a stroke to the path.

To convert a clipping path into a frame:

1. Use either selection tool to select the 
image with the clipping path.

2. Choose Object > Clipping Path > Convert 
Clipping Path to Frame. The clipping 
path is converted into an ordinary frame.

You don’t have to designate a clipping path in 
Photoshop. InDesign lets you select any path 
saved with the image fi le as a clipping path.

To choose a path as an InDesign clipping 
path:

1. Select the placed image that includes a 
path.

2. Choose Object > Clipping Path > 
Options. The Clipping Path dialog box 
appears  B .

3. Use the Type menu in the Clipping Path 
dialog box to select the Photoshop Path 
option  C .

4. Use the Path menu to select which path 
should be used as a clipping path  D .

5. Click the Preview checkbox to see the 
effects of choosing a path.

6. Click OK to apply the path.

 A  Use the  Direct Selection tool 
to manipulate the shape of a 
clipping path  around an image.

Point

Path segment

Manipulating a 
point

 C  Use the  Clipping Path Type list  to choose 
which type of clipping path to apply.

 D  Use  the Path list  to choose a specifi c 
path attached to a graphic.

 B  The  Clipping Path dialog box  
lets you create or modify a 
clipping path for a graphic.
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Viewing Images

When you have a large document with a 
lot of images in it, you might fi nd that the 
redraw time is delayed as you move around. 
However, you can set preferences for how 
your images are displayed by lowering some 
of the image detail for increased speed as you 
move through pages. These display settings 
can be applied to the entire document or to 
individually selected objects.

TIPTIP The display settings for images don’t affect 
how the document will print.

To set the default appearance of previews: 

1. Choose Edit > Preferences > Display 
Performance (Win).
or 
Choose InDesign > Preferences > Display 
Performance (Mac). This opens the 
Display Performance Preferences dialog 
box  E .

2. Choose one of the three options from the 
Default View menu  F .
 • Fast is used when you want fast screen 

redraw and the best performance.
 • Typical is used when you want a better 

representation of the images.
 • High Quality is used when you want 

to see as much detail as possible 
onscreen. This option may cause 
InDesign to work slower than it will 
with the other choices.

TIPTIP Each of the menu choices corresponds to one 
choice in the Adjust View Settings list.

3. Select Preserve Object-level Display 
Settings to use the display settings that 
have been applied to individual images  G .

 E  The  Display Performance Preferences 
dialog box  controls how images and 
transparency eff ects are displayed.

 F  The  Default View list  lets you 
choose which display performance 
setup is applied to images.

 G  Select  Preserve Object-level 
Display Settings  to let each 
object’s settings override the overall 
document display setting.
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As you work, you can switch between the 
menu commands without having to open the 
Display Performance Preferences dialog box.

To switch the default view setting:

1. With no object selected, Right-click 
(Win) or Control-click (Mac). This opens a 
context-sensitive menu  A .

2. Choose one of the view settings from the 
Display Performance submenu.

3. Choose Allow Object-Level Display 
Settings to override any individual image 
previews. This does not delete those 
individual settings, it only overrides them.

4. Choose Clear Object-Level Display 
Settings to delete any individual image 
previews.

TIP You can also use the View menu to choose the 
view settings or to override any individual 
image previews.

You can also set each individual image to 
its own display setting. This lets you set one 
large image to faster screen redraw while 
showing more detail in other objects.

To set individual image previews: 

1. Select the image.
2. Right-click (Win) or Control-click (Mac). 

This opens the context-sensitive menu for 
the display of that object  B .

3. Choose one of the options from the 
Display Performance submenu of the 
context-sensitive menu.

TIP The Use View Setting command sets the 
object back to the current View Setting in the 
Display Performance Preferences. 

TIP You can also use the Object > Display 
Performance submenu to choose the view 
settings for a selected object.

 B  The  Display Performance context-
sensitive menu  for an object.

 A  The  Display Performance context-
sensitive menu  lets you switch from one 
display performance setup to another.
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The labels Fast, Typical, and High Quality 
are merely guides. You can customize the 
specifi c displays for raster images, vector art, 
and transparency eff ects in the Adjust View 
Settings area of the Display Performance 
Preferences.

To set the raster and vector displays: 

1. Choose Edit > Preferences > Display 
Performance (Win).
or
Choose InDesign > Preferences > Display 
Performance (Mac).

2. Choose one of the options in the Adjust 
View Settings menu  C .

3. Drag the slider for the Raster Images or 
Vector Graphics as follows  D :
 • Gray Out (far left) displays a gray 

background instead of the image  E . 
This is the fastest performance.

 • Proxy (middle) displays a 72-ppi screen 
preview of the image  F . This setting 
provides the best performance that still 
shows what the image looks like.

 • High Resolution (far right) displays the 
maximum resolution for the image  F .

4. Repeat the process for each of the other 
menu settings.

TIPTIP Raster Images and Vector Graphics settings 
don’t have to be set for the same resolution. 
This allows you to have a faster redraw for 
large raster files, and more details in the lines 
of vector graphics.

 C  The  Adjust View Settings menu  gives 
you three display settings to apply to 
a document or individual images.

 D  The  Raster Images and Vector 
Graphics slider s let you control how 
those formats are displayed.

 E  An example of the  Gray Out view setting . 

 F  The diff erence between the Proxy setting 
and the High Resolution setting.

Proxy display High Resolution display
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You can also adjust the display for the trans-
parency eff ects as well as the drop shadows 
and feather eff ects.

To set the transparency eff ects displays: 

1. Choose one of the listings in the Adjust 
View Settings menu.

2. Drag the Transparency slider to each 
notch setting as follows  A . (The labels 
appear as you drag the slider):
 • Off (far left) displays no transparency 

effects. This is the fastest performance.
 • Low Quality (second from left) displays 

basic opacity and blend modes. Drop 
shadows and feathers are displayed in 
low resolution only. Some blend modes 
may change in the final output.

 • Medium Quality (second from right) 
displays drop shadows and feathers in 
low resolution.

 • High Quality (far right) displays high 
resolution drop shadows and feathers. 
Blend modes appear in their correct 
CMYK color display.

3. Repeat the process for each of the other 
Adjust View Settings menu items.

 A  The  Transparency slider  lets you control 
the display of drop shadows, feathers, 
and transparency eff ects. The setting 
labels appear as you move the slider.
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Text Effects
Go back and look at the newspaper  

magazine advertisements created 
in the 1800s. (Yes, that was way before 
I worked in advertising.) In those ads, 
the text marches along in a straight line 
without swerving toward or moving 
around the images.

Back then, it was extremely diffi  cult to 
wrap text around an image. Each line of 
text had to be cut and pasted around 
the edges of an image.

The paste-up artists never dreamed of 
set ting text along a path so that it fol-
lows the shape of a rollercoaster — that 
would have been far too much work!

Adding short horizontal rules to divide 
paragraphs was another tedious task. 
In fact, if you look closely at some old 
advertisements, you can see that the 
rule isn’t perfectly centered between 
the columns.

Fortunately, electronic page-lay out 
programs such as InDesign make it easy 
to do all these special text eff ects with 
incredible precision.
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Wrapping Text

One of my favorite eff ects to apply to text is 
to arrange it to fl ow around images and other 
objects. This is called text wrap in InDesign, 
a text runaround in some other programs. 
(InDesign doesn’t give you the runaround.) 

To apply a text wrap:

1. Select the object that you want the text 
to wrap around. This can be an imported 
graphic, a text frame, or an unassigned 
frame.

2. Choose Window > Text Wrap. This 
opens the Text Wrap panel  A .

3. Choose one of the following options for 
how the text should flow around the 
object  B . (Options shown in the chart on 
the following page.)
 • No Wrap lets the text flow across the 

object.
 • Bounding Box flows the text around 

the bounding box for the object.
 • Object Shape flows the text around 

the shape of the frame or the shape of 
the placed graphic. 

 • Jump Object flows the text to the 
next available space under the object.

 • Jump to Next Column flows the text 
to the next column or text frame.

4. Select the Invert checkbox to force the 
text to flow inside the object  C .

5. Enter an amount in the offset fields to 
control the distance between the text and 
the object  D .

TIP Click the Make All Settings the Same icon 
(chain) so that all the offsets are equal.

TIP The number of available offset fields depends 
on the type of text wrap you choose.

 A  The  Text Wrap panel  controls the settings 
for how text fl ows around an object.

No 
wrap

 B  The  fi ve diff erent text wrap buttons  let you 
choose how the text wraps around objects.

Bounding 
box

Object 
shape

Jump 
object

Jump to next 
column

 C  When the  Invert command  is turned 
on, the text wrap causes the text to 
fl ow inside, not outside, an object.

Regular text wrap

Invert text wrap

 D  Use the  text wrap off set controls  to set 
the distance between text and a graphic.

RightLeftBottomTop
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Wrap Chosen Off set Available Results

No Wrap No off set options available.

Bounding Box Top, bottom, left, and right 
off set options available.

Object Shape Top off set option is the only one 
available. The amount is used 
as the space around the entire 
graphic.

Jump Object Top, bottom, left, and right 
off set options available. How-
ever, only the top and bottom 
off sets aff ect the text.

Jump to Next Column Top, bottom, left, and right 
off set options available. How-
ever, only the top off set aff ects 
the text.

TIPTIP Unless you change the preference setting, 
lines that wrap below the text wrap object 
skip to the next available leading increment 
below the object.
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When you choose Object Shape for the text 
wrap, InDesign lets you set how the text 
wraps as well as the contour options for that 
shape.

To set the text wrap contour options:

1. Use the Direct Selection tool to select the 
image.

2. Click the Object Shape text wrap button 
in the Text Wrap panel. 

3. Choose Show Options from the Text 
Wrap panel menu to display the Contour 
Options at the bottom of the Text Wrap 
panel.

4. Use the Contour Options Type menu to 
choose the type of element that should 
be used to create the text wrap  A :
 • Bounding Box uses the rectangle that 

contains the image.
 • Detect Edges uses the differences 

between the pixels of the image and its 
background.

 • Alpha Channel lets you choose an 
embedded alpha channel.

 • Photoshop Path lets you choose an 
embedded path.

 • Graphic Frame uses the shape of the 
frame that contains the image.

 • Same as Clipping uses whatever 
shape has been designated as the 
clipping path for the image.

5. If you choose Alpha Channel or Photo-
shop Path, use the second pop-up menu 
to choose a specific channel or path.

6. Select the Include Inside Edges checkbox 
to make the text wrap inside any holes in 
the image, path, or alpha channel  B .

 A  The Contour Options Type menu 
lets you choose what type of element 
controls the shape of the text wrap.

 B  Use the Include Inside Edges 

option to have text wrap within 
the edges of the image, such as 
within the handles of the basket.
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Just as you can set the alignment for a para-
graph, you can also set how text wraps to the 
object.

To set the Wrap To options for a text wrap:

1. Use the Direct Selection tool to select the 
image.

2. Click the Object Shape text wrap button 
in the Text Wrap panel. 

3. Choose Show Options from the Text Wrap 
panel menu to display the Wrap Options 
in the Text Wrap panel.

4. Use the Wrap To menu to choose the 
orientation for the text wrap  C :
 • Right Side wraps only around the 

right side of the object.
 • Left Side wraps only around the left 

side of the object.
 • Both Left & Right Sides wraps to 

both sides of the object  D .
 • Side Towards Spine wraps to either 

the left or right side of the object 
depending which side of a facing page 
document the object is on.

 • Side Away From Spine wraps to the 
opposite side of the object compared 
to the command above.

 • Largest Area wraps only on the side 
that has the most area. This may cause 
the text to flip from left to right  E .

In the books, the origins of the 

character are rather gruesome. 

Originally an ordinary man by 

the name of Nick Chopper, the Tin 

Woodman used to make his living 

chopping down trees in the for-

ests of Oz. The Wicked W i tc h 

of the East enchanted his axe 

to prevent him from m a r r y -

ing the girl that he l o v e d . 

 D  The Wrap To option set to wrap the 
text on both sides of the object.

In the books, the origins of the charac-

ter are rather gruesome. Originally an 

ordinary man by the 

name of Nick Chop-

per, the Tin Wood-

man used to make 

his living chopping 

down trees in 

the forests 

of Oz. The 

 E  The Wrap To option set to wrap the text 
on whichever side has the largest area.

 C  The  Wrap To menu  lets you choose the 
orientation for text wraps around objects.
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A text wrap doesn’t have to be around visible 
objects. You can use an object with no fi ll or 
stroke as the shape to wrap text around  A . 
This creates a special eff ect for text around an 
image.

To wrap text around an invisible object:

1. Draw an object with no fill or stroke.
2. Set the Text Wrap to Object Shape.

Once you set a text wrap, you can still mani-
pulate it so that the text reads more legibly or 
fi ts more attractively into the contour of the 
object. This is called a custom text wrap.

To create a custom text wrap:

1. Use either selection tool to select the 
object that has the text wrap applied to it.

TIP Apply the Object Shape text wrap button 
set for Graphic Frame to create a simple text 
wrap without a lot of points.

2. Use the Direct Selection tool to move the 
points on the text wrap path  B .

TIP You can preview how the text reflows around 
the text wrap. Press and hold for a moment 
before you move the point of the text wrap. 
You can then see the text reflow as you move 
the point.

3. Click the Pen tool between points on the 
text wrap path to add a new point to the 
path  C .

4. Click the Pen tool on a point on the text 
wrap path to delete the point from the 
path  D .

TIP Hold the Cmd/Ctrl key to access the Direct 
Selection tool while using the Pen tool.

 B  Use the Direct Selection tool to  change 
the shape of a text wrap path .

 C  The  plus sign next to the Pen 
tool  indicates that you can add a 
point to the text wrap path.

 D  Position the Pen tool over a point and click 
to  delete points from a text wrap path .

 A  An example of how an invisible object 
can be used to create a text wrap.
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You may fi nd that you don’t want some text 
to be aff ected by a text wrap. For instance, 
you might want to have the body text in one 
frame run around an image but have the 
text label in another frame appear over the 
image  E . That’s when you need to direct the 
text frame to ignore a nearby text wrap.

To ignore the text wrap:

1. Select the text frame that contains the 
text that you don’t want affected by the 
text wrap command.

2. Choose Object > Text Frame Options. 

This opens the Text Frame Options dialog 
box  F .

3. Select the Ignore Text Wrap checkbox. 
The text in that frame is unaffected by any 
objects that have a text wrap applied.

TIPTIP Text wrap is applied even if the object that 
has the wrap is on a hidden layer. Use the 
Layer Options dialog box to change this so 
that hidden layers do not exert a text wrap.

Master pages (covered in Chapter 10, “Pages 
and Books”) allow you to place an object on 
many pages at once. You can set the text 
wrap for an object so that it is only applied on 
the master page, not any document pages.

To set the text wrap for an object on a 
master page:

1. Place the object on a master page.
2. Choose Apply to Master Page Only 

from the Text Wrap panel menu. (This 
command is only available for objects on 
a master page.)

 F  The Ignore Text Wrap checkbox 
in the Text Frame Options dialog box 
prevents text from being aff ected 
by any text wrap settings.

There was no 
garret at all, 
and no 

cellar ---  
except a 
small hole 
dug in the 
ground, 
called a 

cyclone cellar, where the family could go in case one 
f h h l d h h

The Great 
State of Kansas

 E  An example of how Ignore Text 

Wrap keeps the map title from being 
aff ected by the text wrap applied 
to the outline of the state.

Text frame that ignores 
the text wrap

Text frame that follows 
the text wrap
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Text on a Path

When you create an object such as a text 
frame, the outside shape of the frame is 
considered the object’s path. Not only can 
InDesign fi t text inside a text frame, it also 
lets you position text so that it runs along the 
outside of the frame.

To run text on the outside of a path:

1. Choose the Path Type tool in the Tools 
panel  A .

2. Move the tool so that it is near the path. 
A small plus sign appears next to the tool 
cursor  B .

3. Click with the Path Type tool. A blinking 
insertion point appears on the path.

4. Type the text. Use any of the text controls 
to select or modify the text.

TIP Use the Direct Selection tool to select the 
path and change its fill or stroke to None to 
make the path invisible.

Once you apply text to a path, you can drag 
to position the text.

To position text on a path:

Drag the indicator at the start or end of 
the text on a path to change the start or 
end point of the text  C .
or
Drag the small indicator within the text to 
change the center point of the text  D .

TIP You can also drag the center point indicator 
to the other side of the path.

TIP You can use the Paragraph panel to change 
the alignment of the text between the start 
and end indicators.

 A  The Path Type tool in 
the Tools panel is used 
to add text to a path.

 C  Drag the indicator line to move 
the text along a path.

 B  The plus sign next to 
the Path Type cursor 
indicates that you can 
click to add text to a path.

 D  The center point indicator allows 
you to move text or fl ip it from one 
side of the path to another.
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To apply eff ects to text on a path:

1. Choose Type > Type on a 

Path > Options. This opens the Path 
Type Options dialog box  E .

2. Use the Effect menu  F  to control how the 
text is positioned in relation ship to the 
path  G .
 • Rainbow positions the text in an arc 

along any curves in the path.
 • Skew distorts the text vertically as it is 

positioned along curves in the path.
 • 3D Ribbon distorts the text 

horizontally as it is positioned along 
curves in the path.

 • Stair Step aligns the individual 
baselines of each letter so that the text 
stays vertical as it is positioned along 
curves in the path.

 • Gravity uses the shape of the path to 
distort the text as it is positioned along 
curves in the path.

3. Select the Flip checkbox to position the 
text on the other side of the path.

4. If the spacing of the text is uneven, 
use the spacing control to tighten the 
character spacing around sharp turns and 
acute angles on the path.

TIPTIP Higher values remove more space from 
between the characters.

 E  The Path Type Options dialog box allows 
you to control how text is applied to a path.

Wizardry

Wizardry

Wizardry

Wizardry

Wizardry
 G  The fi ve Eff ect settings 

applied to text on a path.

Rainbow

Skew

3D Ribbon

Stair Step

Gravity

 F  The Eff ect menu controls the 
appearance of the text on the path.
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You can also control where the letters are 
positioned vertically on the path.

To set the vertical alignment of text on a 
path:

1. Use the Align menu  A  to control how the 
text is positioned in relation ship to the 
path  B .
 • Ascender positions the text so that 

the tops of the tallest letters touch the 
path.

 • Descender positions the text so that 
the bottoms of the lowest letters touch 
the path.

 • Center positions the text so that the 
middle of the text touches the path.

 • Baseline positions the text so that the 
baseline of the text touches the path.

2. Use the To Path menu to position the 
vertical alignment in one of the following 
positions  C :
 • Top positions the text relative to the 

top of the path’s stroke weight  D .
 • Center positions the text in the middle 

of the path’s stroke weight  D .
 • Bottom positions the text relative to 

the bottom of the stroke weight  D .

TIP If you do not see any changes between the To 
Path settings, try increasing the thickness of 
the stroke weight.

TIP You can also use the Baseline Shift controls 
to move the text up or down relative to 
the path.

 A  The Align menu controls how the text is 
positioned in relationship to the path.

 C  The To Path menu positions the vertical 
alignment of the text on the path.

The cyclone 
lif

te
d 

the house slowly 

The cyclone
 lif

ted

 the house slowly 

The cyclone 
li

ft
ed

 th
e house slowly 

The cyclone l
ift

ed

 the house slowly 

 B  The Align choices applied 
to text on a path.

Baseline
Ascender

Descender
Center

 D  The eff ect of the To Path settings on the 
position of text on a stroked path.

Top

Bottom
Center
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Working with Paragraph Rules

The correct way to create a line above or 
below a paragraph is with paragraph rules. 
These are lines that travel with the para-
graph and that can be applied as part of style 
sheets.

To apply paragraph rules:

1. Select the paragraph to which you want 
to apply the rule and choose Paragraph 
Rules from the Paragraph panel menu. 
This opens the Paragraph Rules dialog 
box  E .

2. Choose Rule Above or Rule Below to 
specify whether the rule appears before 
or after the selected paragraph  F .

3. Select the Rule On checkbox to activate 
the rule.

TIPTIP If you want rules both above and below the 
paragraph, repeat steps 2 and 3.

 E  The Paragraph Rules dialog box 
controls the settings for paragraph lines.

 F  Choose Rule Above or Rule 

Below to position the line above 
or below a paragraph.

Why Use Paragraph Rules?

If you want a line (technically called a rule) 
to appear above or below a paragraph, you 
might draw a line using the Pen or the Line 
tool. Unfortunately, if the text reflows, that 
line does not travel with the text. You could 
also paste the line into the text as an inline 
graphic, but you would not have much control 
over that line.

The proper way to create lines above or below 
paragraphs is to use the Paragraph Rules com-
mands. Because the rules are applied as part 
of the paragraph settings, they automatically 
move if the paragraph moves. In addition, 
they can be precisely positioned in relation-
ship to the paragraph. 
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Once you have turned on the rule, you can 
style its appearance. This is somewhat similar 
to styling the stroke for an object.

To style the appearance of a rule:

1. Set an amount for the weight (or 
thickness) of the rule  A .

2. Use the Type list to set a stroke style  B .
3. Use the Color list to apply one of the pre-

defined swatch colors or gradients  C .

TIP The Text Color setting sets the rule to the 
same color as the text.

4. If desired, select Overprint Stroke to set 
the ink to overprint.

5. Use the Tint controls to create a shade of 
the color  D .

6. If you have chosen a rule style that has a 
gap, use the Gap Color list to apply a color 
or gradient swatch to the gap  E . 

7. If you have chosen a gap color, use the 
Gap Tint controls to create a shade of the 
gap color  F .

8. If desired, select Overprint Gap to set the 
gap ink to overprint.

If a paragraph rule falls at the top of a para-
graph, you may want to control whether the 
rule is displayed inside or outside the frame.

To control the position of the rule within a 
frame:

1. Select the paragraph with the rule.
2. Open the Paragraph Rules dialog box.
3. Select or deselect the Keep in Frame 

checkbox.

 A  Use the Weight control to defi ne the 
thickness of the paragraph rule.

 B  Use the Type list to choose the stroke 
style for the paragraph rule.

 C  Use the Color list to choose the 
main color for the paragraph rule.

 D  Use the Tint control to set the screen 
for the color of the paragraph rule.

 E  Use the Gap Color list to set the 
secondary color of the paragraph rule.

 F  Use the Gap Tint control to set the screen 
for the gap color of the paragraph rule.
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The length of a rule (called its width) can be 
set to cover the width of the column or the 
width of the text. The rule can also be set to 
be indented from the column or text margins.

To control the width of a rule:

1. Choose from the Width list in the 
Paragraph Rules dialog box as follows  G :
 • Column creates a rule that is the same 

width as the column that holds the 
text  H .

 • Text creates a rule that is the same 
width as the closest line of text  H .

TIPTIP If you set a rule below a paragraph that 
ends in a short line, the rule will be the same 
length as the last line.

2. Set the Left Indent to the amount that the 
rule should be indented from the left side 
of the column or text  I .

3. Set the Right Indent to the amount that 
the rule should be indented from the 
right side of the column or text  I .

TIPTIP Use positive numbers to move the rule in 
from the margin  J . Use negative numbers to 
move the rule outside the margin. The rule 
can extend outside the text frame.

By default the paragraph rule is positioned on 
the baseline of the text. You can control the 
position above or below the baseline  K . This 
is called the off set of the rule.

To control the off set of a rule:

In the Paragraph Rules dialog box, enter a 
value in the Offset field.
 • For a Rule Above, positive numbers 

raise the rule above the baseline.
 • For a Rule Below, positive numbers 

lower the rule below the baseline.

TIPTIP Negative numbers move rules in the opposite 
direction.

 G  The Width list lets you choose 
the length of paragraph rules.

 H  Column width fi ts the rule to the 
width of the column. Text width fi ts 
the rule to the neighboring text.

Column

Text

 I  The Left Indent and Right Indent fi elds 
let you modify the length of a rule.

 J  How changing the Left and Right Indent 
settings changes the look of rules.

No indent

Left and 
right 
indents

 K  Change the Off set amount to move a 
rule up or down relative to the text.

No offset

0p8 offset
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You can create many special eff ects with 
paragraph rules. One of the most common is 
to superimpose text inside paragraph rules 
to create the eff ect of reversed text. Most 
reversed text is white type inside a black 
background. However, any light color can be 
used inside any dark background  A .

TIP Don’t forget that you can also use the 
underline or strikethough styles to create 
reversed text.

To reverse text using rules:

1. Apply a light color to a line of type.
2. Open the Paragraph Rules dialog box.
3. Create a Rule Below.
4. Set the weight of the rule to a point size 

large enough to enclose the text. For 
instance, if the text is 12 points, the rule 
should be at least 12 points  B .

TIP If you have more than one line of text, you 
need to calculate the size of the leading times 
the number of lines.

5. Set a negative number for the offset 
value.

TIP The offset amount should be slightly less 
than the weight of the rule. For instance, a 
rule of 14 points might take an offset of minus 
11 points.

6. Select the Preview checkbox so you can 
see the effect of the weight and offset 
settings you choose.

7. Adjust the weight and offset, if necessary.
8. Click OK to apply the rule.

True Story

When I first started learning page layout soft-
ware, I used the art director’s computer at the 
advertising agency where I worked. I stayed 
after hours to explore the programs and create 
my own documents.

When I saw the command “Rules” in the menu, 
I figured that was where they kept the laws 
governing the program. Since I didn’t want to 
mess up the art director’s machine, I never chose 
the command.

It was several years later (and several horrible 
jobs without any paragraph rules) that I discov-
ered what the “Rules” were.

The Guardian of the Gate
It was some time before the Cowardly Lion 
awakened, for he had lain among the pop-
pies a long while.

 A  A paragraph rule can create the 
eff ect of reversed text.

 B  A dialog box showing the sample settings 
for a paragraph rule that create 
the eff ect of reversed text.
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Inline and Anchored Objects

Another type of nested element is called an 
inline object. An inline object is a frame that is 
pasted as a character into the actual text.

TIPTIP An inline object can also be used to add 
images to a table.

To create an inline object:

1. Select the element that you want 
positioned.

2. Cut or copy the element to the clipboard.
3. Click to place an insertion point where 

you want the inline object to be 
positioned.

4. Choose Edit > Paste. The element is 
pasted into the text and flows along with 
any changes to the text  C .

TTIPIP Use the Direct Selection tool to move the 
graphic within its inline frame.

TTIPIP Use the Selection tool to select and move 
inline objects up or down inside the text.

TIPTIP Use any of the Text Wrap commands to force 
text around the inline object.

You can also place an image directly into the 
text as an inline object.

To import an image directly as an inline 
object:

1. Place your insertion point where you 
would like the graphic to appear.

2. Choose File > Place and select the image 
you want to import. The image appears 
inside an inline frame.

Uses for Inline Objects

The biggest problem with inline objects is that 
most people forget they are available.

Have you ever wanted to use a little picture 
instead of a plain bullet? Inline graphics make 
it easy to add the picture so it flows along with 
the text.

You can also use an inline object to keep a 
picture of an author along with her biography.

Inline objects don’t have to be graphic elements. 
You can insert an inline text frame to create two 
columns of text within a single column story.

Finally, you can paste a horizontal line as an 
inline graphic to make the fill-in-the-blank lines 
in a coupon.

 C  An inline object fl ows along with text.
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In addition to inline objects, InDesign also 
allows you to insert anchored objects into 
text fl ow. Anchored objects require a little 
more preparation but are much more power-
ful than inline objects.

To create an anchored object:

1. Place the insertion point in the text where 
you want to anchor the object.

TIP This does not have to be the exact position 
where you want the anchored object to 
appear.

2. Choose Object > Anchored Object > 

Insert. The Insert Anchored Object dialog 
box appears  A .

3. Set each of the options for the Anchored 
Object as described in the following 
exercises.

4. Click OK to insert the anchored object 
into the story. An anchored object hidden 
character symbol appears in the text.

To set the Object Options for an anchored 
object:

1. Use the Content list to choose the type 
of object to be anchored. These are the 
same as the Object > Content options  B .

2. Use the Object Style list to choose 
a graphic style for the object. (See 
Chapter 15, “Styles,” for more information 
on graphic styles.)

3. If you select Text as the content, use the 
Paragraph Style list to choose the style for 
the text. 

4. Use the Height and Width controls to set 
the size of the anchored object.

TIP Anchored objects are always defined as 
rectangles by default. You can use any of 
the drawing tools or the Convert Shape 
commands to change the rectangle to other 
shapes.

 A  The Insert Anchored Object 

dialog box lets you control the 
options for an anchored object.

 B  The Content list lets you choose 
the type of anchored object.
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I divide anchored objects into two diff erent 
types based on their position on the page.

To set the Position for the anchored object:

Use the Position list to choose the type of 
positioning for the anchored object  C :
 • Inline or Above Line positions the 

anchored object within the text frame.
 • Custom allows you to position the 

anchored object outside the text frame.

Once you have chosen the positioning for the 
anchored object, you can set the options for 
the location of the anchored object  D .

To set the options for inline objects:

1. Select the Inline radio button to specify 
that option for the object. This removes 
all the options except the Y Offset.

2. Use the Y Offset controls to move the 
object above or below the baseline of the 
text.

TIPTIP Positive numbers move the object above the 
baseline. Negative numbers move the object 
below the baseline.

 C  The Position list lets you choose the 
location for anchored objects.

 D  The Position options for Inline or 

Above Line anchored objects.
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To set the options for Above Line objects:

1. Click the Above Line radio button to 
position the object above the line that 
contains the anchor insertion point  A .

2. Use the Alignment list to position the 
object in the text frame as follows  B :
 • Right aligns the object on the right.
 • Left aligns the object on the left.
 • Center aligns the object in the center.
 • Text Alignment uses whatever 

alignment was set for the paragraph 
that contains the anchored object.

3. If you have a facing-page document, 
you have two additional options. 
These options flip the anchored object 
depending on whether it is on a left- or 
right-hand page.
 • Towards Spine positions the object so 

that it is closest to the spine.
 • Away From Spine positions the 

object so that it is farthest away from 
the spine.

4. Use the Space Before or Space After 
control to add space above or below the 
object.

5. Select the Prevent Manual Positioning 
checkbox to stop the object from being 
moved with any of the selection tools.

 B  The Alignment list for Above 
Line anchored objects.

 A  An Above Line anchored 

object inside a text frame.

Anchored object indicator in the text
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The other type of anchored object is the 
custom object. This option off ers the most 
choices for positioning the anchored object.

TIPTIP I find the Custom Anchored Objects dialog 
box baffling  C . The only way I can apply the 
settings is to first insert the anchored object 
and then close the dialog box. Next, with 
the anchored object still selected, I choose 
Object > Anchored Object > Options. This 
opens the Options dialog box, which has a 
preview so I can see what the settings do.

To set the options for custom objects:

1. Use the Anchored Object Reference Point 
proxy box to choose which point on the 
anchored object should be used as the 
orientation of the anchored object.

2. If the document has facing pages, you 
can select the Relative to Spine checkbox 
to allow the settings to flip depending 
on whether they are left- or right-hand 
pages.

3. Click the Anchored Position Reference 
Point to choose the position on the page 
where the object should align.

4. Use the X Relative To list to set the point 
from which the horizontal axis should 
start  D .

5. Use the Y Relative To list to set the point 
from which the vertical axis should 
start  E .

6. Use the X Offset and Y Offset controls to 
move the anchored object from the X and 
Y reference points.

7. Select Keep Within Top/Bottom Column 
Boundaries to ensure that the anchored 
object does not move above or below the 
frame that contains the text.

8. Select Prevent Manual Positioning to 
prevent the object from being moved.

TIPTIP Custom anchored objects are indicated on 
the page by a little anchor (cute!)  F .

 C  The Custom Anchored 

Objects dialog box.

 D  The X Relative To list for 
custom anchored objects.

 E  The Y Relative To list for 
custom anchored objects.

 F  The indicator for custom 

anchored objects.
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As I said on the previous page, it’s a lot easier 
to set the options for a custom anchored 
object if you edit the settings for an existing 
anchored object.

To edit the settings for an anchored object:

1. Use the Selection tool to select the 
anchored object.

2. Choose Object > Anchored Object > 

Options. This opens the Anchored Object 
Options dialog box, which gives you 
a Preview option in addition to all the 
settings to control the anchored object.

So what if you want to convert the anchored 
object into a regular object but position it 
in the same spot as when it was anchored? I 
thought I could cut and paste the object to 
get it out of the text fl ow. Nope; instead you 
need to release the anchored object.

To release an anchored object:

1. Use the Selection tool to select the 
anchored object.

2. Choose Object > Anchored Object > 

Release. This converts the anchored 
object into an ordinary object.

You may want to jump from one inline or 
anchored object to another to make changes.

To move between inline or anchored 
objects:

1. Use the Selection tool to select the inline 
or anchored object.

2. Choose Object > Select > Next Object 
to select the next object in the story.
or
Choose Object > Select > Previous 

Object to select the previous object in 
the story.

TIP You can also use the Next Object and Previous 
Object buttons in the Control panel.

Tips for Using Anchored Objects

Although the settings for custom anchored 
objects may take a while to master, you should 
not give up learning to use them. There are quite 
a few ways to use custom anchored objects.

It is important to remember that custom 
anchored objects can be positioned well out-
side the frame of text that contains the anchor 
position. This lets you use the custom anchored 
object for marginalia, notes, or images. Many 
textbooks, for example, require notes for teacher 
editions. Custom anchored objects make it easy 
to insert those notes.

Anchored objects have to start off as rectangles, 
but once you insert the object, you can apply 
any of the Convert Shape commands to change 
their shape. My favorite is to use the Orthogonal 
Line command to change the anchored object 
into a stroked line that I can extend down the 
side of the text frame. This makes it easy to 
highlight important paragraphs.
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Pages and Books
Most people who lay out docu-

ments work on projects that have 
more than one page — booklets, bro-
chures, newsletters, menus, annual 
reports, maga zines, books, and so on. 
Even a lowly business card has two 
pages if you design a front and back.

When you work with multipage docu-
ments, you need to add pages, fl ow 
text, apply page numbers, and force 
text to move to certain pages.

If you are working on very complex 
documents, you need to make sure all 
the pages have the same structure.

If you are working on a book, you 
will want to join individual chapters 
together. You may also want to auto-
mate the process of creating a table of 
contents or an index.

Here’s where you’ll learn how to auto-
mate and organize working with multi-
page layouts. In addition, you’ll learn 
how to use InDesign’s Book features to 
synchronize multiple documents in a 
large project. You’ll also discover special 
features for creating a table of contents 
from text.
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Changing the Pages Panel

You may want to change the display of the 
Pages panel.

To open the Pages panel:

If the Pages panel is not visible, choose  
Window > Pages to open the panel  A .

To control the display of the Pages panel:

1. Choose Panel options from the Pages 
panel menu. This opens the Panel Options 
dialog box  B .

2. Use the Pages Icon Size menu to choose 
the size of the document pages icons.

3. Deselect Show Vertically to display the 
pages horizontally in the panel  C .

4. Deselect Show Thumbnails to hide the 
thumbnail preview of the pages in the 
Pages panel.

TIP Turning the Show Vertically option off 
makes it easier to fit more pages in a smaller 
panel area.

5. Use the Masters Icon Size menu to change 
the size of the master page icons. These 
choices are the same as the Pages Icon 
Size menu.

6. Choose Pages on Top to position the 
document pages at the top of the panel.

7. Choose Masters on Top to position the 
master pages at the top of the panel.

8. Use the Resize list to control what 
happens when you resize the panel:
 • Proportional maintains the same 

relative area as you change the size of 
the panel.

 • Pages Fixed adds new space only to 
the masters area.

 • Masters Fixed adds new space only to 
the pages area.

 B  The  Panel Options dialog box  lets you 
control the appearance of the Pages panel.

 C  The Pages panel with Show Vertically 
turned off  (left) and turned on (right).

Horizontal arrangement Vertical arrangement

 A  The  Pages panel  is the command 
center for multipage documents.

Delete page

New page

Document 
page area

Master page 
area

Thumbnail 
preview
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Adding Blank Pages

Although you probably specifi ed a certain 
number of pages in the New Document 
dialog box, you might need to add more 
pages after you’ve started working on the fi le. 
You can add pages as you work or you can 
add a particular number of pages at a precise 
location.

TIPTIP A checkerboard grid next to the number of 
the page in the Pages panel indicates that 
an effect that requires flattening such as 
a transparency, drop shadow, feather, or 
Photoshop transparency has been applied 
on that page  D . (See Chapter 19, “Output” for 
more information on flattening.)

If you need to add just a few pages, you can 
add them one by one, manually.

To manually add pages:

1. Click the New Page icon in the Pages 
panel to add a single page.
or
Drag a master page or a nonmaster 
page from the master page area to the 
document area of the panel  E . 

2. Repeat as many times as necessary until 
you have added all the pages you need.

 D  The  checkerboard grid  next to a 
page indicates that an eff ect such 
as a transparency or a drop shadow 
has been applied to that page.

 E  Drag a master 
page from the 
master page 
area of the 
Pages panel to 
the document 
area to add 
pages to a 
document.

Glossary of Page Terms

As you work with pages and the Pages panel, it helps if you understand the following:

Document pages: The main pages of your document. These are the pages that contain your project. Items 
that are on the document pages are document page items.

Master pages: The pages that contain elements that are repeated on all the document pages. Items that are 
on the master pages are called master page items.

Local Overrides: Normally you can’t select or modify master page items on a documentpage. However, if 
you apply a local override to the master page items on a specific document page, they can be modified on 
the document page. 
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If you need to add many pages, rather than 
dragging pages over and over in the Pages 
panel, you can add them using the Insert 
command. This also lets you specify where to 
add the pages.

To add pages using the Insert command:

1. Choose Insert Pages from the Pages 
panel menu. The Insert Pages dialog box 
appears  A .

2. Type the number of pages you want to 
insert in the Pages field.

3. Choose where to add the pages within 
the document from the Insert menu as 
follows  B :
 • After Page lets you insert new pages 

after a specific page.
 • Before Page lets you insert new pages 

before a specific page.
 • At Start of Document inserts new 

pages at the beginning of the 
document.

 • At End of Document inserts new pages 
at the end of the document.

4. Use the Master menu to choose the 
master page that the new pages should 
be based on.
or
Choose None from the Master menu to 
have an empty page that does not act as 
a master applied to the new pages.

5. Click OK. The new pages appear in the 
Pages panel.

 A  The  Insert Pages dialog box  lets you add 
many pages at once to a document.

 B  The  Insert menu  gives you specifi c 
choices as to where to insert pages.
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Navigating and Moving Pages

As you work with pages in the Pages panel, 
you should understand the diff erence 
between targeting a page and working on a 
page. The active page is the page you are cur-
rently working on. The targeted page is the 
page chosen in the Pages panel.

To target a page:

Click the page in the Pages panel. A 
highlight appears on the page  C .

TIPTIP When a page is targeted, it means you can 
apply a command in the Pages panel even 
without working on the page.

To work on a page:

Double-click the page number or name 
of the master page spread in the Pages 
panel. A highlight appears on the number 
or name of the page  D .

TIPTIP When you work on the page, that page or 
spread is centered within the document 
window.

InDesign has several diff erent ways to move 
from page to page.

To move to a specifi c page using the 
Pages panel:

Double-click the page in the Pages panel 
that you want to move to. The page is 
centered within the document window.
or
Double-click the name of the spread to fit 
both pages in the document window.

TIPTIP You can also scroll or use the Hand tool to 
move through the document.

 C  The colored highlight on the targeted 
pages (pages 4-5) shows they are 
not the active pages (pages 2-3).

 D  The highlight on both the page number and 
the page for the active pages (pages 2-3) 
shows they are both targeted and active.
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You can also use the navigation controls at  
the bottom of the document window.

To navigate using the window page menu:

Click a page number in the window 
page menu to navigate through the 
document  A .
or
Enter a number in the Page field to move 
to a specific page.

To use the navigation controls:

Click each of the navigation arrows to 
move through the document  B .

You can also navigate using the commands in 
the Layout menu in the menu bar at the top 
of the application.

TIP The Layout menu commands can be applied 
using keyboard shortcuts. This lets you move 
through the document without using the 
mouse.

To navigate using the Layout menu:

Choose one of the following:
 • Layout > First Page moves to the first 

page of the document.
 • Layout > Previous Page moves to the 

previous page.
 • Layout > Next Page moves to the next 

page.
 • Layout > Last Page moves to the last 

page of the document.
 • Layout > Next Spread moves to display 

the next spread of pages.
 • Layout > Previous Spread moves to 

display the previous spread of pages.
 • Layout > Go Back moves to the page 

that was previously active.
 • Layout > Go Forward moves to the 

page that was active before the Go 
Back command was applied.

 A  The  pop-up page list  at the bottom 
of the document lets you navigate 
through the document. 

 B  Use the  navigation controls  at the 
bottom of the document window 
to move through the document.

Last pagePrevious page
Next 
pageFirst page
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You can also use the Pages panel to duplicate 
and delete pages from the document.

To duplicate pages:

1. Select the page or spreads you want to 
duplicate.

2. Drag the pages onto the New Page icon.
or
Choose Duplicate Spread from the Pages 
panel menu.

To delete pages:

1. Use the Pages panel to select the pages.

TIPTIP Hold the Shift key to select contiguous 
pages. Hold the Cmd/Ctrl key to select 
noncontiguous pages.

2. Choose Delete Pages from the Pages 
panel menu.
or
Click the Delete Page icon at the bottom 
of the Pages panel.

TIPTIP The command may change to Delete Spreads 
if you have a spread or spreads selected.

3. When the confirmation dialog box 
appears, click OK to confirm your choice.

TIPTIP Hold the Opt/Alt key to bypass the 
confirmation dialog box.

Maximum Number of Pages?

The maximum number of pages in an 
InDesign document is 9,999. Although most 
documents fall well below that number, 
many people do need to create books and 
catalogs that contain 10,000 or more pages.

If you need to create those types of super-
long documents, you should break your 
projects into separate documents. Then, 
use the Book feature (covered later in this 
chapter) to maintain proper pagination as 
well as synchronize master pages and styles.
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You can use the Pages panel to change how 
pages are arranged in the document.

To rearrange pages in a document:

Drag a page next to or between the pages 
of a spread as follows  A :
 • With Allow Document Pages to Shuffle 

turned on, the new page forces other 
pages to a new spread  B .

 • With Allow Selected Spread to Shuffle 
turned off, the new page is added to 
the existing spread without moving the 
other pages  C .

TIP The arrow cursor indicates which side of a 
spine the new page is inserted on  A .

TIP You can drag pages between documents. 
When you do, a dialog box appears asking 
where you would like the pages to appear.

To move pages in a document:

1. Choose Move Pages from the Pages panel 
menu. This opens the Move Pages dialog 
box  D .

2. Use the Move Pages field to list the pages 
you want to move.

TIP Use hyphens to designate contiguous pages. 
Use commas to separate noncontiguous 
pages.

3. Use the Destination list to choose where 
you want the pages to move.

4. If you have chosen After Page or Before 
Page, enter the page number in the field.

5. Use the Move To list to choose the 
document location. This can be 
the current document or any open 
documents.

6. If you choose an external open document, 
you can select Delete Pages after Moving 
to delete the pages from the original file.

7. Click OK to move the pages.

 C  When  Allow Document Pages to 
Shuffl  e is turned off  , a page moved 
between other pages is added between 
the two pages in the spread.

Before page drag After page drag

 B  When  Allow Document Pages to 
Shuffl  e is turned on , a page moved 
between two other pages forces one 
of the pages to the next spread.

Before page drag After page drag

 A  Pages can be moved by  dragging 
their icons in the Pages panel .

Arrow points in 
direction page 
will be added

 D  The  Move Pages dialog box . 
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Modifying Page Sizes

Most documents contain pages that are all 
the same size. But there are many projects 
that need diff erent-sized pages — a brochure 
with a return postcard, a letterhead with busi-
ness card, or magazine with a foldout cover. 
Fortunately InDesign makes it easy to change 
the size of individual pages in a document.

To change the size of a page:

1. Select the Page tool in the Tools panel  E .
2. Click the page you want to modify in the 

Pages panel or in the document window.

TIPTIP To select multiple pages hold the Cmd/Ctrl 
key and click additional pages.

3. Use the W (width) and H (height) fields in 
the Control panel to adjust the size of the 
page  F .

4. Choose a specific page size from the 
menu in the Control panel.

TIPTIP Select a point in the proxy box to control from 
what position the page changes size.

5. Use the orientation icons to choose 
Portrait or Landscape page.

6. Choose one of the following options for 
the Page tool  G :
 • Select Enable Layout Adjustment 

to control whether objects move 
along with the guides and margins 
as the size of the page changes. (See 
Adjusting Layouts on page 283 for more 
information)

 • Select Show Master Page Overlay to 
see a representation of the size of the 
master applied to a page  H .

 • Select Objects Move with Page to 
control whether objects move with a 
page when the Page tool changes the 
position of a page.

 H  The  master page overlay  shows the 
size and name of the master page 
applied to a document page.

 F  The  page size controls  in the Control panel.

 G  The  Page tool options  in the Control panel.

 E  The  Page tool  in the Tools panel.
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In addition to selecting pages, the Page tool 
also lets you move pages around the artboard 
in custom positions. This is helpful if you 
need a special arrangement of the pages in a 
document.

TIP The following technique does not work when 
working on a facing page document. If you 
are working on a facing page document, 
choose File > Document Setup and deselect 
Facing Pages.

To move pages on the artboard:

1. From the Pages panel menu, deselect 
Allow Document Pages to Shuffle. This 
allows you to move all the pages in the 
document.

TIP You can also deselect Allow Selected Spread 
to Shuffle. This allows you to move just the 
pages in the selected spread.

2. Use the Page tool to drag a page on the 
artboard from one position to another  A  
and  B .

TIP Pages can be moved so they overlap portions 
of other pages. This allows an element on one 
page to be printed on two separate pages.

 A  Use the Page tool to  drag one page 
away from another  on the artboard.

 B  Two pages separated and repositioned.

But Will It Print?

The concept of different-sized pages within one 
document may be difficult for your print shop 
to accept. If you do create a job with pages of 
different sizes, talk to your print shop ahead of 
time. Make sure they have time to test the files. 
Or better yet, send them a PDF to see if that will 
output correctly.

It doesn’t help to be on the cutting edge of 
technology if you end up bleeding from the 
experience.
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Creating and Separating 

Spreads

Most documents are either single-page or 
facing-page documents. However, you can 
create spreads with more than one or two 
pages. These are island spreads, like the fold-
outs found in special issues of magazines  C .

To create an island spread:

1. Deselect Allow Document Pages to 
Shuffle in the Pages panel menu.

TIPTIP This command is turned off so that the pages 
that are already in the spread do not move to 
new positions.

2. Drag a page from the pages area, or a 
master page, next to the spread. 

3. Release the mouse button when the 
vertical line appears next to the spread  D . 
This adds the page to the island spread  E .

To dismantle an island spread:

1. Drag each page outside the spread.
or
Choose Allow Document Pages to Shuffle 
from the Pages panel menu. A dialog box 
asks if you want to maintain the current 
number of pages in the spread  F .

2. Click the No button. This dismantles the 
island spread into the default number of 
pages per spread in the document.

You can also control whether or not the pages 
in a spread are kept together or allowed to 
separate.

To keep the pages in a spread together:

1. Select the spread you want to protect.
2. Deselect Allow Selected Spread to Shuffle 

from the Pages panel menu. Brackets 
appear around the page numbers  G . This 
prevents the spread from separating if 
you add pages.

 C  An example of how three pages can be 
put together to form  an island spread .

 D  The thick vertical line indicates that the new 
page will be added as an island spread.

 E  An example of  an island spread 
in the Pages panel .

 F  You can dismantle an island 
spread by changing the number 
of pages in the spread.

 G  The  brackets around 
the numbers  indicate 
that Allow Selected 
Spread to Shuffl  e 
has been turned 
off  for the pages.
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Importing Text

If you have a short amount of text, you 
can easily type it directly in InDesign’s text 
frames. However, if you are working with long 
amounts of text, most likely you will want 
to import the text from a word processing 
program. You will also want to place the text 
so that it fl ows from page to page.

To import text:

1. Choose File > Place. The options for 
placing text are at the bottom of the Place 
dialog box  A .

2. Navigate to find the file you want to 
import.

3. Select Show Import Options to open the 
specific import options for that type of 
text file.

4. Click Replace Selected Item to replace the 
contents of a selected text frame with the 
new text.

5. Select Open to load the text into a text 
cursor (also called a loaded cursor)  B .

TIP The text cursor also contains a preview area 
to show the type of object being placed. For 
the rest of this book, however, I will show 
only the text cursor itself to make it easier to 
see its behavior.

TIP If you hold the Shift key as you click Choose, 
you open the Import Options dialog box even 
if the checkbox is not selected.

TIP If the text file uses fonts not installed on your 
computer, an alert box informs you that the 
fonts are missing. 

 A  The  Import options  in the Place dialog box.

Importing Text Files

InDesign lets you import text files saved 
from Microsoft Word 98 or higher. You simply 
save the Word DOCDOC file and import that into 
InDesign.

If you have an earlier version of Word, you 
should save the text as an RTFRTF (Rich Text 
Format) document. RTFRTF files retain most 
of their original formatting and can be 
imported by InDesign.

InDesign can also import ASCIIASCII text. ASCIIASCII 
stands for American Standard Code for 
Information Interchange. This is a standard 
character-coding scheme used by most 
computers to display letters, digits, and 
special characters. It is the most primitive 
computer text format. For example, when 
text is saved in the ASCIIASCII format, any italic or 
bold formatting is lost.

Although ASCIIASCII text is stripped down, it is 
useful for importing text from databases 
or Internet sites. However, you do have to 
reformat text imported in the ASCIIASCII format.

 B  The  loaded text 
cursor  indicates 
that you can place 
the imported text.

Text cursor

Preview
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The options for importing text change 
depending on which type of text fi le you 
choose to import.

To open the import options for Microsoft 
Word fi les:

Choose Import Options to open the 
Microsoft Word Import Options dialog 
box  C .

To set the Word import options:

1. Use the Include area to include Word’s 
Table of Contents Text, Index Text, 
Footnotes, or Endnotes.

2. Choose whether dumb quotes and 
apostrophes (such as ‘ and “) should 
be converted into proper typographer 
quotes (such as ‘ and ’ or “ and ”).

To control the formatting in the Word 
import options:

1. Select Remove Styles and Formatting 
from Text and Tables to remove the 
formatting that was applied in Word.

2. If you choose to remove styles and 
formatting, you can select Preserve Local 
Overrides to keep attributes such as italic 
and bold.

3. Use the Manual Page Breaks list to control 
how Word page break commands are 
handled  D .

4. Select Import Inline Graphics to include 
images inserted into the Word text.

5. Select Import Unused Styles to add all 
styles from the Word document even if 
some have not been applied to text.

6. Select Track Changes to see the edits 
applied to the text when using InCopy.

7. Select Convert Bullets & Numbers to Text 
to convert Word’s electronic bullets and 
numbers into actual characters.

 C  The  Microsoft Word Import Options 
dialog box  is used to import Word fi les.

 D  The  Manual Page Breaks list  controls 
how Word page breaks are converted.
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If your Word document contains one or more 
tables, you can control how those tables are 
imported.

To control the formatting in the Word 
import options:

Use the Convert Tables To list to choose 
one of the following  A :
 • Unformatted Tables creates a table 

with InDesign’s default settings.
 • Unformatted Tabbed Text converts 

tables into tab-delimited text.

TIP The import options for RTFRTF files contain the 
same options as the Microsoft Word Import 
Choices.

When you import a Microsoft Excel fi le, you 
can set the import options for the fi le. (See 
Chapter 13, “Tabs and Tables,” for more informa-
tion on working with the tables imported from 
Excel fi les.)

To set the options for Microsoft Excel fi les:

Choose Import Options to open the 
Microsoft Excel Import Options dialog 
box  B .

To choose which data to import from 
Excel fi les:

1. Use the Sheet list to control which parts 
of the spreadsheet you want to import.

2. Use the View list to control which view 
information to import.

3. Use the Cell Range list to control which 
cells to import.

4. Select Import Hidden Cells not Saved in 
View to import that data.

 A  The  Convert Tables To list  controls 
how Word tables are converted.

 B  The  Microsoft Excel Import Options 
dialog box  is used to import Excel tables.
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To choose how the Excel data is formatted:

1. Use the Formatting Table list to choose 
how the table should be formatted  C .

2. Use the Formatting Table Style list to 
apply one of InDesign’s table styles.

3. Use the Cell Alignment list to choose the 
paragraph alignment for the information 
in the table.

4. Select Include Inline Graphics to include 
placed images along with the text.

You can also control how plain text fi les, such 
as ASCIIASCII fi les, are imported into an InDesign 
document.

To set the options for ASCIIASCII fi les:

1. Choose Import Options to open the Text 
Import Options dialog box  D .

2. Choose the character set, platform, 
and dictionary to ensure that special 
characters are imported correctly.

3. Choose how to handle extra carriage 
(paragraph) returns at the ends of lines 
and paragraphs.

4. Choose how to delete extra spaces 
inserted into the text.

 C  The  Formatting Table list  controls 
how tables are imported.

 D  The  Text Import Options dialog box  
is used to import raw ASCIIASCII text fi les.
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Flowing Text

Once you have imported the text into the 
loaded text cursor, you can choose how the 
text fl ows into the document.

To import text into a new frame:

Drag the loaded text cursor to create a 
text frame that contains the text  A . The 
straight lines indicate the text will be 
placed into a new frame.
or
Click the loaded text cursor on the page. 
InDesign creates a text frame the width of 
the margins of the page.

TIP To unload the text cursor, choose any tool in 
the Tools panel.

You can place text automatically into text 
frames that are master page items. This 
makes it easy to fl ow text from page to page.

To create master text frames:

Choose Master Text Frame when you first 
create the document  B . This creates a text 
frame that fits within the margins of the 
master page.

To import text into an existing or master 
frame:

1. Move the loaded text cursor inside the 
frame. Curved lines appear  C .

2. Click the loaded text cursor inside the 
frame. The text flows into the frame.

To import text within the margins:

1. Move the loaded text cursor near the top-
left corner of the margins.

2. Click the loaded text cursor. The text flows 
into the frame.

TIP Look for the cursor arrow to turn white. This 
indicates you will pour the text exactly within 
the margins.

 A  The  straight lines around the loaded 
text cursor  indicate that the text will 
be placed into a new text frame.

 C  The  curved lines around the loaded 
text cursor  indicate that the text will 
be placed into an existing frame.

Do You Need Master Frames?

Coming from QuarkXPress as my first page 
layout program, I used master frames in 
InDesign. I felt there was no other way to 
flow text through many pages.

But as I’ve worked with InDesign over the 
past six years, I’ve come to the conclusion 
that I don’t need master frames to flow text 
from one page to another.

All you have to do is flow the text within 
the margins and the text will make as many 
pages as you want. 

 B  Apply the  Master Text Frame  option 
when you create a new document.
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If you want, you can import many pages 
of text so they’re linked from one page to 
another. There are several techniques for 
fl owing the text. The manual method lets you 
choose exactly where the text should appear. 
For instance, you can use this method to 
place text onto noncontiguous pages.

To manually fl ow text:

1. Import the text so that you have a loaded 
cursor.

2. Move the cursor inside the area where the 
master text frame is located.
or
Move the cursor inside the top-left corner 
of the margins.

TIPTIP The cursor displays curved lines when it is 
within the area of the master text frame  D .

3. Click inside the area where the master 
text frame is located. The text fills the 
frame. If there is more text, an overflow 
symbol appears at the bottom of the 
frame  E .

4. Click the overflow symbol to load the 
overflow text into the cursor  F .

5. Move to another page. The cursor 
changes to a link symbol  G . Click to flow 
the text onto that page  H .

6. If there is additional overflow text, repeat 
steps 3, 4, and 5 until all the text has been 
manually flowed onto the pages.

 D  Move the loaded cursor 
inside an existing or 
master frame to fl ow 
text onto a page.

 E  If there is more text 
than can fi t on the page, 
an overfl ow (plus sign) 
symbol appears at the 
bottom of the frame.

 F  Click the overfl ow 
symbol to manually 
load the overfl ow 
text into the cursor.

 G  Click the 
link cursor 
to fl ow the 
text to the 
next page.

 H  The text 
fl ows onto 
the next 
page.



274 Chapter 10 Pages and Books

Flowing text manually is tedious and cum-
bersome. Rather than manually load the 
overfl ow text onto the cursor, you can use the 
semi-autofl ow command to easily load the 
cursor with the overfl ow text.

To semi-autofl ow text:

1. Import the text so that you have a loaded 
cursor.

2. Hold the Opt/Alt key to display the semi-
autoflow cursor  A .

TIP The cursor displays curved lines if you place 
it inside an existing frame or within a master 
frame.

3. Click the cursor within a frame or the 
margins.
or
Drag to create a text frame. The semi-
autoflow cursor automatically loads any 
overflow text into a new cursor, which can 
be placed into a new frame  B .

4. Hold the Opt/Alt key and click or drag to 
create another text box linked to the first.

5. Repeat step 4 as many times as necessary 
to place all the text in the story  C .

What Can You Do With a Loaded Cursor?

Once you load a cursor with text, it may seem like all you can do is click to place the text. However, 
there are some things you can do without losing the text loaded into the cursor. You can:

 • Use any of the menu or Pages panel commands to add pages to the document.

 • Use the keyboard shortcuts to zoom in or out.

 • Use the scroll bars to move through the page or the document.

 • Move the onscreen elements, such as the panels, to new positions.

But remember, never point a loaded cursor at anyone. It always seems funny till someone loses an icon!

 B  After clicking with 
the semi-autofl ow 
cursor the text 
is automatically 
loaded into a 
new cursor.

 C  Each click with 
the semi-autofl ow 
cursor loads 
the text onto 
new pages.

 A  The  semi - autofl ow cursors  let 
you fl ow text page by page.
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If you have many pages of text, you can auto-
matically fl ow the text and create new pages 
at the same time using the autofl ow feature.

To autofl ow pages with text:

1. Import the text so that you have a loaded 
cursor.

2. Hold the Shift key. This cursor changes to 
the autoflow text cursor  D .

3. Move the cursor over the area inside an 
existing frame or the master frame of 
the page.
or
Click the cursor at the top-left corner of 
the margins.

4. Click the mouse button. This flows the 
text onto that page and creates as many 
additional pages as are necessary to hold 
all the text  E .

TIPTIP Do not select the master text frame before 
you flow the text or you will lose the ability to 
autoflow the text.

What if you want to automatically fl ow text 
onto the existing pages of a document with-
out adding any new pages? 

To fl ow text onto a fi xed number of pages:

1. Import the text so that you have a loaded 
cursor.

2. Hold the Shift+Opt/Alt keys. The cursor 
changes to the fixed-page autoflow 
cursor  F .

3. Click anywhere inside a master text frame 
or the margins of the page  G . This flows 
the text automatically onto as many 
pages as are in the document. If there is 
more text, an overflow symbol appears 
on the last page.

 E  After clicking 
with the autofl ow 
cursor new pages 
are created to 
hold the text.

 D  Use the  autofl ow cursors  to 
create all the pages necessary 
to hold the imported text.

 G  The  fi xed - page autofl ow 
cursor  indicates the text 
will fl ow only onto existing 
pages in the document.

 F  Use the  fi xed - page autofl ow 
cursors  to fl ow text only 
onto the existing pages.

Adding Pages As You Type?

Most designers import text from external files 
into InDesign files. But some writers type directly 
into InDesign text frames. What happens when 
the text overflows those frames? Is it possible to 
add pages as you type?

Yes, it is called Smart TextFlow and it is automati-
cally turned on when you first open InDesign. 
For more information on setting the Smart 
TextFlow options, see Chapter 21, “Customizing.”
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You can fi ll a frame with dummy text instead 
of importing real text.

To fi ll a frame with placeholder text:

1. Click inside a frame.
2. Choose Type > Fill with Placeholder Text. 

The dummy text fills the frame  A .

TIP You can use your own text for the placeholder 
by saving a file named placeholder.txt in the 
InDesign application folder.

Creating Text Breaks

InDesign has special characters that force the 
text to break to a new position.

To insert break characters:

1. Place the insertion point where you want 
to jump to the next location.

2. Choose Type > Insert Break Character or 
Control-click (Mac) or right-click (Win) to 
choose Insert Break Character from the 
contextual menu.

3. Choose one of the following:

Break character Description Symbol

Column break Jumps text to the next column. If there is no column in the frame, the 
column break forces the text to the next page.

Frame break Jumps text to the next frame.

Page break Jumps text to the next page.

Odd page break Jumps text to the next odd page.

Even page break Jumps text to the next even page.

TIP To see a representation of the break 
characters, choose Type > Show Hidden 
Characters.

 A  A sample of the  placeholder text  
that is used to fi ll text frames.
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Working with Master Pages

Every new document includes a master page. 
When you add objects to the master page, 
they appear on all the document pages based 
on that master page.

To add objects to a master page:

1. In the Pages panel, double-click the name 
of the master page  B . This opens the 
master page in the document window.

2. Add text boxes, graphics, or any other 
elements you want on the master page.

TIPTIP If the document has been set for facing 
pages, there are two sides to the master page, 
left-hand and right-hand. 
The left-hand master page governs the left-
hand document pages. 
Similarly, the right-hand master page governs 
the right-hand document pages.

3. Double-click the name of the document 
page to make it the active page. Any 
items placed on the master page now 
appear on the document page.

You can also add master pages from one 
document into another.

To import masters from one document into 
another:

1. Choose Load Master Pages from the 
Pages panel menu.

2. Use the dialog box to select the 
document that contains the masters you 
want to import.

3. If the masters contain the same name, 
you will be asked how to resolve the 
conflict.

4. An alert will tell you if the masters are not 
the same page size.

 B  Double-click a master page in the 
Pages panel to view that  master 
page in the document window .

Uses for Master Pages

Master pages allow you to automate page layout 
changes. For instance, if you have a hundred-
page book, you wouldn’t want to have to draw 
a text frame on every page and type the name 
of the chapter or book title.

Master pages allow you to place an object or 
frame on the master page and have it appear 
on all the document pages.

If you place an object on the master page, it will 
always be positioned in exactly the same spot 
on every page that has that master applied.

You can also use master pages to store design 
alternatives such as different column layouts or 
margin settings.

Think of master pages as the style sheets for 
pages.
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You can have many master pages in a 
document. This allows you to have diff erent 
layouts for diff erent parts of your document.

To create new master pages:

1. Choose New Master from the Pages panel 
menu. This opens the New Master dialog 
box  A .

2. Choose a letter for the prefix for the 
master page.

TIP The prefix is the letter that appears inside the 
pages that have that master page applied to 
them.

3. Enter a name for the master page.
4. Use the pop-up menu to set which master 

page, if any, the new master page should 
be based on.

TIP Basing one master page on another allows 
you to make changes on one master page 
that are applied to the other.

5. Enter the number of pages for the master. 
This allows you to create spreads that 
serve as master pages.

TIP To create a new master page without opening 
the New Master dialog box, hold the Cmd/
Ctrl key and click the New Page icon at the 
bottom of the Pages panel.

As you work, you might want to convert a 
document page into a master page. InDesign 
makes it easy to turn a document page into a 
master page.

To convert a document page to a master 
page:

1. Select the page or pages.
2. Drag the page or pages from the docu-

ment area to the master page area  B .
or
Choose Save as Master from the Pages 
panel menu.

 A  The  New Master dialog box  allows you 
to set the attributes for the master page.

Strategies for Basing 
Master Pages on Each Other

I have three master page spreads for this book. 
One master — the main master — holds only 
the guides and page numbers for the book. The 
master for ordinary pages is based on that main 
master. The master for the chapter opener is also 
based on that main master.

That way, if I need to move the page numbers 
I only need to change the page number on 
the main master. The other masters update 
automatically.

 B  Drag a document page into the 
master page area to convert the 
document page to a master.
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New pages are based on the master page 
applied to the last existing page of the docu-
ment. You can easily change the master page 
that governs pages.

To apply a new master to a page:

1. Select the page or pages.
2. Choose Apply Master to Pages from the 

Pages panel. This opens the Apply Master 
dialog box  C .

3. Use the Apply Master menu to apply a 
master to the pages.

4. Use the To Pages field to change the 
selected pages.

TIPTIP Selecting None creates pages that have no 
master page applied.

To apply masters with the Pages panel:

Drag the master page onto the document 
pages as follows:
 • To apply to a single page, drag the 

master page icon onto the page. A 
rectangle appears around the page  D .

 • To apply to a spread, drag the master 
page icon onto the spread. A rectangle 
appears around the spread  E .

You can also base one master page on 
another using the Pages panel.

To base masters on existing masters:

1. Create a new master or spread.
2. Drag one master page onto another.

 • To base the spread on the master, drag 
the master onto the spread.

 • To base one page on the master, drag 
the master onto a single page.

3. Release the mouse button. The prefix of 
the master appears inside the second 
master page  F . The prefix indicates that 
the master page governs the other 
master page.

 C  The  Apply Master dialog box  allows you 
to change the master that governs pages.

 D   The rectangle around the single 
page  indicates that the master 
will be applied to that page only.

 E   The rectangle around the 
spread  indicates that the master 
will be applied to the spread.

 F  The  letters inside the page icons  
indicate what masters are applied 
to pages or other masters.

Master based on 
other masters

Spread based on 
[None] page

Spread based on 
B-Master
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Ordinarily you modify the elements of a 
master page only on the master page itself. 
The elements on the document pages are 
protected from being selected or modifi ed. 
However, you can release that protection and 
modify the master elements by creating local 
overrides.

To modify master elements on document 
pages:

1. Hold Cmd/Ctrl-Shift and click the element 
you want to modify. This releases the 
protection and leaves the item selected.

2. Make any local changes to the item.

You might want to modify all the master 
elements on a page. Rather than release each 
item one by one, InDesign lets you do it with 
a single command.

To release all master elements on a page:

Choose Override All Master Page Items 
from the Pages panel menu. This releases 
the objects so they can be modified.

You may want to set master page items, such 
as page numbers and headers, to never be 
modifi ed on the document page.

To set a master page item to not be 
overridden:

1. Select the item on the master page.
2. Deselect Allow Master Item Overrides on 

Selection from the Pages panel menu.

You can also set a master page item to apply 
its text wrap to other master page items, and 
not any document page items.

To control the text wrap of a master 
page item:

Select the item on the master page.
1. Apply a text wrap setting.
2. Use the Text Wrap panel menu to select or 

deselect Apply to Master Page Only.

Overriding Master Page Elements

If you modify a master page element on a 
document page, the local override loses its link 
to the master page element. However, the ele-
ment may have partial links to the master page 
element.

Let’s say you add a stroke to an object on the 
document page. From that point on, the stroke 
of the element is removed from the con trol of 
the element on the master page.

But other attributes of the element maintain 
their link to the master page item. For instance, 
the position of the element maintains a link 
to the master page item. So if you move the 
element on the master page, the item on the 
document page also moves.

Similarly, the fill color of the elements on the 
document pages changes if you change the 
master page element. Only the formatting for 
the stroke is separated from the master page 
element.
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Once you have created a local override on a 
master page element, it may still have links to 
the original master page item. You can com-
pletely sever all ties between the master page 
item and the item on the document page. 

To separate an item from the master item:

1. Select the object that has been released.
2. Choose Detach Selection From Master in 

the Pages panel menu.

Of course you can also separate all the objects 
on a page from their links to the master page 
items.

To separate all the master items on a page:

1. Use the command Override All Master 
Page Items to first release all the master 
page items from the master page.

2. Choose Detach All Objects From Master 
in the Pages panel menu. This severs any 
remaining link between the item and the 
master page.

You can also hide master page items on docu-
ment pages so they do not print.

To change the display of master page 
items:

Choose Hide Master Items from the Pages 
panel menu or choose Show Master Items 
from the Pages panel menu.

InDesign also lets you quickly clear all local 
overrides and reapply the master page items 
to the document page.

To remove local overrides and reapply the 
master:

Choose Remove All Local Overrides in 
the Pages panel menu. All local override 
elements will be deleted and the master 
page items will be reapplied.

How Many Master Pages?

Although it may seem like a lot of work to set up 
master pages, the more masters you have the 
easier it is to lay out complicated documents.

A weekly magazine can easily have 50 or more 
master pages — some for special editorial 
spreads and others for different types of adver-
tising spaces.

Some publishers insist that every page must be 
based on a master and do not allow any modifi-
cations of the master page elements. Others let 
the  designers override the master pages.

You decide which way best suits your work 
habits and the project.

Stacking Order of Master Page Items

The items on the master page are always behind 
any new items you may put on a page. But when 
you release the master page items from the 
master page, they always spring to the front of 
the document page.

If you want, you can use the Object > Arrange 
menu to change the stacking order of the items. 
However, if you release many items on many 
pages, it may seem cumbersome to move them 
backwards.

Instead, create two layers in your document 
(see Chapter 11, “Layers”). Put all the master page 
elements on the bottom layer, and your regular 
document objects on the top layer. That way 
when you release the master page items, they 
will not move in front of your regular page items.
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Rotating Spreads

Pages don’t all have to be in the same orien-
tation. You might have an item, such as a long 
table, that you want to lay out horizontally, 
rather than vertically. Although it’s easy to 
rotate the text frame on the page, it’s dif-
fi cult to read the text when rotated. Rotating 
the page spread makes it easier to read the 
text  A .

To rotate a spread:

1. Select the spread that you want to rotate. 
(Only spreads can be rotated, not single 
pages.)

2. Choose Rotate Spread View from the 
Pages panel menu and then choose one 
of the following:
 • 90° CW (clockwise)
 • 90° CCW (counter clockwise)
 • 180° 

A rotation indicator appears next to the 
spread in the Pages panel to indicate that 
the spread has been rotated  B .

To restore a spread to normal rotation:

1. Select the spread.
2. Choose Rotate Spread View > Clear 

Rotation from the Pages panel menu. 
The spread view is restored to the normal 
orientation.

 A  An example of how  rotating a spread  
makes it easier to read the information in a 
table that has been laid out horizontally.

 B  The  Rotation icon in the Pages 
panel  indicates that the page 
view has been rotated.
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 Adjusting Layouts

You certainly are not expected to set layouts 
perfectly the fi rst time, or every time. Fortu-
nately, InDesign has a powerful layout adjust-
ment feature that moves and resizes objects 
as you change the page size or margins.
Once layout adjustment is turned on, any 
changes to the layout will alter the posi tion of 
the elements on both the master pages and 
the document pages.

To set the layout adjustment options:

1. Choose Layout > Layout Adjustment. 
This opens the Layout Adjustment dialog 
box  C .

2. Select Enable Layout Adjustment so that 
elements change position when page 
size, orientation, margins, or columns are 
changed  D .

3. Set a value for the Snap Zone to specify 
how close an object must be before it will 
align and move to a margin or column 
guide, or page edge.

4. Select Allow Graphics and Groups to 
Resize so that elements change size as 
well as move during the adjustment.

5. Select Allow Ruler Guides to Move to have 
ruler guides move as part of the layout 
adjustment.

6. Select Ignore Ruler Guide Alignments to 
keep objects from moving along with 
ruler guides.

7. Select Ignore Object and Layer Locks to 
move objects that are locked or on locked 
layers.

8. Click OK to set the options. The document 
will change according to the new settings 
when the document setup or margins are 
changed.

C  The  Layout Adjustment dialog box  
controls which elements change if 
you change document attributes 
such as the page size or margins.

 D  When Enable Layout Adjustment is 
turned on, the items on the page 
adjust their size and position when the 
margins and page size are changed.
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Page Numbers and Text 

Variables

The most common element that is added to a 
master page is the page-number character.

 To add automatic page numbering:

1. Draw a text frame on the master where 
you want the page number to appear.

2. Choose Type > Insert Special Character > 
Markers > Current Page Number. This 
inserts a special character in the text 
frame  A .

TIP The current page number character is the 
prefix for the master page.

3. If the master page is a facing-page 
master, repeat steps 1 and 2 for the other 
page in the master.

You may want to change the format of page 
numbers or the number they start from. You 
do that by creating a new section.

To create a document section:

1. Move to the page where you want the 
section to start.

2. Choose Layout > Numbering & Section 
Options. The New Section dialog box 
appears  B .

3. Select Start Section to open the options.
4. Choose the Page Numbering options:

 • Automatic Page Numbering continues 
the count from the previous pages.

 • Start Page Numbering At lets you 
enter a specific number to start the 
section from.

5. Use the Style pop-up list to set the format 
for the automatic page numbering  C .

TIP The choices for roman numerals or letters are 
commonly used for front and back matter in 
book publishing. 

 B  The  New Section dialog box  
lets you change the formatting 
and numbering of pages.

 C  The  Style menu  allows you to 
choose diff erent formats for page 
numbering of a section.

 A  The  current page 
number  appears as a 
letter on master pages 
but as a number on 
document pages.
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You can also create a section prefi x that 
appears in front of the current page number.

 To work with a section marker:

1. Choose Layout > Numbering & Section 
Options to open the New Section 
dialog box.

2. Type the label (up to five characters) for 
the section in the Section Prefix field.

3. Choose Include Prefix when Numbering 
Pages to add the section prefix to the 
page number.

4. Enter a label for the Section Marker  D .

Once you have created an entry for the 
section marker, you need to insert a section 
marker character in the text frame to see the 
entry on document pages.

To add a section marker character:

1. Place the insertion point in a text frame 
where you want the section marker to 
appear.

TIPTIP The text frame can be on a master page or a 
document page.

2. Choose Type > Insert Special 
Character > Markers and then choose 
Section Marker from the menu.

TIPTIP If the text frame that contains the section 
marker character is on the master page, the 
word “Section” appears on the master page. If 
the text frame is on the document page, the 
label for the section marker appears  E .

 D  The entry in the  Section Marker fi eld  allows 
you to create custom labels for pages.

 E  The  section marker  
appears as the word 
“Section” on master 
pages but as the label 
on document pages.

Absolute or Section Numbering?

What if you create a document that has its first 
section begin on page i and then starts a new 
section that begins on page 1? This could create 
some confusion if you try to print page “one.” 
Which one of the “ones” would you print?

Fortunately, InDesign has a preference setting 
that allows you to change the section number-
ing to absolute numbering. This makes it easier 
to avoid confusion if a document has multiple 
sections that begin with the same number.

However, you can also specify page numbers 
by using the plus (+) sign in the Print dialog 
box. For instance +1 means the first page in the 
document even if that first page is numbered i 
or 1 or any other number.
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Books have more than just page num-
bers. They also have chapter numbers. You 
can specify the chapter number for your 
document. Then you can insert the chapter 
number as a text variable in a frame.

To specify a chapter number:

1. Choose Layout > Numbering & Section 
Options to open the New Section 
dialog box.

2. Enter a number in the Chapter Number 
field  A .

TIP The number can also be created 
automatically as part of a Book document, as 
covered on page 298.

3. Use the Document Chapter Numbering 
Style list to choose the style of the 
characters used for the chapter 
numbers  B .

TIP These are similar to the styles for page 
numbers with the exception of the 01, 02, 03, 
04 style, which is used in many textbooks.

Chapter numbers are inserted as special char-
acters that can appear anywhere.

 To add a chapter number:

1. Place the insertion point in a text frame.
2. Choose Type > Text Variables > Insert 

Variable and then choose Chapter 
Number from the list of preset text 
variables. The text variable for Chapter 
Number appears with a line around the 
display  C .

TIP Other text variables include creation date, file 
name, last page number, modification date, 
output date, and running headers. 

 A  The  Document Chapter Numbering  
allows you to set the chapter 
number for a document.

 B  Use the  Document Style list  to set the 
elements that are used for chapter numbers.

 C  A  text variable  is 
displayed with a 
rectangle around 
the information.
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You can also insert special characters that 
create jump lines that show the page where 
the text fl ow continues to or from.

To create a continued to/from page 
number:

1. Place the insertion point in a text frame 
that touches the frame that holds the 
story.

2. Choose Type > Insert Special Character 
and then choose one of the following:
 • Next Page Number inserts the number 

of the page that the text jumps to or 
continues on  D .

 • Previous Page Number inserts the 
number of the page that the text 
continued from  E .

TIPTIP The continued to/from character needs a 
separate text frame so that if the text reflows, 
the continued to/from character doesn’t 
move along with the text.

TIPTIP The continued to/from characters only insert 
the page number that the story is linked to. 
You have to type the words “Continued on” or 
“Continued from” yourself.

 D  The  Next Page Number character  shows 
the page number that the story is continued 
on. The overlapping area is where the page 
number frame touches the story frame.

Overlap

 E  The  Previous Page Number character  
shows the page number that the 
story comes from. The overlapping 
area is where the page number 
frame touches the story frame.

Overlap
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Conditional Text

Conditional text is simply text that has been 
assigned with an electronic “marker.” This 
marker can be set to make the text either 
visible or invisible. This allows you to have 
a document where some text can be set to 
print or not print. This is very handy for books 
that have teacher notes or other text that 
needs to be hidden at times.

To create a condition for text:

1. Choose Window > Type & Tables > 
Conditional Text. This opens the 
Conditional Text panel  A .

2. Choose New Condition from the panel 
menu. This opens the New Condition 
dialog box  B .
or
Click the New Condition icon at the 
bottom of the panel. This opens the New 
Condition dialog box  B .

3. Give the condition a name.
4. Use the Indicator area to set the 

appearance of the conditional text. (See 
the exercise on the following page for how 
to set the indicators.)

5. Click OK to create the condition.

TIP Every document automatically contains 
a setting for Unconditional text in the 
Conditional Text panel. All text is by default 
set to Unconditional.

To modify a condition:

Double-click the condition in the 
Conditional Text panel. This opens the 
Condition Options dialog box which is the 
same as the New Condition dialog box 
covered above.
or
With the condition selected, choose 
Condition Options from the panel menu.

 A  The  Conditional Text panel  lets you 
defi ne new conditions for text as well 
as show or hide the conditional text.

 B  The  New Condition dialog box  
is where you name and set the 
indicators for conditional text.
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Conditional text can have electronic indica-
tors that are displayed to show that a special 
condition has been applied. You use the 
Indicator area of the New Condition dialog 
box to set the appearance of the indicators 
for conditional text  C .

To set the indicator appearance for 
conditional text:

1. With the New Condition dialog box open, 
choose one of the following from the 
Method menu:
 • Underline creates an underline for the 

conditional text.
 • Highlight creates a solid block of color 

over the conditional text.
2. If you have chosen Underline, use the 

Appearance menu to choose one of the 
following:
 • Wavy for a wavy line.
 • Solid for a solid line.
 • Dashed for a dashed line. 

3. Use the Color menu to choose a color for 
the underline or highlight.

Once you have created a condition, it is very 
simple to apply it to text.

To apply conditional text:

1. Select the text.
2. Click the Apply Condition column to 

display a checkmark next to the name 
of the condition in the Conditional Text 
panel  D .

TIPTIP You can apply more than one condition to 
selected text. This helps your work with 
conditions be more flexible.

TIPTIP Conditional text can also be applied using 
the Change To attributes of the Find/Change 
dialog box. (See Chapter 14, “Automating Your 
Work,” for more information on using Find/
Change.)

Price £2 ¥10 €6 $5
 C  The  indicators for conditional text  

can be set for underlines (solid, 
wavy, or dashed) or highlight.

 D  An example of  setting a condition to text .
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Once text has a condition applied to it, you 
can hide or show the text by changing the 
visibility of the condition  A .

To show or hide conditional text:

Click the visibility eyeball next to a 
condition as follows:
 • A visible eyeball indicates that the text 

is visible and will print.
 • A hidden eyeball indicates that the text 

is hidden and will not print.

TIP When you hide conditional text, the space 
that the text occupied reflows.

You may want to change the visibility of the 
indicators that are applied to the condition.

To control the conditional text indicators:

1. Select the condition in the Conditional 
Text panel.

2. Choose one of the following from the 
Indicators menu  B :
 • Show displays the indicators but they 

do not print.
 • Show and Print displays the indicators 

on screen and when printed or 
exported to PDFPDF.

 • Hide turns off the visibility of the 
indicators.

Conditions can be imported from one docu-
ment into another.

To control the conditional text indicators:

1. Open the document that you want to add 
the conditions to.

2. Choose Load Conditions from the 
Conditional Text menu.

3. Navigate to and select the document that 
contains the conditions.

4. Choose OK. The conditions appear in the 
Conditional Text panel.

 A  An example of  hiding conditional text . 
Here the visibility controls for the text for 
Euros and Yen have been turned off .

 B  The  Indicators menu  for the Conditional 
Text panel lets you control the display of 
the indicators applied to conditional text.
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Conditional Text Sets

As soon as you create a few conditions for 
text, you may fi nd it easier to group those 
conditions into sets. These sets make it easier 
to turn the visibility of many conditions on 
and off  with a single click.

To create a conditional text set:

1. Choose Show Options from the 
Conditional Text panel. This shows the Set 
menu at the bottom of the panel  C .

2. Apply the visibility to the conditions as 
desired.

3. Choose Create New Set from the Set 
menu. This opens the Condition Set Name 
dialog box.

4. Name the set and click OK.

TIPTIP Choose Load Conditions and Sets from the 
Conditional Text panel menu to add both 
conditions and sets to a document.

Once you have defi ned a set, you can choose 
it from the Set menu.

To apply a condition set:

Choose the set from the Set menu in the 
Conditional Text panel  D .

You can easily change the defi nition of a 
condition set.

To apply a condition set:

1. Choose the set from the Set menu in the 
Conditional Text panel.

2. Make whatever changes you want to the 
visibility of the conditions. A plus (+) sign 
appears next to the set name.

3. Choose Redefine “[set name]” from the 
Set menu. The plus sign disappears and 
the set is changed.

 C  The  Set menu  for the 
Conditional Text panel.

 D  Choose the  saved conditional sets  
from the Conditional Text Set menu.
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Applying Captions to Graphics

A caption is the text that describes a placed 
graphic. InDesign’s Live Captions feature 
automatically creates captions for placed 
images. This greatly speeds up how much 
time it takes to lay out books or magazines. 
There are several steps for creating Live 
Captions. First someone needs to enter the 
metadata for the caption.

To enter the information for the caption:

1. Select the graphic in Adobe Bridge.
2. Choose File > File Info. This opens the 

Adobe XMP dialog box  A .
3. Click the Description tab at the top of the 

dialog box.
4. Enter the metadata information, such as 

Description, Author, or Document Title, in 
the appropriate fields.

5. Deselect the document in Bridge. The 
metadata is automatically saved with the 
graphic.

TIP You can also access the Adobe XMP dialog 
box in Photoshop or Illustrator by choosing 
File > File Info.

Next, you need to defi ne what type of infor-
mation will be inserted as the contents of the 
caption. This is the caption setup.

To set the metadata in the caption setup:

1. Choose Object > Captions > Caption 
Setup. This opens the Caption Setup 
dialog box  B .

2. Select a metadata label from the 
Metadata menu. This menu corresponds 
to the metadata fields in the Adobe XMP 
dialog box.

3. Use the Text Before or Text After fields to 
add custom text to the metadata.

4. Click the plus or minus buttons to add 
other metadata labels.

A Workflow for Captions

Designers laying out pages are not the people 
who know what the metadata should be for 
which graphics. Those are usually the editors or 
authors of the text.

As a designer, you should let the editors on 
your project know that they can use Bridge to 
enter the metadata for graphics. If they have to 
enter metadata for large numbers of graphics, 
there are third-party applications that can add 
metadata automatically from databases.

Once the metadata has been added to the 
graphics, you can easily import it into the layout.

 A  The  Adobe XMP dialog box  holds 
the metadata for graphics that are 
placed into InDesign documents.

 B  The  Caption Setup dialog box  lets you 
defi ne the text and metadata for captions 
plus the position and style of the captions.



InDesign CS5 Visual Quickstart Guide 293

The caption setup also lets you control the 
position and formatting of the text frame that 
holds the caption.

To format the text frame for the caption:

1. In the Caption Setup dialog box use the 
Alignment menu to position the caption 
frame under, over, to the left, or to the 
right of the graphic frame  C .

2. Use the Offset controls to add space 
between the graphic and the caption 
frame.

3. Use the Paragraph Style menu to apply a 
style to the caption text.

4. Use the Layer menu to send the caption 
text frame to a specific layer.

5. Select Group Caption with Image if you 
want the caption and image frames 
grouped together.

TIPTIP Ordinarily the text frame must touch the 
graphic for a live caption to be created  D . 
However, grouping the caption and image 
allows the two items to be separated.

A live caption is one that updates when the 
metadata changes.

To create live captions for graphics:

With the graphics selected, choose 
Object > Captions > Generate Live 
Caption. The caption frames appear.

A static caption is not linked to the metadata 
and does not update.

To create static captions for graphics:

With the graphics selected, choose 
Object > Captions > Generate Static 
Caption. The caption frames appear.

To convert live captions to static:

With the caption frame selected, choose 
Object > Captions > Convert to Static 
Caption.

 C  The  Alignment options  for the position 
of the text frame that contains a caption.

 D  The frame that contains a live caption  must 
touch or be grouped with the graphic it 
describes  in order for the caption to appear. 

Frames touching Frames separated
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Making Books

Most people who create long documents 
break them up so that each chapter is con-
tained in its own document. They need a way 
to coordinate the page numbers, colors, and 
styles. An InDesign book is an electronic fi le 
that keeps track of all those documents.

To create an electronic book fi le:

1. Choose File > New > Book.
2. Use the dialog box to name the book 

document and save it in a location  A . The 
Book panel appears  B .

TIP The tab for the Book panel contains the name 
of the book.

Once you have created the book fi le, you can 
then add documents that make up the book.

TIP You don’t have to create the book file first. 
For instance, I created these chapters before I 
added them to a book document.

To add documents to a book:

1. Click the Add Document button at the 
bottom of the Book panel.
or
Choose Add Document from the Book 
panel menu.

2. Use the dialog box to find the document 
you want to add to the book. The name of 
the chapter appears in the Book panel.

3. Repeat steps 1 and 2 to add other docu-
ments to the book.

To remove documents from a book:

1. Select the documents you want to 
remove.

2. Click the Remove Document button at the 
bottom of the Book panel.
or
Choose Remove Document from the Book 
panel menu.

 B  An  empty Book panel  displays the 
name of the book on its panel tab.

Remove 
document 

Add document 

Print bookSynchronize

Save book

 A  A saved book document 
appears with its own 
document icon.
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You can use the Book panel and Book panel 
menu to open, rearrange, and control the 
documents that make up the book.

To open documents in a book:

Double-click the name of a document in 
the Book panel. The open book symbol 
next to the name indicates that the 
document is open  C .

The order that documents are listed in the 
Book panel determines the page numbers of 
the book.

To change the order of the documents in 
a book:

Drag the name of a document in the Book 
panel to a new position in the panel  D . 

One of the benefi ts of creating a book docu-
ment is that you can have one fi le (called 
the style source) control the style sheets, 
swatches, and master pages for the other 
documents in the book. If you make changes 
to the style source, all the other fi les in the 
book synchronize to that fi le.

To set the style source for a book 
document:

Click the Style Source box next to the 
name of the file that you want to control 
the rest of the documents in the book  E .

To synchronize fi les to the style source:

Click the Synchronize button in the Book 
panel.
or
Choose Synchronize Book in the Book 
panel menu.

TIPTIP The menu command says Synchronize 
Selected Documents if only some of the files 
in the book are selected.

 C  The  open book icon  indicates that 
a document of the book is open.

 D   Drag a listing in the Book panel  
to change the order in which the 
documents appear in the book.

 E  The  style source fi le  is used to 
synchronize the style sheets and colors 
for other documents in a book.

Style source icon
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To set the synchronizing options:

1. Choose Synchronize Options from the 
Book panel menu. The Synchronize 
Options dialog box opens  A .

2. Choose the options that you want to 
apply from the style source document.

If the book is closed when you modify the 
fi les in the book, you need to update them 
when you do reopen the book document.

TIP This step is not necessary if you modify book 
files while the book document is open.

To update fi les in a book:

1. Choose File > Open and then navigate to 
the book document you want to work on.

2. Use the Book panel to open, then modify 
any files in the book document. An Alert 
icon appears next to the modified files  B .
or
Use the Open command in the File menu 
to open, then modify any files in the book 
document.

3. If necessary, synchronize the files to the 
style source document.

You can also replace missing fi les in a book or 
swap one fi le for another.

TIP A Missing icon indicates that the file has been 
moved after being added to the book  C . 

To replace a fi le in a book:

1. Select the file in the Book panel that you 
want to replace.

2. Choose Replace Document from the Book 
panel menu.

3. Navigate to find the file you want to 
replace or relink.

4. If necessary, synchronize the files.

 A  Use the  Synchronize Options dialog box  
to set which attributes of the style source 
fi le will be applied to the fi les in the book.

 B  The  Alert icon in the Book panel  indicates 
that the fi le has been modifi ed.

 C  The  Missing icon in the Book panel  
indicates that the fi le has been moved 
after it was imported into the book.
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Files in a book automatically run in consecu-
tive numbers. As you add or delete pages in 
one document, the page numbers in the rest 
of the book adjust. You can control how the 
page numbers are adjusted.

To set how page numbers are adjusted:

1. Choose Book Page Numbering Options 
from the Book panel menu to open the 
dialog box  D .

2. Choose the Page Order options as follows:
 • Continue from previous document 

starts new pages sequentially from the 
end of the previous listing.

 • Continue on next odd page always 
starts new pages on an odd number.

 • Continue on next even page always 
starts new pages on an even number.

3. If using the odd or even options results in 
a skipped page, select Insert Blank Page.

4. Deselect Automatically Update Page & 
Section Numbers to stop InDesign 
from automatically numbering the files 
in a book.

To set the numbers for each document in 
a book:

1. Choose Document Numbering Options 
from the Book panel menu to open the 
dialog box  E .

2. Choose Automatic Page Numbering to 
number pages as they appear in the Book 
panel.
or
Choose Start Page Numbering At to set 
a specific page number to start that 
document on  F .

3. Set the rest of the options for styling the 
number as described on pages 284 and 285.

 D  Use the  Book Page Numbering 
Options  dialog box to set how pages 
will be numbered in a book.

 E  Use the  Document Numbering Options 
dialog box  to set how an individual 
document is numbered in a book.

 F  The  Page Numbering options  
for a document in a book.
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 To set the chapter numbers for book fi les:

1. Choose Document Numbering Options 
from the Book panel menu to open the 
dialog box  A .

2. Choose one of the following to set the 
number for the chapter:
 • Chapter Number field sets a number.
 • Continue from Previous Document in 

the Book applies the next number.
 • Same as Previous Document in the 

Book uses the same chapter number as 
the previous document.

3. Set the Style options for the chapter 
number as described on page 286.

To update the numbering in a book:

Choose one of the following from the 
Book panel menu’s Update Numbering 
submenu:
 • Update Page & Section Numbers
 • Update Chapter & Paragraph Numbers
 • Update All Numbers

You can also apply output commands to the 
fi les in a book. (See Chapter 19, “Output,” for 
more information on printing files.)

To set the output options for a book:

Choose one of the following output 
commands from the Book panel menu:
 • Print Book prints the entire book.
 • Preflight Book preflights all the 

documents in the book.
 • Package Book for Print collects the 

files for output.
 • Export Book to Digital Editions 

creates an eBook type of PDFPDF.
 • Export Book to PDFPDF creates a PDFPDF of the 

documents in the book.

TIP Select just some of the files in the Book panel 
to output just those files  B .

 A  The  Document Chapter Numbering 
options  for a document in a book.

 B  With no fi les selected, the  Book panel 
menu controls all the fi les in a book  
(top). However, when you select 
individual fi les in the Book, the  Book 
panel menu commands are applied 
only to those selected fi les  (bottom).
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Creating a Table of Contents

InDesign creates a table of contents (TOC) by 
looking at the styles applied to paragraphs 
and then listing the text and page numbers 
for those paragraphs. The TOC for this book 
lists the chapters and the section heads  C .

To prepare a document for a table of 
contents:

1. Add the page or pages that will hold the 
TOC.

TIPTIP Most tables of contents are part of the 
front matter of a book and are numbered 
separately without affecting the regular page 
numbering.

TIPTIP If the document is part of a book, make sure 
the book’s pagination is current.

2. Apply paragraph styles to the paragraphs 
that you want to appear in the TOC. 

To defi ne the styles for TOCTOC entries:

1. Choose Layout > Table of Contents to 
open the Table of Contents dialog box  D .

2. Set the Title and Listing controls as 
described in the exercises that start on 
the next page.

3. Click Save Style. This opens the Save Style 
dialog box  E .

4. Name the style and click OKOK.

To generate the TOCTOC:

1. Choose Layout > Table of Contents to 
open the Table of Contents dialog box.

2. Set each of the controls as described in 
the following exercises.

3. Click OKOK. This closes the dialog box and 
creates a loaded text cursor that contains 
the TOC.

4. Click or drag the loaded cursor to apply 
the TOC text where you want it to appear 
in the document.

 D  The  Table of Contents dialog 
box  lets you select and format 
listings for a table of contents.

 E  The  Save Style dialog box  lets 
you save the settings from the 
Table of Contents dialog box.

 C  The  paragraph styles applied to chapter 
titles and section heads in this book  can 
be used to create a table of contents.

Chapter title

Section head
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The title is the label that is applied before 
each entry in the table of contents. You can 
set the type for the title as well as the para-
graph style that formats the title.

To enter the title of the table of contents:

1. Type the text for the title in the Title 
field  A .

2. Use the Style menu to the right of the 
Title field to choose which paragraph 
style is applied to format the title.

You create the entries for a table of contents 
by selecting the paragraph styles that are 
applied to those sections of your documents.

To choose the listings for the table of 
contents:

1. Select a paragraph style listed in the 
Other Styles area of the Table of Contents 
dialog box  B .

2. Click the Add button. This moves the style 
to the Include Paragraph Styles list.

3. Repeat steps 1 and 2 for any additional 
styles.

If your TOC uses a style with auto numbers, 
you can set how the TOCTOC styles those entries.

To set the options for numbered 
paragraphs:

1. Select a paragraph style listed in the 
Other Styles area of the Table of Contents 
dialog box.

2. Choose one of the options from the 
Numbered Paragraphs list as follows  C :
 • Include Full Paragraph includes the 

text and the numbers.
 • Include Numbers Only includes just 

the numbers for the paragraph.
 • Exclude Numbers includes the text but 

not the numbers.

A TOC of Nonexisting Items

The items in a TOC don’t have to be from items 
that are visible on each page. For instance, let’s 
say you want a list of all photographers in your 
book and where their pictures appear. Simply 
put the names of the photographers next to 
their photos, but set the names to not print or 
on a layer set to not print.

Then, run the TOCTOC for the items. You get a list of 
the photographers’ names, even though those 
names don’t actually appear on the printed 
pages.

 A  Use the  Title fi eld in the Table of 
Contents dialog box  to enter the text 
you want to appear before the listings.

 B  Move styles from the Other Styles 
list to the  Include Paragraph Styles 
list  to choose which paragraphs are 
added to the table of contents.

 C  The options in the  Numbered 
Paragraphs list  let you choose how 
paragraphs with auto numbering are 
handled in the table of contents.
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Most likely you will want to format the entries 
in a table of contents with a diff erent style 
than the one used within the document.

To format the entries in the table of 
contents:

1. Select the entry listing in the Include 
Paragraph Styles area.

2. Choose a paragraph style sheet from the 
Entry Style menu under the Style: [Name] 
in the Table of Contents dialog box  D .

3. Repeat steps 1 and 2 for any additional 
styles.

The Table of Contents dialog box has addi-
tional controls for more advanced options 
such as formatting the page numbers for 
each entry.

To open the additional table of contents 
controls:

Click the More Options button in the 
Table of Contents dialog box  E . This opens 
the advanced options at the bottom of 
the dialog box  F .

TIPTIP If the button says Fewer Options, then the 
dialog box already shows the advanced 
options.

 D  Use the  Entry Style menu  to choose 
a style sheet that you have created 
to format the listing as it should 
appear in the table of contents.

 F  The  Table of Contents dialog box 
 with all the options available.

 E  Click the  More Options button  
to expand the controls in the 
Table of Contents dialog box.
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With the advanced options open, you have 
additional controls for the style for each entry 
in the TOC  A . This gives you greater control 
over where the page numbers appear and 
how they are formatted.

To set the advanced Style options for 
each entry:

1. Choose one of the styles in the Include 
Paragraph Styles list. The style name 
appears in the Style options area.

2. If you have not already applied a listing 
from the Entry Style menu, do so as 
explained on the previous page.

3. Use the Page Number menu to choose a 
position for the entry’s page number  B .

4. If desired, choose a character style for the 
page number from the Style list to the 
right of the Page Number menu.

TIP The character style lets you apply formatting 
to the page number for each entry. 

You can also control how the entry name and 
the page number are separated.

To control the separator character:

1. Select one of the character options from 
the Between Entry and Number menu  A . 
The character symbol appears in the field.

2. If you want, type additional text before or 
after the character symbol. This lets you 
add a label before the page number.

3. If desired, apply a style from the Style 
menu for the Between Entry and Number 
character  A .

 B  The  Page Number menu  controls where the 
page number will appear in the TOCTOC listings.

 A  The  Style options area  gives you 
controls to format how the entries are 
formatted and arranged in the TOCTOC.

Other Uses for a Table of Contents

You’re not limited to using the Table of Contents 
commands just for listings of chapters and sec-
tion heads.

If you have a sales catalog you can use the com-
mands to create a list of all the items, which can 
be used as a price list. I could generate a separate 
file for this book that lists all the titles for side-
bars such as this one. In a book of illustrations, 
you can use it to create a list of names of all the 
artists for each illustration.

The only thing you need to remember is to 
assign a style sheet to each item that you want 
to appear in the table of contents.
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A table of contents doesn’t have to be orga-
nized in the order that the items appear.

To alphabetize the table of contents:

Select Sort Entries in Alphabetical order 
from the advanced options area  B .

To indent the entries in a table of contents:

Use the Level controls to indent each 
table of contents entry  B .

TIPTIP Each entry in the Include Paragraph Styles list 
is automatically indented. This is for display 
purposes in that dialog box and does not 
affect the final TOCTOC.

There are additional options you can set for a 
table of contents  C .

To set the table of contents options:

Select each of the table of contents 
options at the bottom of the Table of 
Contents dialog box as follows:
 • Create PDF Bookmarks adds 

bookmarks to the PDFPDF that is created 
from the TOC. This is in addition to any 
hyperlinks within the TOC.

 • Replace Existing Table of Contents 
lets you update or change the table of 
contents that has already been placed 
in the document.

 • Include Book Documents lets you 
create a table of contents for all the 
documents in a book.

 • Run-in creates a single paragraph table 
of contents with each entry divided by 
a semicolon (;) and a space.

 • Include Text on Hidden Layers uses 
text that is on layers that are not 
visible. 

 • Numbered Paragraphs lets you format 
how paragraphs with auto numbering 
are formatted in the TOCTOC.

 C  The  Options for creating TOC documents .

Benefits of an Automatic TOCTOC

If all this seems like too much work just to create 
a short table of contents, you may be tempted 
to create one by hand — manually entering the 
items in the TOC. 

For instance, I could easily create the table of 
contents at the front of this book just by typing 
it out by hand.

But there is a big benefit in creating an automatic 
TOC. When you export PDFPDF files with an automati-
cally created TOC, they will have hyperlinks from 
the TOC to the document pages. 

This means someone reading the PDFPDF document 
can just click on the page number listed in the 
TOC to go to that specific page. Without the 
electronic TOCTOC, you’d have to manually add all 
those links in InDesign or Acrobat.
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In This Chapter:

Creating and Deleting Layers 306
Setting the Layer Options 308
Working with Layers 311
Layer Contents 313

Layers
When I was in advertising, we used 

to lay clear acetate sheets over our 
mechanical board as a way to create 
variations for our layouts. One acetate 
layer might have copy and prices for 
a test market newspaper ad. Another 
piece of acetate might have prices for a 
special Sunday-circular ad. Yet another 
might have copy without prices for the 
national magazine ads. The artwork and 
other graphics stayed on the bottom 
layer and were visible through the 
acetate layers.

When the mechanical was sent to be 
printed, the print shop workers fl ipped 
the diff erent acetate sheets on or off  
the board to create the diff erent types 
of ads. Because a new mechanical didn’t 
have to be created for each variation, it 
saved a lot of time and eff ort.

InDesign gives you the same sort of 
fl exibility with electronic layers. You 
may have just two layers — one for text, 
the other for graphics. Or you may have 
a document with hundreds of diff erent 
layers.

For instance, if you have English and 
French versions of a document, you can 
put the text for each language on its 
own layer. You can then display just one 
version at a time.
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Creating and Deleting Layers

Every InDesign document opens with a 
default layer in the Layers panel. You don’t 
have to do anything special to work with this 
default layer. It is instantly active, and every-
thing you do is automatically on that layer.

To open the Layers panel:

If the Layers panel is not visible, choose 
Window > Layers to open it  A .

As you work, you may want additional layers 
in your document.

To create new layers:

1. Choose New Layer from the Layers 
panel menu. This opens the New Layer 
dialog box.
or
Click the New Layer icon. This creates a 
new layer without opening the New Layer 
dialog box.

2. Set the layer options as described in the 
next section.

3. Click OK to create the layer.

TIP You can open the layer options at any time by 
double-clicking the name of the layer in the 
Layers panel or by choosing Layer Options 
from the Layers panel menu.

It may be easier to create diff erent versions of 
a document by duplicating a layer, as well as 
the objects on that layer.

To duplicate a layer:

Drag the layer onto the New Layer icon  B . 
This creates a copy of the layer.

 A  The  Layers panel  for all new 
documents contains one layer.

New Layer

Delete Layer

Active Layer

 B  You can duplicate a layer by dragging 
it onto the New Layer icon.
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You can also import the layers automatically 
when you paste items from one document 
to another. This behavior is controlled by the 
Paste Remembers Layers command.

To create new layers while pasting:

1. Choose Paste Remembers Layers from 
the Layers panel menu. If there is a check 
mark next to the command, then it is 
already turned on.

2. Drag and drop or copy and paste the 
items from one document into a second 
document. New layers are created in the 
second document as follows  C .
 • The layers from the first document are 

added as new layers if they do not have 
the same name as the layers in the 
second document.

 • The layers from the first document are 
merged with the layers if they have 
the same name as layers in the second 
document.

TIPTIP If Paste Remembers Layers is turned off, the 
items are pasted onto the active layer in the 
second document.

As you work, you may want to delete a layer. 
This also deletes all objects on the layer.

To delete a layer:

1. Select the layer you want to delete.

TIPTIP Shift-click to select multiple layers.

2. Click the Delete Layer icon. If there are 
items on the layer an alert box appears  D .

TIPTIP Opt/Alt-click the Delete Layer icon to bypass 
the alert box.

You can quickly delete layers with no objects.

To delete all unused layers:

Choose Delete Unused layers from the 
Layers panel menu.

 D  An alert dialog box makes sure you 
don’t inadvertently delete artwork 
when you delete a layer.

 C  The Paste Remembers Layers 

command adds new layers when objects 
are pasted from one document to another.

Before paste

After paste
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Setting the Layer Options

The Layer Options dialog box contains some 
housekeeping options that make it easier to 
organize and work with layers  A .

To name a layer:

Use the Name field to name the layer.

TIP If you have many layers, you should use 
descriptive names instead of the default 
names Layer  1, Layer  2 , etc.

Each layer has a color associated with it. This 
is the color used to highlight object frames 
and paths.

To set the highlight color for a layer:

Choose a color from one of the  37  colors 
in the Color list  B .

TIP Each new layer is automatically assigned the 
next color in the Color list. This means you 
can have  37  layers without ever repeating 
a color.

TIP Select Custom to choose your own color for 
a layer.

Layers help you organize your documents. 
For instance, if you lock a layer you lock all the 
objects, so they cannot be selected, moved, 
modifi ed, or deleted.

To lock a layer:

Choose Lock Layer from the Layer Options 
dialog box.
or
Click the Toggle Lock space in the Layers 
panel  C . A padlock indicates that the layer 
is locked. A blank space indicates the layer 
is unlocked.

TIP Use the Lock Others command from the 
Layers panel menu or Opt/Alt-click the Toggle 
Lock space in one layer to lock all the other 
layers in the document  D .

 A  The Layer Options dialog box 
is the command center for all 
the attributes of a layer.

 D  Opt/Alt-click the Toggle Lock space to 
lock all the other layers in the document.

 B  The Color list contains all the 
choices for highlighting objects.

 C  Click the Toggle Lock space to 
lock the layer. The spotlighted icons 
indicate that the layer is locked.
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To prevent a layer from printing:

Deselect Print Layer from the Layer 
Options dialog box.

TIPTIP A layer set to not print is displayed in italic 
letters in the Layers panel.

You can also use layers to hide and show the 
information on the layer. This can make it 
easy to focus on certain information.

TIPTIP Hidden layers automatically do not print.

To hide a layer:

Deselect Show Layer from the Layer 
Options dialog box.
or
Click the Toggle Visibility space in the 
Layers panel so that the space is blank  E . 
When the space is blank, the layer is 
invisible.

TIPTIP You cannot work on invisible layers.

TIPTIP Use the Hide Others command from the 
Layers panel menu or Opt/Alt-click the Toggle 
Visibility space in one layer to hide all the 
other layers in the document  F .

To show a layer:

Select Show Layer from the Layer Options 
dialog box.
or
Click the Toggle Visibility space in the 
Layers panel. When the eyeball is visible, 
the layer is visible.

 E   Click the Toggle Visibility space  
to hide or show the layer.

 F   Opt/Alt-click the Toggle Visibility  space to 
hide all the other layers in the document.
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To control the visibility of guides on a layer:

1. Choose Show Guides in the Layer Options 
dialog box to display the guides for that 
layer.

2. Choose Lock Guides to protect the guides 
on the layer from being changed.

Although hidden layers don’t print, they still 
can aff ect other objects on the page. The 
Layer Options dialog box contains the Sup-
press Text Wrap When Layer Is Hidden setting, 
which controls what happens if you turn off  
the visibility for a layer that has a text wrap 
applied to images  A .

To control the text wrap for hidden layers:

1. Apply a text wrap to an image that is on 
one layer.

2. Create text that is on another layer  B .
3. Set the Layer Options dialog box as 

follows:
 • Turn off Suppress Text Wrap When 

Layer Is Hidden to maintain the text 
wrap when the layer is not visible  C .

 • Turn on Suppress Text Wrap When 
Layer Is Hidden to discard the text wrap 
when the layer is not visible  D .

 B  An image with a text wrap is placed on one 
layer aff ecting the text on another layer.

 C  When the layer is hidden, the wrap 
continues to aff ect text when the 
Suppress Text Wrap option is turned off .

 A  The  Suppress Text Wrap When Layer Is 
Hidden option  controls what happens 
to the text wrap for hidden layers.

 D  When the layer is hidden, the wrap 
does not aff ect text when the Suppress 
Text Wrap option is turned on.
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Working with Layers

Once you’ve created additional layers in your 
document, you can move objects onto the 
new layers.

To apply objects to layers:

Click the layer in the Layers panel so 
that it’s highlighted, and then create the 
object.

You can use the Layers panel to move the 
object between layers.

To move objects from one layer to another:

1. Select the object. A square object proxy 
appears next to the name of the layer in 
the Layers panel.

2. Drag the object proxy from one layer to 
another  E . This moves the object to a new 
layer.

TIPTIP Hold the Opt/Alt key as you drag the proxy to 
create a copy of the object on the new layer  F . 
The original object stays on its layer.

To reorder layers:

Drag one layer above or below another to 
change the order in which objects appear 
in the document  G .

 E  Drag the proxy square to move an 
object from one layer to another.

 F  Hold the Opt/Alt key as you drag 
the proxy square to  copy an object 
from one layer to another .

 G  Drag a layer up or down in the Layers 
panel to  change the order of the layers .
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If you have many layers in your document, 
you may want to combine several layers 
together to make it easier to work with the 
layers. This is called merging layers.

To merge layers:

1. Select the layer that you want the other 
layers to merge onto  A .

2. Select the other layers that you want to 
merge.

TIPTIP This order is important. The first layer chosen 
is the layer that will remain after the merge.

3. Choose Merge Layers from the Layers 
panel menu. The items on the layers are 
combined into a single layer  B .

Nobody likes empty boxes and cartons 
taking up space in a cupboard or refrigerator. 
Similarly, it’s confusing to have layers without 
content in a document. Fortunately, it is easy 
to delete empty layers.

To delete unused layers:

Choose Delete Unused Layers from the 
Layers panel menu. InDesign finds all 
empty layers and deletes them.

So What About Photoshop, Illustrator, and Acrobat Layers?

“Hey, Sandee, didn’t I see you speak at a conference and say that InDesign can show and hide the layers from 
Photoshop, Illustrator, and Acrobat files? How come you’re not covering that topic in this chapter?”

You’re right. InDesign does let you change the visibility of layers in those types of placed graphics. But the 
layers in those graphics aren’t controlled using the Layers panel. They’re shown and hidden using the Image 
Import Options when you first place the graphic, or later, in the Object Layer Options. (See Chapter 6, “Fills, 
Strokes, and Effects,” for how to control the layers in placed files.)

 B  The result of  merging two layers . 
Notice that the Circles layer remains 
and the other layer has been deleted.

 A  Select two or more layers to be merged. 
Here, the Circles layer was chosen fi rst.
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 C  You can  view the contents of a 
layer or a group  by opening the 
triangle next to the layer name.

 D  Click the  proxy square for a layer  to 
select all the items on that layer.

 E  When you select items on a layer, the proxy 
squares next to those items are highlighted.

Layer Contents

You can see the objects on a layer by look-
ing at the page. But you can also see which 
objects are on each layer by opening the 
contents of the layer in the Layers panel.

To view the contents of a layer:

Click the triangle “twisty” for that layer so 
that the triangle points down. This reveals 
the items on that layer.

To view the contents of a group:

Click the triangle “twisty” for the group so 
that the triangle points down. This reveals 
the items in that group  C .

TIPTIP You can select and delete an item in a group 
by selecting its proxy square and then 
deleting the item.

You can also use the Layers panel to select 
specifi c items on a layer or all the items on 
a layer.

To select all the items on a layer:

Click the proxy square placeholder to the 
right of the layer name. This selects all the 
items on that layer  D . The proxy squares 
are highlighted with the color assigned 
for that layer  E .

TIPTIP If the layer contents are visible, the proxy 
squares for each of the items will also be 
highlighted.

To select specifi c items on a layer:

1. Open the layer triangle to view its 
contents.

2. Click the proxy square placeholder to the 
right of the name of the item. This selects 
all the items on that layer.
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Items on the page are named with generic 
names such as rectangle, group, or the name 
of the graphic. You can name the groups or 
items within a layer. This makes it easier to 
identify items on the layer.

To change the name of an item in the 
Layers panel:

1. Use a single click to select the object in 
the Layers panel.

2. With the object still selected, click the 
name of the object. This reveals the field 
for the name  A .

3. Type the new name for the object.
4. Press the Return key to apply the name.

Just as you can change the order, delete, lock, 
and hide layers, you can do the same with the 
items on the layer.

To rearrange an item on a layer:

Drag the item from one position to 
another within the Layers panel  B . 
Objects at the top of the panel are in front 
of other objects in the document.

TIP Hold the Opt/Alt key as you drag to create a 
copy of the item.

To lock an item on a layer:

Click the lock area next to the item on the 
layer  C . This locks the item.

TIP You can also use this technique to unlock a 
single item. This is very useful if you don’t 
want to have to unlock all the items on a 
spread.

To hide an item on a layer:

Click the visibility icon next to the item on 
the layer  C . This hides the item.

To delete an item on a layer:

Drag the item from the list into the Layer 
trash icon  D . This deletes the item.

 A  Click to  highlight and rename  
an item in the Layers panel.

 C  A  hidden object and a locked 
object  on a layer.

 D  Drag  to delete an object 
from the document .

 B  Drag  to move an object above 
others or to another layer .
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Libraries and Snippets
Back when I worked in advertising, I 

noticed that the art directors would 
stick little bits and pieces of type and 
logos on their mechanical board, draft-
ing table, lamp, and wall. This made it 
easy to grab an often-used logo or piece 
of art to insert into a layout. 

Similarly, when you work with electronic 
page layouts, you use certain elements 
over and over. For instance, if you’re 
working on a magazine, you might 
want to have a series of diff erent-sized 
frames to hold frequently used ads.

Rather than copying and pasting the 
frames from one part of the document 
to another, you can use InDesign’s librar-
ies or snippets to hold the elements you 
use repeatedly.

Then, when you need to use an item 
from the library or the saved snippet fi le, 
you can simply drag it onto the page.
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Storing Items in a Library

A library allows you to store elements, such as 
text frames, images, or empty frames. When 
elements are in a library, they can be dragged 
easily into open documents. Libraries are 
especially useful when you need to use the 
same element in many diff erent places.

TIP Libraries appear as panels that float above 
the open InDesign documents. Libraries are 
available to use with any InDesign document.

To create a library:

1. Choose File > New > Library. This opens 
the New Library dialog box.

2. Use this dialog box to name the library 
file and select its location.

TIP The name of the library file appears in the tab 
of the Library panel.

3. Click Save. The library appears as a 
floating panel  A .

To add items to a library:

1. With a library open, select the item you 
want to insert in it.

2. Click the Add Item button at the bottom 
of the Library panel.
or
Drag the item into the library  B . The item 
appears in the Library panel.
or
Choose Add Item from the Library panel 
menu  C .

TIP Multiple objects are always entered as a 
single library item. If you want individual 
objects, you need to select and add them to 
the library one by one.

 A  A  new Library panel  does 
not contain any items.

Add Item 

Delete Item

Item Information Show Subset

 C  The  Library panel menu  contains the 
commands for working with a library.

 B  You can  add items to a library  by dragging 
them from the page into the Library panel.
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You can also add all the items on the current 
page to a library.

To add a page to a library:

1. With a library open, move to the page you 
want to add to the library.

2. Choose Add Items on Page [number] from 
the Library panel submenu.

TIPTIP The Add Items on Page [number] command 
automatically labels the entry as a single 
page in the Library Item Information 
dialog box.

Instead of the Add Items on Page [number] 
command, you may want to add all the items 
on a page as individual library entries. Instead 
of dragging them one by one into the Library 
panel, you can add the items as separate 
elements.

To add all the items on a page separately:

1. With a library open, move to the page 
that contains all the items that you want 
to add to the library.

2. Choose Add Items on Page [number] as 
Separate Objects from the Library panel 
menu.

To delete items from a library:

1. Select the item in the library.
2. Click the Delete Item icon.

or
Choose Delete Item(s) from the Library 
panel menu.

3. A dialog box appears asking for confir-
mation that you want to delete the items. 
Click Yes.

TIPTIP Hold the Opt/Alt key to bypass the dialog box 
when you delete a library item.

Strategies for Using Libraries

Libraries can be used in many different ways. 
I used to use libraries to store items that I use 
often in a document.

For instance, I used to have one library labeled  
IDVQS for my Visual QuickStart books. One of 
the elements was a graphic frame with a text 
frame underneath. I used to drag that out for 
the illustrations and captions.

Other elements are the empty circles, lines, and 
curved arrows I use to point to elements in the 
figures.

Another element is a gray text frame with a 
stroke around it. I used to drag it out when I 
wrote sidebars such as this.

See the sidebar on page 321 for why I have aban-
doned libaries and switched to snippets.
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Applying Library Items to a 

Page

Libraries can be opened and the elements 
in the libraries dragged onto any InDesign 
documents.

To add library items to a document:

1. Select the item in the library.

TIP Shift-click to select multiple contiguous 
entries in the Library panel.

TIP Cmd/Ctrl-click to select multiple non-
contiguous entries in the Library panel.

2. Drag the items from the library onto the 
page  A .
or
Choose Place Item(s) from the Library 
panel menu.

TIP The Place Item(s) command adds the library 
item in the same position it was in when first 
defined.

You may want to modify an item in a library 
with a new object, text, or image. The Update 
Library Item command makes this easy to do.

To update an item in a library:

1. Select the item on the page that you want 
to use as the replacement in the library.

2. Select the item in the library that needs to 
be updated.

3. Choose Update Library Item from the 
Library panel menu. The library thumbnail 
updates to display the new item.

 A  Items can be dragged from a 
library onto a document.

Libraries in the Bridge

Libraries appear in the Adobe Bridge as icons, 
not previewed documents.

Library icons can be opened through the Bridge 
as you would any InDesign file.

Although you can add descriptions to the items 
in a library, the library items in the Adobe Bridge 
cannot have keywords or other XMP metadata 
applied to them.
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Setting the Library Display

If you have many items in a library, you may 
want to change how the items are displayed.

To change the library display:

Choose List View in the Library panel 
menu to see the item name and an icon 
that indicates the type of item  B .
or
Choose Thumbnail View or Large 
Thumbnail View to see the name and a 
preview of the item  C .

You can also add information such as fi le type 
and keywords that makes it easy to search for 
library entries.

To modify the library item information:

1. Select the item.
2. Click the Library Item Information icon.

or
Choose Item Information from the 
Library panel menu. This opens the Item 
Information dialog box  D .

3. Enter the name in the Item Name field.
4. Use the Object Type list to choose one of 

following categories  E :
 • Image contains raster images.
 • EPS contains EPSEPS files.
 • PDF contains PDF files.
 • Geometry includes frames and rules 

that do not contain images or text.
 • Page is an entire page.
 • Text contains text frames.
 • Structure contains XMLXML elements.
 • InDesign File contains InDesign files.

TIPTIP InDesign assigns a category when items are 
entered into a library. You can change that 
listing to any category you want.

5. Enter a description for the item.

 C  The  Thumbnail View  shows the name 
of the item and a preview of the item.

 D  The  Item Information dialog box  
lets you change the information 
assigned to each item.

 E  Use the  Object Type list  to apply 
a label for the library element.

 B  The  List View  shows the name of the item 
and an icon that shows the type of item.

EPS icon

Text icon

PDF icon

Geometry icon

Page icon

Image icon

Structure icon

InDesign icon
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Searching and Sorting 

Libraries

If you have many items in a library, you may 
fi nd it diffi  cult to fi nd specifi c library entries. 
InDesign has a powerful search feature that 
makes it easy to locate specifi c items in a 
library.

To search within a library:

1. Click the Show Library Subset icon.
or
Choose Show Subset from the Library 
panel menu. This opens the Subset dialog 
box  A .

2. Choose Search Entire Library to search all 
entries in the library  B .
or
Choose Search Currently Shown Items to 
search through only those items currently 
displayed in the library.

3. Use the Parameters menu and fields to set 
the search criteria  C .

4. Click More Choices to add up to five 
choices to the parameters list.

5. Choose Match All to choose only 
those items that match all the search 
parameters  D .
or
Choose Match Any One to find items 
that meet at least one of the search 
parameters.

6. Click OK to display the items that meet the 
search criteria.

TIP Use the Back or Forward button to move 
through the search settings in the Subset 
dialog box.

 A  The  Subset dialog box  lets you 
fi nd specifi c library items.

 C  The  Parameters menu  lets you 
choose which part of the item 
information is searched.

 D  The  match criteria  in the Subset dialog box 
control how the search items are matched.

 B  The  search criteria in the Subset 
dialog box  let you specify where 
to search in the library.
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Once you have sorted a library, you may need 
to show all the items at some other time.

To display all the library entries:

Choose Show All from the Library panel 
submenu.

You can also control the order in which the 
library items are displayed. This makes it 
easier to fi nd items in large libraries.

To sort library entries:

Choose one of the Sort Items options 
from the Library panel menu:
 • By Name arranges the items in 

alphabetical order.
 • By Newest arranges the items in 

the order they were added, with the 
newest items first.

 • By Oldest arranges the items in the 
order they were added, with the oldest 
items first.

 • By Type arranges the items in groups 
according to their categories.

 Libraries or Snippets?

As you read about libraries and snippets you 
may wonder which one you should use. I agree 
that the two features are very similar. But I have 
noticed a few significant differences.

Libraries can hold hundreds, if not thousands 
of items, and can be sorted using sophisticated 
sorting commands. 

Unlike library items, snippets can be dragged 
from the Bridge onto an InDesign document and 
can be set to appear on the page in exactly the 
same spot where they originated. Library items 
cannot be dragged onto the page in the same 
position. They must be added using the Place 
command.

Also, snippets have smaller file sizes than librar-
ies. Snippets should be used when you need to 
save just a few items from a page.

You can see a preview of the elements in snip-
pets in Bridge. Libraries only show the document 
icon.

For these reasons I recommend storing snippets 
in folders and searching for specific snippets by 
using Bridge or Mini Bridge.

But not only that, snippets have a more fun 
name. I like reading the word snippets. I like 
writing the word snippets. I like saying the word 
snippets! Snippets make me happy.
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Creating and Using Snippets

Snippets are exactly what they sound 
like — little bits of a page that you snip off  to 
use somewhere else. 

To create snippets using the Export 
command:

1. Select the items on the page that you 
want to turn into a snippet.

2. Choose File > Export.
3. In the Export dialog box choose InDesign 

Snippet from the Format list  A .

TIP You cannot drag portions of text as a snippet, 
only the entire frame.

4. Name and save the file. The snippet icon 
appears in the directory.

To create snippets by dragging:

1. Select and drag the items that you want 
to turn into a snippet onto the desktop. 
The Snippet icon appears with a bizarre 
temporary name.

2. Change the name to something more 
understandable.

Once you have created snippets, you can drag 
them onto a page.

To drag snippets onto a page:

1. Select the snippet on the desktop or in 
the file directory.

2. Drag the Snippet icon onto the InDesign 
document page. 

TIP Use the Snippet Import setting in the 
Preferences > File Handling dialog box to 
choose whether the snippet appears at its 
original coordinates or the cursor position  B .

TIP Snippets can be previewed in Bridge or Mini 
Bridge and dragged onto an InDesign page.

 A  The  Export dialog box  lets you 
save items as InDesign snippets.

 B  The  Snippet Import setting  in the File 
Handling Preferences lets you control where 
snippets appear when dragged onto a page.



Before layouts had tabs and tables, 
there was chaos. Well, perhaps not 

chaos, but it was diffi  cult to line up col-
umns of text in an orderly fashion.

The word “tab” comes from the tabula-
tor key on a typewriter. (Does anyone 
still use a typewriter?) The tabulator key 
moved the carriage a certain number of 
spaces.

The tabulator key was named because 
it allowed typists to create tabular data. 
Tabular data is information arranged in 
systematic rows and columns — other-
wise known as a table.

However, mathematical information 
isn’t the only thing arranged in tables. 
Résumés, menus, train schedules, cal-
endars, and even classifi ed ads are all 
arranged in some form of table.

Anytime you need to keep text or 
graphics aligned in either columns or 
rows, consider using the tabs and tables 
features in InDesign.

Not only can you align text using tabs, 
but you can create tab leaders that 
make it easy to read across the lines 
of text. You can also create tables with 
repeating headers and footers and add 
custom strokes and fi lls to the tables.
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Inserting Tab Characters

There are two parts to working with tabs. The 
fi rst part is to insert the tab characters that 
force the text to jump to a certain position. 

To insert tab characters into text:

1. Position the insertion point where you 
want the tab character to be located.

2. Press the Tab key on the keyboard. This 
creates a tab character in the text  A .

TIPTIP Choose Type > Show Hidden Characters to 
see the display of the tab character within 
the text.

TIPTIP InDesign recognizes tab characters in 
imported text.

InDesign also has a special type of tab charac-
ter called a right indent tab. This tab character 
automatically sets the text to the rightmost 
position in the frame  B .

To insert a right indent tab character:

1. Place the insertion point to the left of the 
text that should be shifted to the right.

2. Press Shift-Tab or choose Type > Insert 
Special Charcter > Other > Right 
Indent Tab.

Inserting Tabs in Text

It’s actually very simple to insert a tab character 
into text. Just tap the Tab key on the keyboard. 
However, before you go tapping away, you 
should follow the guides for working with tabs.

Insert only one tab character for each column. 
Even if the text doesn’t line up correctly, don’t 
add another tab character. Use the Tab panel 
and tab stops to line up the columns.

If you’re over a certain age, you may have 
been taught to put a tab at the beginning of 
a paragraph to indent the first line. Don’t do it! 
As mentioned in Chapter 3, “Basic Text,” you can 
use the first line indent to format paragraphs.

 A  A  tab character  is displayed as part 
of the hidden characters in text.

 B  The  right indent tab character  
automatically moves the text to 
the right side of the text frame.
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Setting Tab Stops

The next — and most important — part to 
working with tabs is to set the tab stops or 
the formatting controls that set where the 
text should stop after it jumps to a new posi-
tion. This is controlled using the Tabs panel.

To open the Tabs panel:

Choose Type > Tabs. The Tabs panel 
appears above the text frame  C .

TIPTIP The Tabs panel can be kept onscreen like any 
other panel.

TIPTIP If the Tabs panel is not positioned above the 
text, click the Magnet icon in the panel to 
automatically move the panel to the correct 
position.

To set tab stops:

1. Select the text.
2. Choose the type of tab alignment from 

the four tab icons in the ruler  D . The four 
alignments work as follows  E :
 • Left aligns the left side of the text at 

the tab stop.
 • Center centers the text on either side 

of the tab stop.
 • Right aligns the right side of the text at 

the tab stop.
 • Decimal aligns the text at the decimal 

point or period within the text.
3. Click the ruler area where you want the 

tab stop to be positioned. Or type a 
number in the X position field. A small 
tab arrow corresponding to the tab type 
appears that indicates the position of the 
tab stop.

TIPTIP The default tab stops are invisible left-aligned 
tabs positioned every half inch. Adding a tab 
stop to the ruler overrides all tab stops to the 
left of the new tab.

 C  The  Tabs panel  contains the controls for 
inserting tab stops and aligning the tabs.

X position field Magnet

 D  Choose one of the  four tab alignment 
icons  to control how the text is aligned.

Left Right

Center Decimal

 E  Examples of  how the four tab 
alignments  control the text.

LeftRight Center Decimal
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To change tab settings:

1. Select the text.
2. Open the Tabs panel.
3. To change the alignment of a tab stop, 

select the tab arrow and then click a new 
alignment icon. Or hold the Opt/Alt key 
and click the tab arrow in the ruler.

4. To change the position of a tab stop, drag 
the tab arrow to a new position.

TIP As you move a tab stop along the ruler, a 
line extends through the text, even if the 
Tabs panel is not aligned to the text frame  A . 
Watch for this line to help judge the position 
of the tab stop.

Many times you will want to have tab stops 
repeated at the same interval. InDesign 
makes it easy to set repeating tabs.

To set a repeating tab:

1. Position the first tab stop on the ruler.
2. With the tab stop still selected, choose 

Repeat Tab from the Tabs panel menu  B . 
This adds new tab stops at the same 
interval along the ruler  C .

TIP The tab stops created by the Repeat 
Tab command are not linked and move 
independently.  C  The  Repeat Tab command  allows 

you to easily add tab stops at the 
same interval along the ruler.

 B  The  Tabs panel menu  gives you several 
important commands for working with tabs.

 A  As you move a tab stop,  a line 
extends through the text  to help 
you position the tab stop correctly.
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Once you have added tab stops to the Tabs 
panel ruler, you can remove them easily.

To remove tab stops:

1. Select the tab stop on the Tabs panel 
ruler.

2. Drag the tab stop off the ruler. This 
deletes the tab stop  D . Or choose Delete 
Tab from the Tab panel menu.

TIPTIP If there are no tab stops to the left of the 
one you removed, this restores the invisible 
default tab stops at the nearest half-inch 
position.

If you have many tab stops on the Tabs panel 
ruler, it may be easier to delete all the tab 
stops with a single command.

To clear all the tabs off  the ruler:

Choose Clear All from the Tabs panel 
menu. This restores the invisible default 
tab stops at every half-inch mark.

The Decimal tab aligns numerical data to 
a decimal point. However, you may need 
to align text to a diff erent character. For 
instance, some European currency uses a 
comma instead of a decimal. InDesign lets 
you set a custom alignment character.

To set a custom alignment character:

1. Choose the Decimal Tab icon.
2. Add a tab stop to the ruler.
3. Replace the period in the Align On field 

with a different character. The text aligns 
around that character  E .

 E  You can enter a custom alignment 
character for the Align On fi eld. Here 
the text aligns to the hyphen.

 D  To  remove a tab stop,  drag it 
off  the Tabs panel ruler.
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Creating Tab Leaders

A tab leader allows you to automatically fi ll 
the space between the tabbed material with 
a repeating character. Tab leaders are often 
used in the tables of contents of books. You’ll 
fi nd an example of tab leaders in the table of 
contents at the front of this book. 

TIP Tab leaders are added when the reader needs 
to move horizontally across a wide column 
from one entry to another. The tab leader 
helps the reader’s eye stay on the correct line 
of text. There’s no need to insert tab leaders if 
the line of text is not wide.

To add tab leaders:

1. Select the tab stop arrow on the Tabs 
panel ruler.

2. Click inside the Leader field of the Tabs 
panel and type up to eight characters. 
This changes the white space between 
the text to a repeating leader character.

TIP I often add spaces to the period character 
in the Leader field to give the leader a more 
pleasing look  A .

TIP If you want to preview the characters in 
the Leader field, press the Tab key on the 
keyboard. This applies the changes.

TIP You can select the characters in a tab leader 
as you would ordinary text and change the 
point size, kerning, or other attributes.

 A  An example of  adding spaces 
to separate the tab leader .

Choosing Between Tabs and Tables

For the longest time, designers wanted a way to 
create tables in page-layout documents. But the 
programs didn’t provide tables. So we suffered 
with multiple frames linked together in strange 
groups. When InDesign first introduced tables, 
many designers wondered if there was any 
reason to still use tabs.

Absolutely! I use tabs in this book to separate 
numbers from the text in the exercises. I also use 
tabs with leaders for the listings in the table of 
contents.

I use tables whenever I need side-by-side para-
graphs, such as in a résumé. I also use tables 
whenever I need to separate the information 
with horizontal and vertical lines.
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Creating and Using Tables

Tabs are limited to lining up only a single line 
of text. Tables can line up text so it extends 
down into several lines. Tables also let you 
add borders to the cell that contains the text 
or add fi lls of color behind the text.

To create a new table in a text frame:

1. Place an insertion point inside a text 
frame.

2. Choose Table > Insert Table. The Insert 
Table dialog box appears  B .

3. Use the Body Rows control to set the 
number of rows in the table.

4. Use the Columns control to set the 
number of columns.

5. Use the Header Rows control to set the 
number of rows across the top of the 
table.

6. Use the Footer Rows control to set the 
number of rows across the bottom of the 
table.

7. If you have defined a table style, use the 
Table Style list to choose that style for the 
table.

8. Click OK. InDesign creates a table that fills 
the text frame as follows:
 • The width of the table is set to fill the 

width of the text frame.
 • The table columns are distributed 

evenly across the table.

TIPTIP Headers and footers are special cells that are 
repeated when the table is divided between 
frames or pages. 

 B  Use the  Insert Table dialog box  to 
create an empty table in a text frame.

Table and Cell Styles

As you read through the rest of this chapter, you 
may feel that it’s too much work to create and 
format tables and the cells within tables. Relax, 
InDesign has powerful table and cell styles 
which make it easy to create very sophisticated-
looking tables with just a few clicks.

However, rather than totally overwhelm you in 
this chapter, I’ll cover the styles for tables and 
cells in Chapter 15, “Styles.” 

So, as you go through this chapter, consider this 
the part where you learn to bake bread from 
scratch. Later on I’ll show you how to automate 
the whole process.
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Many times you will import text that you’d 
like to convert into a table. Fortunately, this is 
rather easy to do.

To convert text into a table:

1. Select the text.
2. Choose Table > Convert Text to Table. 

The Convert Text to Table dialog box 
appears  A .

3. Use the Column Separator menu to 
choose which character should be used as 
the marker for each column in the table. 
Or type the character that you would like 
as the marker in the Column Separator 
field.

TIP If you have imported tabbed delimited text, 
the marker is most likely a tab character. 
However, some databases will use paragraph 
returns or spaces as the column separators.

4. Use the Row Separator menu to choose 
which character should be used as the 
marker for each row in the table. Or type 
the character that you would like as the 
marker in the Row Separator field.

TIP For most text, the row separator is the 
paragraph symbol.

5. If you have chosen anything except a 
paragraph symbol for the Row Separator, 
use the Number of Columns field to 
choose how many columns there should 
be in the table.

6. If you have defined a table style, use the 
Table Style list to choose that style for the 
table.

7. Click OK to create the table  B .

 B  The  Convert Text to Table command 
 transforms tabs and paragraphs 
into rows and columns.

 A  The  Convert Text to Table dialog box  lets 
you choose how text is converted to a table.
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What if you’ve already got a beautiful table, 
and some tabbed text, but they’re separated 
from each other? InDesign lets you paste 
tabbed text into existing tables.

To paste text into a table:

1. Copy the tabbed text.
2. Highlight the cells in the table where you 

want the text to appear.
3. Choose Paste. The text will populate the 

cells of the table and make additional 
table cells if necessary.

Most people use Micro soft Word and Excel to 
create text and spreadsheets. InDesign lets 
you import the tables created by both Word 
and Excel.

To import a table from Word or Excel:

1. Choose File > Place and navigate to the 
Word or Excel file that you want to insert 
into your document.

2. If necessary, use the Microsoft Excel 
Import Options  C  or the Microsoft 
Word Import Options  D  to control how 
the file will be imported, as described on 
the next two pages. Click OKOK to close the 
Import Options dialog box.

3. Use the loaded text cursor to draw a text 
frame with the imported document. Or 
use any of the techniques described in 
Chapter 10 to flow the text onto the pages 
of the document.

 C  The  Microsoft Excel Import Options dialog 
box  lets you choose which worksheet and 
cells are imported from an Excel document.

 D  The  Microsoft Word Import Options dialog 
box  lets you choose how Word tables are 
imported into the InDesign document.
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You can also customize which Excel data is 
imported.

To choose the cells that should be 
imported:

1. Use the Sheet menu to select a 
worksheet.

2. Use the View menu to choose a custom 
view.

3. Use the Cell Range field to select cells.
4. If desired, select the Import Hidden Cells 

Not Saved in View checkbox.

To set the formatting for Excel cells:

1. Use the Table menu to change the 
formatting options as follows:
 • Formatted Table imports the cells with 

whatever formatting was applied in 
Excel.

 • Unformatted Table imports the cells 
with no formatting except a stroke 
around each InDesign cell.

 • Unformatted Tabbed Text converts the 
cells into text divided by tab characters.

2. If you have defined a table style, choose 
one from the Table Style list.

3. Use the Cell Alignment menu to choose:
 • Current Spreadsheet imports the text 

with the alignment that was set in the 
spreadsheet.

 • Left sets the text aligned to the 
left side.

 • Center aligns the text to the center.
 • Right sets the text aligned to the right.

4. Use Number of Decimal Places to Include 
to set how many decimal places are 
included in the imported cells.

5. If desired, select Use Typographer’s 
Quotes to convert straight "quotes" 
(like these) into open and close 
“quotes” (like these).

Importing from Spreadsheets

Most likely, if you need to import data from 
Excel spreadsheets, the files have been created 
by accountants or others who know little about 
graphic design or page layout.

Try to talk to them before they send you the file 
for layout. Explain that they should not format 
their document using the controls in Microsoft 
Excel. Most of the time you will just have to 
strip out that formatting in order to make the 
file work in your layout.

You may also want to ask them for a test file 
so you can see how the information will be 
imported.
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You can also control how table information in 
Word documents is imported.

To set the formatting for Word tables:

1. Select Remove Styles and Formatting 
from Text and Tables in the Microsoft 
Word Import Options dialog box to 
change the original formatting applied in 
Word.

TIPTIP Use this option to remove some of the 
hideous formatting that may have been 
applied to Word tables. 

2. If you have set the option to remove the 
formatting, choose one of the following 
from the Convert Tables To menu:
 • Unformatted Tables imports the Word 

table with no formatting except a 
stroke around each cell.

 • Unformatted Tabbed Text converts the 
cells into text divided by tab characters.

To place a table in a table cell:

1. Click with the Text tool to place an 
insertion point inside a table cell.

2. Use the Insert Table command or a Place 
command to create a table within that 
cell  A .

To convert a table to text:

1. Place an insertion point in any cell inside 
the table.

2. Choose Table > Convert Table to Text.
3. Use the Convert Table to Text dialog 

box to choose what elements should be 
used to designate the column and row 
separators  B :
 • You can convert columns and rows to 

tabs, commas, or paragraph returns. 
 • You can type your own character in the 

field to customize the conversion.

 A  An example of how a table can be 
inserted inside a cell of another table.

 B  The  Convert Table to Text command  
trans forms table rows and columns 
into tabs and paragraph returns.
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Navigating Through Tables

As you work with tables, you will want to add 
content to the cells, move from cell to cell, 
and select cells, rows, and columns.

To insert text into table cells:

1. Place an insertion point inside a table cell.
2. Type the text for the cell or choose 

File > Place to insert the imported text in 
the cell.

To move from one cell to another:

Press the Tab key to jump forward from 
one cell to another  A  or press Shift-Tab 
to move backward from one cell to 
another  B .

Because you use the tab key to navigate 
through a table, you need special techniques 
to insert actual tab characters into a table.

To insert a tab character into a table:

Press Opt/Alt-Tab to insert a tab character 
inside a cell  C  or choose Type > Insert 
Special Character > Tab Character.

To jump to a specifi c row:

1. Choose Table > Go to Row. The Go to Row 
dialog box appears  D .

2. Use the menu to move to the body, 
header, or footer of the table.

3. Enter the number for the row you want to 
move to.

 D  The  Go to Row dialog box  lets you 
quickly jump from one row to another.

 A  Press the Tab key to  jump forward 
from one cell to another  in a table.

 B  Press Shift-Tab to  jump backward 
from one cell to another  in a table.

 C  Press  Opt/Alt-Tab to insert a 
tab character  into a table.
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Selecting Tables

By clicking and dragging your cursor, you can 
select cells, columns, rows, or the entire table.

TIPTIP When the entire cell, row, column, or 
combination of cells are selected, you can 
copy and paste cells from one part of a table 
to another.

To select text in a table cell:

1. Place an insertion point inside a table cell.
2. Drag across the cell until all the text in the 

cell is highlighted.
or
Choose Edit > Select All to select all the 
text within that cell.

TIPTIP There is a difference between the highlight 
of a cell with just the text selected and the 
highlight with an entire cell selected  E .

To select text in multiple table cells:

1. Use the Text tool to drag across to select 
the cells in specific columns  F .

2. If you want, continue to drag down to 
select the cells in additional rows.

To select a table column:

1. Place the Text tool cursor at the top of the 
table. A down arrow cursor appears.

2. Click the down arrow. The entire column 
is selected  G .

3. Drag across with the down arrow cursor 
to select any additional columns or move 
the down arrow to another column and 
Shift-click to select multiple columns. 

 F  Drag across and then down to select 
a specifi c group of cells in a table.

 E  When the text in a cell is selected, only the 
text is highlighted. When the entire cell is 
selected, the entire cell area is highlighted.

Text only selected

Cell selected

 G   Drag with the down arrow cursor  
to select columns in a table.
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To select a table row:

1. Place the Text tool cursor at the left side 
of the table. A left arrow cursor appears.

2. Click the left arrow. The entire row is 
selected  A .

3. Drag down with the left arrow cursor to 
select any additional rows or move the 
left arrow to another row and Shift-click 
to select multiple rows.

To select the entire table:

1. Place the Text tool cursor at the top 
corner of the table. A slanted arrow cursor 
appears.

2. Click the slanted arrow. The entire table is 
selected  B .

To use the table selection commands:

1. Place the insertion point in a cell in the 
table.

2. Choose one of the following commands:
 • Table > Select > Cell selects the cell.
 • Table > Select > Row selects the row 

that contains the cell.
 • Table > Select > Column selects the 

column that contains the cell.
 • Table > Select > Table selects the entire 

table.

TIP The table selection commands are helpful for 
applying borders and fills to cells.

 B  Position the cursor at the upper-left corner 
and click to  select the entire table .

 A  The left arrow cursor indicates you can 
click to select an entire row in a table.
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Working with Rows and 

Columns

Once you’ve created a table, you may want to 
change the number of rows and columns in 
the table.

TIPTIP In addition to the Table menu and dialog 
boxes, many adjustments to tables can be 
made using the Table panel or Control panel. 
(See the section “Using the Table or Control 
Panels” at the end of this chapter for more 
information on modifying tables with those 
onscreen elements.)

To change the number of rows and columns 
in a table:

1. Select the entire table or any part of the 
table. 

2. Choose Table > Table Options > Table 
Setup to open the Table Setup dialog 
box  C .

3. Set the Body Rows controls in the Table 
Dimensions area to increase or decrease 
the number of rows in the main section of 
the table  D .

4. Set the Header Rows controls to increase 
or decrease the number of rows in the 
header section of the table  D . 

5. Set the Columns controls to increase or 
decrease the number of columns in the 
table  D .

6. Set the Footer Rows controls to increase 
or decrease the number of rows in the 
footer section of the table  D . 

TIPTIP Use the Preview control at the bottom of the 
Table Setup dialog box to see the results of 
changing the controls.

TIPTIP The commands in the Table Dimensions 
section always add rows and columns at the 
end of the table sections. The next exercise 
explains how to insert rows and columns into 
a specific location in the table.

 C  The  Table Setup dialog box  contains the 
basic options for a table’s appearance.

 D  The  Table Dimensions area  lets you 
set the number of rows, columns, 
header rows, and footer rows.
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You can also insert columns and rows into a 
specifi c location in a table.

To insert columns into a table:

1. Place an insertion point where you want 
to insert the columns.

2. Choose Table > Insert > Column. The 
Insert Columns(s) dialog box appears  A .
or
Choose Insert > Column from the Table 
panel menu.

3. Use the Number field to set the number 
of columns.

4. Choose either Left or Right to specify 
where the new columns should be 
inserted  B .

To insert rows into a table:

1. Place an insertion point where you want 
to insert the rows.

2. Choose Table > Insert > Row. The Insert 
Row(s) dialog box appears  C .
or
Choose Insert > Row from the Table panel 
menu.

3. Use the Number field to set the number 
of rows.

4. Choose either Above or Below to specify 
where the new rows should be inserted.

TIP The Insert Row(s) dialog box inserts rows into 
the header, footer, or main section of a table.

To insert rows as you type:

1. Place the insertion point in the final cell 
of the last row of the table main body, 
header, or footer.

2. Press the Tab key. A new row is 
automatically inserted.

 A  Use the  Insert Column(s) dialog box  to add 
columns at a specifi c location within a table.

 C  Use the  Insert Row(s) dialog box  to add 
rows at a specifi c location within a table.

Selected 
cell

Original table

After column is inserted New column

 B  An example of  how a column is added  
to the left of the selected cell.
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To add columns as you drag the table edge:

1. Drag the last column of the table.
2. Press the Opt/Alt key as you drag. This 

expands the size of the table by adding 
columns  D .

To add rows as you drag the table edge:

1. Drag the last row of the table.
2. Press the Opt/Alt key as you drag. This 

expands the size of the table by adding 
rows  E .

To delete table columns:

1. Select the columns you want to delete.
2. Choose Table > Delete> Column.

To delete table rows:

1. Select the rows you want to delete.
2. Choose Table > Delete> Row.

To delete the entire table:

1. Select the table.
2. Choose Table > Delete> Table.

You may want to delete the content inside a 
cell without deleting the cell itself.

To delete the content in table cells:

1. Select the cells, columns, or rows.
2. Press the Delete/Backspace key or choose 

Edit > Clear.

TIPTIP The content is deleted but the cells 
themselves remain in place  F . 

 F  An example of how you can  delete 
the content of selected cells .

Selected cells After deleting content

 D  Hold the Opt/Alt key as you drag 
across to  add columns to a table .

 E  Hold the Opt/Alt key as you drag 
down  to add rows to a table .
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You can’t move cells from one place to 
another, but you can copy and paste cells and 
their content to new locations.

To copy and paste the content in table cells:

1. Select the cells, columns, or rows that you 
want to move to a new position.

2. Choose Edit > Copy or Edit > Cut. This 
puts the selected cells on the clipboard.

3. Select the new cells, columns, or rows.

TIP You should select at least the same number of 
cells, columns, or rows that were selected in 
step 1.

4. Choose Edit > Paste. The content on 
the clipboard is pasted into the selected 
cells  A .

TIP If you selected more cells than were selected 
in step 1, the excess cells are not changed.

When you create a table, all the columns and 
rows are evenly spaced. However, you can 
modify the size of the rows and columns.

TIP A red dot inside a table cell indicates there is 
an overflow of text  B . You can change the size 
of the cell to display the overflow text.

To change a single row height visually:

1. With the Text tool selected, place the 
cursor along the border of the row you 
want to adjust. The cursor changes to an 
up/down arrow  C .

2. Drag to adjust the height of the row.

To change all the rows visually:

1. Place the cursor along the bottom border 
of the table. The cursor changes to an up/
down arrow.

2. Hold the Shift key as you drag to adjust 
the height of all the rows in the table.

 C  The  Up/ Down arrow  indicates 
you can adjust the row height.

Select and copy cells

Select empty cells

 A  The three-step process to  copy and move 
cells from one position to another. 

Paste cells to new position

 B  A  red dot inside a table cell  indicates that 
there is an overfl ow of text inside the cell.
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To set the row height numerically:

1. Select the rows you want to adjust.
2. Choose Table > Cell Options > Rows and 

Columns to open the Cell Options dialog 
box to the Rows and Columns options  D .

3. Set the Row Height menu as follows:
 • At Least sets a row height that can 

increase to hold text or an image.
 • Exactly sets a row height that does not 

get larger.
4. Enter an amount in the Row Height field.
5. Use the Maximum field to prevent the 

row from becoming too tall.

To change the column width visually:

1. With the Text tool selected, place the 
cursor along the border of the column 
you want to adjust. The cursor changes to 
a left/right arrow  E .

2. Drag to adjust the width of the column.

To set the column width numerically:

1. Select the columns you want to adjust.
2. Enter an amount in the Column Width 

field  F .

You can adjust columns or rows so their spac-
ing is evenly distributed.

To automatically distribute columns:

1. Set the rightmost column to the position 
it should be after the adjustment.

2. Select the columns you want to adjust.
3. Choose Table > Distribute Columns 

Evenly. The column widths adjust  G .

 E  The  Left/ Right arrow  indicates you 
can adjust the column width.

 D  The  Rows and Columns category 
 of the Cell Options dialog box. 

 F  The  Column Width control  of 
the Cell Options dialog box.

 G  The results of using the  Distribute 
Columns Evenly command .
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To automatically distribute rows:

1. Set the bottommost row to the position it 
should be after the adjustment.

2. Select the rows you want to adjust.
3. Choose Table > Distribute Rows Evenly. 

The row heights adjust so they are the 
same size  A .

You can control when and how the rows of a 
table break across text frames. 

To set the keep options for rows:

1. Select the rows you want to control.
2. Choose Table > Cell Options > Rows and 

Columns.
3. Choose from the Start Row menu as 

follows  B :
 • Anywhere lets the row start anywhere 

in a text frame.
 • In Next Text Column forces the row 

to the next column in the frame or the 
next text frame.

 • In Next Frame forces the row to the 
next text frame.

 • On Next Page forces the row to the 
next page.

 • On Next Odd Page forces the row to 
the next odd-numbered page.

 • On Next Even Page forces the row to 
the next even-numbered page.

4. Select Keep with Next Row to make sure 
one row doesn’t separate from another  C .

 A  The results of using the  Distribute 
Rows Evenly command .

 C  Select  Keep with Next Row  to force one 
row to always stay with the next one.

 B  The  Start Row menu  lets you 
choose where that row starts.
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Adjusting Tables Within a Text 

Frame

Tables are always contained within text 
frames. You can control how much space 
there is between the table and the text that 
precedes or follows it  D .

To set the spacing around a table:

1. With the table selected, choose 
Table > Table Options > Table Setup. 
The Table Options dialog box appears.

2. Use the Table Spacing control for Space 
Before to set the amount of space 
between text and the top of the table  E .

3. Use the Table Spacing control for Space 
After to set the amount of space between 
the bottom of the table and the text that 
follows it.

TIPTIP A table is inserted into a text frame as an 
inline object in its own paragraph. This means 
that any space before or after the paragraph 
that holds the table is added to the space set 
by the Table Spacing controls.

If a table extends longer than a text frame, 
you get a text frame overfl ow. You can easily 
fl ow the rest of the table from frame to frame 
across pages.

To fl ow tables between frames:

1. Use the Selection tool to load the 
overflow cursor.

2. Click the overflow cursor inside the new 
frame to flow the rest of the table into the 
frame  F .

 D   Add some space around a table  to 
keep it from colliding with text.

No space around 
table

Space added 
around table

 E  The  Table Spacing controls  let you set the 
amount of space before and after a table.

 F  The text threads show how tables can 
fl ow from one frame to another.
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Working with Headers and 

Footers

Tables with lots of data often fl ow from one 
location to another. To make it easier for 
readers to follow the table information, you 
can repeat the fi rst and last rows of the table 
each time it appears in a new place. When 
the fi rst row of a table repeats, it is called a 
header. When the last row repeats, it is called 
a footer. 

To add a header or footer to a table:

1. With the table selected, choose Table > 
Table Options > Headers and Footers. 
The Table Options dialog box opens with 
the Headers and Footers tab chosen  A .

2. Use the Header Rows controls to set the 
number of repeating rows added to the 
top of the table  B .

3. Use the Footer Rows controls to set the 
number of repeating rows added to the 
bottom of the table.

TIP To turn off a header or footer, set the Header 
Rows or Footer Rows to zero.

To set the repeat options for headers and 
footers:

1. Use the Repeat Header or Repeat Footer 
menu as follows  C :
 • Every Text Column repeats the header 

or footer whenever the table appears.
 • Once per Frame repeats the header 

or footer only once in the same frame. 
This is useful when a table flows from 
one column to another.

 • Once per Page repeats the header or 
footer only once in the same page. 
This is useful when a table flows into 
multiple frames on the same page.

2. Select Skip First (for headers) or Skip Last 
(for footers) to display a header or footer 
only after the first instance of a table  D .

 A  The  Headers and Footers area in Table 
Options  lets you control the appearance 
of headers and footers in the table.

 D  The  Skip First or Skip Last  options 
let you repeat headers or footers 
after the fi rst instance of a table.

 B  Use the  Table Dimensions for 
Headers and Footers  to control the 
number of header and footer rows.

 C  Use the  Repeat Header menu  to set 
how frequently the header appears.
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As you work, you may want to convert body 
table cells into a header or footer.

To convert cells into a table header:

1. Select the rows that you want to convert. 
These rows must start with the first row of 
the table.

2. Choose Table > Convert Rows > To 
Header. The rows are converted from the 
body of the table to the table header  E .

TIPTIP If there already is a header for the table, the 
cells are added to the bottom of the existing 
cells.

To convert cells into a table footer:

1. Select the rows that you want to convert. 
These rows must end with the last row of 
the table.

2. Choose Table > Convert Rows > To 
Footer. The rows are converted from the 
body of the table to the table footer.

TIPTIP If there already is a footer for the table, the 
cells are added to the top of the existing cells.

Finally, you may want to convert the rows in a 
header or footer into the body of the table.

To convert header or footer cells into body 
cells:

1. Select the rows that you want to convert.

TIPTIP The rows must include the bottom rows of 
the header or the top rows of the footer.

2. Choose Table > Convert Rows > To Body.

TIPTIP When header or footer cells are converted 
into body cells, they take on the attributes of 
the body cells  E .

 E  An example of what happens when footer 
cells are converted to body cells. Notice 
that the footer takes on the alternating 
fi ll applied to the body cells of the table.

Body cells

Body cells

Footer 
cells
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Adding Images to Tables

Although table cells are created to hold text, 
you can easily add images as inline graphics 
to each cell.

To insert a graphic into a table cell:

1. Place an insertion point inside a table cell.
2. Choose File > Place to insert an image 

into the cell  A .
or
Paste a graphic copied to the clipboard 
into the cell.

TIP Graphics in cells are pasted as inline graphics.

If the graphic is larger than the size of the cell, 
some of the graphic may stick out beyond the 
cell. You use the Clipping setting to control 
whether placed graphics are seen outside 
a cell.

To control the display of a graphic inside a 
cell:

1. Place your insertion point inside the cell 
that contains the placed graphic.

2. Choose Table > Cell Options > Text. This 
opens the Cell Options dialog box  B .

3. Select Clip Contents to Cell to limit the 
display of the graphic to inside the cell  C .
or
Deselect Clip Contents to Cell to allow the 
graphic to be displayed outside the cell  D .

TIP In addition to allowing a graphic to appear 
outside the cell boundaries, you can also drag 
a table so that the table itself extends outside 
the text frame.

 A  An example of how a placed image 
can be inserted into a table cell.

 B  The  Clip Contents to Cell  option 
for inline graphics in a cell.

 D  With the  Clip Contents to Cell option 
turned off  , an inline graphic extends 
outside the boundaries of the cell.

 C  With the  Clip Contents to Cell option 
turned on , an inline graphic is confi ned 
to the boundaries of the cell.
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Customizing Cells

In addition to setting the controls for the 
entire table, you can also make settings 
for individual cells. You can customize the 
arrangement of rows and columns by merg-
ing or splitting cells. You may want to merge 
cells to fi t more text within a cell. You can also 
change the positioning of text within a cell.

To merge cells:

1. Select the cells you want to merge.
2. Choose Table > Merge Cells. The dividers 

between the cells are deleted  E .

TIPTIP If the merged cells contain text, the text will 
be divided into paragraphs.

To unmerge cells:

1. Select the cells you want to unmerge.
2. Choose Table > Unmerge Cells.

To split cells:

1. Select the cell you want to split.
2. Choose Table > Split Cell Horizontally or  

Table > Split Cell Vertically  F  or  G .

 F  The results of using the  Split Cell 
Horizontally command .

 G  The results of using the  Split 
Cell Vertically command .

 E  The results of using the  Merge 
Cells command .

InDesign CS5 Visual Quickstart Guide 347



You can also control how text is positioned 
horizontally and vertically within each cell.

TIP These settings also control how inline 
graphics are positioned within cells.

To set the cell options for text:

1. Select the cells you want to adjust.
2. Choose Table > Cell Options > Text. This 

opens the Cell Options dialog box for text 
controls  A .

3. Use the Cell Insets fields to adjust the 
space between the text and the top, 
bottom, left, and right sides of cells  B .

TIP Select the link icon to make all the cell insets 
the same amount.

4. Choose one of the four settings from the 
Text Rotation menu to rotate the text in 
90° increments.

You can also set the vertical alignment for 
where the text is positioned in the cell.

To set the text vertical alignment:

1. Select the cells you want to adjust.
2. Choose Table > Cell Options > Text. This 

opens the Cell Options dialog box for text 
controls.

3. Use the Vertical Justification Align menu 
to choose one of the four alignment 
options as follows:
 • Top positions the text at the top edge 

of the cell.
 • Center positions the text in the middle 

of the cell.
 • Bottom positions the text at the 

bottom edge of the cell.
 • Justify distributes the lines of the text 

evenly so that it extends from the top 
to the bottom of the cell.

TIP The Justify setting overrides any leading 
applied to the text.

 A  The  Text area of the Cell Options  controls 
how text is positioned within each cell.

 B  The  Cell Insets controls  let you specify 
how far text sits from the edge of a cell.
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If you choose Justify for the vertical align-
ment, you can then control the space 
between the lines or paragraphs.

To set the vertical justifi cation spacing:

1. Select the cells you want to adjust.
2. Choose Table > Cell Options > Text. This 

opens the text controls for the cells.
3. Choose Justify from the Vertical 

Justification list.
4. Set an amount for the Paragraph Spacing 

Limit  C .

TIPTIP Increase the value for the paragraph spacing 
to avoid increasing the space between the 
lines within the paragraph.

Just as you can control where the fi rst base-
line of text appears in a text frame, you can 
also control the position of the text baseline 
within a cell.

To control the fi rst baseline in a cell:

1. Select the cells you want to control.
2. Choose Table > Cell Options > Text. This 

opens the text controls for the cells.
3. In the First Baseline area, use the Offset 

menu to choose a setting  D .
4. In the Min field, set the minimum amount 

of space for the first baseline.

 C  When the  Justify option is chosen in the 
Vertical Justifi cation Align menu , the 
Paragraph Spacing Limit control is available.

 D  The  First Baseline controls  let 
you set the position of the fi rst 
baseline of text within a cell.
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Setting Borders, Strokes, 

and Fills

One of the benefi ts of using tables instead of 
tabs is how easy it is to add lines and colors 
to the table. (The line around a table is called 
the border. Lines around cells are called 
strokes. Colors inside the cells are called 
fi lls  A .)

To add a border around the table:

1. Select at least one cell in the table.
2. Choose Table > Table Options > Table 

Setup. The Table Options dialog box 
opens with the Table Setup options 
selected  B .

3. In the Table Border category, use the 
Weight field to set the thickness of the 
border/line  C .

4. Use the Color menu to set the color of the 
border/line.

5. Use the Tint field to apply a screen to the 
color.

6. If desired, select the Overprint checkbox 
for the color.

7. Use the Type menu to set a stripe pattern 
for the border.

If you have applied a stroke to a cell that 
touches the table border, the Preserve Local 
Formatting checkbox controls how the table 
border changes the local settings to cells.

To preserve the formatting applied to cells:

1. Apply a stroke to the cells.
2. In the Table Options dialog box, select 

Preserve Local Formatting to maintain the 
appearance of the cell edges that touch 
the table border  D .
or
Deselect Preserve Local Formatting to 
allow the table border to override the 
stroke applied to the cell.

 B  The  Table Setup dialog box  lets you 
apply a border around the entire table.

 C  You can format the line around a table 
with the  Table Border controls .

A
p

ri
l

M
ay

Started 34 54

Ended 76 85

Progress 42 31

 A  The  table border  goes around 
the outside of a table.

Table 
border

Cell strokes

A
p

ri
l

M
ay

Started 34 54

Ended 76 85

Progress 42 31

 D  The Preserve Local Formatting 
option maintains the appearance of 
cells that touch the table border.

Local formatting
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Tables are automatically created with strokes 
around the cells. You can remove those cell 
strokes, apply new ones, or customize them 
as you see fi t.

To customize the strokes around 
individual cells:

1. Select the cells you want to modify.
2. Choose Table > Cell Options > Strokes 

and Fills. The Cell Options dialog box 
appears with the Strokes and Fills options 
selected  E .

3. Click the proxy lines in the cell preview to 
select which edges of the selected cells 
should be formatted  F . The top, bottom, 
left, and right edges of the preview area 
correspond to the position of the edges in 
the selected cells.

TIPTIP Important! Select and deselect the proxy lines 
in the cell preview before you change any of 
the settings in the dialog box. This avoids 
applying partial settings to the cells.

TIPTIP The cell preview area changes depending on 
the combination of cells, rows, or columns 
you have selected  G .

4. Set the controls under Cell Stroke to 
format the appearance of the selected 
edges.

5. Click OK to apply the settings.

 E  The  Strokes and Fills controls  under Cell 
Options let you format cells in a table.

 F  Click the  proxy lines for the cell 
stroke  to control which edges of the 
cell are stroked. The colored lines 
indicate the edge is selected.

Selected edge Unselected edge

 G  The  cell preview area  changes 
depending on how many cells, 
rows, or columns are selected.

One cell Two or more columns

Two or more rows Two or more columns and rows
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If all your strokes are the same solid color, you 
don’t have to worry about how the table is 
drawn. But as soon as you mix strokes or use 
nonsolid strokes, you need to set preferences 
for how the strokes appear when they cross 
each other.

To set the stacking order for the border and 
strokes:

1. Select at least one cell in the table.
2. Choose Table > Table Options > Table 

Setup. The Table Options dialog box 
appears.

3. Choose one of the following from the 
Draw menu  A :
 • Best Joins lets InDesign create the 

best possible appearance for how the 
strokes intersect.

 • Row Strokes in Front moves the 
strokes for the rows in front of the 
strokes for the columns.

 • Column Strokes in Front moves the 
strokes for the columns in front of the 
strokes for the rows.

 • InDesign 2.0 Compatibility uses a 
combination of the Best Joins for the 
table border and the rows in front of 
the strokes for the interior cells.

You can also fi ll the inside of a cell with a 
color or gradient.

To customize the fi ll inside individual cells:

1. Select the cells you want to modify.
2. Choose Table > Cell Options > Strokes 

and Fills. The Cell Options dialog box 
opens set to Strokes and Fills.

3. Set the controls under Cell Fill to format 
the color inside the selected cells  B .

TIP If you have already defined a gradient swatch, 
you can fill the selected cells with a gradient.

 A  Examples of  how the Draw menu 
settings are applied  to tables.

Best Joins

Row Strokes in 
Front

Column Strokes 
in Front

InDesign 2.0 
Compatibility

 B  The  Cell Fill controls  let you apply 
colors to individual cells in a table.
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Alternating Strokes and Fills

Many people who work with tables fi nd it 
helpful to set alternating strokes or fi lls for 
entire rows or columns in repeating patterns. 
This can help readers easily navigate down 
the column or across the row in lengthy 
tables.

TIPTIP Even if you insert or delete rows or columns, 
the Alternating Pattern feature automatically 
reapplies the correct sequence of fills to your 
table.

To alternate repeating strokes for rows:

1. Select at least one cell in the table.
2. Choose Table > Table Options > 

Alternating Row Strokes. The Table 
Options dialog box opens set to the Row 
Strokes tab  C .

3. Use the Alternating Pattern menu to 
choose how frequently the row strokes 
will alternate  D .

4. Set the controls on the left side of the 
Alternating area to format the stroke 
appearance for the first set of rows  E .

5. Set the controls on the right side of the 
Alternating area to format the appearance 
of the stroke for the next or second set 
of rows.

6. Use the Skip First and Skip Last fields to 
omit a certain number of rows at the start 
and end of the table from the alternating 
count.

TIPTIP If you have applied custom strokes to 
individual cells and want to override the 
local formatting, deselect the Preserve Local 
Formatting checkbox.

 C  The  Table Options for Row Strokes 
 allow you to apply alternating patterns 
for the strokes applied to rows.

 D  The  Alternating Pattern menu  
for setting table rows.

 E  The  Alternating controls  allow 
you to choose the appearance for 
the alternating row strokes.
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To alternate repeating strokes for columns:

1. Select at least one cell in the table.
2. Choose Table > Table Options > 

Alternating Column Strokes. The Table 
Options dialog box opens set to Column 
Strokes  A .

3. Use the Alternating Pattern menu to 
choose how many column strokes will 
alternate  B .

4. Set the controls on the left side 
of the Alternating area to format the 
appearance of the stroke for the first set 
of columns  C .

5. Set the controls on the right side of the 
Alternating area to format the appearance 
for the second set of columns.

6. Use the Skip First and Skip Last fields to 
omit certain columns at the start and end 
of the table from the alternating count.

TIP If you have applied strokes to individual cells, 
the Preserve Local Formatting command 
controls whether the alternating strokes for 
columns override that local formatting.

 A  The  Column Strokes controls  under 
Table Options let you apply automatic 
alternating strokes to table columns.

 B  The  Alternating Pattern 
menu  for table columns.

 C  The  Alternating controls  allow you 
to choose the appearance for the 
alternating column strokes.
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To alternate repeating fi lls:

1. Select at least one cell in the table.
2. Choose Table > Table Options > 

Alternating Fills. The Table Options 
dialog box appears set to Fills  D .
or
Choose Table Options > Alternating Fills 
from the Table panel.

3. Use the Alternating Pattern menu to 
choose how many row or column fills will 
alternate  E .

4. Set the controls on the left side of the 
Alternating area to format the appearance 
of the fill for the first set of columns or 
rows  F .

5. Set the controls on the right side of the 
Alternating area to format the appearance 
of the second set of columns or rows.

6. Use the Skip First and Skip Last fields to 
omit certain rows or columns at the start 
and end of the table from the alternating 
count.

TIPTIP If you have applied fills to individual cells, the 
Preserve Local Formatting command controls 
whether the alternating fills override that 
local formatting.

TIPTIP My own personal favorite is to set repeating 
fills of light and dark rows  G .

 D  The  Fills controls  under Table Options 
let you apply automatic alternating 
fi lls to table rows or columns.

 E  The  Alternating Pattern menu 
 for setting table fi lls.

 F  The  Alternating controls  allow 
you to choose the appearance 
for the alternating fi lls.

A B C D E F G

H I J K L M N

O P Q R S T U

V W X Y Z

 G  An example of a table that uses the 
alternating fi lls for repeating rows.
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Adding Diagonal Lines in Cells

Many people who design tables use diagonal 
lines to indicate empty data or corrected 
information. InDesign lets you apply diagonal 
lines inside cells.

To add diagonal lines in cells:

1. Select the cells you want to modify.
2. Choose Table > Cell Options > Diagonal 

Lines. The Cell Options dialog box 
opens with the Diagonal Lines options 
selected  A .

3. Click one of the direction controls to set 
the direction of the diagonal lines  B  and 
their styles  C .

4. Set the Line Stroke options to format the 
appearance of the line  D .

5. Choose one of the following from the 
Draw menu:
 • Content in Front positions the 

diagonal line behind any text in 
the cell.

 • Diagonal in Front positions the 
diagonal line in front of any text in 
the cell.

 A  The  Diagonal Lines controls  under Cell 
Options let you add diagonal lines to cells.

 C  Examples of how the diagonal 
lines can be used in cells.

 D  The  Line Stroke controls  for diagonal 
lines let you style the appearance 
of the diagonal lines inside cells.

 B  The  direction controls  for the 
diagonal lines in cells.

None Down Up Crossed
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Using the Table or Control 

Panels

You can also work with the Table panel or 
the Control panel to modify the number of 
columns and rows, their width and height, 
and other settings in tables.

To work with the Table panel or Control 
panel:

1. Select the table or cells in the table.
2. Choose Window > Type & Tables > Table. 

This opens the Table panel  E .
or
Choose Window > Control. This opens the 
Control panel  F .

3. Use the controls, fields, and icons as 
shown in the following table.

Table feature Icon

Number of rows

Number of 
columns

Row height menu

Row height 

Column width 
control

Text vertical 
justifi cation 

Text rotation 

Top cell inset 

Bottom cell inset 

 E  The  Table panel  provides an onscreen 
panel to modify many of the table controls.

 F  When a table is selected, the  Control 
panel  displays the table controls.
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Table feature Icon

Left cell inset 

Right cell inset 

There are some additional table icons that are 
only found in the Control panel.

Merge cells (com-
mand located in the 
Table panel menu)
Unmerge cells (com-
mand located in the 
Table panel menu)

Stroke weight (icon 
in Stroke panel)

Stroke type (icon in 
Stroke panel)

Cell preview

TIP You can also use the commands in the Table 
panel menu or Control panel menu to modify 
the table.

TIP And if you were wondering, this table uses 
a header to repeat the top information from 
one page to another.
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Automating Your Work
I have a general rule about working 

with a computer. Anytime I fi nd myself 
doing the same thing more than ten 
times in a row, I stop. Most likely there 
is a command or tool that I can use to 
automate the process.

That’s what this chapter is about —
learning how to automate InDesign so 
the application does the dull, tedious 
chores for you. (Sadly, I can’t apply this 
rule to other parts of my life, such as 
washing dishes, cleaning the litter box, 
or folding socks.)

There are many diff erent automation 
features. You can use Find/Change, 
Spell Check, Footnotes, and Find Font 
to quickly change text formatting. 
Footnotes make it possible to simply 
choose the command and let InDesign 
do its stuff .

As amazing as these features are, they 
are not the ultimate in automation. 
Chapter 15 shows how text, table, and 
object styles are even more powerful 
automation tools.

Of course, you’re not required to learn 
any of these automation features. You 
are perfectly welcome to modify text by 
hand, one word at a time — especially 
if you don’t care about doing anything 
else in your life.
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Changing Case

InDesign gives you a command to quickly 
change text case.

To change text case:

1. Select the text you want to change.
2. Choose Type > Change Case and then 

choose one of the following: lowercase, 
Title Case, Sentence case, or UPPERCASE 
from the submenu.

Checking Spelling

One of the most popular features of page 
layout programs is the spelling checker, 
which searches for misspelled words.

To use the spell check command:

1. To check the spelling in a specific text 
frame or linked frames, click to place an 
insertion point anywhere within the text.

2. Choose Edit > Spelling > Check Spelling. 
The Check Spelling dialog box appears 
and displays the first word that needs 
attention  A .

3. Choose one of the Suggested Corrections 
for the word.

4. Click Change. The word is corrected 
and the next word is displayed. Or click 
Change All to change all instances of the 
word in the text.

5. Click Skip to continue the spelling 
check with out changing that instance 
of the text.
or
Click Ignore All to continue the spelling 
check without changing any instance of 
that word in the text.

6. Click Done to stop the spelling check. The 
dialog box stays open in case you want to 
run more spelling checks.

 A  The  Check Spelling dialog box  is the 
command center for a spelling check.
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Once you have opened the Spelling check, 
you can set which text frames should be 
searched.

To set the search criteria:

1. In the Search list, choose where the 
spelling check should be performed:
 • All Documents checks all open files.
 • Document checks the entire 

active file.
 • Story checks all the linked frames of 

the selected text.
 • To End of Story checks from the 

insertion point.
 • Selection checks only the 

selected text.
2. Select the Case Sensitive option to 

require a match for upper- and lowercase 
characters.

Of course, the spelling checker wouldn’t be 
very helpful if it couldn’t make changes to 
suspect words.

To correct the error displayed:

1. Type a correction in the Change To box.
or
Select a word from the Suggested 
Corrections list  B .

2. Click Change to change only that instance 
of the word in the text.

 B  InDesign gives you  a list of suggested 
corrections  for the unknown words 
found during a spelling check.

The Limitations of the Spelling Check

Every once in a while, I read an article about 
how the use of spelling checkers in computers 
is contributing to the death of proper writing 
and language. It’s true; too many people run a 
spelling check and don’t bother to actually read 
the document. Consider the following text:

Their is knot any thing wrung with using a spelling 
cheque on a sent tents in a doc you mint. Ewe just 
haft to clique the write butt ends.

Obviously the paragraph is utter nonsense. Yet 
InDesign’s spelling checker (as well as the spell-
ing checker in most other programs) wouldn’t 
flag a single word as being incorrect.

A spelling checker only flags words it doesn’t 
recognize; but because everything in the para-
graph is an actual word, InDesign doesn’t see 
any problems. So, please, don’t skip a session 
with a proofreader just because you’ve run a 
spelling check.
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The Ignore commands only work during 
a particular session of InDesign. If you use 
specialized words frequently, you should add 
them to the dictionary that InDesign uses 
during a spell check.

To add words to the spelling check 
dictionary:

Click Add when the word is displayed 
during the spelling check.

To edit the dictionary:

1. Choose Edit > Spelling > Dictionary to 
open the Dictionary dialog box  A .

TIP You can also open the Dictionary by clicking 
the Dictionary button in the Check Spelling 
dialog box.

2. Use the Target list to choose which 
dictionary you want to add the words to.

3. Choose the language from the 
Language list.

4. Choose Added Words, Removed Words, or 
Ignored Words from the Dictionary List.

5. Select the Case Sensitive checkbox to 
ensure that the case of the word as 
entered in the dictionary is used during 
the spelling check.

6. Type the word you want to add in the 
Word field.
or
Select the word you want to remove.

7. Click the Add or Remove button.

 A  The  Dictionary dialog box  allows you 
to add or delete words in the dictionary 
used during a spelling check.
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You may want to send your dictionary list to 
others. To do this, you can export the list.

To export entries in the spelling check 
dictionary:

1. Click the Export button.
2. Name the file and save it.

To import entries into a spelling check 
dictionary:

1. Click the Import button.
2. Find the file you wish to import.

InDesign also fl ags suspect words in the 
layout or Story Editor the same way it would 
in the spelling checker.

To use the dynamic spelling:

Choose Edit > Spelling > Dynamic 
Spelling. The dynamic spell checker 
displays unknown words and other 
spelling errors with wavy underlines  B . 

You can also set InDesign to automatically 
correct spelling errors as you type. This is 
called the Autocorrect feature. 

To automatically correct spelling errors as 
you type:

Choose Edit > Spelling > Autocorrect. 
A check mark appears in front of the 
command to indicate that Autocorrect is 
turned on.

TIPTIP The Autocorrection feature only corrects 
words that are in the Autocorrect preferences 
or wrongly capitalized words  C . It does not 
automatically correct unknown words or 
repeated words.

 B  The  wavy underlines  indicate 
which words have been fl agged by 
the dynamic spelling checker.

 C  An example of how the  Autocorrect 
feature  corrects the capital letter 
and the misspelled word.

As typed

After the 
autocorrection
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Using Find/Change

InDesign has a powerful Find/Change control 
panel that lets you fi nd and replace text, font 
characters, or object attributes.

To choose the Find/Change mode:

1. Choose Edit > Find/Change. The Find/
Change dialog box appears  A .

2. Click one of the following four Find/
Change categories  B :
 • Text lets you search and replace strings 

of text as well as text formatting.
 • GREP lets you use codes that search for 

patterns within text.
 • Glyph lets you look for and replace 

specific glyphs using their Unicode or 
GID/CID values.

 • Object lets you search for and replace 
objects with certain formatting.

TIP Click the More Options button to see all the 
Find/Change controls. 

The Find/Change dialog box lets you control 
which areas of the document are searched.

To set the search areas:

Click one of the following icons to allow a 
search in the area  C .
 • Locked layers looks on layers that have 

been locked. This works only for the 
Find field.

 • Locked stories looks inside stories that 
have been checked out as part of the 
InCopy workflow. This works only for 
the Find field.

 • Hidden layers looks on layers that have 
been turned off in the Layers panel.

 • Master pages looks on master pages.
 • Footnotes looks inside InDesign’s 

electronic footnotes.

 B  The  four categories for Find/Change  
are Text, GREP, Glyph, and Object.

 A  The  Find/Change dialog box 
 allows you to set the controls for 
searching for and replacing text.

 C  Use  the search areas  to control 
which part of the document the 
Find/Change will look at.

Locked 
layers

Locked 
stories

Hidden 
layers

Master 
pages Footnotes
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Although all four categories look for and 
replace diff erent things, the control buttons 
work the same for all the searches  D .

To use the Find/Change control buttons:

1. Click Find to start the search. Once 
something has been found, this button 
changes to Find Next.

2. Click Change to make the change without 
moving to the next instance.
or
Click Change/Find to make the change 
and move to the next instance.
or
Click Change All to change all the 
instances in the text.

3. Click Find Next to skip to the next 
occurrence without changing that 
instance of the found text.

4. Click Done if you wish to stop the search 
without going through the whole 
document.

 D  The  Find/Change buttons  control 
the actions during a search.

Undo After a Find/Change?

I get a lot of oohs and ahhhs when I show 
that even after a Find/Change that has made 
hundreds of changes across many pages of a 
document, I can still undo those changes in just 
one Edit > Undo command.

Just because InDesign has done a lot of work 
doesn’t mean that you can’t undo that work.

Of course, having said that, I’m sure that if I 
performed some incredibly complicated rou-
tine that worked across many documents with 
thousands and thousands of changes, I might 
exhaust the memory for the undo string.

But don’t let that stop you from trying an undo. 
The worst you’ll get is a slight “beep” from 
InDesign.
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Using the Text Find/Change

The Text category looks for text and changes 
it into new text or applies formatting. A 
simple Find/Change works with text only.

To set the Find/Change text strings:

1. To find and change within a specific text 
frame or linked frames, click to place an 
insertion point within the text.

2. In the Find what field, type or paste the 
text you want to search for.

3. In the Change to field, type or paste the 
text to be inserted.

4. In the Search pop-up list, choose where 
the search should be performed  A :
 • All Documents checks all open 

documents.
 • Document checks the entire 

document.
 • Story checks all the linked frames of 

the selected text.
 • To End of Story checks from the 

insertion point.
 • Selection checks only the selected text.

5. Select Case Sensitive to limit the search 
to text with the same capitalization  B . 
For instance, a case-sensitive search for 
“ InDesign” does not find “Indesign.”

6. Select Whole Word to disregard the text 
if it is contained within another word. 
For instance, a whole-word search for 
“Design” omits the instance in “InDesign.”

7. Click Find. InDesign looks through the 
text and selects each matching text 
string.

 A  The  Search list  lets you choose which 
documents or stories should be searched.

 C  The  Find What list  lets you enter the 
special characters to look for in a search.

 B  Use  the case and whole word 
controls  to modify the parameters 
of a text Find/Change.

Case 
sensitive

Whole 
word
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InDesign also lets you search for special char-
acters such as spaces, hyphens, paragraph 
returns, tab characters, or inline graphic 
markers. These are called meta characters.

To Find/Change metacharacters: 

1. Choose the character you want to look for 
in the Find what menu  C . The codes are 
entered in the Find what field  D .

2. Choose the codes you want to sub stitute 
in the Change To menu  D .

TIPTIP The metacharacter codes can also be entered 
using the keyboard.

3. Use the control buttons to run the Find/
Change routine.

TIPTIP InDesign also keeps a list of the past 15 strings 
for the Find what and the Change to fields  E . 
You can also permanently save queries as 
described later in this chapter.

With the Find/Change dialog box expanded, 
you can set the formatting options for either 
the Find or Change fi eld.

To set the Find/Change formatting options:

1. Click the Find formatting icon button in 
the Find Format Settings area of the Find/
Change dialog box  F . This opens the Find 
Format Settings dialog box.

2. Choose the formatting categories on 
the left side of the Find Format Settings 
dialog box  G . 

3. Enter the criteria you want to search for in 
the fields for the chosen category.

4. Click OK. The search criteria are dis played 
in the Find Format Settings area  H .

To delete the formatting options:

Click the Delete icon to delete all the 
formatting in the Find Format Settings or  
Change Format Settings area.

 D  An  example of the metacharacter codes . 
Here the dashes around a > character are 
replaced using the codes for thin spaces.

 E  The  list of 15 previous search strings  
is saved for each session of InDesign.

 G  The  Find Format Settings  for the 
Find or Change search criteria.

 H  The results of the  Find Format Settings  are 
displayed in the Find Format Settings area.

 F  Click the  formatting icons  to add specifi c 
formatting to the Find/Change queries.

Find formattingDelete formatting
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Using the GREPGREP Find/Change

To perform GREPGREP searches:

1. Click the GREP tab in the Find/Change 
dialog box  A .

2. Insert the GREP search codes in the Find 
What or Change to fields.

3. Set the rest of the dialog box controls the 
same way as for the Text Find/Change.

 A  The menu for the  GREP codes .

Using the GREPGREP Find/Change

Although it may sound like a rude noise heard after a full meal, GREPGREP stands for Global Regular Expression 
Parser. This is a set of commands that looks for patterns in text (called regular expressions) and allows you 
to replace those patterns. Although a complete GREPGREP tutorial is way beyond the scope of this book, here’s a 
simple GREP lesson to help you automate your Find/Change routines.

Let’s say you want to set all the text that is between parentheses as italic. You couldn’t do it with an ordinary 
Text Find/Change because you don’t know what text is between the parentheses.

The regular expressions in GREPGREP let you insert symbols that stand in for the real text. For instance, to search 
for any text between two parentheses, you would type \([\d\l\u\s]*\) in the Find what field. Here’s how that 
search string breaks down: 

\( open parenthesis. This sets the information within the parenthesis as a group to be searched for as 
a single unit.

[ and ] groups the codes together.
\d any digit. This includes the numbers 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.
\l any lowercase character.
\u any uppercase character. 
\s any type of space.
* any of these items can appear zero or more times.
\) close parenthesis.

In ordinary talk this translates into find any letters, numbers, or spaces that may or may not appear any number 
of times between two parentheses. Once you’ve found the text, it’s a simple matter to style it as italic.
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Using the Glyph Find/Change

As mentioned in Chapter 3, characters can 
have alternate glyphs used for fractions, 
ligatures, and other letter forms. The Glyph 
Find/Change area lets you search for these 
alternate glyphs using special codes as well as 
visual identifi cation  B .

TIPTIP The Glyph Find/Change only searches and 
replaces one character at a time.

To perform glyph searches:

1. Click the Glyph tab in the Find/Change 
dialog box.

2. Use the Find Glyph and Change Glyph 
areas to choose one or more of the 
following:
 • Font Family chooses the typeface.
 • Font Style chooses the style.
 • ID lets you choose either the Unicode 

or the CID/GID numbering system. Then 
enter that number in the following 
field.

 • Glyph opens a version of the Glyphs 
panel, which lets you visually choose 
the letterform  C .

3. Set the rest of the dialog box controls as 
described in the earlier section for Text 
Find/Change.

TIPTIP The control buttons for the Glyph Find/
Change are the same as the ones for the 
Text Find/Change with the exception of the 
additional Clear Glyphs button. This button 
clears all the information from the glyph 
fields to make it easier to perform new 
searches.

 B  The  Glyph category  of the Find/
Change dialog box.

 C  The  Glyphs panel  lets you visually choose 
the specialized glyphs to fi nd and change.
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Using the Object Find/Change

The Object Find/Change lets you search for 
objects with certain attributes and change 
them to something else.

To perform object attribute searches:

1. Click the Object tab in the Find/Change 
dialog box  A .

2. Click the Find Formatting icons in the Find 
Object Format and Change Object Format 
fields. The Change Object Format Options 
dialog box opens  B .

3. Click each of the categories under the 
Basic Attributes to choose the object style 
or object attributes  B .

4. Use the Type list to choose Text Frames, 
Graphic Frames, or Unassigned Frames  C . 
The default is All Frames.

Saving Searches

You can save your searches so you don’t have 
to type the codes and choose the attributes 
over and over.

To save searches:

1. Click the Save Query icon  D .
2. Name the search.

To apply saved searches:

Choose the saved search from the Query 
pop-up list.

To delete saved searches:

1. Choose the search you want to delete 
from the Query list.

2. Click the Delete Query icon.

 A  The  Object category  of the 
Find/Change dialog box.

 B  The  Change Object Format Options 
dialog box  lets you choose the 
attributes to search for or change.

 C  Use the  Type list  to choose a specifi c 
type of object frame to search for.

 D  Use the  Query controls  list to save, apply, 
and delete Find/Change searches.

Save Query Delete Query
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 E  The  File Info dialog box  lets you add 
custom metadata for images.

Adding Captions to Images

As you add images to your layouts, you may 
need to place captions along with the images. 
Instead of typing in those captions manually, 
InDesign lets you automate the process by 
entering captions from the image informa-
tion. There are two ways to add image infor-
mation to a fi le. One way is to use Photoshop. 
The other way is to use Bridge.

To add information to a fi le in Photoshop:

1. Open the file in Photoshop and then 
choose File > File Info to open the File 
Info dialog box  E .

2. Click the Description tab to enter 
metadata information such as the file 
name, author, document title, etc.

3. Enter information for any of the fields.
4. Repeat steps 2 and 3 for each of the other 

tabs in the dialog box.
5. Click OK to add the metadata to the file.

TIPTIP Some fields can’t be modified. For instance, 
the camera data for how the image was 
captured can’t be modified.

To add information to a fi le in Bridge:

1. Select the file or files in the Bridge 
window and choose File > File Info. 
The same File Info dialog box as in the 
previous exercise appears.

2. Click the Description tab to enter 
metadata such as the file name, author, 
document title, etc.

3. Click any of the other tabs to enter the 
metadata information.

TIPTIP Using Bridge allows you to select multiple 
files and enter the same metadata for all 
the files.
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Another step you need to take is to set the 
options for what information the caption 
should contain.

To set the Metadata Caption information:

1. Choose Object > Captions > Caption 
Setup to open the Caption Setup dialog 
box  A .

2. Set the contents of the Metadata Caption 
as follows:
 • Use the Text Before or Text After fields 

to insert text strings that you want 
applied before or after the metadata.

 • Choose a metadata field from the 
Metadata list.

 • Use the Symbols list to enter the codes 
for special items in the text fields  B .

 • Use the Add text options button to set 
additional text strings for the caption.

3. Click OK to apply the settings or set the 
Position and Style options as described in 
the following exercise.

To set the Position and Style of the caption:

1. Choose one of the Alignment options to 
set the caption frame above, below, to the 
right, or to the left of the image  C .

2. Choose an offset amount to set how close 
the caption frame should be to the image 
frame.

3. Choose a paragraph style to be applied to 
the caption.

4. Choose a layer on which the caption 
should be placed.
or
Choose Group Caption with Image to 
place the image and caption in a group 
together.

 A  The  Caption Setup dialog box  lets you 
set the content of automatic captions.

 C  The  Alignment options  for the position of 
the caption frame relative to the image.

 B  The controls to set the  contents 
of the captions .

Symbols list Add text options
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Once you have added the metadata and set 
up how the caption should be formatted, you 
can apply the caption to images. There are 
two types of captions. A static caption applies 
the information in the metadata but does not 
update if the metadata changes. A live cap-
tion is automatically updated if the metadata 
for the image changes.

To apply a static caption:

Select the image or images and choose 
Object > Captions > Generate Static 
Caption. The information from the 
metadata is inserted into a new frame 
positioned near the image.

To apply a live caption:

Select the image or images and choose 
Object > Captions > Generate Live 
Caption. The information from the 
metadata is inserted into a new frame 
positioned near the image.

TIPTIP A light-colored rectangle surrounds the 
live caption data. This indicates that the 
information changes if the metadata is 
modified  D . Static captions do not have the 
rectangle.

TIPTIP Live captions update when the placed image 
is updated in the Links panel.

TIPTIP A live caption frame must touch the image it 
is associated with for the metadata to appear.

You may want to “freeze” the caption so that 
it no longer updates. This requires converting 
the live caption to a static caption.

Select the live caption text and choose 
Object > Captions > Convert to Static 
Caption. The caption is no longer tied to 
the metadata for the image.

 D  The diff erence between the appearance 
of a live caption and a static caption.

Live caption Static caption
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Using the Story Editor

For people like me, one of the good things 
about electronic page layout is that I edit text 
as it appears on the page. 
For others, one of the bad things about 
electronic page layout is that they edit text 
as it appears on the page. Those people like 
to edit text without seeing images, typefaces, 
sizes, and other design elements. For those 
people, InDesign has a Story Editor  A .

To use the Story Editor:

1. Select the text frame that contains the 
text you want to edit, or place your 
insertion point inside the text.

2. Choose Edit > Edit in Story Editor. The 
Story Editor opens.

3. Use the right side of the Story Editor to 
make changes to the text. Any changes 
you make in the Story Editor appear on 
the document page.

4. Use the left side of the Story Editor to 
view the paragraph styles that may have 
been assigned to the text  B . 

5. If your text contains a table, click the 
small triangle next to the table to reveal 
the text inside the table  C .

6. If your text is overset inside the text 
frame, the overset text indicator displays 
where the overset appears  D .

TIP The Story Editor appears as a separate 
window from your document page. You don’t 
have to close the Story Editor to work on 
the regular document page. Just click the 
document page to work on it; then click to 
move back to the Story Editor.

TIP You can change the display of the Story Editor 
by changing the preference settings.

 C  Click the  Table control triangle  in the 
Story Editor to see the text inside a table.

 A  Text is displayed in the  Story Editor  
without most of its special formatting.

 B  The Story Editor displays the various 
elements within the story.

Styles Text       Table Inline graphic

Vertical 
Depth 
Ruler

 D  The  Overset Text indicator   shows 
where the text extends outside the 
visible area of the text frame.
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Tracking Text Changes

If you’re the only one who works on a project, 
you know who made the changes in your 
text. It’s you. If you work with others, you 
may want to see what changes each person 
makes. The Track Changes feature indicates 
who has done what to the text.

TIPTTIPT This workflow is more commonly used 
between InDesign and InCopy. But it can be 
used within an InDesign document.

Before you work with Track Changes, you 
need to tell InDesign who you are so it knows 
who is making which changes. This is called 
setting the user.

To set the user:

1. Choose File > User. This opens the User 
dialog box  E .

2. Enter a user name.
3. Choose a user color so that your changes 

stand out from others.

In order to track changes, you need to turn on 
the Track Changes command. You can do this 
for all stories in a document or for a single 
story.

To turn on Track Changes globally:

Choose Type > Track Changes > Enable 
Tracking in All Stories or choose Enable 
Tracking in All Stories from the Track 
Changes panel menu.

To turn on Track Changes for a single story:

1. Place your insertion point in the frame of 
the story you want to track.

2. Choose Type > Track Changes > Track 
Changes in Current Story or choose Track 
Changes in Current Story from the Track 
Changes panel menu.

TIPTIP You can also click the Track Changes icon in 
the Track Changes panel  F .

 E  The User dialog box allows you to identify 
each user with a name and a color.

 F  The  Track Changes panel  lets you move 
through changes and accept or reject them.

Track changes in 
current story

Show/Hide 
changes
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You can only see the changes in a document 
in the Story Editor  A . The Layout View shows 
the changes applied to the text.

To see the changes in a document:

1. Choose Edit > Edit in Story Editor.
2. Click the Show/Hide Changes icon in the 

Track Changes panel.

You use the Track Changes commands to 
move through the story to apply or discard 
changes.

To navigate through the changes:

1. Place your insertion point within the text 
in the Story Editor.

2. Click the Next Change icon to move to the 
first change  B .

3. Use the Accept Change or Reject Change 
icons to apply or discard the changes  C .

4. If necessary, use the Previous Change icon 
to move to the previous change.

5. Repeat steps 2 and 3 until finished.

TIP Hold the Opt/Alt key as you accept or reject a 
change and go to the next change. 

To use the other Track Changes commands:

Use the following additional commands 
when working with tracked changes. 

Command Location

Accept All Changes > In This Story Track Changes icon
Accept All Changes > In This Document Track Changes panel menu
Reject All Changes > In This Story Track Changes icon
Reject All Changes > In This Document Track Changes panel menu
Accept All Changes by This User > In This Story Track Changes panel menu
Accept All Changes by This User > In This Document Track Changes panel menu
Reject All Changes by This User > In This Story Track Changes panel menu
Reject All Changes by This User > In This Document Track Changes panel menu

 A   Tracked changes  displayed 
in the Story Editor

 B  Use the  Navigation icons to move 
from one change to another.

Previous 
Change

Next 
Change

 C  Use the  Accept Change and Reject Change 
icons  to apply or discard the changes.

Accept Change
Accept All 
Changes

Reject Change
Reject All 
Changes
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Bullets and Numbering

InDesign can also automatically add bullets 
and numbers in front of paragraphs. This 
makes it easier to create and format those 
paragraph lists.

To apply bullets to paragraphs:

Click the Bullets icon in the Control 
panel  D . Choose Type > Bulleted & 
Numbered Lists > Apply Bullets. 

TIPTIP This applies the last-used setting of the bullet 
options.

You will most likely want to format your own 
custom bullets.

To format the bullets in a paragraph:

1. Choose Bullets and Numbering from the 
Paragraph panel menu. The Bullets and 
Numbering dialog box appears  E .

2. Choose Bullets from the List Type menu. 
This displays the bullets options.

3. Choose a bullet from the Bullet Character 
glyph display.

TIPTIP The letter u under the character indicates that 
the bullet can be styled with any font. Bullets 
without a u are confined to a single font.

4. Use the Text After field to type which 
characters you want to separate the bullet 
from the start of the text.

5. If desired, use the Character Style list to 
choose a character style to format the 
bullets. (See Chapter 15, “Styles,” for more 
information on character styles.)

TIPTIP The position settings described later in this 
section control how the bullets hang outside 
the text indent.

 E  The  Bullets options  of the Bullets and 
Numbering dialog box let you select 
and format bullets automatically.

 D  The  Bullets icon  in the Control panel 
quickly applies bulleted lists.
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To add custom bullet characters:

1. Click the Add button in the Bullets and 
Numbering dialog box. The Add Bullets 
dialog box opens  A .

2. Use the glyphs area to choose the 
character for the bullet.

3. If you want, choose the Font Family and 
Font Style for the bullet.

4. To set the bullet to a specific font, select 
Remember Font with Bullet.

5. Click Add or OK to add the character to the 
bullet list and choose new characters.

Bullets are just one type of character that 
can be added to paragraphs. You can also 
automatically create numbered lists with the 
Bullets and Numbering controls.

To apply numbers to paragraphs:

Click the Numbers icon in the Control 
panel  B . Choose Type > Bulleted & 
Numbered Lists > Apply Numbers. 

To format numbers in paragraphs:

1. In the Bullets and Numbering dialog box, 
choose Numbers from the List Type menu 
to display the numbers options  C .

2. Use the Format list to choose Roman or 
Arabic numerals, or letters for the list.

3. Use the Number field to choose which 
characters should follow the number. You 
can also type your own character.

4. Use the Character Style list to choose a 
format for the numbers.

5. Use the Mode list to choose to start 
the list at a number or continue from a 
previous number.

 A  The  Add Bullets dialog box  lets 
you add new bullet characters.

 C  The  Numbers options  of the Bullets and 
Numbering dialog box let you select 
and format numbers automatically.

 B  The  Numbers icon  in the Control panel 
quickly applies numbered lists.
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One of the benefi ts of the automatic bullets 
and numbers is that you don’t have to worry 
about inserting tab characters or setting 
the left and fi rst line indents. The Bullet or 
Number Position area lets you control those 
positions.

To set the position of bullets or numbers:

1. Open the Bullets and Numbering 
dialog box.

2. Use the Alignment list to choose Left, 
Center, or Right alignment  D .

TIPTIP Use the Right alignment for numbers so that 
double-digit numbers align correctly.

3. Use the Left Indent field to set how the 
left margin of the text is indented.

4. Use the First Line Indent field to set 
how the first line should be indented 
separately from the left indent.

5. Use the Tab Position field to set the 
position of the first character after the 
bullet or number.

There may come a time when you want the 
automatic bullets or numbers to become 
ordinary text and stop responding to the 
automatic controls.

To convert bullets or numbers to ordinary 
text:

1. Select the text.
2. Choose Type > Bulleted & Numbered 

Lists > Convert [Bullets or Numbering] 
To Text.

TIPTIP Use this command if you are going to export 
the text or save the document to a previous 
version of InDesign.

 D  The  Position controls  of the Bullets 
and Numbering dialog box.

Bullets and Numbers in This Book

You can see the results of using automatic bul-
lets and numbered lists throughout this book.

All the numbered lists have been set with auto-
matic numbering. This makes it possible to insert 
new items in a list without having to go back and 
renumber all the other steps.

It also has meant I can move list items around 
quickly and easily.

I also use automatic bullets for all the bulleted 
lists in the book.
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Footnotes

Footnotes are the tiny reference markers 
inserted into text that correspond to com-
ments usually inserted at the bottom of that 
column of text. InDesign makes it easy to 
insert, format, and update footnotes.

To insert a footnote into text:

1. Position the insertion point where you 
want the footnote reference to appear.

2. Choose Type > Insert Footnote. The 
reference appears in the text and the 
insertion point appears in the footnote 
position at the bottom of the text  A .

3. Type or paste the text for the footnote.

You can also format the style for the reference 
and the footnote.

To format the style of the footnote:

1. Choose Type > Document Footnote 
Options.

2. Click the Numbering and Formatting tab 
to display those options  B .

3. Use the Style list to choose Roman or 
Arabic numerals, symbols, letters, or 
asterisks for the reference  C .

4. Use the Start At field to set what number 
the footnotes should start with.

5. If desired, click the options for Restart 
Numbering Every and then choose Page, 
Spread, or Section.

6. If desired, turn on the option for Show 
Prefix/Suffix in and then choose Footnote 
Reference, Footnote Text, or Both 
Reference and Text.

7. Use the Prefix field to choose a special 
character or to type in your own prefix for 
the reference.

8. Use the Suffix field to choose a special 
character or to type in your own suffix for 
the reference.

According to Littlefield, Baum wrote the book as a parable 
of the Populists, an allegory of their failed efforts to reform 
the nation in 1896.1 Scholars soon began to find additional 
correspondences between Populism and The Wonderful 
Wizard of Oz. Richard Jensen, in a 1971 study of Mid-
western politics and culture, devoted two pages to Baum’s 
story.2

1 Littlefield, “Parable on Populism,” 50, 58.
2 Richard Jensen, The Winning of the Midwest: Social and 

Political Conflict, 1888-1896 (Chicago, 1971), 282-83.

 A   Footnotes within text  allow you 
to easily insert reference markers 
and the footnote text.

Reference Footnote

 B  The  Numbering controls  of the 
Footnote Options dialog box.

 C  The  Style options  for the 
footnote reference.
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You can also control the appearance of the 
reference and the footnote text. 

To format the reference:

1. Click the Numbering and Formatting tab 
to open the Formatting controls  D .

2. Use the Position list to Apply Superscript, 
Apply Subscript, or Apply Normal 
position.

3. Use the Character Style list to apply a 
previously defined character style.

To format the footnote:

1. Click the Numbering and Formatting tab 
to open the Formatting controls  D .

2. Use the Paragraph Style list to apply a 
previously defined paragraph style.

3. Use the Separator field to enter a tab or 
space between the footnote reference 
and the footnote text.

TIPTIP You can enter your own character in this field, 
as well as have multiple characters in the 
field.

You can also control the appearance and posi-
tion of the layout of the footnote.

To control the spacing options for the 
footnote:

1. Click the Layout tab of the Footnote 
Options dialog box to open the Layout 
controls  E .

2. Use the Minimum Space Before First 
Footnote field to control how much space 
separates the bottom of the column and 
the first footnote. 

3. Use the Space Between Footnotes field 
to control the distance between the last 
paragraph of one footnote and the first 
paragraph of the next.

 D  The  Formatting controls  of the 
Footnote Options dialog box.

 E  The  Layout controls  of the 
Footnote Options dialog box.
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You can also control the position of the fi rst 
baseline of the footnote.

To set the fi rst baseline of the footnote:

1. Use the Offset list to choose the vertical 
alignment for the baseline.

2. Use the Min. field to increase or decrease 
this setting.

To set the placement options:

1. Select Place End of Story Footnotes at 
Bottom of Text to force a footnote that 
appears at the end of a story to the 
bottom of the text frame.

2. Select Allow Split Footnotes to permit 
long footnotes to flow from their original 
column to the next.

To set the controls for the footnote rule:

1. Choose if a separator rule is applied to 
one of the following:
 • First Footnote in Column applies the 

rule to the first footnote in the text 
column  A .

 • Continued Footnotes applies the rule 
to footnotes that are continued from 
previous columns or pages  A .

2. Select the Rule On checkbox to apply 
the rule.

3. Use the rest of the controls to style the 
appearance of the rule.

 A  The  Rule Above controls  for footnotes.

Importing Footnotes from 
Microsoft Word

When you import Word documents, the Word 
Import Options dialog box lets you import 
footnotes and endnotes.

The footnotes in Word documents are converted 
into electronic footnotes in InDesign docu-
ments.

Endnotes, however, are imported as ordinary 
text. This means that although you may see the 
reference in the text and the note at the end of 
the story, there is no electronic link between 
the reference and the note. Unlike electronic 
footnotes, if you delete the reference, you won’t 
delete the endnote at the end of the text.
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Creating Tagged Text

If you import text from Microsoft Word, 
InDesign reads the paragraph and character 
styles applied in Word. But what happens if 
you want to import text from an application 
such as a database that doesn’t have style 
sheets? Tags let you add the codes for styles  B  
so that the correct formatting imports with 
the text  C .
You can learn the correct tags for diff erent 
formatting by exporting tags from InDesign.

To export tags from InDesign:

1. Select the text you want to export.
2. Choose File > Export.
3. Choose Adobe InDesign Tagged Text from 

the Save as File Type (Win) or Format 
(Mac) menu.

4. Click Save. The Adobe InDesign Tagged 
Text Export Options dialog box appears  D .

5. Choose the type of tag:
 • Verbose shows the longer version of 

the tags.
 • Abbreviated shows the short version 

of the tags.
6. Choose the type of encoding  E :

 • ASCII, for most English language files.
 • ANSI, for most international characters.
 • Unicode, a standard for most 

languages.
 • Shift_JIS, for Japanese characters.
 • GB 18030, for Chinese characters.
 • Big 5, for Taiwan and Hong Kong 

traditional Chinese characters.
 • KSC5601, for Korean characters.

 B  The  tagged text codes  as they 
appear outside InDesign.

 C  The same text as it appears 
on the InDesign page.

 D  The  Export Options dialog box  for 
setting the Tagged Text options.

 E  The  Encoding menu  for how tagged 
text should be exported.
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You can import tagged text as ordinary text. 
However, there are some special import 
options for tagged text.

To import tagged text:

1. Choose File > Place.
2. Navigate to find the text-only file with the 

tagged text codes.
3. If you want to control how the text is 

placed, click Show Import Options.
4. Click Open. The Adobe InDesign 

Tagged Text Import Options dialog box 
appears  A .

The tagged-text import options control how 
any confl icts and missing tags are treated  B .

To set tagged-text import options:

1. Select Use Typographer’s Quotes to 
import text with the proper smart quotes.

2. Select Remove Text Formatting to import 
the text without any local formatting 
applied.

3. Use the Resolve Text Style Conflicts 
Using list to choose how to treat conflicts 
between the styles in the original 
document and those in the tagged text 
file. (See Chapter 15, “Styles,” for more 
information on working with styles.)
 • Publication Definition uses the style as 

it is already defined in the document.
 • Tagged File Definition uses the style 

as defined in the tagged text. This adds 
a new style to the document with the 
word “copy” added to the style name.

4. Select Show List of Problem Tags before 
Place to display a list of incorrect or 
unrecognized tags.

 B  The  Resolve Text Style Confl icts Using 
menu  lets you determine how two 
confl icting styles should be resolved.

 A  The  Adobe InDesign Tagged Text 
Import Options dialog box  controls 
how tagged text is imported.
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Using Find Font

In addition to the Find/Change commands for 
text, InDesign lets you make global changes 
for font families. This helps if you open docu-
ments that contain missing fonts.

To make changes using Find Font:

1. Choose Type > Find Font. The Find Font 
dialog box appears  C .

2. Select the font that you want to change.

TIPTIP The icons next to each font display the type of 
font and its status  D .

3. Use the Replace With controls to choose a 
replacement for the selected font.

4. Click Find First to find the first instance 
of the font. InDesign highlights the first 
place the font is used.

TIPTIP When you find the first instance, the Find First 
button changes to Find Next.

5. Click one of the following options:
 • Find Next skips that instance.
 • Change replaces that instance.
 • Change/Find replaces that instance 

and finds the next instance.
 • Change All changes all the instances of 

the font.
6. Use the More Info button to find more 

information, such as if the fonts can be 
embedded in PDF documents  E .

7. Use the Reveal in Finder (Mac) or Explorer 
(Windows) button to locate where the 
font is on the computer.

To replace missing fonts:

1. Open the document. If fonts are missing, 
an alert box appears.

2. Click Find Font to open the Find Font 
dialog box.

3. Choose the missing font and follow the 
steps in the previous exercise.

 C  The  Find Font dialog box  lets you make 
global changes to the fonts in a document.

 E  The  Info area  of the Find Font dialog box 
gives you more information about the font.

 D  The  Find Font icons  tell you the status 
and type of fonts used in the document.

Missing font

OpenType font

Type 1 font

TrueType font

Font in graphic
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Keeping Lines Together

Another automation technique is to specify 
how many lines of text must remain together 
in a column or page. InDesign does this using 
the Keep Options controls.

To set the keep options for a paragraph:

1. Choose Keep Options from the Paragraph 
panel menu. This opens the Keep Options 
dialog box  A .

2. Enter a number in the Keep With Next 
Lines field to force the last line in a 
paragraph to stay in the same column or 
page with the specified number of lines.

TIP This option ensures that subheads or titles 
remain in the same column as the body copy 
that follows.

3. Click Keep Lines Together and set one of 
these options  B :
 • All Lines in Paragraph prevents the 

paragraph from ever breaking.
 • At Start/End of Paragraph lets you set 

the number of lines that must remain 
together for the start and the end of 
the paragraph.

4. Use the Start Paragraph menu to choose 
where the lines must jump to  C .
 • Anywhere allows the text to jump 

anywhere.
 • In Next Column forces the text to the 

next column or page.
 • In Next Frame forces the text to the 

next frame or page.
 • On Next Page forces the text to the 

next page.
 • On Next Odd Page forces the text to 

the next odd-numbered page.
 • On Next Even Page forces the text to 

the next even-numbered page.

 B  The  Keep Lines Together controls  
of the Keep Options dialog box.

 C  The  Start Paragraph list  lets 
you choose where the next lines 
of the paragraph appear.

 A  The  Keep Options dialog box  controls how 
paragraphs break across columns or pages.
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Using the Eyedropper on Text

The Eyedropper tool lets you quickly grab 
the formatting from one part of the text and 
apply it to another. 

To set the eyedropper options for text:

1. Double-click the Eyedropper tool in the 
Tools panel  D . This opens the Eyedropper 
Options dialog box.

2. Click the triangle control to open the 
Paragraph Settings from the list  E .

3. Select which paragraph attributes you 
want the Eyedropper tool to sample.

4. Click the triangle control to open the 
Character Settings from the list  F .

5. Select which character attributes you 
want the Eyedropper tool to sample.

 D  The  Eyedropper tool in the 
Tools panel  lets you sample 
and apply text formatting.

 E  The  Eyedropper Options dialog 
box  contains the controls for text 
as well as object styling.

 F  Use the checkboxes to set the  Paragraph 
Settings or the Character Settings .
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Once you have set the eyedropper options, 
you can sample and apply paragraph or char-
acter attributes. 

TIP Deselect the text frame as you use the 
Eyedropper tool to avoid styling the text 
frame itself.

To sample and apply paragraph attributes:

1. Choose the Eyedropper tool.
2. Click the white eyedropper inside the 

para graph that you want to sample  A . The 
eyedropper changes from white to black.

3. Click the black eyedropper inside the 
paragraph that you want to change  B . 
This changes the paragraph attributes.

TIP The black eyedropper does not apply 
character attributes when clicked unless a 
paragraph style was already applied to the 
sampled text.

4. Click the eyedropper inside any additional 
paragraphs that you want to change.

To sample and apply character attributes:

1. Choose the Eyedropper tool.
2. Click the white eyedropper inside the 

text that you want to sample  C . The 
eyedropper changes from white to black.

3. Drag the black eyedropper across the 
exact text you want to change. This 
highlights the text  D .

4. Release the mouse button to apply the 
changes.

To sample new text attributes:

1. Hold the Opt/Alt key as you click the 
Eyedropper tool. The Eyedropper cursor 
changes to white.

2. Click the eyedropper inside the new text 
that you want to sample.

 A  Click the white eyedropper to sample the 
right alignment of the paragraph attributes.

 B  Click the black eyedropper to apply the 
right alignment of the paragraph attributes.

 C  Click the white eyedropper to sample 
local character attributes.

 D  Drag the black eyedropper to apply 
character attributes to text.
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Using Scripts

Perhaps the most powerful way to automate 
working in InDesign is with AppleScripts 
on the Macintosh or VisualBasic scripts in 
Windows. You can also use JavaScripts, which 
work on both platforms. Although you need 
to know code to write scripts, it’s very easy to 
run scripts in InDesign. Writing code is much 
too diffi  cult for me. Running scripts is totally 
easy. (Honestly, if I can do it, anyone can!)

To run scripts in InDesign:

1. Place the script file or the folder 
containing the script file inside the 
following directory path: 
InDesign Application Folder: Scripts: 
Scripts Panel.

2. Choose Windows > Utilities > Scripts to 
open the Scripts panel  E .

3. If you have placed a folder inside the 
Scripts directory, click the triangle 
controller to open the scripts in the folder.

4. Double-click the script that appears in the 
panel. This prompts the start of the script.

TIPTIP Certain scripts require an object or text to be 
selected. Follow any onscreen prompts that 
occur.

TIPTIP You can also assign keyboard shortcuts to run 
scripts. Choose Edit > Keyboard Shortcuts to 
open the dialog box.

 E  Use the  Scripts panel  to run 
scripts from within InDesign.

My Favorite Script

My favorite script was written for me by 
Peter Truskier of Premedia Systems (www.pre-
mediasystems.com). This script automates the 
process of creating the special spotlight used on 
certain screen shots in this book.

With Peter’s marvelous script, I can do in just a 
single click that which used to take me almost 
a minute for each illustration. Ordinarily, it costs 
big bucks to hire people to write scripts for you, 
but if you go to the Adobe Studio Exchange 
(www.adobestudioexchange.com), you will find 
other similarly wonderful scripts that are free to 
download.

www.premediasystems.com
www.premediasystems.com
www.adobestudioexchange.com
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Styles
A while back I taught InDesign to a 

group of designers that included a 
young woman who was responsible for 
a yearly 100-page catalog of her com-
pany’s products. When I got to the part 
of the class where I showed what text 
styles could do, she began to cry.

I’d never had a student cry in a class, so I 
was concerned. “What’s wrong?” I asked. 

It took her a while to speak, but she 
eventually explained that it was “those 
styles.” Turns out she had never been 
taught what styles did and she had been 
formatting the thousands of entries in 
the catalog by hand.

She now realized just how much 
time she could have saved by using 
text styles. Of course, this was before 
InDesign added object styles. And even 
more before table styles.

I dedicate this chapter to all of you who 
have been slaving away, working with-
out text, object, and table styles. May 
the techniques you learn here bring 
smiles, not tears, to your faces. 
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Working with Paragraph Styles

InDesign has two types of text styles. Para-
graph styles apply formatting for both charac-
ter and paragraph attributes. Character styles 
apply formatting for only character attributes.

To open the Paragraph Styles panel:

Choose Window > Styles > Paragraph 
Styles.

The Basic Paragraph style is the style that is 
automatically applied to new text  A . If you 
change the defi nition of the Basic Paragraph 
style, it automatically updates all text that has 
been styled with that style.

To set the Basic Paragraph by example:

1. Select some text and use any of the 
formatting controls to change the text 
attributes.

2. A plus sign (+) appears next to the 
Basic Paragraph listing in the Paragraph 
Styles panel  B . This indicates that local 
formatting has been applied to the Basic 
Paragraph.

3. Choose Redefine Style from the 
Paragraph Styles panel menu. This 
changes the definition of the Basic 
Paragraph to match the local formatting. 
The plus sign disappears.

To set the Basic Paragraph by defi nition:

1. Double-click the Basic Paragraph listing in 
the Paragraph Styles panel. This opens the 
Paragraph Styles Options dialog box.

2. Make whatever changes to the style 
definition you like as explained on the 
following pages.

3. Click OK to make the changes.

TIP The Basic Paragraph style can be modified 
but not deleted.

 A  The  Basic Paragraph  is the default style 
that appears in all new documents.

 B  The  plus sign (+) next to the style 
name  indicates that local formatting 
has been applied to the text.
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You can use the Paragraph Styles panel to 
defi ne new paragraph styles for a document.

To defi ne a paragraph style manually:

1. Choose Window > Styles > Paragraph 
Styles. This opens the Paragraph Styles 
panel  C .

2. Choose Paragraph Style Options from the 
Paragraph Styles panel menu.
or
Opt/Alt-click the New Style icon in the 
Paragraph Styles panel. This opens the 
New Paragraph Style dialog box set to the 
General options  D .

3. Use the Style Name field to name the 
style.

4. Set the Based On, Next Style, and 
Shortcut options as described later in 
this chapter.

5. Click each category on the left side of the 
dialog box and set the criteria for each 
one  E . (These categories are the same as 
the character and paragraph formatting 
described in Chapter 3, “Basic Text.”)

6. Click OK to define the style. The name of 
the style appears in the Paragraph Styles 
panel.

 D  The  Paragraph Style Options dialog 
box  set to the General options.

 E  Click  each category 
in the Paragraph 
Styles dialog box  
to set the format 
of the style.

 C  The  Paragraph Styles panel  lets you 
defi ne and apply paragraph styles.

Clear Overrides Delete Style

New Style Group New Style
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The easier way to defi ne a style is to format 
the selection and defi ne the style by example.

To defi ne a paragraph style by example:

1. Select some text.
2. Use any of the commands to format 

the text.
3. Leave the insertion point in the 

formatted text.
4. Open the Paragraph Styles panel. 
5. With the insertion point blinking in the 

formatted text, click the New Style icon. 
This adds a new style to the Paragraph 
Styles panel.

TIP Select the Apply Style to Selection checkbox 
to apply the newly named style to the text 
originally selected.

TIP Double-click to rename the style created by 
the New Style icon.

The Next Style command for paragraph styles 
has two features. For typists who enter text 
directly into InDesign, it allows you to auto-
matically switch to a new style as you type 
text. For instance, as I type this paragraph, I 
press the paragraph return after the period. 
This automatically switches to the next style, 
which is the exercise header.

To set the next paragraph style:

1. Select the General category in the 
Paragraph Style Options dialog box.

2. Choose a style from the Next Style list in 
the Paragraph Style Options dialog box  A . 
The chosen style is applied to the next 
paragraph when you press the Return 
key  B .
or
Choose Same Style from the Next Style 
list  A . This retains the original style until 
you manually change the style.

 A  The  Next Style menu  lets you choose 
[Same Style] or an already defi ned style.

 B  The  Next Style command  changes the 
paragraph style when the Return key is 
pressed. The  Same Style command  keeps 
the style when the return is pressed.

Next style 
applied

Same style 
applied
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The Next Style feature does even more magic 
when you use it to apply the next style to 
selected text. This allows you to format many 
paragraphs in one simple click.

To apply the Next Style to multiple 
paragraphs:

1. Highlight the text that you want to style.
or
Select the text frame that contains the 
text that you want to style.

2. Position your cursor over the name of the 
paragraph style that you want to apply to 
the first paragraph.

3. Right-click (Windows) or Control-click 
(Mac) the name of the style. A contextual 
menu appears  C .

4. Choose Apply “name of style” then Next 
Style. This styles the text according to the 
Next Style controls  D . 

TIPTIP The command to apply the Next Style is only 
available if a Next Style has been defined for 
the paragraph style. If the style has Same 
Style for the Next Style, then the contextual 
menu will not display the Next Style option.

 C  The  contextual menu over a style 
name  allows you to apply a paragraph 
style and then the Next Style to 
the rest of the selected text.

FRIDAY 
The Princess Bride (1987) Directed by: 
Rob Reiner

SATURDAY 
On the Waterfront (1954) Directed by: 
Elia Kazan

SUNDAY 
The Wizard of Oz (1939) Directed by: 
Victor Fleming, Richard Thorpe
 D  An example of how the  Next Style 

command  applies the style for the 
day. This changes to the movie listing 
and then back to the day, and so on.
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Working with Character Styles

Character styles allow you to set specifi c 
attributes that override the paragraph style 
character attributes. For instance, this bold 
text was set by applying a character style to 
the paragraph style.

To open the Character Styles panel:

Choose Window > Styles > Character 
Styles.

To defi ne a character style:

1. Open the Character Styles panel  A .
2. Choose New Character Style from the 

Character Styles panel menu. This opens 
the New Character Style dialog box  B .

3. Name the style.
4. Set the Based On and Shortcut controls as 

described later in this chapter.
5. Click each category to set the character 

attributes  C .
6. Click OK to define the style. The name of 

the style appears in the Character Styles 
panel.

TIP Select Apply Style to Selection to apply the 
newly named style to the text originally 
selected.

You can also format the text and then defi ne 
a character style by example.

To defi ne a character style by example:

1. Select some sample text.
2. Format the text.
3. Leave the insertion point in the newly 

formatted text. 
4. Choose Window > Styles > Character 

Styles. 
5. Click the New Style icon. This adds a new 

style to the Character Styles panel.

 B  The  New Character Style dialog box  
lets you specify settings for each of 
the categories for character styles.

 C  Click each  category 
in the New 
Character Style 
dialog box  to set the 
format of the style.

 A  The  Character Styles panel  lets you 
defi ne and apply character styles.

New style

New style groupNew style group Delete style
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Working with Styles

The great thing about styles is that once 
you understand the basics of paragraph and 
character styles, you also know the basics 
for object and table styles. However, rather 
than wait till the end of this chapter to cover 
working with styles, I’m going to cover those 
techniques now. You can then use these tech-
niques for the other types of styles.
Basing one style on another makes it easy to 
coordinate multiple text styles.

TIPTIP You can only base like styles on each other 
(paragraph on paragraph or character on 
character).

To base one style on another:

1. Start with at least one style.
2. Open the New Style dialog box to define 

a new style.
3. From the Based On pop-up menu, 

choose the style you want to use as the 
foundation of the new style.

4. Make changes to define the second style’s 
attributes.

TIPTIP The changes to the second style are displayed 
in the Style Settings area  D .

TIPTIP Any changes you make later to the original 
style also affect the second style.

If you have based one style on another, at 
some point you may want to remove any 
changes to the style so that it is like the fi rst. 

To reset to the base style:

Click the Reset To Base button.

You can also set the text so that it no longer is 
governed by the style.

To break the link to a style:

Choose Break Link to Style from the Styles 
panel menu.

 D  When you base a new style on an 
existing style, you can see how they 
diff er in the  Style Settings fi eld  of the 
New Character Style dialog box.

Basing Styles

The style for the numbers of the exer-
cises in this book is based on the style of 
the subheads. If I change the style for 
the subheads, the number style and the numbers 
change automatically.

Similarly, the style for the exercises is based on 
the style for the body copy. So if my publisher 
asks me to make the copy a little smaller, I only 
have to change the point size for one style.

Limit how many levels you go when you base 
one style on another. Theo retically, you can base 
one style on another, which is based on another, 
which is based on another, and so on. However, 
this can be confusing if you go down too many 
 levels.

I always use one style as the main one and base 
others on it. I think of the main style as the hub of 
a wheel, and the others are the spokes around it.
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Rather than create a new style from scratch, 
it may be easier to duplicate an existing style 
and then redefi ne it. 

To duplicate a style:

1. Select the style.
2. Drag the style onto the New Style icon in 

the Styles panel.
or
Choose Duplicate Style from the Styles 
panel menu.

To sort styles:

Drag the style to the position where you 
want it to be.
or
Choose Sort by Name from the Styles 
panel menu.

You can also set keyboard shortcuts for styles. 
This makes it easy to apply styles as you type.

To set style keyboard shortcuts:

1. Open the New Style dialog box.
or
Double-click the name of the style to 
open the Style Options dialog box.

2. Click in the Shortcut field.
3. Press a keyboard modifier plus a number 

from the number pad. The keyboard 
modifiers can be a combination of one or 
more of the following keys:
 • Cmd (Mac) or Ctrl (Win) keys
 • Shift key
 • Opt (Mac) or Alt (Win) keys

TIP In Windows, the Num Lock key must be 
turned on to set and apply keyboard 
shortcuts.

TIP The keyboard shortcut appears next to the 
style name in the Styles panel  A .

 A  The  keyboard shortcut for a style  is 
listed next to the name of the style.

Style Guidelines

I like to arrange my styles by function in the 
Styles panel. For instance, the styles that are 
applied only on master pages are grouped 
together; the styles for sidebars are grouped 
together. Rather than drag the styles all around, 
I use the Sort by Name command to do the work 
for me.

For instance, I have three different paragraph 
styles for the numbered lists in this book. Each 
style starts with the name List and is followed by 
a descriptive word, such as List Header, List Item, 
List Item Bulleted, and so on. So when I sort the 
styles by name, the styles automatically group 
together. (I haven’t used the style group fold-
ers as I have some troubles remembering the 
proper naming conventions for working with 
those style groups.)

If you use keyboard shortcuts, keep them in 
groups. For instance, the styles for the list items 
all use the keypad number 2 with variations 
of the keyboard modifiers. So List Item Plain is 
Shift-2, while List Item Body is Shift-Cmd/Ctrl-2.
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Creating Style Groups

Just as you can create folders to organize fi les 
on your computer, so can you create folders 
(style groups) that allow you to organize your 
styles. Style groups are available for all types 
of styles.

To create a style group:

1. Click the New Style Group icon in the 
Styles panel. A new style group folder 
appears   B  .
or
Choose New Style Group from the Styles 
panel. The Style Group Options dialog box 
appears  C .
or
Opt/Alt-Click the New Style Group icon in 
the Styles panel. The Style Group Options 
dialog box appears.

2. You can double-click a style group 
folder to open the Style Group Options 
dialog box.

3. Choose a name for the style group and 
click OKOK.

TIPTIP If a style is in a style group, the group appears 
next to the word Location in the Styles dialog 
box  D .

To move styles into a style group:

1. Select the styles you wish to move.
2. Drag them into the style group folder.

TIPTIP You can also select several styles and choose 
New Group from Styles in the Styles panel 
menu to create a group and put the styles in 
the folder at once.

TIPTIP Select the styles and choose Copy to Group 
from the Styles panel menu to make copies of 
those styles in a style group.

 C  The  Style Group Options dialog 
box  lets you name a style group.

 D  A style in a style group has a name in the 
 Location area  of the Styles dialog box.

 B  The  style groups  as they 
appear in a Styles panel.

Styles in groupStyles not in group

Open style groupClosed style group

Style Names in Style Groups

When you put styles in a style group, their name 
changes invisibly. For instance, I can have only 
one style named Tip at the top level of the Styles 
panel.

But as soon as I put the Tip style into a style 
group, I can now have another style named Tip 
at the top level of the panel. I can also have other 
styles named Tip in other style groups.

Each of these Tip styles is independent of the 
other styles and they can each have different 
definitions.
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Loading and Importing Styles

You can transfer or load styles from one docu-
ment into another.

To transfer text styles into an InDesign 
document:

1. Choose one of the following from the 
Paragraph or Character Styles panel 
menus:
 • Load Character Styles transfers the 

character styles.
 • Load Paragraph Styles transfers the 

paragraph styles.
 • Load All Text Styles transfers both 

character and paragraph styles.
2. Navigate to find the document with the 

text styles you want to import.
3. Click Open. The text styles are added to 

the current document.

TIP Text style names are case-sensitive. Therefore, 
a paragraph style name of Body Text will be 
added as a separate style to a document that 
already has a paragraph style named body 
text  A .

To transfer other styles into an InDesign 
document:

1. Choose Load [type of ] Styles from the 
Styles panel menu.

2. Navigate to find the document with the 
styles you want to import.

3. Click Open. The styles are added to the 
current document.

 A   Style names are case sensitive , so 
two styles can be listed by the same 
name but diff erent character cases.

How Many Styles?

I was taught to create a unique style for each 
type of element in my document. For instance, 
I might have a paragraph that I use in these 
sidebars that looks identical to the paragraph 
I use in the regular body text.

Some people might be tempted to define only 
one style and apply it to both paragraphs. That’s 
not how I work. Instead, I have a unique para-
graph style for each type of element.

There are two reasons for this. The first reason is 
that if I ever decide to change the appearance 
of one type of paragraph, I have that flexibility. 
The other reason comes from using styles as the 
tags that give my document structure.

With this type of structure applied to the text, 
I can export the text and reuse it in an XML 
workflow. While XMLXML is way beyond the scope 
of this book, the concept of tagging each type 
of element with its own style is a good practice 
to learn.
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When you load styles from one document to 
another, there may be times when the styles 
coming into the document have the same 
name, but diff erent defi nitions. This is called a 
style confl ict. When this happens you need to 
resolve the confl ict between the styles.

To resolve style confl icts:

1. Choose one of the Load Styles commands. 
If there are conflicts, the Load Styles 
dialog box displays the incoming styles 
that have the same name as the existing 
styles  B .

2. Select the styles that you want to load 
into the document, and resolve the 
conflict  C .
or
Deselect the styles that you don’t want to 
load into the document.

TIPTIP Use the Check All or the Uncheck All button to 
quickly make choices in a long list of styles.

3. For all the selected styles choose one 
of the following from the Conflict With 
Existing Style menu  D :
 • Auto-Rename imports the style with 

a suffix to differentiate it from the 
existing style.

 • Use Incoming Style Definition 
changes the existing style to match the 
imported style definition.

 B  The  Load Styles dialog box  
allows you to choose how style 
confl icts should be resolved.

 C   A check mark next to the style name 
 indicates the incoming style defi nition 
should be resolved.  No check mark  indicates 
the existing style defi nition should be used.

 D  Use the  Confl ict With Existing Style 
menu  to resolve a style confl ict.
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Importing Text Styles from 

Word

When you place text from word process-
ing programs such as Microsoft Word into 
InDesign, the text styles from the imported 
text are added to the document.

To import styles in Microsoft Word text:

1. Choose File > Place and navigate to find 
the Word file you want to import.

2. Select Show Import Options and click 
Open. This opens the Microsoft Word 
Import Options dialog box  A .

3. Select Preserve Styles and Formatting 
from Text and Tables.

4. Select Import Styles Automatically or 
select Customize Style Import.

If you chose to import the styles automati-
cally, you can choose how style confl icts are 
resolved.

To resolve style confl icts automatically:

1. To resolve paragraph style conflicts, 
choose one of the following from the 
Paragraph Style Conflicts menu  B :
 • Choose Use InDesign Style Definition 

to have the InDesign style override the 
incoming style.

 • Choose Redefine InDesign Style to 
have the incoming style override the 
InDesign style.

 • Choose Auto Rename to add the 
incoming style to the list of styles in the 
InDesign Styles panel.

2. To resolve character style conflicts, choose 
from the Character Style Conflicts menu.

TIP A disk icon indicates the style definition came 
from the imported text  C .

TIP The disk icon disappears if you modify the 
imported style.

 A  The  Microsoft Word Import Options 
dialog box  allows you to control how 
styles are imported from Word fi les.

 B  Use the  Paragraph Style Confl icts 
 or  Character Style Confl icts menu 
 to resolve a style confl ict.

 C  The  disk icon  indicates that the style 
defi nition came from an imported text fi le.
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What if you have a style name in Word that 
is totally diff erent from the name of the style 
in the InDesign document? You need a way 
to tell InDesign which existing style to apply 
to the Word text. The custom style mapping 
controls let you change an incoming style to a 
specifi c existing style.

To map one style to another:

1. In the Microsoft Word Import Options 
dialog box, select Customize Style 
Import  D . This makes the Style Mapping 
button available.

2. Click the Style Mapping button. This 
opens the Style Mapping dialog box  E .

3. Under the InDesign Style column, choose 
one of the styles from the pop-up menu 
for each of the incoming Word styles  F .

4. Click OK to close the Style Mapping 
dialog box.

5. Click OK in the Microsoft Word Import 
Options dialog box to import the text.

TIPTIP Only paragraph styles are shown in the pop-
up menu for incoming Word paragraph styles. 
Similarly, only character styles are shown 
in the pop-up menu for incoming Word 
character styles.

 D  Choose Customize Style Import to 
click the  Style Mapping button .

 E  The  Style Mapping dialog box  lets 
you choose how each Microsoft 
Word style should be applied.

 F  The  style choices list  lets you map one style 
to another. Here the Word style  answer  has 
been mapped to the InDesign style  body .
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Applying Styles and Style 

Overrides

Defi ning styles is just half of the process. You 
reap the benefi ts of your planning when you 
apply styles.
You can apply paragraph and character styles 
as you type new text, or you can add the 
styles to existing text  A .

To apply paragraph styles:

1. Select the paragraphs.

TIP You do not need to select entire paragraphs. 
As long as a portion is selected, the 
paragraph style will be applied to the entire 
paragraph.

2. Click the name of the paragraph style or 
type the keyboard shortcut.

You can override the paragraph style by 
applying a character style or local formatting.

To apply local formatting:

1. Select the text.
2. Use the Control panel or Character panel 

to format the text.

TIP A plus (+) sign next to the paragraph style 
name indicates that local formatting has 
been applied to the text  B .

Rather than use local formatting, I prefer to 
use character styles on text. That way if I want 
to make changes later on, I can just redefi ne 
the character style.

To apply character styles:

1. Select the text.

TIP You must select all the text you want to 
format with a character style.

2. Click the name of the character style or 
type the keyboard shortcut.

 A  An example of paragraph and 
character styles applied to text.

Paragraph style

Character styles

Character Style Strategies

InDesign character styles only need to be 
defined with a single change from the para-
graph attributes.

For instance, if you want to change text to italic, 
define a character attribute with just italic as the 
definition.

You can then apply the italic character attribute 
to many different paragraph styles, even if they 
are different typefaces or point sizes.

 B  A  plus sign next to the paragraph 
style  indicates that local overrides 
have been applied.
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Clearing Style Overrides

When you apply local formatting or character 
styles, you have diff erent ways to clear those 
style overrides.
You can use the Clear Overrides button to 
clear the overrides in a text selection.

To clear the local formatting in a text 
selection:

1. Select the text you want to clear.
2. Click the Clear Overrides button in the 

Paragraph Styles panel  B . This changes 
the local formatting in the selection to 
the underlying paragraph style.

You may fi nd that you want to clear just the 
character attributes that were applied as 
local formatting, but you want to keep any 
paragraph attributes.

To clear only local character formatting in a 
text selection:

1. Select the text you want to clear.
2. Hold Cmd/Ctrl and click the Clear 

Overrides button. This changes the local 
character formatting in the selection to 
the underlying paragraph style.

 B  The  Clear Overrides button  lets you 
remove local formatting applied to text.

A Summary for Clearing Overrides

To do this: Do this:

Clear all the local formatting in a selection Select the text and click the Clear Overrides button

Clear just the local character formatting in a 
selection

Hold Cmd/Ctrl and click the Clear Overrides 
button

Clear just the local paragraph formatting in a selec-
tion

Hold Cmd/Ctrl-Shift and click the Clear Overrides 
button

Clear all the local formatting applied to a 
paragraph

Hold Opt/Alt and click the name of the paragraph 
style

Clear all the local formatting and any character 
styles applied to a paragraph

Hold Opt/Alt-Shift and click the name of the 
paragraph style
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The opposite to the previous exercise allows 
you to clear just the paragraph attributes that 
were applied as local formatting, but keep 
any character attributes.

To clear only local paragraph formatting in 
a text selection:

1. Select the text you want to clear.
2. Hold Cmd/Ctrl-Shift and click the Clear 

Overrides button. This changes the local 
paragraph formatting in the selection to 
the underlying paragraph style.

You can also remove all local formatting with-
out making a specifi c text selection.

To override local formatting:

1. Place your insertion point in the 
paragraph you want to override.

2. Hold the Opt/Alt key as you click the 
name of the paragraph style  A .

You may want to clear the character styles 
and local formatting applied to the text.

To override character styles and local 
formatting:

1. Place your insertion point in the 
paragraph you want to override.

2. Hold the Opt/Alt and Shift keys as you 
click the name of the paragraph style. This 
deletes both the character styles and the 
local formatting applied to the text  B .

To break the link to a style:

1. Place your insertion point in the 
paragraph you want to override.

2. Choose Break Link to Style from the 
Paragraph Styles or Character Styles 
panel. This removes the style from the 
text, but does not change the formatting.

 A   Opt/Alt-click a paragraph style name  to 
remove any local formatting applied to text.

Original text with local 
formatting

Opt/Alt-click removes local 
formatting

 B  Press  Opt/Alt-Shift and click a 
paragraph style name  to remove 
character styles and local formatting. 

Original text with character 
style applied

Opt/Alt-Shift-
click removes 
character style
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Redefining and Deleting Styles

One of the advantages of using text or other 
styles is that when you redefi ne the style, it 
changes all the existing text or objects that 
have that style applied to it.

To redefi ne a style:

1. Double-click the style name in the panel. 
This opens the Style Options dialog 
box, where you can change the style 
attributes.

2. Click OK. The style is redefined, and text 
and objects that have the style applied 
are modified to reflect the new definition 
of the style.

To redefi ne a style by example:

1. Select the text or objects that have the 
style applied.

2. Use the commands to make any changes 
to the text or objects.

TIPTIP A plus (+) sign appears next to the style 
name.

3. Choose Redefine Style from the Styles 
panel. The style is redefined based on the 
modified example.

TIPTIP The plus (+) sign disappears.

You may have styles that you do not need in 
your InDesign document. You can shorten the 
styles list by deleting unused styles.

To delete unused styles:

1. Select the styles you want to delete.
2. Drag the styles onto the Delete Style icon.

or
Choose Delete Styles from the Styles 
panel menu.

TIPTIP Use Select All Unused to delete all the unused 
styles from a document.

A Totally Style-Driven Workflow?

I use styles religiously. Everything in my book 
has a style applied to it. There is no text that has 
local formatting applied to it. So I never see a 
plus sign in my Paragraph Styles panel.

However, most of my students are not quite as 
strict as I am. They use paragraph and character 
styles for almost all their text. The one exception 
is if they have a single word hanging around at 
the end of a paragraph. In that case they apply 
tracking to suck the work up into the previous 
lines.

That type of local formatting isn’t really so 
bad — especially since they can easily override it.
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You can also delete styles that are being used 
in the document. In that case, you have a 
choice as to how to handle the text that has 
the style applied to it.

To delete paragraph styles that are in use:

1. Select the style you want to delete.
2. Delete the style as described in the 

previous exercise. An alert box appears  A .
3. Use the pop-up menu in the alert box 

to choose [No Paragraph Style], [Basic 
Paragraph], or one of the other paragraph 
styles.

To delete character styles that are in use:

1. Select the style you want to delete.
2. Delete the style as described in the 

previous exercise. An alert box appears  B .
3. Use the pop-up menu in the alert box 

to choose [None] or one of the other 
character styles.

4. Select the Preserve Formatting checkbox 
to convert the character style into local 
formatting.

 A  The  Delete Paragraph Style 
alert box  lets you assign another 
paragraph style to deleted styles.

 B  The  Delete Character Style 
alert box  lets you assign another 
character style to deleted styles.
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Automatic Drop Cap Styling

Each chapter of this book has a drop cap that 
is not the same font as the rest of the text in 
the paragraph. This is an example of an auto-
matic drop cap with a character style.

To apply automatic drop cap character 
styling:

1. Define a character style that contains the 
formatting for the drop cap character.

2. Select the paragraph that you want to 
style with the drop cap.

3. Choose Drop Caps and Nested Styles from 
the Paragraph panel menu. The Drop Caps 
and Nested Styles dialog box appears  C .

4. Use the Lines field to set the number 
of lines that the drop cap character will 
descend into the text.

5. Use the Characters field to set the number 
of characters for drop cap characters.

6. Use the Character Style menu to choose a 
predefined character style  D .

TIPTIP If you don’t have a previously defined style, 
choose New Character Style to open the New 
Character Style dialog box. 

7. Click Align Left Edge to force the left edge 
of the character to align to the left indent 
of the text.

8. Click Scale for Descenders to scale and 
adjust the drop cap so that descenders 
don’t collide with the lines below  E .

9. Click OK. 

TIPTIP Choose the Drop Caps and Nested Styles 
category from the Paragraph Style Options 
dialog box  F  to make the drop cap part of a 
paragraph style.

 C  The  Drop Caps area  of the Drop Caps 
and Nested Styles dialog box .

 D  Use the  Character Style menu  to 
assign a character style to format 
the drop cap character.

Very soon the 
Rabbit 
noticed 

Alice, as she went hunting about, 
and called out to her in an angry 
tone, “Why, Mary Ann, what 
ARE you doing out here? 

Very soon the Rabbit 
noticed Alice, 
as she went 

hunting about, and called out 
to her in an angry tone, “Why, 
Mary Ann, what ARE you doing 
out here? 

 E  An example of how the  Scale for 
Descenders command  avoids problems 
when descenders are used in drop caps.

 F  The  Drop Caps and Nested Styles 
category  for paragraph styles allows 
you to automate drop cap characters 
as you apply a paragraph style.
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Using Nested Styles

Every once in a while I see a feature that is 
revolutionary in the fi eld of desktop publish-
ing. Nested styles are such a feature. Nested 
styles allow you to automate how character 
styles are applied to paragraphs.
Imagine you are formatting a phone direc-
tory. Each paragraph starts with a person’s 
name followed by a colon. After that comes a 
phone number, and then a new line symbol 
forces the rest of the address to the end of the 
paragraph. These are repeating elements that 
you can reliably count on to use as markers 
for formatting using nested styles.
You want the person’s name to be italic, the 
phone number to be bold, and the text after 
the new line symbol to be the regular para-
graph style.
Before nested styles, you would have had 
to manually highlight each element in the 
paragraph and apply a character style. With 
nested styles all the formatting is applied in 
one fell swoop  A !

TIP As you work with nested styles, remember 
that you need predictable elements that you 
can use as part of the automatic formatting. 
If you can’t predict where the elements will 
be in the text, you probably can’t use nested 
styles for that text.

To prepare to use nested styles:

Define all the character styles that will be 
used to apply the formatting for nested 
styles.

TIP You can only use character styles as part of 
nested styles, not local formatting from the 
Character panel.

Searching for Repeating Elements

It may seem difficult to find repeating elements, 
but they are much easier to find than you might 
think.

Consider the steps in my exercises. The numbers 
are always separated from the rest of the body 
copy by a tab character. So I can easily set the 
tab as the repeating element for a nested style.

If you are formatting any text that comes from 
databases, it is extremely easy to have the people 
who create the database add tab characters to 
divide the different parts of the text. Then you 
can use the repeating tab characters to format 
with the nested styles.

 A  An example of the kind of formatting that 
can be automated using nested styles. 
The predictable elements can be used 
to apply the automatic formatting.
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Once you have defi ned the character styles, 
you can apply them using the Nested Styles 
command.

To apply the Nested Styles command 
to text:

1. Place your insertion point inside the 
paragraph that you want to format.

2. Choose Drop Caps and Nested Styles from 
the Paragraph panel menu. The Drop Caps 
and Nested Styles dialog box appears  B .

3. Click the New Nested Style button. This 
adds a new listing under the Nested 
Styles area  C .

4. Use the Style menu to choose which 
character style will be applied to the 
repetitive element  D .

TIPTIP If you don’t have a previously defined style, 
choose New Character Style to open the New 
Character Style dialog box. 

5. Use the Duration menu to choose the 
extent to which the character style is 
applied  E :
 • Through applies the style so it includes 

the repeating character.
 • Up to applies the style so it ends before 

the repeating character.
6. Use the Count field to set how many 

repeating characters should occur before 
the character style ends.

7. Use the Repeating Element menu to 
set which element controls the nested 
style  F . 

8. Click OK to apply the nested style.
or
Click the New Nested Style button to add 
more nested styles.

TIPTIP Choose the Drop Caps and Nested Styles 
category from the Paragraph Styles dialog 
box to make the nested style settings part of 
a paragraph style.

 B  The Nested Styles area of the  Drop Caps 
and Nested Styles dialog box  allows 
you to apply multiple character styles to 
predictably occurring text elements.

 D  Click the  Style menu  to choose the 
character style that should be applied 
as the formatting for the nested style.

 C  The  New Nested Style button  creates a 
new listing in the Nested Styles area.

Style menu Duration menu Count field Repeating element

 E  Click the  Duration menu  to set the extent 
to which the formatting is applied.

 F  Click the  Repeating Element 
menu  to choose the element 
that ends the nested style.
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To change the order of multiple nested 
styles:

1. Select the nested style you want to move.
2. Click the up or down arrow to move the 

nested style to a new position  A .

What if you know your repeating elements 
are going to repeat over and over? For 
instance, you want to change from bold to 
italic after every comma. Instead of setting 
a long string of nested styles, you can loop 
them.

To loop two or more nested styles:

1. Choose Repeat from the Character Style 
list  B .

2. Set the number for how many styles 
should loop.

TIP If you type multiple characters, InDesign 
uses any of those characters as the repeating 
element.

If you don’t have any repeating element in 
the text, you can insert the End Nested Style 
Here character to control the appearance of a 
nested style.

To manually insert the End Nested Style 
Here character:

1. Place your insertion point where you 
want the End Nested Style Here character 
to appear.

2. Choose Type > Insert Special Character > 
Other > End Nested Style Here. This 
inserts the End Nested Style Here 
character into the text  C .

TIP The End Nested Style Here character can 
be seen if you choose Type > Show Hidden 
Characters.

TIP The End Nested Style Here character can be 
inserted as part of Find/Change text or GREP 
searches.

Using the End Nested 
Style Here character

When might you need to insert the End Nested 
Style Here character? Imagine that you want to 
style the last set of information in an address 
such as a zip code or postal code.

You can’t rely on a certain number of commas 
appearing before the zip code appears, nor can 
you rely on the code to only have numbers if you 
have a mixture of U.S. and European addresses.

That’s when you want to insert the End Nested 
Style Here character in front of the code.

If necessary, you can ask the editorial depart-
ment that generates the text to insert a special 
character before the code. For instance, the zip 
code 10003 might appear as CODE10003. You can 
then use the Find/Change command to change 
the word CODE into the End Nested Style Here 
character. 

 C  The  End Nested Style Here 
character  can be inserted to end 
the eff ects of a nested style.

 B  The  Repeat command in the 
Character Style list  is used to loop 
two or more nested styles.

 A  Use the  up/down arrows  to change 
the order of nested styles.
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Creating Nested Line Styles

You can also automatically apply a character 
style to a certain number of lines in a para-
graph. This is called a  nested line style.

To apply the Nested Line Style command 
to text:

1. With your insertion point inside the 
paragraph, choose Drop Caps and Nested 
Styles from the Paragraph panel menu. 
The Nested Line Styles area is at the 
bottom of the dialog box  D .

2. Click the New Line Style button to add a 
new listing to the Nested Line Styles  E .

3. Use the Style menu to choose a character 
style  F .

4. Use the Count field to choose how many 
lines should have the nested style.

5. Click OK to apply the nested style.
or
Click the New Line Style button to add 
more nested styles.

TIPTIP If you don’t have a previously defined style, 
choose New Character Style to open the New 
Character Style dialog box.

TIPTIP Choose the Drop Caps and Nested Styles 
category from the Paragraph Styles dialog 
box to make the nested line style part of a 
paragraph style.

Like repeating nested styles, you can repeat 
nested line styles.

To repeat two or more nested line styles:

1. Create two or more nested line styles.
2. Create an additional nested line style.
3. Choose Repeat from the Style menu.
4. Set the number for how many styles 

should loop.

 E  The  controls for a nested line style  in the 
Drop Caps and Nested Styles dialog box.

Style menu Count field

 F  The  Style menu  lets you choose a character 
style to apply to lines in a paragraph.

 D  The  Nested Line Styles area  of the Drop 
Caps and Nested Styles dialog box.
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Creating GREPGREP Styles

Not only can you use the power of GREPGREP as 
part of Find/Change searches, you can also 
create GREPGREP styles within paragraph styles. 
(For more information on GREP, see Chapter 14, 
“Automating Your Work.”) What this does is 
automatically apply character styles to text 
whenever that text meets the GREP criteria. 
(Trust me, it’s actually easier to do than to 
explain.)

To create a GREPGREP style:

1. Place your insertion point inside the 
paragraph that you want to format.

2. Choose GREP Styles from the Paragraph 
panel menu. The GREP Style dialog box 
appears  A .

3. Click the New GREP Style button. This adds 
a new listing.

4. Use the Apply Style menu to choose 
which character style will be applied to 
the GREPGREP text  B .

TIP If you don’t have a previously defined style, 
choose New Character Style to open the New 
Character Style dialog box. 

5. Use the To Text field to enter the GREP 
code for which text should be modified 
by the style  C .

6. Click OK to apply the GREP style to the 
text  D .
or
Click the New GREP Style button to add 
more GREP styles.

TIP Choose the GREPGREP Styles category from the 
Paragraph Styles dialog box to make a GREPGREP 
style part of a paragraph style.

 A  The  GREP Style dialog box  lets you 
apply GREPGREP formulas to text.

 B  The  Apply Style menu  lets you 
choose which character style 
should be applied to the text.

 C  Enter  GREP codes inside the To Text 
fi eld  to control which text should 
be formatted by the GREPGREP style.

The Wonderful Wizard of Oz (Hardcover) 
Limited Edition ($49.99)
The Wizard Of Oz (Audio) ($14.78)
The Wonderful Wizard of Oz (Books of 
Wonder) Color Illustrations ($23.89)
Available in June

 D  An example of the  code $\d\d.\d\d 
applied as a GREPGREP style  to automatically 
format prices into italic text.
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Defining Object Styles

Just as character and paragraph styles make it 
easy to apply formatting to text, object styles 
make it easy to apply formatting to objects. 
InDesign comes with three built-in object 
style settings.

TIPTIP If you understand the principles of text styles, 
it will be easy to work with object styles.

To apply the built-in object styles:

1. Select the object you want to style.
2. Choose Window > Styles > Object Styles 

to open the Object Styles panel  E .
3. Click one of the following in the Object 

Styles panel:
 • [Basic Graphics Frame] applies the 

default object settings for graphics 
frames. 

 • [Basic Text Frame] applies the default 
settings for text frames. 

 • [None] removes all formatting from the 
object.

To modify the default styles:

1. Double-click the Basic Graphics Frame 
or Basic Text Frame style. This opens the 
Object Style Options dialog box.

TIPTIP The [None] style can’t be modified.

2. Click each of the categories on the left 
side of the dialog box. This displays the 
settings for each category  F . 

3. Make whatever changes you like to each 
of the category settings.

4. Use the Style Settings controls to see 
a description of the settings for each 
category  G .

 F  The  Object Style Options dialog box  lets 
you modify the object style attributes.

 G  Click the  Style Settings controls  to see the 
description of the settings for each category.

 E  The  three built-in object style 
settings  in the Object Styles panel.
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You will most likely want to create your own 
object styles.

To create a new object style:

1. Choose New Style from the Object Styles 
panel menu. Or hold the Opt/Alt key and 
click the New Object Style icon in the 
Object Styles panel. The New Object Style 
dialog box appears  A .

2. Use the Style Name field to name the 
style.

3. Use the checkboxes to control which 
categories are part of the style  B . 
Deselected categories are not part of the 
style  B .

4. Use the Based On field to base one style 
on another.

5. Click the Reset To Base button to remove 
all differences between a style and the 
original style it’s based on.

6. Click OK to create the style.

The easier way to defi ne an object style is 
to format the object and defi ne the style by 
example.

To defi ne an object style by example:

1. Select a sample object.
2. Use the panels and commands to format 

the object.
3. Choose New Style from the Object Styles 

panel menu. Or hold the Opt/Alt key and 
click the New Object Style icon in the 
Object Styles panel. The New Object Style 
dialog box appears.

4. Name the style.
5. Click OK to create the style.

TIP Object styles can be duplicated just like text 
styles.

 A  Use the  New Object Style dialog box  to 
defi ne the attributes of an object style.

 B  Click the  category controls  to 
choose which attributes should be 
included in the object style.



InDesign CS5 Visual Quickstart Guide 417

Working with Object Styles

For the most part, you work with object styles 
as you would text styles. However, there is a 
diff erence in how the default object style is 
applied. With text styles, whichever style is 
highlighted with no text selected will become 
the default style. But with object styles, you 
need to choose a default for either graphics 
frames or text frames.

To change the default object styles:

Drag the Default Graphics Frame icon to a 
new object style  C .
or
Drag the Default Text Frame icon to a new 
object style.

Like text styles, a plus (+) sign next to an 
object style name indicates that local format-
ting changes have been made to the object. 
However, you may also have made changes 
to the object in categories that were not 
selected in the object style. This local format-
ting is not indicated by a plus sign.

To clear local formatting not defi ned in the 
style:

1. Select the object that has the 
modifications to the object style.

2. Click the Clear Overrides Not Defined in 
the Style icon to clear the local formatting 
applied to the object  D .

TIPTIP The only way to know if that local formatting 
has been applied to the object is if the icon is 
visible in the Object Styles panel.

 D  There are  two ways to clear overrides  
applied to object styles.

Clear Overrides icon
Clear Overrides Not 
Defined in the Style icon

 C  The  two default icons for object 
styles  indicate which style is the 
default for new objects.

Default graphics frameDefault text frame
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Defining Table and Cell Styles

If you create just one or two tables in a docu-
ment, you most likely won’t have to worry 
about table and cell styles. But anyone who 
creates a lot of tables will enjoy how these 
features automate their work. As you work 
with table and cell styles, it is best to start by 
defi ning cell styles.

To defi ne cell styles:

1. Choose New Cell Style from the Cell Styles 
panel menu. The New Cell Style dialog 
box appears  A .

2. Name the style and set the Style Info 
controls.

3. If you want, you can use the Paragraph 
Style list to choose a default paragraph 
style for table cells.

4. If desired, choose each of the Cell Styles 
categories to select the attributes of the 
style  B .

TIP Unlike the relationship between paragraph 
and character styles, the formatting of cell 
styles is not duplicated by a table style. This 
means you must define a cell style if you want 
the cells in a table to be controlled by a style. 

TIP The Style Settings area displays a description 
of the attributes for the cell style  C .

 A  Use the  New Cell Style dialog box 
 to defi ne the attributes of cells.

 B  The  Cell Styles categories  let you 
defi ne the attributes of a cell style.

 C  The  Style Settings area  shows you 
the attributes of a cell style.
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Once you have defi ned your cell styles, you 
can then “move up the ladder” to defi ne table 
styles.

To defi ne table styles:

1. Choose New Table Style from the Table 
Styles panel menu. The New Table Style 
dialog box appears  D .

2. Use the Cell Styles pop-up lists to apply 
a cell style to the cells in each position of 
the table  E . (That’s why you needed to 
define the cell styles first.)

3. If desired, choose each of the Table Styles 
categories to select the attributes of the 
style  F .

TIPTIP The Style Settings area displays a description 
of the attributes for the table style  G .

TIPTIP Unlike paragraph styles, table styles do not 
have to have all their attributes defined. This 
is why the Style Settings area displays only a 
description of the defined attributes for the 
table style.

 D  Use the  New Table Style dialog box 
 to defi ne the attributes of tables.

 E  Use the  Cell Styles pop-up lists  to 
apply a cell style to the cells in the 
various positions of the table.

 F  The  Table Styles categories  let you 
defi ne the attributes of a table style.

 G  The  Style Settings area  shows you the 
defi ned attributes of a table style.
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Using the Quick Apply Feature

Once you have defi ned your text, table, and 
object styles, there is a very easy way to 
quickly apply them. The Quick Apply feature 
works entirely from the keyboard — 
no mouse required!

To use Quick Apply to apply styles:

1. Select the text, table, or object that you 
want to apply the style to.

2. Press Cmd/Ctrl and then press Return/
Enter to open the Quick Apply panel.
or
Click the Quick Apply icon on any of the 
Style panels or the Control panel  A .

TIP The panel can be moved to other positions on 
your screen.

3. Type a few of the letters that appear in 
the name of the style. As you type, the 
Quick Apply area shows just those styles 
that contain the letters.

TIP The letters you type do not have to appear in 
sequence in the name of the style.

4. Keep typing until you have the style you 
want  B .
or
Use the up and down arrow keys to move 
to the style you want.

5. Press the Return/Enter key to select the 
style.

TIP Quick Apply remembers the last selected 
style, so you can open Quick Apply and 
simply press Return/Enter to apply the same 
style to another selection.

TIP Press Shift-Return/Enter to apply the Quick 
Apply entry without closing the Quick Apply 
panel.

 B  As you type in the  Quick Apply 
fi eld , the list shows just the styles 
that contain those letters.

 A  The  Quick Apply icon  appears in all the 
Style panels as well as the Control panel.
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You can even use Quick Apply to edit the 
styles dialog box for the selected Quick Apply 
style.

To edit a style through Quick Apply:

1. Open the Quick Apply panel.
2. Type or navigate to get to the style that 

you want to edit.

TIPTIP This technique only works with styles, not the 
menu commands, scripts, or text variables.

3. Press Cmd-Return (Mac) or Control-Enter 
(Windows). This opens the dialog box for 
that style.

In addition to paragraph, character, object, 
table, and cell styles, Quick Apply can also 
apply menu commands, text variables, and 
scripts. However, you may not want to wade 
through hundreds of menus and scripts 
before getting to your own style. That’s when 
you can customize the settings for Quick 
Apply.

To customize the results for Quick Apply:

1. Open the Quick Apply panel.
2. Press the menu control to open the list of 

items that Quick Apply will apply  C .
3. Select those items you want to have 

displayed using Quick Apply. Deselected 
items are not displayed using Quick 
Apply.

 C  Use the  Quick Apply menu control  
to open the list of items that will be 
displayed as part of Quick Apply.

Quick Apply on Macintosh notebooks

The keyboard shortcuts for text styles require 
you to use the numbers on the keyboard 
number pad.

However, Macintosh notebooks don’t have a 
keyboard number pad. Older models, such as 
my 15-inch MacBook Pro, let you use the fn key 
to get the numbers from some of the keys on 
the keyboard. But the newer models, such as my 
13-inch MacBook Pro, don’t have that feature.

That’s why I use QuickApply’s keystrokes to 
assign keyboard shortcuts to my styles. It does 
require a few more keystrokes, but this way I 
can apply the same keyboard shortcuts without 
having to worry on which model of Mac I am 
working.
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You can also use the prefi x letters for each of 
the styles, commands, or scripts that are part 
of a Quick Apply display.

To use the letter commands with Quick 
Apply:

1. Open Quick Apply.
2. Type one of the following prefixes before 

the name of the item you want to apply:
 • p: for paragraph styles
 • c: for character styles
 • o: for object styles
 • m: for menu commands
 • s: for scripts
 • t: for table styles
 • v: for text variables
 • e: for cell styles

3. Type the rest of the command or style 
name.

TIP Don’t put a space after the colon when you 
type the rest of the name. For example, to 
apply a paragraph style called Callouts, you 
would type p:Callouts.

4. Press Return/Enter to apply the Quick 
Apply item.
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Typography
The one thing that truly separates 

the amateurs from the experts in 
page layout is the control they take 
over their text. Amateurs are pleased if 
they can apply simple formatting such 
as fonts, sizes, alignment, tracking, and 
so on.

Experts, though, want more from 
a page-layout program. They want 
sophisticated control over kerning. This 
includes the ability to move one char-
acter in so that it tucks under the stroke 
of another.

They want to control how lines are justi-
fi ed within a text frame. This means that 
if one line looks too crowded and the 
next has big gaps between the words, 
the experts tell the program to reappor-
tion the spaces.

The experts also want to work with 
the newest typefaces that give more 
choices for how letters look and act 
together.

These are advanced text eff ects. Once 
you apply these features, you move 
from being an ordinary designer to a 
typographer.
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Optical Margin Alignment

One of the most sophisticated text eff ects 
in InDesign is the ability to apply hanging 
punctuation to justifi ed text, in which a slight 
adjustment of the margin creates a more 
uniform appearance for the edge of the text. 
Hanging punctuation is applied by setting 
the optical margin alignment. This moves 
punctu ation characters slightly outside the 
text margin  A . In addi tion, optical margin 
alignment moves the serifs of letters outside 
the margin  B .
Optical margin alignment is set using the 
Story panel.

To set optical margin adjustment:

1. Select the text.
2. Choose Window > Type & Tables > Story. 

This opens the Story panel  C .
3. Select the Optical Margin Alignment 

checkbox. The text reflows so that the 
punctuation and serifs lie outside the 
margin edges.

4. Enter a size for the amount of overhang.

TIP As a general rule, set the overhang to the 
same size as the text.  C  The  Story panel  lets you set the 

Optical Margin Alignment to hang 
punctuation in the margin.

 B  The  Optical Margin Alignment 
setting  also moves the serifs of 
letters slightly outside the margin.

Off On

 A  To create the eff ect of a straight edge, 
optical margin alignment  moves 
punctuation outside the margin edges.
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Using Adobe Paragraph 

Composer

InDesign has two ways of composing (laying 
out) text. Single-line composition looks at the 
current line and evaluates the best place to 
break the line or apply hyphenation. Para-
graph composition looks at all the text in a 
paragraph — forward and backward — when 
it evaluates the best place to break lines. 
When paragraph composition is turned on, 
the result is more even spacing for the text 
and fewer hyphens  D .

To apply paragraph composition:

1. Select the text.
2. Choose Type > Paragraph to open the 

Paragraph panel.
3. Choose Adobe Paragraph Composer 

from the Paragraph panel menu. The text 
reflows.

TIPTIP Adobe Paragraph Composer is a paragraph 
attribute and is applied to all the text in a 
paragraph.

TIPTIP Adobe Paragraph Composer is turned on by 
default when you first open InDesign.

TIPTIP Choose Adobe Single-line Composer to apply 
standard line-by-line composition.

 D  Turn on  Adobe Paragraph Composer  to 
improve the spacing between words.

Off

On

When to Use Paragraph Composition?

Why would anyone want to turn off the miracle 
of paragraph composition? Well, there are 
times when the Paragraph Composer insists on 
breaking a paragraph where you don’t want it 
to break. If that happens, you can turn off the 
Paragraph Composer.

You may also want to turn off the Paragraph 
Composer if you have converted a QuarkXPress 
document into InDesign and you want to keep 
the text from reflowing.

Also, some statistical data may be easier to work 
with if you turn off the Paragraph Composer.
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Applying Justification Controls

Justifi cation determines how lines fi t 
between margins. (See the sidebar below for 
information on how justifi cation aff ects text.) 
InDesign provides three diff erent ways to 
control justifi cation: word spacing, letter 
spacing, and glyph scaling. Word spacing 
changes the space between words.

To set word spacing:

1. Select the text.
2. Choose Type > Paragraph to open the 

Paragraph panel.
3. Choose Justification from the Paragraph 

panel menu. This opens the Justification 
dialog box  A .

4. Set the Word Spacing options as 
follows  B :
 • Minimum controls the smallest 

amount of space you want between 
words. For instance, a value of 80% 
means that you are willing to allow the 
space to be 80% of the normal space.

 • Desired controls the preferred amount 
of space between words. A value of 
100% indicates that you want the 
same amount that the designer of the 
typeface created.

 • Maximum controls the largest amount 
of space you want between words. 
A value of 120% means that you are 
willing to allow the space to be 120% of 
the normal space.

5. Click OK to apply the changes  C .

TIP The Minimum, Desired, and Maximum 
settings apply only to text that is set to one 
of the Justified settings. Other alignments, 
such as left-aligned text, use only the Desired 
setting.

 A  The  Justifi cation dialog box  
controls word and letter spacing.

 B  The  spacing controls  in the 
Justifi cation dialog box.

 C  The eff ect of changing the  word 
spacing.  Notice the change in the 
amount of space between the words.

Min: 80, 
Desired: 100, 
Max: 120

Min: 80, 
Desired: 100, 
Max: 100

Understanding Justification

The text in this paragraph is  justified — that 
is, both ends of the line are aligned with the 
paragraph margins. Not all the words can fit 
evenly between the margins, so some lines have 
a bit more space between the words and others 
have less. 

The Justification settings control how much 
space is added to make the lines fit between 
the margins.
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The space between letters is letter spacing, 
sometimes called character spacing. InDesign 
lets you change the letter spacing for text 
whether justifi ed or not. 

To set letter spacing:

1. Select the text.
2. Choose Type > Paragraph to open the 

Paragraph panel.
3. Choose Justification from the Paragraph 

panel menu.
4. Set the Letter Spacing options as follows:

 • Desired controls the preferred amount 
of space between letters. A value of 0% 
indicates that you do not want to add 
or subtract any space.

 • Minimum controls the smallest 
amount of space between letters. A 
value of –5% allows the space to be 
reduced by 5% of the normal space.

 • Maximum controls the largest amount 
of space between letters. A value of 5% 
allows the space to be increased by 5% 
of the normal space.

5. Click OK to apply the changes  D .

TIPTIP If a paragraph cannot be set according to the 
Justification controls you choose, InDesign 
violates the settings by adding or subtracting 
spaces. Set the Composition preferences to 
have those violations highlighted.

What Are the Best 
Justification Settings?

Perhaps the most debated issue in desktop 
publishing is what the best settings are for the 
Justification controls. The answer depends on 
a variety of factors. The typeface, width of the 
columns, even the type of text all need to be 
considered in setting the Justification controls.

For body text, such as the text here, I use word 
spacing of 70%, 100%, and 110%. (Here in New 
York City, most designers like to set copy tightly.) 
For headlines, I fit letters tighter, with word spac-
ing of 60%, 90%, and 100%. 

I keep all the letter spacing values at 0%. I set 
the glyph scaling values at 100%. I don’t like 
to scrunch up the space between letters, and I 
definitely don’t like to change the shape of the 
text, which happens with glyph scaling (see the 
next page).

But that’s just me. And that’s why they call them 
preferences!

 D  The eff ect of changing the  letter spacing . 
Notice how there is less space between 
the characters within the words.

Min: 0, 
Desired: 0, 
Max: 0

Min: -4, 
Desired: 0, 
Max: 4
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Another way to control justifi cation is to use 
glyph scaling. (Glyph is the proper term for 
all the letters, numbers, punctuation marks, 
and other parts of text.) Glyph scaling applies 
horizontal scaling to the letters themselves 
so that the text takes up more or less space 
within the line.

To set glyph scaling:

1. Select the text.
2. Choose Type > Paragraph to open the 

Paragraph panel.
3. Choose Justification from the Paragraph 

panel menu.
4. Set the Glyph Scaling options as follows:

 • Desired controls the preferred amount 
of scaling. A value of 100% indicates 
that you do not want to apply any 
scaling to the character shape.

 • Minimum controls the smallest 
amount of scaling that you are willing 
to apply to the text. A value of 98% 
means that you are willing to allow the 
characters to be reduced by 2% of their 
normal width.

 • Maximum controls the amount that 
you are willing to expand the space 
between words. A value of 105% 
means that you are willing to allow the 
characters to be increased by 5% of 
their normal width.

5. Click OK to apply the changes  A  .

TIP Glyph scaling distorts the shape of letters. 
Most people say you can’t see the slight 
distortion. However, typographic purists 
(such as this author) try to avoid distorting 
the letterforms whenever possible  B .

 A  The eff ects of changing the  glyph scaling. 

Min: 100
Desired: 100
Max: 100

Min: 80
Desired: 100
Max: 120

 B  The black area shows 
the original shape 
of the character. 
The gray area shows 
the eff ects of 80% 
glyph scaling. 
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The Auto Leading fi eld controls how much 
space is put between the lines whenever 
automatic leading is chosen.

To set the Auto Leading percentage:

1. Choose Justification from the Paragraph 
panel menu.

2. Enter an amount in the Auto Leading 
field  C .

TIPTIP The Auto Leading percentage is based 
on the point size of the text. So an 
Auto Leading of 120% applied to 12-point text 
creates a leading of 14.4 points (12 × 1.20 = 
14.4).

TIPTIP Most professional designers use an absolute 
amount for leading by entering a specific 
number, rather than relying on the automatic 
leading.

Have you ever seen a paragraph of justifi ed 
text where a single word stretched out along 
the entire line? InDesign lets you control 
what happens to a single word in a justifi ed 
paragraph.

To set the single word justifi cation:

1. Choose Justification from the Paragraph 
panel menu.

2. Choose a setting from the Single Word 
Justification menu  D . Any text that is set 
to Justify in the Paragraph panel will be 
set according to the menu command  E .

 D  The  Single Word Justifi cation menu  
controls what happens when a single 
word occupies a line of justifi ed text.

 C  The  Auto Leading fi eld  controls 
how InDesign calculates the 
leading when set to Auto.

 E  The eff ects of the  Single Word 
Justifi cation settings .

Full Justify

Align Left

Align Center

Align Right
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Controlling Hyphenation

InDesign lets you turn on hyphenation in the 
Paragraph panel. Once hyphenation is turned 
on, you can then control how the hyphen-
ation is applied.

To turn on hyphenation:

1. Select the text.
2. Select the Hyphenate checkbox in the 

Paragraph panel  A .

To control the hyphenation:

1. Choose Hyphenation from the Paragraph 
panel menu. The Hyphenation Settings 
dialog box appears  B .

2. Select the Hyphenate checkbox to set the 
following controls  C :
 • Words with at Least controls the mini-

mum number of letters a word must 
contain before it can be hyphenated.

 • After First sets the minimum number 
of letters before the hyphen.

 • Before Last sets the minimum number 
of letters after the hyphen.

 • Hyphen Limit sets how many con-
secutive lines can end with hyphens.

 • Hyphenation Zone controls the 
amount of whitespace at the end of a 
nonjustified line. 

3. Select Hyphenate Capitalized Words to 
allow those words to be hyphenated. 

4. Select Hyphenate Last Word to let the last 
word in a paragraph be hyphenated.

5. Select Hyphenate Across Column to let 
words that break across a column be 
hyphenated.

6. Adjust the hyphenation slider to control 
the total number of hyphens in the 
paragraph.

 A  Select the  Hyphenate checkbox  to turn on 
automatic hyphenation for a paragraph.

 C  The Hyphenation controls let you enter 
values for how words are hyphenated.

Hyphenation Units are Nigels

The units in the hyphenation slider are called 
Nigels in honor of Nigel Tufnel (Christopher 
Guest), the Spinal Tap guitarist, whose amplifier 
went to 11.

 B  The  Hyphenation Settings dialog box  lets 
you control how hyphenation is applied.
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Sometimes you may want to prevent words 
or phrases from being hyphenated or break-
ing across lines. For instance, you might not 
want the words Mr. Cohen to be separated at 
the end of a line. You might not want a com-
pound word such as self-eff acing to be broken 
with another hyphen  D .

To apply the No Break command:

1. Select the text.
2. Choose Type > Character to open the 

Character panel.
3. Choose No Break from the Character 

panel menu.

You can also control hyphenation by inserting 
a discretionary hyphen, which forces the word 
to hyphenate at that point if it breaks at the 
end of a line.

To use a discretionary hyphen:

1. Place the insertion point where you want 
the hyphen to occur.

2. Press Command/Ctrl-Shift-
(hyphen) or Control-click (Mac) 
or right-click and choose Insert 
Special Character > Hyphens and 
Dashes > Discretionary Hyphen from the 
contextual menu.

TIPTIP The discretionary hyphen prints only when it 
appears at the end of the line  E .

TIPTIP Insert a discretionary hyphen before a word 
to prevent that instance of the word from 
being hyphenated.

Setting Hyphenation Controls

My own preference is to set “Words with at Least” 
to six or more. This allows a word such as person 
to be hyphenated. I also prefer a minimum of 
three letters before the hyphen and three letters 
after. This avoids breaking words as un-excited 
or reluctant-ly.

Hyphenate Capitalized Words?

Some people automatically turn this off so that 
capitalized words do not hyphenate. I don’t. The 
command doesn’t distinguish between proper 
nouns and words that begin a sentence. So I 
would rather selectively control how proper 
nouns break by using the No Break command 
or by inserting a discretionary hyphen before 
the word. 

 D  In the bottom example the word 
 powerful  was selected and the  No 
Break command  was applied to 
prevent the text from hyphenating.

 E  A  discretionary hyphen  appears 
within the word but prints only when 
it appears at the end of a line.
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You can control where a word is hyphenated.

To edit the hyphenation in the dictionary:

1. Choose Edit > Spelling > Dictionary.
2. Type the word you want to modify in the 

Word field as follows  A :
 • One tilde (~) indicates the best 

possible hyphenation position.
 • Two tildes (~~) indicates the next best 

possible position.
 • Three tildes (~~~) indicates the least 

acceptable position.
 • A tilde before the word prevents the 

word from being hyphenated.
3. Click Add to add the new hyphenation 

preferences to the dictionary.

Baseline Grid

InDesign has an electronic grid that you can 
force text to align to. This ensures that text 
lines up correctly in two separate frames  B .

To set the baseline grid:

1. Choose Edit > Preferences > Grids (Win) 
or InDesign > Preferences > Grids (Mac). 
This opens the Grids settings in the 
Preferences dialog box  C .

2. Use the Color menu to set the grid color.
3. Use the Start field to control where 

the grid should start vertically in the 
document.

4. Use the Relative To menu to choose 
between the top of the page or the top 
margin  D .

5. Use the Increment Every field to control 
the space between the gridlines.

6. Set View Threshold for the magnification 
amount above which the grid is visible.

 A  The tilde characters control the preference 
for where hyphenation should occur.

 C  The  Baseline Grid settings  in 
the Grids preferences.

 B  When  Align to Baseline Grid  is turned on, 
the text in two diff erent frames lines up.

Align to Baseline Grid off

Align to 
Baseline 
Grid on

 D  The  Relative To menu  lets you choose 
where the baseline grid should start.
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To align text to a baseline grid:

1. Select the text.
2. Click the Align to Baseline Grid button in 

the Paragraph panel  E . The text aligns to 
the grid.

TIPTIP When you align to the baseline grid, the grid 
setting overrides the leading. Most designers 
set the baseline grid to the same amount as 
the leading for the text  F .

TIPTIP Aligning to the baseline grid may also change 
the space between paragraphs.

In addition to setting the baseline grid, you 
can choose to set just the fi rst line of a para-
graph to the baseline grid.

To align just the fi rst line to the baseline 
grid:

1. Select the text.
2. Click the Align to Baseline Grid icon 

in the Paragraph panel. All the lines in 
the paragraph will be aligned to the 
baseline grid.

3. Choose Only Align First Line to Grid in the 
Paragraph panel menu or choose First 
Line Only from the Align to Grid menu 
in the Indents and Spacing area of the 
Paragraph Style Options dialog box.

TIPTIP This forces the first line of a paragraph to 
align to the grid but allows the other lines 
in the paragraph to be controlled by the 
leading  G .

 E  The  Align to Baseline Grid buttons  
in the Paragraph panel.

Do not align to baseline grid

Align to 
baseline grid

 F  When text is  aligned to the baseline 
grid , the leading may increase. Also, the 
space between paragraphs may adjust.

Align to Baseline Grid off

Align to 
Baseline 
Grid on

 G  Use the  Only Align First Line to Grid 
command  to align just the fi rst line of a 
paragraph without aff ecting the leading.

Align all lines to grid

Only align first line to grid
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You can also set a custom baseline grid for a 
text frame. This is especially helpful for for-
matting margin notes alongside text  A .

To create a custom grid for a text frame:

1. Select the text frame.
2. Choose Object > Text Frame Options and 

then click Baseline Options. This opens 
the text frame baseline controls  B .

3. Select the Use Custom Baseline Grid 
checkbox to set the options.

4. Use the Start field to control where 
the grid should start vertically in the 
document.

5. Use the Relative To menu to choose 
between the top of the page or the top 
margin.

6. Use the Increment Every field to control 
the space between the gridlines.

7. Use the Color controls to set the color of 
the grid.

8. Don’t forget to set the text to align to the 
baseline grid.

 B  The  Baseline Grid settings  in 
the Text Frame Options.

“All the same,” said the Scare-
crow, “I shall ask for brains in-
stead of a heart; for a fool would 
not know what to do with a 
heart if he had one.”
“I shall take the heart,” returned 
the Tin Woodman; “for brains 
do not make one happy, and 
happiness is the best thing in 
the world.”

Is the Scarecrow 
actually smart 
here? Does the 
Tin Woodman 
show feeling? 
What does this 
tell you?

 A  A  custom frame grid  allows you to 
have multiple grids in a document.

Document grid Custom frame grid
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Balancing Ragged Lines

Another nuance for good typography is to 
make sure that there are no uneven line 
breaks, especially in headlines or centered 
type. InDesign’s Balance Ragged Lines com-
mand makes this easier  C .

To balance uneven line breaks:

1. Select the text.
2. Choose Balance Ragged Lines from the 

Paragraph panel menu or choose Balance 
Ragged Lines in the Indents and Spacing 
area of the Paragraph Style Options 
dialog box.

Using OpenType

Instead of the paltry 256 glyphs (characters) 
in ordinary fonts, OpenType fonts can have 
thousands of glyphs. InDesign has special 
commands that help you get the most out of 
OpenType fonts. For instance, you can set the 
commands to automatically swap ordinary 
characters with special OpenType glyphs.

To set automatic OpenType alternate 
characters:

1. Select the text.

TIPTIP OpenType features can be applied to all the 
text in a document or just part of the text.

2. Choose Type > Character to open the 
Character panel.

3. Choose the options from the OpenType 
submenu in the Character panel menu. 
InDesign automatically swaps characters 
with the alternate glyphs in each 
category  D . 

 C  The  Balance Ragged Lines command  
rearranges text so there is a more 
equal number of words in the lines.

 D  As you add more letters to an OpenType 
font, the previous letters change.

What is OpenType?

OpenType is a type format that was developed 
by Adobe and Microsoft. OpenType fonts have 
many advantages over previous type formats. 
In addition to containing thousands of glyphs, 
OpenType fonts are also cross-platform. This 
means you can use the same font on Mac or 
Windows without any document reflow.

Adobe sells different types of OpenType fonts. 
“Pro” versions of a font, such as Minion Pro, con-
tain the extended character sets that give you 
access to fractions, ligatures, and other special 
effects. “Standard” versions, such as Futura Std, 
contain only the basic characters.
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You can also manually choose alternate 
glyphs for each character in the font.

To choose the alternate glyphs:

1. Select the character in the text.
2. Choose Type > Glyphs to open the Glyphs 

panel.
3. Press the triangle next to the selected 

character in the panel  A . The alternate 
glyphs for the selection appear.

4. Choose one of the alternate characters. 
This replaces the selected text with the 
alternate character in the Glyphs panel.

You can also set the Glyphs panel to display 
just certain categories of glyphs.

To view certain categories in the Glyphs 
panel:

1. Press the Show list in the Glyphs panel.
2. Choose the category of OpenType 

characters that you want to display  B .

TIP Not all OpenType fonts contain all the 
possible glyph features. So the Show list will 
display different categories depending on the 
OpenType font chosen.

 A  Press a character or letter that has a 
triangle to see the alternate glyphs.

 B  The  Show list  in the Glyphs 
panel lets you choose to see the 
categories of specialized glyphs.
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OpenType Categories

Feature name Comments Examples

All Caps Changes text to uppercase letters. Also 
changes punctuation and spacing. Notice 
how the question marks and hyphen are 
raised in the OpenType all caps format-
ting.

Manually typed 
all caps

OpenType all caps 

Small Caps Changes lowercase text to small capital 
letters. More appropriate weight for the 
letters compared to the fake small caps 
created electronically.

Electronic small 
caps
OpenType 
small caps

All Small Caps Changes all text, including uppercase 
characters, to small capital letters. Use 
for acronyms such as FBI, CIA, and PDF. The 
advantage to this setting is that you do 
not have to retype uppercase characters 
to make the conversion.

Without small 
caps

With small caps

Ligatures Applies the special letter combinations 
such as fi  and fl . Other ligatures, such 
as ffi  , ffl  , and ff  may be present in most 
Adobe Pro OpenType fonts.

No ligatures

With ligatures

Discretionary 
Ligatures

Applies both discretionary ligatures 
and historical ligatures. These ligatures 
should be used sparingly as they are not 
common in contemporary text.

No discretionary
ligatures
With discretion-
ary ligatures

Fractions Converts numbers around a slash into 
numerator and denominator characters 
and changes the slash to a virgule. Set-
tings for Numerator and Denominator 
also use the fraction glyphs.

Manually styled 

OpenType format-
ted

Ordinals Converts the characters to the super-
script position. Like fractions, the Open-
Type version is faster to apply and has a 
better weight than electronic styling.

Manually styled

OpenType format-
ted

Swash Substitutes a stylized alternative for the 
ordinary glyphs. Swashes are usually 
found in the italic version of a font. They 
are contextual and are inserted at the 
beginning or end of a word.

Without swash

With swash

Stylistic Sets Substitutes sets of characters that are 
applied depending on their context in 
relationship to other letters. Visible in the 
Glyphs panel.

Without stylistic 
set
With stylistic set

continues on next page
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Feature name Comments Examples

Contextual
Alternates

Substitutes specially designed characters 
that are applied depending on their con-
text in relationship to other letters. 

Without contex-
tual alternates
With contextual 
alternates

Stylistic 
Alternates

Created by the type designer, these alter-
natives are inserted as alternate choices 
to the selected glyphs.

Original character

Stylistic alternate

Superscript/
Superior

Substitutes proper superscript or 
superior characters for ordinary glyphs. 
Limited to numbers, punctuation, and a 
selected set of letters. 

Manually styled

OpenType format-
ted

Subscript/Infe-
rior

Like superscript, this substitutes proper 
subscript characters for ordinary glyphs. 
Limited to just numbers and punctua-
tion, not letters.

Manually styled

OpenType format-
ted

Slashed Zero Substitutes a slashed zero for the normal 
character. Used in scientifi c and math-
ematical writing. 

No 
slashed zero

Slashed zero

Figure 
(number) types

There are two main categories for fi gures: 
Tabular and Proportional.
Tabular fi gures have fi xed widths and are 
used particularly where the numbers 
need to line up under each other.
Proportional fi gures have variable widths. 
Use these unless it is necessary to line 
fi gures up into columns of tabular data.
Tabular fi gures and Proportional fi gures 
each come in two varieties: Lining and 
Oldstyle.
Lining fi gures have a uniform height. Use 
them with all cap text or for a contempo-
rary look. 
Oldstyle fi gures have unequal heights. 
Use them with mixed-case text or when a 
more traditional look is desired.
Default fi gure is the category that the 
type designer has designated as the 
default. This is usually tabular lining.

These are the four types of fi gures:
Tabular lining

Tabular oldstyle

Proportional 
lining

Proportional 
oldstyle

OpenType Categories continued
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Color Management
I remember when my family got our 

fi rst color television set. Back then, 
there weren’t many programs broad-
cast in color, so a color television was a 
strange and mysterious thing.

No one in the family knew how to make 
the pictures look realistic. We jumped 
up to adjust the image whenever we 
changed channels. My sister and I spent 
more time fi ddling with the TVTV controls 
than watching the shows.

Well, not many people understand how 
color is managed in desktop publishing. 
They don’t know how to make colors 
look better or how to control images 
from diff erent appli cations. They spend 
most of their time fi ddling with the 
knobs.

Color management is a very complex 
subject — far too deep for the scope of 
this book. This chapter covers only the 
most basic steps for managing color 
in InDesign. Fortunately, the controls 
are similar to those in other Adobe 
products. So if you’ve set your color 
management in Photoshop, you will 
fi nd the same settings in InDesign.

If you are interested in learning more 
about color, I suggest Real World Color 
Management, by Bruce Fraser, Fred 
Bunting, and Chris Murphy, published 
by Peachpit Press.
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Choosing Color Settings

The fi rst step for color management is to 
set up the color system. Fortunately, Adobe 
 provides predefi ned color settings that are 
suitable for many users.

To turn on color management:

1. Choose Edit > Color Settings. This opens 
the Color Settings dialog box  A .

2. Choose one of the predefined settings 
from the Settings menu  B :
 • Choose General Purpose if you are 

printing to an office printer.
 • Choose Prepress if you are sending 

files out to a high-end service provider.
 • Choose Web/Internet if you will be 

outputting to the Web.
 • Choose CMS Off to minimize the 

effects of color management. (Color 
management is never completely off.)

TIP You may have different settings from those 
shown here if you are not in North America.

3. Click OK to apply the color settings. In 
many cases, this is all you need to do to 
set color management in InDesign.

 A  The  Color Settings dialog box  contains 
the controls for managing how 
colors are displayed and printed.

 B  The  Settings menu  lets you choose one of 
the predefi ned color management settings.

Talk to Your Print Shop

Most designers I know are embarrassed to admit they don’t understand color management. It’s nothing to be 
ashamed of. What you need to do is talk to your print shop. Ask them what settings they recommend for color 
management. And remember, color management also needs to be set in image-creation applications — such 
as Adobe Illustrator and Adobe Photoshop — that you use to create images placed in InDesign.
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The working space applies the default color 
profi les for RGB and CMYK colors (see Chapter 5, 
“Working in Color”).

To set the RGB working space:

Use the RGB menu to choose one of the 
following RGB display settings  C :
 • Adobe RGB (1998) has a large color 

gamut. Use it if you do print work with 
a broad range of colors.

 • Apple RGB reflects the characteristics 
of the Apple standard 13-inch monitor. 
Use for files displayed on Mac OS 
monitors or for working with older 
desktop publishing files.

 • ColorMatch RGB matches the color 
space of Radius PressView monitors.

 • ProPhoto RGB is a color space develped 
by Kodak. It is larger than Adobe RGB.

 • sRGB IEC61966-2.1 reflects the 
characteristics of the average PC 
monitor. It is recommended for Web 
work, but is too limited for prepress.

 • Monitor RGB sets the working space to 
the color profile of your monitor. Use 
this if your other applications do not 
support color management.

 • ColorSync RGB (Mac) matches the RGB 
space specified in the Control panel for 
Apple ColorSync 3.0 or later.

TIPTIP When the Advanced Mode is chosen, the 
Working Spaces RGB menu displays additional 
options.

To set the CMYK working space:

Use the CMYK menu to choose the CMYK 
output settings  D .

TIPTIP Each setting describes the type of ink and 
paper used in the printing.

 C  The  Working Spaces RGB menu  lets you 
choose the display options for RGB colors.

 D  The  Working Spaces CMYK menu  lets 
you choose the output destination 
for printing CMYK colors.
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You can also set what happens when placed 
images contain different color profiles than 
the current working spaces.

To set the Color Management Policies:

1. Choose a setting in the RGB and CMYK Color 
Management Policies menus  A  and  B  as 
follows:
 • Off turns off color management for 

imported images or documents.
 • Preserve Embedded Profiles 

maintains the profile in the imported 
image or document.

 • Preserve Numbers maintains the 
actual color values without applying 
any profiles.

 • Convert to Working Space converts 
placed images and documents to 
the working spaces you set for the 
InDesign document.

2. Select Ask When Opening (under Profile 
Mismatches) to give a choice when 
opening documents with different 
profiles  C .

3. Select Ask When Pasting (under Profile 
Mismatches) to give a choice when 
pasting information from documents with 
different profiles.

4. Select Ask When Opening (under Missing 
Profiles) to give a choice when opening 
documents that have no color profiles.

 C  The  Profi le Mismatches and Missing 
Profi les options  control what 
happens when diff erent profi les 
are in the same document.

 A  The RGB Color Management Policies 
menu  lets you choose what to do 
with diff erent RGB color profi les.

 B  The  CMYK Color Management Policies 
menu  lets you choose what to do 
with diff erent CMYK color profi les.
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The Conversion Options, in the Advanced 
Mode, control how objects and color data are 
converted  D .

To set the conversion options:

1. Choose one of the settings in the Engine 
menu  E  and  F :
 • Adobe (ACE) uses the Adobe color 

management system and color engine. 
This is the default setting.

 • Microsoft ICM (Win) uses the color 
management system provided for 
Windows computers.

 • Apple CMM (Mac) uses the color 
management system provided for 
Mac OS computers. Unless you have 
an optional color module installed, 
there is no difference between the two 
settings.

TIPTIP Choose Adobe (ACE) if you are working with 
other Adobe products.

2. Choose one of the settings in the Intent 
menu  G :
 • Perceptual preserves the relationships 

between colors in a way that is 
perceived as natural by the human eye.

 • Saturation is suitable for business 
graphics, where the exact relationship 
between colors is not as important as 
having vivid colors.

 • Relative Colorimetric is the default 
rendering intent used by all predefined 
color management configurations.

 • Absolute Colorimetric maintains color 
accuracy at the expense of preserving 
relationships between colors.

3. Select Use Black Point Compensation to 
adjust for differences in black points.

TIPTIP Adobe strongly recommends you keep 
the Use Black Point Compensation option 
selected. 

 D  The  Conversion Options  are displayed 
in the Color Settings when the Advanced 
Mode checkbox is selected.

 E  The  Engine menu (Win)  lets you choose the 
Adobe Color Engine or the Microsoft Image 
Color Management for color management.

 G  The  Intent menu  lets you choose how 
the fi nal color display should look.

Black and White Points?

A white point is the most extreme highlight in an 
image. This is the part of the image that should 
be totally white without any ink. A black point is 
the most extreme black part of an image.

 F  The  Engine menu (Mac)  lets you choose 
the Adobe Color Engine or the Apple 
ColorSync or Apple Color Management 
Module for color management.
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Saving and Loading 

Color Settings

One of the things that drives my students 
crazy is when a color in Adobe InDesign looks 
diff erent when displayed in Adobe Illustrator 
or Adobe Photoshop. Fortunately, it is easy 
to synchronize your Adobe application color 
settings so the color looks the same.

To save the color settings:

1. Set your color settings as described in the 
previous section.

2. Click the Save button in the Color Settings 
dialog box.

3. Name the color settings file (CSFCSF) and save 
it in the following location  A :
 • Disk: Users: [User]: Library: Application 

Support: Adobe: Color: Settings (Mac).
 • Disk: Documents and Settings: [User]: 

Application Data: Adobe: Color: 
Settings (Win).

TIP This saves the setting in a location where 
the other Adobe applications can use the 
settings file.

Once you have saved the color settings, 
you can open or load them into InDesign or 
another Adobe application.

To open the color settings:

1. Click Load in the Color Settings 
dialog box.

2. Navigate to the Color: Settings folder as 
described in the previous exercise.

3. Choose the color settings file.

TIP If you have chosen the same color settings 
for all your Adobe applications, a message 
appears at the top of the Color Settings 
dialog box stating that your settings are 
synchronized  B .

 A  Use the  Save Color Settings dialog box 
 to save your own color settings fi le.

 B  A  message in the Color Settings 
dialog box  lets you know if all 
your Adobe applications are using 
the same color settings.
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If your copy of InDesign is part of the Adobe 
Creative Suite, you have an additional feature 
that allows you to easily synchronize all the 
applications in the suite.

To synchronize color settings using Adobe 
Bridge:

1. Open Adobe Bridge.
2. Choose Edit > Creative Suite Color 

Settings. This opens the Suite Color 
Settings dialog box.

3. Choose the color setting from the list 
and then click Apply. This synchronizes 
the color management across the Adobe 
Creative Suite applications  C .

TIPTIP If you have chosen the same color settings 
for all your Adobe applications, a message 
appears at the top of both the Suite Color 
Settings and the Color Settings dialog boxes 
stating that your settings are synchronized.

 C  Use the  Adobe Bridge Suite Color Settings 
dialog box  to choose a color settings 
fi le to apply to all the applications.
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Working with Profiles

You can also set profi les and color manage-
ment for individual imported images.

To control a placed image’s color 
management:

1. If the graphic has already been placed 
into the layout, select it, and then choose 
Object > Image Color Settings to open 
the Image Import Options dialog box  D .
or
If you’re about to import the graphic, click 
the Color tab of the Image Import Options 
dialog box. This displays the Profile and 
Rendering Intent menus  E .

2. Use the Profile menu to choose the source 
profile to apply to the graphic.

3. Use the Rendering Intent menu to choose 
a rendering intent.

 D  The  Image Import Options dialog box  
allows you to assign a specifi c profi le and 
rendering intent to an imported image.

 E  The  Color tab in the Image Import 
Options dialog box  allows you to assign 
a specifi c profi le and rendering intent to 
an image that is about to be imported.
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Interactive and Multimedia
At the risk of sounding like an old 

codger, I can remember when a 
page-layout program only laid out print 
fi les. The idea of creating “push buttons” 
that sent you fl ying to other pages — or 
even other documents — was totally 
unfathomable. After all, how was some-
one supposed to press on a weather 
summary on the front page of a news-
paper to jump to the full weather map 
on the last page?

So it is with some amazement that 
I write this chapter. Page layout no 
longer refers to just printed pages. 
InDesign has a wealth of features that 
let you create interactive elements for 
electronic documents.

However, rather than limiting a chapter 
on interactive and multimedia docu-
ments to a printed book, I’ve decided 
to make this chapter a complete, rich 
media experience.

You can download this chapter by going 
to: www.peachpit.com/indesigncs5vqs.

The following pages outline what you 
can expect to learn in this Interactive 
and Multimedia chapter.

www.peachpit.com/indesigncs5vqs
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Setting Up the Interactive 

Workspace

The easiest way to create interactive elements 
is to set the Interactive workspace that comes 
with the default installation of InDesign. This 
sets the panels and menus to the way the 
Adobe engineers feel that people working 
with interactivity would enjoy the most.

Types of Interactive Elements

There are three diff erent types of interactive 
elements you can add to InDesign docu-
ments: hyperlinks, bookmarks, and buttons. 
Each has its own particular uses, but some 
of the features may overlap. Before you start 
work, decide which type of interactive ele-
ment is right for you.

Defining Hyperlinks

A hyperlink is an area of a page that can be 
clicked to send the reader to a new page, 
open a new document, move to a Web page, 
or send an e-mail message. There are two 
parts to creating a hyperlink. The source is 
the object or text that you click to trigger the 
hyperlink. The destination is the page or Web 
link you go to.

Setting the Hyperlink 

Destinations

Once you have set up your destinations and 
hyperlinks, you can use the Hyperlinks panel 
to navigate through the document. This lets 
you easily move to specifi c locations in your 
InDesign document.

Applying Zoom Settings to 

Page Links

When you choose a hyperlink with a page 
destination, you have the option to control 
the magnifi cation or zoom setting for the 
page that you move to. This helps the readers 
orient themselves to the new page.

Formatting Hyperlinks

In addition to setting the destinations for 
hyperlinks, you can also control how the 
hyperlink appears on the page. For hyperlinks 
that come from selected text, this includes 
applying a character style.

Editing and Working with 

Hyperlinks

The easiest way to create a hyperlink destina-
tion is to create it as you defi ne the hyperlink.
However, it’s also possible to defi ne destina-
tions without defi ning the hyperlink. This is 
helpful if you have a lot of destinations that 
you want to defi ne before you know where 
you will create the hyperlinks.

Creating Cross-References

Cross-references are a subset of hyperlinks 
and are found at the bottom of the Hyperlinks 
panel. Like hyperlinks, cross-references create 
an electronic link from one part of a docu-
ment to a destination in the same or diff erent 
document. But cross-references go further 
than hyperlinks in that they also insert a refer-
ence to the page number or text.
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Working with Bookmarks

Bookmarks provide a diff erent way to navi-
gate within a document. Instead of elements 
on the page, bookmarks are displayed in the 
Acrobat or Reader Bookmark pane. The reader 
clicks each bookmark to move to that posi-
tion in the document. One of the advantages 
to using bookmarks is that the Bookmark 
pane can be always visible next to the area 
being read. 

Adding Sounds

Despite the mind-bending concept of adding 
sound to a page layout, it’s actually very 
simple to add sounds to an InDesign docu-
ment. Just remember, you won’t actually play 
the sound in InDesign. The sound is played 
when exported as part of a PDF.

Adding Movies

Movies can be easily added to an InDesign 
document. Just remember, you won’t actu-
ally play the movie in InDesign. The movie is 
played as part of a PDF or when repurposed 
as part of an XML document. Consider what 
it would be like if this book came as a PDF. 
Instead of the static images, you would see 
little movies that showed how things work. 
In fact, that’s what I’ve done with the online 
version of this chapter.

Movie Display Options

You can also set the poster options for the 
movie. This allows you to set an image that 
fi lls the space in the frame for the movie clip.

Creating Buttons

Buttons go much further than links. Links let 
you move to destinations or open Web pages. 
Buttons contain the code that can send you 
to destinations, fl ip pages, open Web pages, 
play movies, show and hide other buttons, 
and other tricks. The fi rst thing you want to 
do is create a button and assign a simple 
action.

General Button Properties

Once you have created a button, you can 
set its properties. These are divided into two 
sections. General properties let you name the 
button and control how it is viewed in the PDF. 
The other section is the Behavior properties, 
which let you apply actions to the button.

Setting the Button States

Part of the fun of using interactive buttons 
in PDF documents is that you can make the 
buttons change their appearance when the 
viewer passes the mouse over them or clicks 
the buttons. Each diff erent appearance for 
the button is called a button state. InDesign 
lets you add states and control their appear-
ance.

Applying Behaviors

A button without a behavior is like a light 
switch that is not connected to a lamp. You 
can press the button all you want, but noth-
ing changes on the page. Behaviors let your 
buttons move pages, play movies, or change 
the appearance of the PDF page.
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Modifying Behaviors

The most sophisticated buttons are those 
that apply multiple behaviors. You can apply 
multiple behaviors to the same mouse event 
or to separate mouse events.

Multistate Objects

Just as you can create buttons that display 
diff erent appearances depending on the 
actions around them, you can also create 
additional appearance states for objects. This 
creates mini slide shows within frames. Each 
state displays a diff erent appearance.

Animating Objects

Objects don’t have to sit idly on the page with 
only the buttons and movies providing all the 
interactive fun. You can select frames or any 
objects on a page and animate them so they 
move gently into a scene or leave quickly. You 
can even import special animation settings 
from Adobe Flash.

Timing Animations

In comedy, timing is everything. Likewise 
with animations and presentations, a 
simple change in timing can make dramatic 
improvements in your documents. Here’s 
how to set the controls for how long it takes 
objects to move or disappear from view.

Working with the Preview 

Controls

Once you’ve created an interactive presenta-
tion, you will want to preview how it works. 
From the opening scene to the animated 
elements to the interactive settings, working 
with the preview helps you catch any unex-
pected behaviors.

Creating Page Transitions

InDesign also lets you control the transitions 
as pages turn from one page to another. 
These transitions can be a simple cut from 
one page to another. Or they can be more 
sophisticated dissolves, wipes, or even the 
illusion of a page curling up to display the 
next page.

Exporting Interactive PDF Files

There are a few settings you must be aware of 
when exporting interactive and multi media 
PDFs from InDesign.

Exporting Interactive SWF Files

Another popular format for creating interac-
tive and multimedia fi les is the SWF format. 
Similar to PDF fi les, SWF fi les allow you to use 
some of the more advanced page transitions 
and document eff ects.
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Output
Several years ago the title of this 

chapter would have been “Printing.” 
That was what you did with page-layout 
documents: You printed them using a 
desktop printer. Today, however, there 
are many more choices for publishing 
your InDesign documents.

Most InDesign fi les are created as part 
of the pro fessional prepress process. 
You need to know more than just how 
to print to a desktop printer. You need to 
know how to make sure your document 
has been set up correctly. You need to 
know what fi les are necessary to send 
to a print shop.

So this chapter is now called “Output.” 
Output refers to preparing documents 
and printing them — either with an 
ordinary desktop printer or with a 
high-end printing device such as an 
imagesetter.
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Printing a Document

When a document is printed, many diff erent 
instructions are sent to the printing machine. 
You need to set those instructions correctly.

TIP Adobe recommends using only the controls 
inside the InDesign Print dialog box — not 
the Page Setup (Mac) dialog box or the 
Printer Properties (Win) dialog box. 

To print a document:

1. Choose File > Print. This opens the Print 
dialog box  A .

2. Click each of the categories  B  on the 
left side of the dialog box to set the 
options as described in the chart on the 
following page.

TIP You do not need to set all the controls every 
time you print unless you need to change a 
specific setting.

3. Click the Print button to print the 
document according to the settings.

Before you print a document, you may want 
to set some objects (such as private notes or 
alternate designs) to not print.

To set elements to not print:

Select the object and turn on Nonprinting 
in the Attributes panel.
or
Turn off the visibility of the layer in the 
document. This suppresses the printing 
for all objects on the layer.

 A  The  Print dialog box  contains all the 
settings for printing documents.

 B  Click each of the 
categories to display 
those settings in the 
Print dialog box.
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Setting the General Print 

Options

If you are printing to a desktop printer, the 
options in the General category may be all 
you need to set to print a document.

To choose the printer:

Choose the printer from the Printer menu 
at the top of the dialog box  C .

To control the copies:

1. Set the number of copies in the Copies 
field  D .

2. Choose Collate to print multiple copies 
organized as complete sets.

3. Choose Reverse Order to print the copies 
back to front.

To control the pages:

1. Choose All to print all the pages or choose 
Range to print a single page or a group of 
pages  E . (See the next exercise for how to 
specify both individual pages and page 
ranges.)

2. Use the Sequence menu to choose All 
Pages, Even Pages, or Odd Pages.

3. Select the Spreads checkbox to print 
spreads together.

4. Select Print Master Pages to print the 
master pages in the document.

To print specifi c pages or page ranges:

Use the following controls in the Range 
field to print specifc pages:
 • Use a comma to separate individual 

pages.
 • Use a hyphen to specify a range of 

pages.

 C  The  Printer list  lets you choose the 
printer to print a document.

 D  The  Copies and Pages  area of the 
General controls for printing.

 E  Use a  combination of hyphens and 
commas  to print both individual 
pages and a range of pages.
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If you have diff erent-sized pages, you can use 
the Select Same-Sized Pages icons to select 
specifi c pages for printing.

To select specifi c page sizes for printing:

1. In the Pages panel, select one of the 
pages that is the size you want to print.

TIP This page does not have to be one of the 
pages that you want to print.

2. In the Pages area of the Print dialog box, 
click the Select Same-Sized Pages icons 
as follows  A :
 • The First Range icon enters the page 

numbers for the first range of pages 
that are the same size as the selected 
page.

 • The Previous Range icon enters the 
page numbers for the preceding range 
of pages that are the same size as the 
selected page.

 • The All Pages icon enters the page 
numbers for all individual pages as well 
as page ranges that are the same size 
as the selected page.

 • The Next Range icon enters the page 
numbers for the next range of pages 
that are the same size as the selected 
page.

 • The Last Range icon enters the page 
numbers for the last range of pages 
that are the same size as the selected 
page.

To set the general options:

1. Use the Print Layers menu to choose 
which layers to print  B .

2. Select Print Non-printing Objects to print 
objects set to not print  C .

3. Select Print Blank Pages to print pages 
that have no visible items  C .

4. Select Print Visible Guides and Baseline 
Grids to print the guides and grids  C .

 A  The  Select Same-Sized Pages 
icons  in the Print dialog box.

Previous range

All pages

Next range

First range Last range

 B  The  Print Layers menu  in the Options 
area of the General controls for printing.

 C  The  Options area  of the General 
controls for printing.
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Choosing the Setup Controls

The Setup options contain the controls to set 
the paper size and orientation.

To set the paper size and orientation:

1. Use the Paper Size menu to choose the 
size of the paper on which to print the 
document  D .

TIPTIP This menu changes depending on the type of 
printer chosen.

2. Click one of the Orientation buttons. This 
changes the rotation of the document on 
the printed page.

To choose the setup options:

1. Set the Scale amount for either Height or 
Width to change the size of the printed 
document on the paper  E .

2. Click the Scale to Fit button to have the 
document automatically resized to fit the 
chosen paper size.

3. Use the Page Position menu to choose 
where to position the document on the 
printed page  F .

4. Select Thumbnails to print small versions 
of the pages on a single page.

5. If you have chosen Thumbnails, use the 
Thumbnails menu to choose how many 
pages are printed on each page  G .

TIPTIP See the next section for information on how 
to use the Tile controls.

 D  The  Paper Size and Orientation controls  in 
the Setup category of the Print dialog box.

 E  The  Options controls  in the Setup 
category of the Print dialog box.

 F  The  Page Position menu  in the Setup 
category of the Print dialog box.

 G  The  Thumbnails menu  in the Setup 
category of the Print dialog box.
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Tiling Pages

If your document is larger than the paper 
in the printer, you can print portions of the 
document on diff erent pages. You can then 
assemble the pages together. This is called 
tiling. Auto tiling automatically divides the 
page into smaller segments.

To set automatic tiling:

1. Select Tile in the Setup category of the 
Print dialog box.

2. Choose Auto from the Tile menu  A .
3. Set the amount in the Overlap field. 

This controls how much of one page is 
repeated on the tile for a second section 
of the page.

TIP The Preview area in the lower-left portion of 
the Print dialog box shows how the page will 
be tiled  B .

Auto justifi ed tiling divides the pages so that 
the right edge of the document lies on the 
right side of a printed page and the bottom 
edge of the document lies on the bottom 
edge of a printed page  C .

TIP The Auto setting ensures that there is no 
white space on the right side and bottom of 
the tiled pages.

To set auto justifi ed tiling:

1. Select Tile in the Setup category of the 
Print dialog box.

2. Choose Auto Justified from the Tile menu.

 A  The  Tile menu  in the Setup category 
of the Print dialog box.

 B  The Preview area 
set to  Auto tile .

Printed area

Nonprinted area

Overlap area

 C  The Preview 
area set to  Auto 
Justifi ed tile .

Printed area

Overlap area
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You can also tile pages manually. This lets you 
make sure that the edge of the paper does 
not cut across an important portion of the 
document.

To set manual tiling:

1. Use the zero-point crosshairs on the 
ruler to set the upper-left corner of the 
area you want to print  D . (See Chapter 2, 
“Document Setup,” for more information on 
setting the zero point of the ruler.)

2. Choose File > Print.
3. Click the Setup category of the Print 

dialog box.
4. Choose Manual from the Tile menu.

TIPTIP The Preview area of the Print dialog box 
shows the area that will be printed  E .

5. Click Print to print that one page.
6. Reposition the zero-point crosshairs to set 

a new area to be printed.
7. Follow steps 2 through 5 to define and 

print the second tile.
8. Repeat the process until the entire page 

has been printed.
 E  The Preview area 

set to  Manual tile .

Printed area

Nonprinted area

 D   Move the zero-point crosshairs  to set 
the area to print as a tile on one page.
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Setting Marks and Bleed

You can also add information that shows 
where the page is to be trimmed, the docu-
ment name, and so on. This information is 
sometimes called printer’s marks or page 
marks.

To set the page marks:

1. Select All Printer’s Marks to turn on all the 
marks, or use the checkboxes to set each 
one individually  A  and  B .
 • Crop Marks indicates where the page 

should be trimmed.
 • Bleed Marks shows how far outside 

the crop marks you must put graphics 
so that they are trimmed correctly.

 • Registration Marks adds crosshair 
targets that are used to line up pieces 
of film.

 • Color Bars provides boxes that display 
the colors used in the document as 
well as the tint bars that can be used to 
calibrate the printing press for correct 
tints of colors.

 • Page Information prints the name of 
the file, the page number, and the time 
the document was printed.

2. Use the Type menu to choose a custom 
set of marks such as those used in 
Japanese printing.

3. Enter an amount in the Weight menu for 
the thickness of the crop marks.

4. Enter an amount in the Offset field to 
determine how far away from the trim the 
page marks should be positioned.

 A  The  Marks settings  in the Marks and 
Bleed category of the Print dialog box.

 B  The  page marks and information  as 
they appear on the printed page.

Tint bars Color bars

Registration mark

Bleed mark

Crop mark

Page 
information



InDesign CS5 Visual Quickstart Guide 459

You can also control the bleed, or the area 
that allows objects that extend off  the page 
to print  C . 

To set the bleed area:

To use the bleed set in the Document 
Setup dialog box, select Use Document 
Bleed Settings  D .
or
Deselect Use Document Bleed Settings 
and then set the custom amounts for the 
bleed around each side of the page  E .

TIPTIP These custom bleed controls make it easy for 
print shops to set a uniform bleed as part of a 
print preset.

If you have set a slug for the document, you 
can choose whether that slug area prints 
or not. 

To set the slug area:

To print items in the slug area, select 
Include Slug Area.

 D  Select the checkbox for  Use Document 
Bleed Settings  to have the bleed 
use the same settings as in the 
Document Setup dialog box.

 C  An example of an object that 
bleeds off  a page.

Bleed area

 E  The  Bleed controls  allow you to defi ne 
a custom bleed in the Print dialog box.
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Setting the Output Controls

You may need to set the color controls to 
choose how color documents are printed.

To control how colors are printed:

1. Choose one of the following from the 
Color menu  A :
 • Composite Leave Unchanged prints 

without converting colors to either RGB 
or CMYK.

 • Composite Gray prints all the colors as 
a gray image. Use this when printing 
on one-color laser printers.

 • Composite RGB prints all the colors as 
an RGB image. Use this when printing 
on RGB ink-jet printers.

 • Composite CMYK prints all the colors as 
a CMYK image. Use this when printing 
on PostScript CMYK printers.

 • Separations prints all the colors onto 
separate plates or pages.

 • In-RIPRIP Separations prints all the 
colors onto separate plates using the 
separation controls in the RIP.

2. If you choose one of the composite 
settings, you can select the Text as Black 
checkbox. 

TIP The Text as Black command is helpful if you 
have color text that you want to be more 
readable when printed on a one-color printer.

3. Use the Flip menu if you need to flip the 
orientation of the page  B  and  C .

4. Select the Negative checkbox in the 
Output category of the Print dialog box.

TIP These last two options are not commonly 
used for desktop printers, but are used 
by print shops when they create film 
separations.

 A  The  Color menu  in the Output 
category of the Print dialog box.

 B  The  Flip menu  in the Output 
category of the Print dialog box.

 C  Examples of how the  Flip menu  changes 
the readability of a document.

Original Horizontal Vertical
Horizontal & 
Vertical

What Does RIP  RIP Stand For?

You may hear people use the term RIPRIP when they 
talk about printing. RIPRIP stands for raster image 
processing. 

RIP is simply a fancy term for what happens when 
a file is processed for output by a high-resolution 
image setter. In addition, RIP also refers to the 
device that does the processing.
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You can also change the screen frequency 
and angle of halftones in the image.

To change the screen settings:

1. Use the Screening menu to set the 
frequency and angle for the screen 
applied to images  D .

2. Select a color in the Inks area and then 
use the Frequency and Angle fields  E .

TIPTIP Always talk to your print service provider for 
the correct settings.

Trapping refers to the various techniques that 
are used to compensate for the misregistra-
tion of printing plates. However, if you don’t 
under stand trapping, you should con sult with 
the service bureau that will print your fi le 
before you set the trapping.

To turn on basic trapping:

Choose Application Built-In or Adobe 
In-RIPRIP from the Trapping menu  F .

 D  The Screening menu in the Output 
category of the Print dialog box.

 E  The Frequency and Angle fi elds in the 
Output category of the Print dialog box.

 F  The Trapping menu in the Output 
category of the Print dialog box.
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Working with Separations 

Preview

When a document is printed with more than 
one color, each color is called a plate. Printing 
the diff erent colors onto separate plates is 
called making separations. You use the Sepa-
rations Preview panel to view the diff erent 
color plates onscreen. This makes it possible 
to gauge how a document will look on press.

To turn on separations preview:

1. Choose Window > Output > Separations 
Preview. The Separations Preview panel 
appears.

2. Choose Separations from the View 
menu  A . This displays the controls for the 
colors in the document  B .

3. Click each Show/Hide icon next to the 
color name to change the display of the 
colors on the page  C .

TIP Click the Show/Hide icon next to the CMYK 
listing to show or hide all those plates 
together.

 A  Use the  View menu  in the 
Separations Preview panel to turn 
on the separations preview.

 B  The  colors in the document  are displayed 
in the Separations Preview panel.

 C  Click the  Show/Hide icons  in the 
Separations Preview panel to change 
the display of the colors on the page.

Visible plate

Hidden plate

My Favorite Childhood Book

One of my favorite books I had as a kid was a World Book Encyclopedia that had acetate pages that you could 
flip to see how colors built up to a full-color image. (It’s true! At the age of 13 I was into page production and 
color separations.)

When I worked in advertising we called these color breakdowns prog proofs (for progressive proofs). But during 
many years of working with computer graphics, we had no way to see how colors combine on the page. The 
best we could do was print color on individual laser prints and then hold them up to the window to see how 
the colors would separate.

With InDesign, I am thrilled to use the separations preview — an electronic version of my World Book acetate 
pages. Instead of flipping pages, I click ink colors on and off. I can spend hours doing it. It makes me feel like 
a kid again!
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The Separations Preview panel also lets you 
view the total amount of ink for each plate.

To view the inks for each plate:

1. Choose Separations from the View menu.
2. Move the cursor around the page. The ink 

percentages appear next to the name of 
each color  D .

The Separations preview also shows you 
the areas of the page that exceed a certain 
ink limit. For instance, many print shops will 
request that you not defi ne colors totaling 
more than 300% of all the inks combined. The 
Ink Limit setting lets you see if there are any 
areas that exceed this limit.

To check the ink limit:

1. Select Ink Limit from the View menu in 
the Separations Preview panel.

2. Use the amount menu to set the ink limit 
amount  E .

TIPTIP When you switch to the Ink Limit view, the 
document preview changes to a grayscale 
image. Any areas that exceed the ink limit are 
shown in red. The deeper the red, the more 
the color is over the ink limit.

TIPTIP You can also enter your own custom amount 
in the Ink Limit field.

 D  The Separations Preview panel displays the 
ink percentages next to each color plate .

 E  Use the  Ink Limit controls  to check the 
total ink applied in areas of the layout.
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Color Separations and Ink 

Manager

The Inks area of the Output category also lets 
you control how the inks are separated and 
printed.

To set the inks to be printed:

Click the printer icon next to the name of 
each color. Each click changes how the ink 
will print as follows  A :
 • If the icon is visible, the color will print.
 • If the icon is not visible, the color does 

not print.

Sometimes you fi nd yourself with a docu-
ment that contains spot colors that should 
be process colors. The Ink Manager lets you 
convert the spot colors to process inks.

To convert spot colors to process:

1. Open the Ink Manager by clicking the Ink 
Manager button in the Output area of the 
Print dialog box  B .

TIP You can also open the Ink Manager from the 
Swatches panel menu or the Separations 
Preview panel menu.

2. Click the color icon next to the name of 
each color. Each click changes how the ink 
will print as follows  C :
 • A CMYK symbol indicates that the color 

will separate as a process color.
 • A spot color symbol indicates that the 

color will separate on its own plate.
3. Select the All Spots to Process checkbox 

to convert all spot colors to process.
4. If desired, select Use Standard Lab Values 

for Spots. This converts the spot colors 
to process using their built-in LAB color 
values.

 A  The  printer icon next to an ink color  
indicates whether that ink will print or not.

Ink does not print

Ink does print

 B  The  Ink Manager dialog box  
gives you control over how inks 
are separated or printed.

 C  Click the  color icons  in the Ink Manager 
to convert spot colors to process.

Spot color

Process color
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When you import artwork that contains spot 
colors, those spot colors are added to the 
document and the Swatches panel. There are 
no problems if the imported colors are named 
exactly the same as existing colors. But if the 
name of the imported color diff ers from the 
color you have defi ned, you can wind up with 
two separate color plates instead of one  D . 
Thankfully, InDesign lets you map one color 
to be an alias of another.

To map one color to be the alias of another:

1. Select the color you want to change in 
the Ink Manager.

2. Use the Ink Alias menu to choose a 
different color to map to the selected 
one  E . The color is listed in the Ink 
Manager as mapped to the other color  F .

TIPTIP You can map the selected color to a spot or 
process color.

TIPTIP Colors that are mapped to another color 
are not listed in the Inks area of the Output 
category. They are also not listed in the 
Separations Preview panel.

 D  An example of how names typed in 
diff erent cases can create  too many 
spot colors  in a document.

 E  Use the  Ink Alias menu  to have one 
color map to a diff erent one.

 F  An example of how  one color is 
used as the alias  for another.



466 Chapter 19 Output

Setting the Graphics Options

The Graphics options control how much infor-
mation is sent to the printer. You can control 
the data that is sent for placed images.

To control the data sent for images:

Choose one of the following from the 
Send Data menu  A :
 • All sends all the information for the 

image. This is the slowest setting.
 • Optimized Subsampling sends only 

the amount of information necessary 
for the chosen output device. Use 
this option if you’re proofing high-
resolution images on a desktop printer.

 • Proxy sends only a 72-ppi version of 
the image.

 • None replaces the image with 
crosshairs within the frame. Use this 
option when you want to proof only 
the text in the file.

You can also control how much of the font 
information is sent to the printer.

To control the font information sent for 
printing:

1. Choose one of the following from the 
Download menu  B :
 • None sends only a reference to the font 

that you can replace in the PostScript 
data stream.

 • Complete sends the entire set of 
glyphs for the font. This is the longest 
option.

 • Subset sends only those glyphs used in 
the document.

2. Choose Download PPD Fonts to send all 
fonts, even if they have been installed on 
the printer  C . This option is helpful if you 
use a variation of the fonts installed on 
the printer.

 A  Use the  Send Data menu  in the Graphics 
category to control how images are printed.

 C  Choose  Download PPD Fonts  to send 
printer fonts as part of the print information.

 B  Use the  Download menu  in the 
Graphics category to control how 
much of a font is sent to the printer.

Setting the Color Management Options

Rather than go into details of color manage-
ment, it is better for me to recommend that 
you ask your print shop how to set the color 
management options.

Not only is the field of color management way 
beyond the scope of this book, it’s probably way 
beyond what you want to read in this book.

Suffice it to say there is no “QuickStart” for color 
management. It’s a deep topic and deserves 
much more than a section in my book. See Real 
World Color Management by Bruce Fraser, Chris 
Murphy, and Fred Bunting (Peachpit Press) for 
the best information on the topic.
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Setting the Advanced Options

The Advanced category lets you set the 
options for OPI and choose a transparency 
preset. OPIOPI stands for Open Prepress Interface. 
The OPI controls are used when fi les are sent 
to Scitex and Kodak prepress systems.

TIPTIP The OPIOPI workflow is considered an outdated 
output system and is not used by modern 
print houses.

To set the OPIOPI controls:

1. In the OPI area, select the OPIOPI Image 
Replacement checkbox  D .

2. Choose which types of images should be 
replaced during an OPIOPI workflow. (An OPIOPI 
workflow uses low-resolution images for 
the layout and swaps them with high-
resolution images just before printing.)

When you use any of the transparency 
features, InDesign needs to fl atten or convert 
those eff ects into vector and raster images 
as they are sent for output. The Transparency 
Flattener section of the Advanced category 
controls how InDesign fl attens the image.

To set the fl attener preset:

1. Use the Preset menu to choose one of the 
flattener settings  E .

2. If you have used the Pages panel to 
flatten individual spreads, you can select 
the Ignore Spread Overrides checkbox 
(located just below the Preset menu) to 
override that setting. This means that the 
setting you choose in this dialog box will 
be used no matter what flattener settings 
you have applied to the individual pages.

 D  Set the  OPIOPI Image Replacement 
options  to control how images 
are handled during prepress.

 E  Use the  Preset menu  in the 
Transparency Flattener area to set the 
resolution for converting transparency 
eff ects into rasterized images.
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Flattener Presets and Preview

The transparency fl attener presets control 
how the transparency eff ects, drop shadows, 
and feathers are handled during output.

To create a transparency fl attener preset:

1. Choose Edit > Transparency Flattener 
Presets. This opens the Transparency 
Flattener Presets dialog box  A .

2. Click the New button. The Transparency 
Flattener Preset Options dialog box 
appears  B .

3. Use the Name field to name the preset.
4. Move the Raster/Vector Balance slider 

to create more vector or more rasterized 
artwork  C .

5. Set an output resolution in the Line Art 
and Text Resolution field.

TIP A setting of 300 PPIPPI is sufficient for most 
output.

6. Set an output resolution for gradient 
objects in the Gradient and Mesh 
Resolution field.

TIP A setting of 150 PPIPPI is sufficient for most 
gradients.

7. Select Convert All Text to Outlines to 
convert the text to paths.

TIP If this checkbox is not selected, only trans-
parent portions of the text may be converted 
to outlines. This option makes the text width 
consistent. 

8. If you have strokes that pass through 
different transparencies, you may want to 
select Convert All Strokes to Outlines to 
convert the strokes to filled paths. 

9. Select Clip Complex Regions to ensure 
that any differences in raster and vector 
objects always fall along existing paths.

TIP This can result in complex clipping paths, 
which may not print on some devices. 

 A  The  Transparency Flattener Presets 
dialog box  lets you defi ne new presets 
for handling transparency eff ects.

 B  The  Transparency Flattener Preset 
Options dialog box  contains the settings 
for a custom trans parency fl attener preset.

 C  The controls in the Transparency 
Flattener Preset Options dialog box.
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To edit a transparency fl attener preset:

1. Choose the preset you want to edit.

TIPTIP The three default presets, surrounded by 
brackets, cannot be edited  D .

2. Click the Edit button.
3. Edit the preset in the Transparency 

Flattener Presets dialog box.

TIPTIP The Preset Settings area displays a readout of 
the settings for each preset  E .

To delete transparency fl attener presets:

1. Choose the presets you want to delete.

TIPTIP The three default presets, surrounded by 
brackets, cannot be deleted  D .

TIPTIP Use the Shift key to select multiple adjacent 
presets. Use the Cmd/Ctrl key to select 
multiple nonadjacent presets.

2. Click the Delete button.

You can also save transparency fl attener 
presets to share among others. Once saved, 
the presets can then be loaded onto other 
machines.

To save a transparency fl attener preset:

1. Choose the presets you want to save.

TIPTIP Use the Shift key to select multiple adjacent 
presets. Use the Cmd/Ctrl key to select 
multiple nonadjacent presets.

2. Click the Save button.
3. Name the file.

To load a transparency fl attener preset:

1. Click the Load button.
2. Navigate to find the file that contains the 

presets.
3. Click Open. The presets appear in the 

Transparency Flattener Presets dialog box.

 D  The  three default transparency 
fl attener presets  in brackets 
cannot be edited or deleted.

 E  The  Preset Settings area  displays a 
readout of the settings for a particular 
transparency fl attener preset.
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You can apply a fl attener preset to the docu-
ment in the Advanced category of the Print 
dialog box. However, you may have one 
page that requires special fl attener controls. 
InDesign lets you apply fl attener presets to 
each specifi c spread.

TIP Flattening must be handled on a per spread, 
not per page, basis.

To apply a fl attener preset to an individual 
spread:

1. Move to the spread.
2. In the Pages panel menu, choose one of 

the following from the Spread Flattening 
menu:
 • Default leaves the spread flattening 

at whatever setting is applied to the 
document.

 • None (Ignore Transparency) prints 
the spread without any transparency 
effect. This setting is useful for print 
shops that need to troubleshoot during 
output.

 • Custom opens the Custom Spread 
Flattener Settings dialog box. These 
settings are identical to ones in the 
Transparency Flattener Preset Options 
dialog box  A .

 A  The  Custom Spread Flattener Settings 
dialog box  lets you apply diff erent 
fl attener controls to a specifi c spread.

A Short Course in Flattening

You may feel a little overwhelmed by all the 
controls for flattening transparency. Don’t panic: 
Most of the flattening options are best set by the 
print house that will output your files.

However, there are some simple rules that can 
make it easier to get successful results when 
flattening artwork.

Unless you absolutely want text to be part of a 
transparency effect, keep your text above any 
transparency effects. For instance, instead of 
putting text underneath a drop shadow, move 
it above. If the text is black, you won’t see any 
difference in the final output. If it’s a color, set 
it to overprint.

Try to avoid overlapping two gradients with 
transparency effects. That combination creates 
objects that are much too complex.

Run tests. The first time I used transparency and 
blend modes, I sent ten sample pages to my 
publisher, who had them output at the print 
shop. We looked to make sure none of the text 
had changed and there were no problems with 
the images. It saved us a lot of worry when the 
book went to press.
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Instead of waiting for your fi le to be printed, 
you can preview how the fl attening will occur 
with the Flattener Preview panel.

To preview the fl attener settings:

1. Choose Window > Output > Flattener 
Preview. This opens the Flattener Preview 
panel  B .

2. Choose one of the options from the 
Highlight menu  C . This controls which 
objects will be displayed in the flattener 
preview. 

3. Use the Preset menu to choose which 
flattener preset is used to control the 
flattener preview.

4. Click the Refresh button to update the 
screen preview. The page displays the 
highlighted objects in red against other 
grayscale objects  D .
or
Select Auto Refresh Highlight to have the 
screen update automatically.

5. Select Ignore Spread Overrides to use 
only the setting in the Preset menu.

6. If you want, click the Apply Settings to 
Print button to apply the settings to 
the Advanced category of the Print 
dialog box.

TIPTIP You can open the Transparency Flattener 
Presets dialog box using the Flattener 
Preview panel menu.

 B  The  Flattener Preview panel  lets 
you see the eff ects of the fl attener 
presets on your document.

 C  Use the  Highlight menu  to choose 
which objects will be displayed 
in the fl attener preview.

 D  The  fl attener preview highlights  the 
objects aff ected by transparency. Here 
the text below the shadow is highlighted 
whereas the text above the shadow is not.

Text below shadow Text above shadow

Transparency Resources

This book can hardly cover all the aspects of setting transparency and flattening. For more information see 
the InDesign online Help pages.

Also, download the document Getting Started with Transparency Using Adobe Creative Suite Software on the 
Adobe Web site.

Finally, if you are a service provider, you should look at the Print Service Provider Resources page of the Adobe 
Solutions Network (ASN).
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Working with Print Presets

With all the areas in the Print dialog box, you 
wouldn’t want to have to set all the con-
trols each time you have a new document. 
InDesign lets you save the print settings so 
you can easily apply them later.

To save a print preset:

1. Set all the categories in the Print dialog 
box to the settings you want to save.

2. Click the Save Preset button at the 
bottom of the Print dialog box  A . This 
opens the Save Preset dialog box  B .

3. Enter a name for the preset.
4. Click OK. This saves the preset.

To apply a print preset:

Choose a saved preset from the Print 
Preset menu at the top of the Print dialog 
box  C .

You don’t need to go through the Print dialog 
box to create and save a print preset.

To defi ne a printer preset:

1. Choose File > Print Presets > Define. 
The Print Presets dialog box appears  D .

2. Click the New button to define a new 
preset. This opens a version of the Print 
dialog box that lets you set the various 
print categories.
or
Click the Edit button to make changes to 
the selected print preset.

To delete a printer preset:

1. Select the presets you want to delete in 
the Print Presets dialog box.

2. Click the Delete button.

 B  Use the  Save Preset dialog box  to 
name your own printer preset.

 A  Click the  Save Preset button  to save the 
current Print settings as a print preset.

 C  A saved preset can be applied 
using the  Print Preset menu  at 
the top of the Print dialog box.

 D  Saved presets are listed in the 
Print Presets dialog box .
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One of the benefi ts of working with printer 
presets is that you can export them so others 
can print docu ments with the same settings.

To export printer presets:

1. In the Print Presets dialog box, select the 
presets you want to export.

TIPTIP Use the Shift key to select adjacent multiple 
presets. Use the Cmd/Ctrl key to select 
nonadjacent multiple presets.

2. Click Save. A dialog box appears where 
you can name the document that 
contains the exported presets.

Your service bureau can provide you with 
printer presets that you can import to use for 
printing or packaging documents.

To import printer presets:

1. In the Print Presets dialog box, click Load.
2. Use the dialog box to select the 

document that contains the presets 
exported from another machine.

3. Click OK. The presets appear in the Print 
Presets dialog box.

Creating a Print Summary

With all the settings in the Print dialog box, 
you may want to keep track of how a docu-
ment has been printed. The Summary area 
gives you a report of all the print settings.

To use the Summary area:

Scroll through the Summary area to see 
all the settings applied to a print job  E .
or
Click the Save Summary button to save a 
text file listing all the print settings.

 E  Use the  Summary area  to see all the 
print settings applied to a document.
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Creating Printer’s Spreads

When you work on an InDesign document, 
you view the pages in what are called reader’s 
spreads. However, when documents are 
printed, they need to be arranged in what 
are called printer’s spreads. (This is also called 
imposing pages in position.)
For example, in an eight-page brochure, 
page one would be paired up with page 
eight. Page two would be next to page seven. 
Manually creating printer’s spreads is a night-
mare. Fortunately, you can easily arrange your 
document into printer’s spreads using the 
Print Booklet command.

To impose a document into printer’s 
spreads:

1. Choose File > Print Booklet. The Print 
Booklet dialog box appears  A .

2. Click the Setup category. The Setup 
controls appear  B .

3. Choose a print preset from the Print 
Preset menu  C . If you have no preset 
available, choose [Current Document 
Settings] to use whatever printer is 
chosen in your Print dialog box.

TIP This setting allows you to choose the Adobe 
PDF printer to impose as a PDF file.

4. Use the Pages control to choose which 
pages should be imposed.

5. Choose the Booklet Type and Margins 
controls as explained in the following 
exercises.

 A  The  Print Booklet dialog box  lets 
you create printer’s spreads.

 B  The  Setup controls  of the 
Print Booklet dialog box.

 C  The  Print Preset menu  lets you choose 
which print preset should be used.
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There are diff erent types of booklets. Each 
one requires separate controls. If you are 
unsure of which type of booklet you are 
creating, ask your print shop.

TIPTIP Check with your printer for the correct 
settings for all of these controls.

To set the type of booklet:

1. Choose the orientation and binding 
for the booklet from the Booklet Type 
menu  D .

2. Depending on the orientation and 
binding, you may need to set any or all of 
the following controls:
 • Space Between Pages is the amount of 

space between the pages.
 • Bleed Between Pages is the amount of 

space added around the pages.
 • Creep is an adjustment for the 

thickness of the pages as they are 
folded.

 • Signature Size is how many pages are 
bound together.

You also need to set the margins for the 
pages that are imposed.

To set the margins:

Select Automatically Adjust to Fit Marks 
and Bleeds  E  to set the amount necessary 
to fit any printer’s marks and bleeds on 
the original layout.
or
Deselect that option and manually set the 
margins.

To print blank spreads:

Select Print Blank Printer Spreads (at the 
bottom of the Print Booklet dialog box) to 
include those spreads that don’t contain 
any items on the pages.

 D  The  Booklet Type menu  of the 
Print Booklet dialog box.

 E  Choose  Automatically Adjust to 
Fit Marks and Bleeds  to set the 
booklet margins automatically.

Please! Think Before You Impose!

At least once a month I read about someone who 
thinks they need to send printer’s spreads in to 
their service bureau before their job (brochure, 
book, pamphlet, or other document) can be 
printed.

This is not a safe road to go down. Creating 
printer’s spreads is not something the average 
designer is trained to do. Even I wouldn’t have 
the foggiest idea of how to make the settings for 
my jobs. There are too many variables.

I have no idea what the signature size is going to 
be or how many pages will be imposed together.

Even worse, I don’t know what to choose for the 
creep size as I don’t know how thick the folds in 
my paper will be.

Having said that, if all you want to do is set up a 
job to be run on your office printing machine, or 
send the job to the local copy shop for a simple 
booklet, then the Print Booklet command is 
perfect for you!
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You can gauge if you’re setting things up cor-
rectly by checking the Preview option in the 
Print Booklet dialog box.

To preview the imposed pages:

1. Choose Preview from the Print Booklet 
dialog box. The pages as they will 
be imposed appear in the Preview 
window  A .

2. Use the page controls to scroll through a 
preview of all the imposed pages  B .

3. Check the Messages area to see if there 
is any information that you should know 
about regarding the imposition  C .

4. Check the Warning area to see if there 
are alerts for any problems in the final 
imposed document  D . 

You can also see a summary of all the settings 
for an imposed document.

To see the summary of the imposed 
settings:

Choose Summary from the Print Booklet 
dialog box. The summary appears.

 A  The  Preview window  of the Print 
Booklet dialog box shows how 
the pages will be imposed.

 D  The  Warning area  of the Print Booklet 
dialog box alerts you to any problems that 
may occur in the imposed document.

 C  The  Messages area  of the Print Booklet 
dialog box gives you information 
about the imposed document.

B Use the  page controls to scroll through 
p e e s o t e posed pages.previews of the imposed pages.
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Creating PostScript Files

Instead of sending the InDesign document to 
a service bureau, you can create a PostScript 
fi le that contains all the information neces-
sary to print the fi le. (This is sometimes called 
printing to disk.) A standard PostScript fi le 
contains all the information needed for print-
ing the fi le as well as the specifi c information 
about the printer.

To create a standard PostScript fi le:

1. Choose File > Print.
2. Choose PostScript® File from the Printer 

menu  E .
3. Choose the type of printer that will print 

the file.
4. Set all the options in the print categories 

in the Print dialog box.

TIPTIP Check with the service bureau that will print 
your file for the correct options. 

5. Choose a name and location for the file.
6. Click Save.

A device-independent PostScript fi le does not 
contain any information about the type of 
printer or output device.

TIPTIP This lets you create a PostScript file even if 
you don’t know the type of printer that your 
document will be printed on.

To create a device-independent 
PostScript fi le:

1. Choose File > Print.
2. Choose Device Independent from the PPDPPD 

menu  F .
3. Follow steps 3 through 6 in the previous 

exercise.

 E  Choose  PostScript® File  from 
the Printer menu to create a fi le 
that contains all the information 
necessary to print the document.

 F  Choose  Device Independent  from the 
PPD menu to create a PostScript fi le 
that can be printed to any printer.



478 Chapter 19 Output

Preflighting Documents

Before you send your document out to be 
printed, you need to know if there could be 
any problems printing your job. Fortunately, 
InDesign can prefl ight the elements in your 
document. (The name comes from the list 
that pilots complete before they take off .)

To run a prefl ight check:

1. Choose Window > Output > Preflight. 
The Preflight panel opens  A .

2. Choose Pages: All to check all the pages in 
the document.
or
Click the button next to the Pages field to 
enter a specific page or range of pages.

3. Click the On button. InDesign lists 
problems in the Error area.

4. Click on a specific error, and then open 
the Info triangle to reveal any additional 
information about the errors  B .

5. Choose Save Report from the Preflight 
panel menu to create a PDF file that 
summarizes all the items in the Preflight 
panel.

Once you fi nd a prefl ight error, you will want 
to fi x it. This can be easily handled through 
the Prefl ight panel.

To fi x errors in the Prefl ight panel:

1. Open the Error list so you can see the 
specific error in the panel.

2. Click the page number link in the Preflight 
panel  C . This moves you to the errant 
object or text.

3. Follow the steps in the Info area to fix the 
error or handle it any other way you can.

TIP When the error is resolved, it disappears from 
the Errors list.

 A  The  Prefl ight panel  lets you check to 
fi nd problems with your document.

 B  The  Info area  gives you specifi cs as to 
why an error is listed and how to fi x it.

 C  Click the  page number in the Errors 
list  to go to the specifi c errant 
object or text in the document.



InDesign CS5 Visual Quickstart Guide 479

Creating Preflight Profiles

The Prefl ight panel only searches for those 
items that it has been told are errors. 
InDesign ships with a Basic profi le that fl ags 
the most common document errors. But it is 
very simple for you to create your own profi le 
that highlights the errors you need to fi nd.

To create your own prefl ight profi le:

1. Choose Define Profiles from the Preflight 
panel menu. The Preflight Profiles dialog 
box appears  D .

2. Click the plus sign to create a new profile.
3. Enter a name in the Profile Name field.
4. Click the triangle to open the General 

category and enter a description that 
explains the purpose of the profile.

5. Use the triangle to open each of the 
categories and choose the errors as 
described in the chart that follows this 
exercise.

6. Click Save to save your settings as you 
work.
or
Click OK to finish the profile.

TIPTIP The table on the next page contains the 
preflight categories and a list of the profile 
items and what each profile flags as an error.

 D  The  Prefl ight Profi les dialog box  
lets you select errors that should be 
fl agged by the Prefl ight panel.
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Categories and Errors for Prefl ight Profi les

Category Profi le Item Flags as an Error

Links Links Missing or Modifi ed Files labeled missing or modifi ed.

OPI Links OPI tags on images.

Color Transparency Blending Space 
Required

Transparency blend space not defi ned as 
CMYKCMYK or RGB.

Cyan, Magenta, or Yellow Plates 
Not Allowed

Presence of non-black plates.

Color Spaces and Modes Not 
Allowed

Presence of RGBRGB, CMYKCMYK, Gray, LAB, or Spot Color plates.

Spot Color Setup Number of spot colors exceeds maximum.

Spot colors using LAB values or CMYKCMYK equivalents.

Overprinting Applied in 
 InDesign

Colors set to overprint.

White or [Paper] colors set to overprint.

[Registration] Applied Objects have color [Registration] applied.

Images and 
Objects

Image Resolution Minimum and maximum resolutions outside the 
defi ned values for color, grayscale, and 1-bit images.

Non-Proportional Scaling of 
Placed Object

Horizontal and vertical scaling are not identical.

Use Transparency Presence of transparency eff ect or transparent image.

Image ICCICC Profi le Profi le that checks to see if image has an ICCICC profi le.

Searches for images that have their ICCICC Profi les 
modifi ed. Exception can be made for images with no 
embedded profi les.

Layer Visibility Overrides Images with layers turned on or off  in InDesign.

Minimum Stroke Weight Stroke weights exceed amount set by the user. Can 
be limited to just multiple inks or white.

Interactive Elements Interactive objects such as buttons or hyperlinks.

Bleed/Trim Hazard Elements that exceed a certain amount outside the 
specifi ed bleed area. Can also look for elements near 
the spine.
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Categories and Errors for Prefl ight Profi les

Category Profi le Item Flags as an Error

Text Overset Text Text frames with overset text.

Paragraph Style and Character 
Style Overrides

Style overrides applied to text. Exceptions can be 
made for styles, language, kerning/tracking, or color.

Font Missing Missing fonts.

Glyphs Missing Glyphs that are missing from a font.

Dynamic Spelling Detects Errors Words fl agged by the Dynamic Spelling feature.

Font Types Not Allowed A choice of protected fonts, TrueType, Bitmap, Type 1 
Multiple Master, OpenType CFFCFF CID, OpenType TTTT, 
Type 1 CID, ATCATC (Adobe Type Composer).

Non-Proportional Type Scaling Unequal horizontal and vertical text scaling.

Minimum Type Size: [amount] Text set below a certain user-defi ned amount. Can be 
limited to text with multiple inks or white.

Cross-References Cross-references that are out of date. Cross-references 
that are unresolved.

Conditional Text Indicators Will 
Print

Conditional text that has been set to print its condi-
tional set indicators

Document Page Size and Orientation Page size not a specifi ed size. Incorrect orientation 
can be ignored.

Number of Pages Required Too many or too little number of pages.

Not a certain number of pages.

Number of pages are not a multiple of an amount.

Blank Pages in Document Pages that contain no objects.

Pages that contain only master page items.

Pages that contain only nonprinting items.

Bleed and Slug Setup Bleed amounts that are not a minimum size, a maxi-
mum size, or exactly a certain size.

Slug amounts that are not a minimum size, a maxi-
mum size, or exactly a certain size.
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To delete a prefl ight profi le:

1. With the Preflight Profiles dialog box 
open, select the profile you want to 
delete.

2. Click the minus sign from the Preflight 
Profiles menu to delete the profile.

3. Click Save or OK when prompted.

You can export a profi le from one document 
so that it can be used by other documents.

To export a prefl ight profi le:

1. With the Preflight Profiles dialog box 
open, select the profile you want to 
export.

2. Choose Export Profile from the Preflight 
Profile menu  A .

3. Name the profile document and navigate 
to store it in the proper folder (directory).

4. Click Save or OK to save the profile.

Prefl ight profi les are saved as part of the 
InDesign application. However, you can 
embed a profi le so that it is always available 
even if the document is moved to another 
person’s copy of InDesign.

To embed a prefl ight profi le:

1. With the Preflight Profiles dialog box 
open, select the profile you want to 
embed.

2. Choose Embed Profile from the Preflight 
Profile menu.
or
Click the Embed Profile icon in the 
Preflight panel  B .

 B  The  Embed Profi le icon  in the 
Prefl ight panel lets you embed 
a profi le in a document.

 A  The  Prefl ight Profi les menu  lets you 
export, add, or embed prefl ight profi les.
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Setting the Preflight Options

You can set how prefl ight profi les should be 
applied as part of a prefl ight check.

To set the prefl ight options:

1. Choose Preflight Options from the 
Preflight panel menu. This opens the 
Preflight Options dialog box  C .

2. Use the Working Profile menu to choose 
which profile should be used as part of 
the preflight.

3. Set the When Opening Documents 
options to choose to use the embedded 
profile or the working profile.

4. Use the Layers menu in the Include area 
to choose which of the following items 
should be part of the preflight:
 • All layers in the document
 • Visible layers only
 • Visible and printing layers only

5. Select the Objects on Pasteboard 
checkbox to include objects not on the 
document pages.

6. Select the Non-printing Objects checkbox 
to include objects not set to print.

 C  The  Prefl ight Options dialog box  
controls which objects and layers should 
be included as part of a prefl ight.
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Packaging a Document

Instead of manually collecting fi les needed to 
print, you can use the Package command to 
assemble the fi les for you.

To package fi les for printing:

1. Choose File > Package to open the 
Package dialog box. This gives you a final 
overview of the document where you can 
spot any obvious errors  A .

2. Click the Package button to open the 
Printing Instructions dialog box.

3. Fill out the contact and file information.
4. Click Continue. This opens the Create 

Package Folder dialog box  B .
5. Name the folder that will hold the files.
6. Select the following options for the 

package:
 • Copy Fonts (except CJK) copies the 

fonts used in the document except 
double-byte fonts such as those for 
Asian languages.

 • Copy Linked Graphics copies placed 
images that are not embedded in 
the file.

 • Update Graphic Links in Package 
automatically updates any modified 
graphics.

 • Use Document Hyphenation Excep-
tions Only limits the hyphena tion 
exceptions to only those added to the 
document.

 • Include Fonts and Links From Hidden 
and Non-Printing Content adds the 
fonts and graphics from layers that are 
not visible.

 • View Report launches a text editor 
to open the report created with the 
document.

7. Click Save to assemble all the necessary 
files in the package folder.

 B  The  Create Package Folder dialog box  
lets you set options for the contents of 
the package that InDesign creates.

 A  The  Package dialog box  shows the 
fonts, images, links, colors, print settings, 
and plug-ins in the document.
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Exporting
Printing your document on paper is 

not the only way in which your 
InDesign fi les can be published. Export-
ing gives you many options for publish-
ing documents.

For instance, you might want clients to 
read your document electronically —  
even if they don’t have the InDesign 
application. Or you might want to take 
a design that you created with InDesign 
and use it as the graphic in another 
page-layout program. Or you may 
want to turn your InDesign document 
into Web pages. You may even want to 
display your InDesign pages on mobile 
phones!

When you convert your InDesign fi les 
into other formats, you use the export 
features of the program. Using the 
Export command lets you change 
InDesign documents into other types 
of publications such as Portable Docu-
ment Format (PDFPDF) fi les or Extensible 
Hypertext Markup Language (XHTMLXHTML) 
pages.
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Setting the Export File Options

InDesign gives you many export options. In 
each case you choose a fi le format, name the 
fi le, and save it to a location.

To choose a fi le format:

1. Choose File > Export. The Export dialog 
box appears  A .

2. Give the file a name and set the location.
3. Choose one of the formats from the table 

below.
4. Click Save. If necessary, this opens an 

options dialog box for each format.

File format Function Notes
Adobe InDesign 
Tagged Text

Creates a text fi le that contains 
the codes used for formatting 
text.

An insertion point must be inside 
a text frame for this option to 
appear in the Export Format list.

Adobe PDF (Interac-
tive)

Allows you to create a PDFPDF with 
interactive and multimedia fea-
tures. See Chapter 18 for informa-
tion on exporting interactive PDF 
fi les. 

Adobe PDF (Print) Brings up the export options for 
creating a static PDF for print and 
editorial review.

EPS Creates a fi le that can be placed 
as a graphic. PDF fi les are pre-
ferred over EPS fi les.

Flash CS5 Pro (FLAFLA) Creates a fi le that can be opened 
by Adobe Flash CSCS5. See Chapter 
18 for information on exporting 
Flash fi les. 

Flash Player (SWFSWF) Creates a Flash movie (SWFSWF) that 
can be played in a Web browser 
or added to a Flash (FLAFLA) presen-
tation. See Chapter 18 for informa-
tion on exporting SWF movies. 

 A  The  options for exporting  
InDesign documents.
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File format Function Notes
InCopy Document Creates a text fi le that can be 

opened using InCopy.
A text frame must be selected or 
an insertion point must be inside 
a text frame for this option to 
appear in the Export Format list.

InDesign Snippet Creates a small fi le that contains 
the instructions for recreating 
InDesign elements. Snippets are 
covered in Chapter 12, “Libraries 
and Snippets.”

An object or objects must be 
selected for this option to appear 
in the Export Format list.

InDesign Markup 
(IDMLIDML)

Creates a fi le that can be opened 
by the InDesign CSCS4 application. 
It also can be used to clean up CSCS5 
fi les that are behaving strangely.

JPEG Converts the page or selected 
elements into a raster image that 
can be used in a Web page.

Rich Text Format Exports selected text with format-
ting that can be read by most 
word processing applications.

An insertion point must be inside 
a text frame for this option to 
appear in the Export Format list.

Text Only Exports selected text without any 
formatting.

An insertion point must be inside 
a text frame for this option to 
appear in the Export Format list.

XML Creates text formatted with the 
Extensible Markup Language, 
which off ers customizable defi ni-
tions and formatting tags. 

Working with XML is beyond 
the scope of this book. I recom-
mend A Designer’s Guide to Adobe 
InDesign and XMLby James Maivald 
and Cathy Palmer.

TIP There are three additional export options under the File > Export For menu. 

File format Function Notes
Buzzword Creates a text fi le that is uploaded 

to the Adobe.com server. This text 
fi le can then be edited by others.

Visit Acrobat.com for more infor-
mation on using Buzzword.

Dreamweaver Creates a package of elements 
that can be incorporated into a 
Dreamweaver Web layout.

Working with Dreamweaver is 
beyond the scope of this book.

EPUB Creates an electronic book 
document which can be read by 
an ebook reader such as Adobe 
Digital Editions.

See the articles by Gabriel Powell 
at InstantInDesign.com for more 
information on creating EPUBs.
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Creating PDFPDF Files
You can convert your InDesign fi les into 
PDF documents so that others can read 
them — even if they do not have the InDesign 
application.

To set the PDFPDF export options:

1. Click each of the categories on the left 
side of the Export Adobe PDF dialog box  A  
to display the options.

TIP You do not need to set all the controls every 
time you print unless you need to change a 
specific setting.

2. Click the Export button to create the 
PDF file.

Setting the PDFPDF General 

Controls

These are the various areas in the General 
category for exporting as a PDF  B .

To set the PDFPDF version and standard:

1. Use the Compatibility menu to choose 
which version of PDF files you want to 
save  C .

TIP Higher versions allow you to save a PDFPDF with 
more options.

2. Use the Standard menu to choose one of 
these five recognized ISOISO (International 
Organization for Standardization) 
standards for PDFPDF/X X files  D :

TIP Check with your print shop or publication for 
which PDF/X file they require.

 A  The Export PDF 
 categories list .

 B  The  General category  of the 
Export Adobe PDF dialog box.

 C  The  Compatibility menu  lets you 
choose which PDF version you export.

 D  The  Standard menu  lets you apply an ISOISO 
printing standard for PDF documents.
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To specify which pages to export:

1. In the Pages area, select All to export all 
the pages in the document  E .
or
Select Range to enter specific pages.

TIPTIP Use the hyphen to select a range of pages 
such as 4–9, or use commas to enter 
individual pages such as 3, 8.

2. Select the Spreads checkbox to keep 
pages that are within spreads together in 
the Acrobat file.

To set the general options:

1. Choose one of the following from the 
Options area in the General category  F :
 • Embed Page Thumbnails adds a 

thumbnail image for each page. It is 
not necessary for Acrobat 5 and higher.

 • Optimize for Fast Web View prepares 
for downloading from Web servers.

 • Create Tagged PDFPDF adds tags that 
allow the PDFPDF to be read by screen 
readers.

 • View PDFPDF after Exporting opens the 
finished Adobe PDFPDF file in Acrobat.

 • Create Acrobat Layers is available 
for PDF 1.5 and higher. It converts the 
InDesign layers into Acrobat layers.

2. Choose which layers to include from the 
Export Layers list  F . 

ISO Standards?

The ISO (International Organization for Standardization) has created standards for PDF documents. When you 
use these standards you are choosing settings that are relied on as working properly for many publishers. This 
eliminates many of the color, font, and trapping variables that may create printing problems.

You may be asked to use a PDF/XPDF/X standard if you are creating PDFPDF documents that will be placed in magazines 
or newspapers.

 F  The  Options controls  in the 
General category of the Export 
Adobe PDF dialog box.

 E  The  Pages area  in the General category 
of the Export Adobe PDF dialog box.
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To control what to include in the PDF:

Choose one of the following from the 
Include area in the General category  A :
 • Bookmarks creates bookmarks for 

table of contents entries, preserving 
the TOCTOC levels. 

 • Hyperlinks creates Acrobat hyperlinks 
from InDesign hyperlinks, cross-
references, table of contents entries, 
and index entries.

 • Non-Printing Objects exports objects 
that have the nonprinting option 
applied. 

 • Visible Guides and Grids exports the 
guides and grids currently visible in the 
document.

If you have interactive elements, such as 
rollover buttons, you need to control how to 
handle those elements during PDF export.

To handle interactive elements:

Choose one of the following from the 
Interactive Elements menu  A :
 • Do Not Include deletes the interactive 

elements from the PDF output. Use this 
option when you want no trace of the 
interactive element in the PDF file. 

 • Include Appearance leaves the visible 
artwork for the interactive elements, 
but deletes the interactivity. 

A  The  Include settings  in the 
General category of the Export 
Adobe PDF dialog box.

Creating PDFPDF Files for Both 
Print and Interactivity

So what should you do if you need a PDFPDF for 
print as well as an interactive presentation? The 
answer is simple, just export once using the 
Adobe PDFPDF (Print) controls and then again using 
the Adobe PDF (Interactive) settings.
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Setting the PDF Compression 

Options

One of the benefi ts of creating PDF fi les is that 
they can be compressed to take up less space. 
You use the same controls for compressing 
color and grayscale bitmap images  B .

To set the color and grayscale 
downsampling:

1. Choose one of the following from the 
Sampling menu  C :
 • Do Not Downsample does not throw 

away any pixel information. Use this to 
maintain all information in the image.

 • Average Downsampling to averages 
the pixels in a sample area.

 • Subsampling to reduces processing 
time compared to downsampling, but 
creates images that are less smooth.

 • Bicubic downsampling to is the 
slowest but most precise method, 
resulting in the smoothest tonal 
gradations.

2. When you have set a downsampling 
method, enter an amount in the 
resolution field  D .

TIPTIP For print work this setting is usually 1.5 times 
the line screen of the printing press.

TIPTIP For onscreen viewing this setting is usually 
72 pixels per inch.

3. Enter an amount in the field for images 
above a certain resolution  D .

TIPTIP This helps you downsample only high-
resolution images without losing information 
in lower-resolution images.

Talk to Your Service Bureau

If you create PDFPDF files for onscreen viewing or to 
be downloaded from the Web, you can use the 
compression settings to reduce the file size.

However, if you create PDFPDF files to be output by 
a service bureau for print work, you should not 
apply too much downsampling or compression.

Ask your service bureau for the correct settings. 
Better yet, ask them to create a PDF preset that 
you can load onto your machine.

 B  The  Compression controls  in the 
Export Adobe PDF dialog box for color 
and grayscale bitmap images.

 C  The  Sampling menu  for color and 
grayscale bitmap images.

 D  The  resolution fi elds  for color 
and grayscale bitmap images.
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To set the color and grayscale compression:

1. Choose one of the following from the 
Compression menu  A :
 • None applies no compression.
 • Automatic (JPEGJPEG) lets InDesign 

automatically determine the best 
quality for color and grayscale images. 

 • Use JPEGJPEG for images with tonal changes.
 • Use ZIPZIP for images with large areas of 

flat color.
 • Use JPEGJPEG 2000 for tonal images for 

Acrobat 6 or higher. 
 • Use Automatic (JPEG 2000) for color 

and grayscale images for Acrobat 6 or 
higher.

2. Choose an Image Quality setting  B :
 • Maximum sets the least amount of 

com pression.
 • Minimum sets the most.

There are diff erent compression options for 
monochrome bitmap images (such as 1-bit 
scanned art)  C .

To set the monochrome bitmap 
downsampling:

Choose one of the following from the 
Sampling menu  D :
 • Do Not Downsample does not throw 

away any pixel information. Use this 
setting if you want to maintain all the 
information in the image.

 • Average Downsampling to averages 
the pixels in a sample area.

 • Subsampling to is faster than down -
samp ling, but creates images that are 
less smooth.

 • Bicubic downsampling to is the 
slowest but most precise method, 
resulting in the smoothest tonal 
gradations.

 A  The  Compression menu  for color 
and grayscale bitmap images.

 B  The  Image Quality menu  for color 
and grayscale bitmap images.

 C  The  Compression controls  for 
monochrome images.

 D  The  Sampling menu  for 
monochrome images.
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To set the monochrome bitmap resolution:

1. When you have set a downsampling 
method, enter an amount in the 
resolution field  E .

TIPTIP For print work, this setting is usually the 
resolution of the output device, with a limit of 
1500 dots per inch.

2. Enter an amount in the field for images 
above a certain resolution  E .

TIPTIP This helps you downsample only high-
resolution images without losing information 
in lower-resolution images.

To set the compression for monochrome 
images:

1. Choose one of the following from the 
Compression menu  F :
 • None applies no compression to the 

image.
 • CCITTCCITT Group 3 is similar to the 

compression used for faxes.
 • CCITTCCITT Group 4 is a general-purpose 

method that produces good results for 
most monochromatic images.

 • ZIP works well for black-and-white 
images that contain repeating patterns.

 • Run Length produces the best results 
for images that contain large areas of 
solid black or white.

2. Select Compress Text and Line Art to 
further reduce the size of the file.

3. Select Crop Image Data to Frames to 
delete the image outside the frame. 

 E  The  resolution fi elds  for 
monochrome images.

 F  The  Compression menu  for 
monochrome images.

Marks and Bleeds PDFPDF Options

The options for setting the Marks and Bleeds 
category for PDFPDF documents are the same as the 
options when you print the file. See Chapter 19, 
“Output,” for how to work with those settings.
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Setting the Output PDFPDF Options

The Output category contains the controls 
for how color is handled as well as the PDFPDF/x 
settings.

To set the color controls:

1. Choose one of the following from the 
Color Conversion menu  A :
 • No Color Conversion does not convert 

the colors in the document.
 • Convert to Destination converts all 

colors to the destination profile.
 • Convert to Destination (Preserve 

Numbers) converts colors to the 
destination profile only if the 
embedded profiles differ.

2. Choose a profile for the type of output 
device from the Destination menu. This 
is typically the type of printing machine 
that will handle the file.

3. Choose one of the following from the 
Profile Inclusion Policy menu to control 
how the color profiles are handled in the 
document  B .
 • Don’t Include Profiles removes 

all color management from the 
document.

 • Include All Profiles creates a color-
managed document.

 • Include Tagged Source Profiles is 
used if you only output to specially 
calibrated output devices.

 • Include All RGBRGB and Tagged Source 
CMYK Profiles is used to calibrate both 
RGB and CMYKCMYK images.

4. Select Simulate Overprint to show 
onscreen a representation of how 
overprinting will look when printed.

5. Click the Ink Manager button to control 
how process and spot colors are handled.

 A  The  Color Conversion menu  allows you to 
control how colors in a PDF are handled.

 B  The  Profi le Inclusion Policy menu  
controls how color management 
profi les are handled.

More Info on Color Profiles

If you are interested in learning more about color 
profiles, you should visit www.color.org. This is 
the home of the International Color Consortium. 
From their Web site:

The International Color Consortium was estab-
lished in 1993 by eight industry vendors for the 
purpose of creating, promoting, and encouraging 
the standardization and evolution of an open, 
vendor-neutral, cross-platform color manage-
ment system architecture and components. The 
outcome of this cooperation was the development 
of the ICC profile specification.

The intent of the International Color Consortium® 
profile format is to provide a cross-platform device 
profile format. Device profiles can be used to trans-
late color data created on one device into another 
device’s native color space.

www.color.org
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If you have chosen a PDF/X standard, you can 
control the output profi les for the document.

To set the PDF/X profi le controls:

1. Use the Output Intent Profile Name menu 
to select the profile that matches how the 
document will be printed  C .

2. If desired, enter an optional description of 
how the file will be output in the Output 
Condition Name field. This information is 
then stored in the PDFPDF/X file.

3. If desired, enter the registration name 
for the output condition in the Output 
Condition Identifier field. This field is 
automatically filled in when you choose 
one of the standard output profiles.

4. If desired, enter the URL in the Registry 
Name field where the output information 
is stored. This field is automatically filled 
in when you choose one of the standard 
output profiles.

 C  The  PDFPDF/X area  controls the 
profi les for PDF/X fi les.

Subsetting Fonts?

One reason why PDFPDFs became popular is you 
don’t have to worry about someone having 
particular fonts in order to view the file. You can 
embed the entire font or you can subset only a 
portion.

If you embed the entire font, you add to the file 
size, but you allow anyone who has the font to 
make changes to the text. If you subset the font, 
it makes a smaller file, but it also means that the 
person on the other end won’t be able to make 
changes to the text.

The default setting of 100% means that only 
a subset of the font will be embedded unless 
you have used every single character in the 
font. If you lower the threshold to, let’s say 35%, 
InDesign embeds only the characters used 
in the document up to a maximum of 35% of 
the characters. If you use more than 35% of the 
characters, InDesign embeds all the characters 
in the font.

There is no option to embed the entire font per 
se, but if you set the amount to 1% then you will 
most likely embed all the characters in the font.
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Setting the Advanced PDFPDF 

Options

The Advanced category contains the controls 
for handling colors and fonts, and for setting 
the transparency fl attener options.

TIP The OPI controls are the same as the ones in 
the Print dialog box.

TIP The Transparency Flattener controls are the 
same as the ones in the Print dialog box.

To control how much of a font is embedded:

Enter an amount in the Subset fonts 
field for the threshold amount  A . That 
threshold determines at what point all the 
characters of the font will be embedded. 

To add a Job Defi nition Format to the fi le:

Select the checkbox to Create JDFJDF File 
Using Acrobat  B . This adds Job Definition 
Format (JDFJDF) information to the PDFPDF 
document.

TIP You must have Acrobat 7 Professional or 
higher installed in order to add the JDFJDF 
information to the file.

 A  The  Subset fonts when percent 
of characters used is less than 
fi eld  in the Advanced area of the 
Export Adobe PDF dialog box.

 B  The  Job Defi nition Format (JDFJDF) 
option  in the Advanced area of the 
Export Adobe PDF dialog box.

What’s a Job Definition Format File?

A Job Definition Format (JDF) file describes the 
intent of the final output of a file. These speci-
fications are used to produce the final printed 
piece. This file can specify the paper and ink, pro-
duction quantities, and customer information. 

The JDFJDF file and associated PDFPDF files travel together 
as part of the JDFJDF workflow, from JDFJDF device to JDFJDF 
device. When the JDFJDF file is submitted to produc-
tion, the information it contains is used to define 
the processes for print production.
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Setting the Security PDF 

Options

You can also set security options for PDF fi les 
to restrict who can open the fi le or to limit 
what they can do to it.
The Document Open Password area allows 
you to set the password that readers must 
enter in order to open the fi le.

To set the document password:

1. Select Require a Password to Open The 
Document  C .

2. Type a password in the Document Open 
Password field.

The Permissions area sets up what edits and 
modifi cations people can make to the PDF 
once they have opened it. The Permissions 
password is needed in order to change the 
settings in the Permissions area.

To set the permissions password:

1. Select Use a Password to Restrict Printing, 
Editing, and Other Tasks  D .

2. Type a password in the Permissions 
Password field.

TIPTIP This can’t be the same as the Document Open 
Password.

To set the printing permission:

Choose one of the following from the 
Printing Allowed menu  E :
 • None turns off all printing from the 

document.
 • Low Resolution (150 DPI) prints only 

low-resolution versions of the images.
 • High Resolution prints the full 

resolution of the images.

 C  The  Document Open Password 
area  of the Security category of the 
Export Adobe PDF dialog box.

 D  The  Permissions area  of the 
Security category of the Export 
Adobe PDFPDF dialog box.

 E  The  Printing Allowed menu  
of the Security category of the 
Export Adobe PDF dialog box.
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To set the changes that are allowed:

1. Choose one of the following from the 
Changes Allowed menu  A :
 • None allows no changes whatsoever.
 • Inserting, deleting and rotating 

pages allows the user only to add, 
remove, or change the position of 
pages in the document. It does not 
allow changing the content of the 
pages.

 • Filling in form fields and signing 
allows changes to form fields or 
applying a security signature to the 
document.

 • Commenting, filling in form fields, 
and signing allows adding comments, 
changing form fields, or applying a 
security signature to the document.

 • Any except extracting pages allows all 
changes except removing pages from 
the document.

2. Select any of the following as desired  B :
 • Enable copying of text, images and 

other content.
 • Enable text access of screen reader 

devices for the visually impaired.
 • Enable plaintext metadata.

 A  The  Changes Allowed menu  
of the Security category of the 
Export Adobe PDF dialog box.

 B  The other permissions you can 
set in the Security category of the 
Export Adobe PDF dialog box.

Limits of Security

Even when you set security options, there are 
some additional things to remember.

First, if you e-mail a PDFPDF document, send the 
password in a separate e-mail. That makes it 
less likely that the password will be found if your 
e-mail is hijacked.

Next, passwords are case sensitive. Use a com-
bination of uppercase and lowercase letters as 
well as numbers to make the password more 
secure. Don’t use ordinary words as passwords.

Finally, if you feel that you would lose your entire 
livelihood if the PDF were to fall into the wrong 
hands, then don’t distribute it as a PDF. There are 
plenty of people who take it as a challenge to 
break into password-protected PDF documents.
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Working with PDF Presets

Just as you can create printer presets for 
printing documents, you can also create PDF 
presets that contain settings for generat-
ing diff erent types of PDF documents. For 
example, you may want to post a PDFPDF fi le on 
the Web or send the fi le to a print shop for 
output.

To save the current PDF settings as a PDF 
preset:

1. Set the options in the Export Adobe PDF 
dialog box.

2. Click the Save Preset button  C . This opens 
the Save Preset dialog box  D .

3. Enter a name for the preset and click OK. 
The new preset appears at the top of the 
Export Adobe PDF dialog box.

Once you have saved a preset, you can easily 
apply it.

To apply a PDFPDF preset:

Choose a saved preset from the Adobe 
PDF Preset menu at the top of the Export 
Adobe PDF dialog box  E .
or
Choose File > Adobe PDF Presets and 
then pick the preset listed in the menu.

You can also defi ne PDF presets without going 
through the Export Adobe PDF dialog box.

To create a PDFPDF preset:

1. Choose File > Adobe PDFPDF Presets > 
Define to open the Adobe PDF Presets 
dialog box  F .

2. Click New. This opens the New PDF Export 
Preset dialog box.

3. Name the preset.
4. Choose each of the categories and set 

them as described earlier in this chapter.

 C   Click the Save Preset button  to create 
a preset based on the current settings 
in the Export Adobe PDF dialog box.

 D  Enter a name for a PDF preset in 
the  Save Preset dialog box .

 F  The  Adobe PDFPDF Presets dialog box  displays 
the PDF presets that ship with InDesign.

 E  Choose a preset to apply to a PDF 
from the  Adobe PDF Preset menu  in 
the Export Adobe PDF dialog box.
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To edit a PDFPDF preset:

1. Select the custom preset you want to edit 
in the Adobe PDF Presets dialog box  A .

2. Click the Edit button. This opens the Edit 
PDF Export Preset dialog box.

TIP There is no difference between the New PDF 
dialog box and the Edit PDFPDF dialog box except 
the name in the title bar.

3. Choose each of the categories and make 
changes as described earlier in this 
section.

To delete a PDFPDF preset:

1. Select the preset you want to delete in 
the Adobe PDFPDF Presets dialog box  A .

TIP Use the Shift key to select multiple adjacent 
presets.

TIP Use the Cmd/Ctrl key to select multiple 
nonadjacent presets.

2. Click the Delete button.
3. Click OK to confirm your choice.

To set the export PDF presets:

1. In the Adobe PDF Presets dialog box, 
select the presets you want to export  A .

TIP Use the Shift key to select multiple adjacent 
presets.

TIP Use the Cmd/Ctrl key to select multiple 
nonadjacent presets.

2. Click the Save As button. This creates a file 
that contains the exported presets.

To import PDFPDF presets:

1. Click the Load button in the Adobe PDF 
Presets dialog box  A .

2. Use the dialog box to select the 
document that contains the presets 
exported from another machine.

3. Click OK. The presets appear in the Adobe 
PDF Presets dialog box.

 A  A   custom PDF preset , listed 
without brackets, can be edited, 
deleted, exported, or imported.
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Creating EPSEPS Files

You might create a special shape or design 
in InDesign that you would like to use in 
another, older, layout program. Instead of 
the more modern PDF format, you may need 
to export the fi le as an EPS, or Encapsulated 
PostScript, fi le.

To create an EPS fi le:

Click the General tab in the Export EPSEPS 
dialog box to display the pages, bleed, 
and general controls  B .
or
Click the Advanced tab to display the 
production controls  C . These are the same 
as the graphic options for printing.

To set the EPS pages options:

1. In the General area, choose All Pages to 
export all the pages in the document as 
EPS files  B .

TIPTIP Each page is exported as its own EPSEPS file.

or
Choose Ranges and enter the numbers of 
the pages you want to export.

2. Select Spreads to export spreads as a 
single EPS file.

The PostScript level sets the complexity of the 
instructions that are sent to the printer.

To set the EPS PostScript level:

In the General area, use the PostScript 
menu to choose the following  D :
 • Level 2 is used with older printers. Use 

Level 2 only if you know your printer is 
too old to support Level 3.

 • Level 3 is used with newer printers. Use 
Level 3 only if you know the printer can 
handle Level 3 PostScript.

 B  The  Export EPSEPS dialog box  lets you create an 
EPS fi le that can be placed in other programs.

 C  The  Advanced section  in the Export 
EPSEPS dialog box contains production 
controls for creating an EPS fi le.

 D  Use the  PostScript menu  in the 
Export EPS dialog box to set the 
type of printing instructions.
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To set the EPS colors:

In the General area, use the Color menu to 
choose one of the following options  A : 
 • CMYKCMYK forces the colors to CMYKCMYK. Use this 

setting for process separations.
 • Gray converts the colors to their 

grayscale values. Use this to limit the 
colors to a black plate.

 • RGB converts the colors to the RGB 
color space. Use this for onscreen 
presentation programs.

 • PostScript® Color Management lets 
a PostScript printer use its own in-RIPRIP 
separations to control the color.

To set the EPS preview:

In the General area, use the Preview menu 
to choose one of the following  B : 
 • None adds no preview to the file.
 • TIFF creates a preview that is visible on 

both the Mac and Windows platforms.
 • PICT (Mac only) creates a preview that 

is visible on the Mac only.

Just as you can embed fonts in a PDF fi le, you 
can also embed fonts in an EPSEPS fi le.

To embed fonts in the EPS fi le:

In the General area, use the Embed Fonts 
menu to choose one of the following 
options  C :
 • None does not embed any fonts in 

the file.
 • Complete includes all the characters in 

the fonts.
 • Subset includes only the characters 

you have used in the file.

Using EPS Files?

EPSEPS is an archaic format that is hardly used today. 
Most of today’s layout programs import PDFPDF files.

The only time I suggest using the EPSEPS format is if 
you are placing images in older programs that 
can’t import PDFPDF files.

 A  Use the  Color menu  in the Export EPSEPS 
dialog box to control the colors in the fi le.

 B  Use the  Preview menu  in the Export EPSEPS 
dialog box to give a preview to the image.

 C  Use the  Embed Fonts menu  in the Export 
EPS dialog box to control how many 
characters in a font are added to the EPS fi le.
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EPS fi les need to be formatted with a specifi c 
type of data.

To set the data format of the EPS fi le:

In the General area, use the Data Format 
menu to choose one of the following 
options  D :
 • Binary is acceptable for most instances.
 • ASCIIASCII is used for a PCPC network that 

requires ASCIIASCII data.

TIPTIP Choose Binary. If you have trouble printing, 
then switch to ASCIIASCII.

Just as you can add a bleed area when print-
ing a document, you can add a bleed to an 
EPS fi le.

To set the size of a bleed:

In the General area, use the Bleed fields to 
create a bleed area  E .

Using InDesign Markup Files

The InDesign Markup export command 
creates an IDMLIDML fi le. This IDMLIDML fi le can then be 
opened using InDesign cs4.

To open CSCS5 fi les using InDesign CSCS4:

1. Choose File > Export to open the Export 
dialog box.

2. Choose InDesign Markup from the Format 
(Mac) or Save as Type (Windows) menu.

3. Name the IDMLIDML file and click Save.
4. In InDesign cs4, choose File > Open and 

navigate to open the IDMLIDML file. The IDMLIDML 
file is converted into an InDesign cs4 file.

TIPTIP There are no further controls for the 
Interchange format.

 D  Use the  Data Format menu  in the 
Export EPS dialog box to specify the 
formatting language of the EPSEPS fi le.

 E  Set the size of the bleed in the  Bleed 
fi elds  in the Export EPSEPS dialog box.

Using IDMLIDML Files?

Yes, you can save an InDesign document as an 
IDML file and then have someone with InDesign 
CS4 open the file. But there are quite a few things 
to remember:

 • If the CS5 file uses features such as 
repeating nested styles, which aren’t 
available in InDesign CS4, those features 
will change.

 • Don’t use the IDML file as a permanent 
workflow. This means don’t expect to 
send files back and forth between two 
designers. Something is going to get lost 
in the translation.

 • Never, never, never, send an IDMLIDML file to 
a print shop to have them open it in the 
older version of InDesign. This is a recipe 
for disaster.

Make sure the InDesign CS4 application has 
all the latest patches. CS4 can’t open IDMLIDML files 
without the proper updates.

You can also save a CS5 file as an IDMLIDML file and 
then re-open it in CSCS5. This can sometimes fix 
problems such as colors that can’t be deleted.
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Setting the JPEGJPEG Options

You might want to convert an InDesign docu-
ment into a JPEGJPEG fi le that can be posted on the 
Web. This can be done using the Export JPEG 
dialog box  A .

To set the area or page to be converted:

1. Use the Export area in the Export JPEG 
dialog box to choose one of the following:
 • Selection exports just the selected 

items as the JPEG. (The selection 
must be made before you choose 
File > Export.)

 • Range exports a range of pages as 
individual JPEG files.

 • All exports all the pages as individual 
JPEG files.

2. If you are exporting pages, you can select 
Spreads to export both pages in the 
spread to a single JPEG file  A .

You can also control the quality of the JPEGJPEG 
image and how it is displayed in the browser.

To set the JPEGJPEG quality and display:

1. Use the Export JPEGJPEG dialog box’s Image 
Quality menu to choose the quality of the 
JPEG image  B . 

TIP The higher the quality, the larger the final 
file size.

2. Choose a Format Method as follows  C :
 • Progressive creates an image that 

appears gradually on the page.
 • Baseline creates an image that appears 

all at once, after the entire image has 
been downloaded.

3. Choose a resolution option.

TIP Use 72 PPIPPI for Web images. Use higher 
resolutions for print images.

 A  Use the  Export JPEG dialog box  to convert 
an InDesign document into a JPEGJPEG fi le.

 B  The  Image Quality menu  controls the 
size and the quality of JPEGJPEG images.

 C  The  Format Method menu  controls 
how JPEGJPEG images are revealed.
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Exporting for InCopy

InCopy is InDesign’s sister program that is 
used for word processing. At about one-third 
the cost of InDesign, InCopy is the best way 
to create an editorial and design workfl ow 
between the two programs. InDesign gives 
you two ways to export InDesign stories as 
InCopy documents. These InCopy documents 
are then automatically linked to the 
InDesign fi le.

To export as an InCopy fi le:

1. Place your insertion point inside the story 
that you want to export.

2. Choose File > Export and then choose the 
InCopy Document format.

3. If prompted, choose a User Name, which 
is used to identify each person working 
on an InCopy document  D .

4. Name and save the document. An icon 
appears on the frame indicating that the 
story is linked to an external InCopy file  E .

TIPTIP A small pencil icon indicates that the story 
has been checked out for editing  F .

 D  The  User dialog box  lets you assign a 
distinct user name to each person who 
works on the InCopy document.

 E  The  linked fi le icon  means that the story 
is linked to an external InCopy fi le.

 F  The  pencil icon  means that the InCopy 
story is currently checked out.

Why Use InCopy?

Once a story has been exported as an InCopy document, a writer or editor can open the InCopy document 
to modify the text for those pages. The designer can continue to work on other parts of the file as the editor 
makes copy changes.

The layout is protected so the designer doesn’t have to worry that the writer will inadvertently move some-
thing or change the layout. And the writer has many more word processing tools than are available in InDesign.

If you are using InCopy, you will find many of its commands and tools very similar to the ones described in 
this book. There are other commands, however, that are unique to InCopy.

For instance, InCopy lets you edit text using text macros and a built-in thesaurus. You can even track changes 
using electronic notes and markups.
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Exporting Text

You may fi nd it necessary to export text from 
InDesign. For instance, you may want to 
send the text to someone who works with 
Microsoft Word. You can send them a text fi le 
by exporting the text.

To export text:

1. Place an insertion point inside the frame 
that contains the text. All the text within 
that story will be exported.

TIP Select an area of text to export only that 
portion of the text.

2. Choose File > Export. This opens the 
Export dialog box.

3. Choose a text export format:
 • Rich Text Format keeps all the styles 

and text formatting. This format can 
be opened by most word processors, 
especially Microsoft Word.

 • Text Only exports only the characters 
of the text and discards any styles 
and text formatting. Use this option 
only if you want to strip out the text 
formatting or if the application you are 
working with does not support Rich 
Text Format.

 • Adobe InDesign Tagged Text format 
exports the text with special codes for 
local character formatting and styles. 

4. Name the file and choose a destination.
5. Click Save to export the file.
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Customizing
Working with computer software 

is a personal thing. I’m always 
impressed with how emotional my 
stu dents are (maybe too emotional) 
about how their software should work. 
One student tells me she hates the way 
a certain feature works; yet another 
insists it’s his favorite thing in the entire 
program.

The InDesign team recognizes that 
some people want the program to work 
one way, and others want it exactly the 
opposite. That’s why there are many 
ways to customize the program.

You can change the keyboard short-
cuts so that they are similar to other 
software you use. You can modify the 
settings for the display of images and 
onscreen elements. You can control 
how text wraps around other objects. 
You can even throw away all your own 
customized settings and start back at 
the out-of-the-box settings.

It’s all your choice. 
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Modifying Keyboard Shortcuts

Keyboard shortcuts are the fastest way to 
invoke program commands. However, if you 
are used to working with other programs, 
your fi ngers may be trained to use those 
other shortcuts. You may also want to assign 
a shortcut to a command that doesn’t have 
a shortcut. InDesign lets you change the 
keyboard shortcuts to keystrokes that match 
your preferences.
InDesign ships with three sets of shortcuts. 
The default set is the one that the Adobe 
engineers created. This set uses most of the 
shortcuts found in Adobe products such as 
Adobe Illustrator or Adobe Photoshop. The 
second set contains the shortcuts used in 
PageMaker 7.0. The third set contains the 
shortcuts used in QuarkXPress 4.0. 

To change the shortcut set:

1. Choose Edit > Keyboard Shortcuts. The 
Keyboard Shortcuts dialog box appears  A .

2. Choose one of the shortcuts from the Set 
menu  B .

3. Click OK. The new shortcuts appear in the 
menus  C .

TIP Some keyboard shortcuts are “hard-wired” to 
the program and do not change to match the 
keystrokes in PageMaker or QuarkXPress. For 
instance, the Zoom tool does not change to 
the XPress Control key (Mac) or Ctrl-Spacebar 
(Win) shortcuts.

 A  The  Keyboard Shortcuts dialog box  
lets you change the shortcuts used 
for commands, tools, and panels.

 B  The  Set menu  lets you choose a 
set of keyboard preferences.

 C  You can switch the InDesign default 
shortcuts to the set for other applications.

QuarkXPress 4.0 
set active

Default set 
active
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If you work with other programs, you may 
want to create your own shortcut set to 
match it.

To create a new shortcut set:

1. Choose Edit > Keyboard Shortcuts.
2. Choose New Set. This opens the New Set 

dialog box  D .
3. Enter a name for the set.
4. Choose a set that the new set will be 

based on.

TIPTIP A set must be based on another set so that it 
starts with some shortcuts. However, if you 
later change something in the original set, 
the one that was based on it does not change.

5. Click OK. You can now edit the set as 
described on the next page.

If you want a list of keyboard shortcuts to 
print out and post next to your computer, you 
can create a fi le with all the shortcuts.

To create a list of the keyboard shortcuts:

1. Choose Edit > Keyboard Shortcuts.
2. Use the menu to choose the set.
3. Click the Show Set button. This opens 

the list of shortcuts in Notepad (Win) or 
TextEdit (Mac).

4. Print the text file.

TIPTIP I can’t always remember where a specific 
shortcut is located. So I create the text file of 
shortcuts and then use the text editor Find 
command to search for the location of the 
shortcut.

 D  The  New Set dialog box  lets you 
name a new shortcut set and choose 
which set it should be based on.

Creating Your Own Keyboard Shortcuts

I use quite a few programs from many different 
software companies. I taught QuarkXPress for 
more than 17 years. I work with both Adobe 
Illustrator and Acrobat. I also know Adobe Pho-
toshop and Adobe Fireworks. And I use InDesign 
to lay out all my books.

With all those programs in my head, I find it 
easier to teach my fingers just one set of short-
cuts. That’s InDesign because I use it the most.

I don’t change InDesign’s keyboard shortcuts to 
follow all those other programs. I find it easier 
to concentrate on learning InDesign’s shortcuts. 
It’s the primary program I use when working on 
a book — so I’d rather remember its shortcuts.



510 Chapter 21 Customizing

You can change the shortcut applied to a 
command. However, not all commands have 
shortcuts assigned to them. So you can also 
assign a shortcut to commands.

To change or assign a shortcut:

1. Choose a shortcut set in the Keyboard 
Shortcuts dialog box.
or
Create a new set.

2. Use the Product Area menu to choose 
the part of the program that contains the 
command to which you want to assign a 
shortcut  A .

3. Choose a command from the list under 
the Product Area menu  B .

4. Use the Context menu to choose in what 
portion of the program the keystroke will 
work  C .

5. Click inside the New Shortcut field to 
make that field active.

6. Press the keys on the keyboard that you 
want to assign to invoke the command.

TIP If the keystroke is already assigned to another 
command, the command that uses the 
shortcut is listed in the Currently Assigned to 
area  D .

7. Change the keys if necessary by selecting 
them and typing a new combination.
or
Click Assign to apply the new shortcut.

8. Click Save to save the set as modified.

To delete a set:

1. Use the Set menu to choose the set you 
want to delete.

2. Click the Delete Set button.

 A  The  Product Area menu  lets 
you choose which parts of the 
program you want to change.

 B  The  Commands fi eld  contains 
a list of the commands available 
for a specifi c product area.

 C  The  Context menu  lets you choose in which 
context a keyboard shortcut is applied.

 D  The  Currently Assigned to area  shows 
what command a keystroke is assigned to.
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Modifying the Menu 

Commands

You may feel that the menus in InDesign are 
too long for you to easily fi nd the command 
you want to choose. Or you would like one 
menu command to stand out from the others. 
You can easily customize the menus to high-
light or hide certain commands.

To highlight menu commands:

1. Choose Edit > Menus. This opens the 
Menu Customization dialog box  E .

2. Use the Category list to choose the 
Application menus or the Context & Panel 
menus  F .

3. Click the command you wish to 
customize.

4. Click the Visibility icon to cause the 
command to be hidden or visible in the 
menu  G .

5. Use the Color menu to choose a 
background color to highlight the 
command in the menu  H .

6. Use the Save or Save As buttons to save 
the custom set of menus.

As you are working, you may want to invoke a 
command that has been hidden. Rather than 
turn off  the custom menu confi guration, you 
can temporarily restore the command.

To restore a hidden command to a menu:

1. Click the menu that ordinarily contains 
the command.

2. Choose Show All Menu Items from the 
bottom of the menu. This temporarily 
restores all hidden commands to that 
menu.

 E  The  Menu Customization dialog 
box  lets you modify the appearance 
of menu commands.

 G  Click the  Visibility icon  to change the 
menu display. When the icon is hidden, 
the menu command does not show.

 H  Use the  Color menu  to highlight a 
command with a color in the menu.

 F  The  Category list  lets you choose 
between the Application menus 
or the Context & Panel menus.
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Choosing the Preferences 

Categories

InDesign has 18 categories that let you cus-
tomize how the program works.

TIP Change the preferences with no document 
open to create the defaults for all new 
documents.

To choose a preference category:

1. Choose Edit > Preferences > [category] 
(Win). This opens the Preferences 
dialog box  A . Or choose InDesign > 
Preferences > [category] (Mac).

2. Click the categories on the left side of the 
dialog box to open a new category. 

General Preferences Controls

The General category lets you control several 
types of preferences  B . 
If you have several sections in the same docu-
ment, they could all have a page number of 
1. The page numbering preferences change 
how the page numbers are displayed.

To set the page number preferences:

Choose one of the following from the 
Page Numbering View menu  C :
 • Absolute Numbering uses the physical 

placement number of the page in the 
document  D .

 • Section Numbering uses the numbers 
set from the section options  D .  C  The  Page Numbering View 

menu  lets you choose the section 
numbers or absolute numbers.

 A  The  Preferences dialog box .

 B  The  General settings  of the 
Preferences dialog box.
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The Font Downloading and Embedding sec-
tion controls the threshold below which a 
font is subset.

To choose the threshold for font 
subsetting:

Enter an amount in the Always Subset 
Fonts With Glyph Counts Greater Than 
field  E .

TIPTIP The number 2000 ensures that fonts with 
large character sets are always subset, 
creating smaller files. Custom fonts with a few 
characters are set in their entirety.

To select locked objects:

Deselect Prevent Selection of Locked 
Objects to use them as the anchored 
objects for alignment  F .

To set the scaling preferences:

Choose one of the following from the 
When Scaling area  G .
 • Apply to Content scales text so that 

the point size changes.
 • Adjust Scaling Percentage scales 

text so that the original point size 
is displayed with the new size in 
parentheses.

Every once in a while you may see a dialog box 
that warns you about doing something. These 
alerts have checkboxes you can select so you 
never see the warning again. If you’ve turned 
them off , you can reset them all to turn back 
on.

To reset the warning dialog boxes:

Click the Reset All Warning Dialogs 
button at the bottom of the General 
preferences  H . An alert box informs you 
that you will now see the warnings.

 D  The diff erence in the Pages panel 
between using absolute numbers and 
section numbers. The black triangles 
indicate the start of a new section.

Absolute 
numbers

Section 
numbers

 E  The  Font Downloading and Embedding  
area lets you control whether fonts 
are embedding or subset.

 F  Deselect  Prevent Selection of 
Locked Objects  to use them as the 
anchored objects for alignment.

 G  Choose one of the  When Scaling 
options  to set how the point size of text 
changes when the frame is scaled.

 H  Click the  Reset All Warning Dialogs  to 
bring back those annoying alert messages 
when you perform certain actions.
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Interface Preferences

The Interface preferences control how some 
aspects of the program appear  A . Tool tips are 
notes that appear when you pause the cursor 
over an onscreen element  B .

To control how quickly the tool tips are 
displayed:

Use the Tool Tips menu to choose one of 
the following:
 • Normal waits a moment before 

displaying the tip.
 • None turns off the display of the tips.
 • Fast displays the tool tips almost 

imme diately.

The Cursor Options let you change how the 
mouse cursor behaves.

To change the place cursor preview:

Deselect the option Show Thumbnails on 
Place to see only the cursor, and not the 
thumbnail preview, for placed text and 
images  C .

To change transformation preview:

Deselect the option Show Transformation 
Values to see only the cursor, and not the 
transformation values as you draw and 
modify objects  D .

You can also control whether InDesign allows 
you to use the multi-touch gestures for track-
pads and mice.

To control trackpad gestures:

Deselect the option Enable Multi-Touch 
Gestures to avoid input by two or three 
fingers on trackpads and mice that use 
that feature.

 B  An example of a  tool tip  that appears when 
you pause over an interface element.

 D  The  transformation values  that appear 
as you create or modify objects.

 C  The  thumbnail preview  
next to the Place cursor.

 A  The  Interface settings  of the 
Preferences dialog box.
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The default for the Tools panel is a single 
column. But you can change that setting.

To change the display of the Tools panel:

Use the Floating Tools Panel menu 
to choose how the Tools panel is 
displayed  E :
 • Double column shows the tools 

vertically in two columns.
 • Single column shows the tools 

vertically in a single column.
 • Single row arranges the tools 

horizontally in a single row.

TIPTIP Click the two arrows in the Tools panel title 
bar to shift between the three settings when 
it is not docked.

You can also change how the panels and 
documents behave.

To change how docked panels collapse:

Select Auto-Collapse Icon Panels to cause 
selected docked panels to automatically 
close when you move back to a 
document. 

To change how hidden panels are 
displayed:

Select Auto-Show Hidden Panels to 
display any panels that were hidden by 
pressing Tab or Shift-Tab when the cursor 
moves over the hidden panel area.

To change how new documents appear:

Select Open Documents as Tabs 
to combine the windows for new 
documents into a tabbed display  F .

To change how documents can be docked 
to others:

Select Enable Floating Document Window 
Docking to allow floating document 
windows to dock as tabs into other 
windows while being dragged.

 F  An example of  documents 
arranged in tabs  .

 E  The  arrangements for the Tools panel .

Double column Single column

Single row
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Type Preferences

Use the Type Preferences controls for working 
with text  A . 

To set the Type Options preferences:

1. Use Typographer’s Quotes auto matically 
changes typewriter quotes into the 
proper curly quote characters  B . 

2. Type Tool Converts Frames to Text Frames 
lets you double-click inside a frame to 
change from the selection tools to the 
Type tool.

3. Automatically Use Correct Optical Size 
sets the correct value for the optical size 
of Multiple Master fonts.

4. Select the Triple Click to Select a Line 
checkbox so that three clicks selects a 
line, four clicks selects a paragraph, and 
five clicks selects the story.

TIP If this option is deselected, three clicks selects 
the paragraph and four clicks selects the 
story.

5. Apply Leading to Entire Para graphs lets 
InDesign work more like QuarkXPress.

6. Adjust Spacing Automatically When 
Cutting and Pasting Words avoids adding 
two spaces when pasting text.

7. Font Preview Size lets you choose the size 
of the preview in the Type menu  C .

TIP Deselect this option to turn off the font 
preview and make the menu display faster.

You can also control whether or not drag-
and-drop text is activated.

To turn on drag-and-drop text:

1. Select Enable in Layout View to drag 
selected text when working within 
frames.

2. Select Enable in Story Editor to drag 
selected text within the Story Editor.

 A  The  Type settings  of the 
Preferences dialog box.

 B  An example of using  typographer’s quotes .

Off

On

 C  An example of the diff erent 
 font preview sizes. 
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The Smart Text Refl ow options control how 
new pages and frames are created when text 
overfl ows a frame.

To set the Smart Text Refl ow options:

1. Turn on Smart Text Reflow to 
automatically add pages when a story 
spans at least two pages.

2. Use the Add Pages To menu to choose 
where the new pages will be added as 
follows  D :
 • End of Story adds pages directly after 

the page that contains the story.
 • End of Section adds pages to the last 

page in that section of the document. 
This can cause the story to skip pages.

 • End of Document adds pages after the 
last page in the document. This can 
cause the story to skip pages.

3. Choose Limit to Master Text Frames to 
only add pages when copy overflows 
master text frames.

4. Choose Preserve Facing-Page Spreads to 
ensure that the number of right- or left-
hand pages remains constant when new 
pages are added.

5. Select Delete Empty Pages to have 
InDesign automatically delete any pages 
where the linked text frame no longer 
contains text.

TIPTIP Pages are deleted only if the text frame is the 
only object on the page.

 D  Use the  Add Pages To menu  to 
control where new pages are 
added for Smart Text Refl ow.

My Preferences for Smart Text Reflow

I’m a typist. So the idea of being able to type 
in InDesign and add or delete pages as I work 
is very appealing. However, I have modified the 
default settings for Smart Text Reflow.

First, I have turned off the setting for Limit to 
Master Text Frames. This way I can place text 
directly onto a page without using master text 
frames.

Next, I always add pages at the end of the story. 
It is too confusing to go find linked pages that 
might appear way at the end of the document 
or section.

Next, I have Preserve Facing-Page Spreads 
turned off. I don’t mind adding another right-
hand page to my document as I add pages.

Finally, I always select Delete Empty Pages. It’s so 
cathartic to watch InDesign delete empty pages 
that I no longer need.

My Preferences for Drag and Drop Text

I grew up using computer word processing 
programs that have drag and drop text features. 
So I always have Drag and Drop Text turned on 
for both Story Editor View as well as Layout View.

However, I understand that many designers find 
drag and drop gets in the way when they work. 
So I suggest turning it on for the Story Editor and 
off for the Layout View.

You get the benefits of drag and drop without 
messing up your layouts.
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Advanced Type Preferences

Don’t let the term “Advanced Type” throw you 
off . These are settings that you may want to 
change depending on the typefaces you 
work with.
The Character Settings control the size and 
position of superscript, subscript, and small 
cap characters  A . 

To set the Character Settings preferences:

1. Enter amounts in the Size fields to control 
the size of the characters. 

2. Enter amounts in the Position fields 
to control how far above or below the 
baseline the characters are positioned.

TIP The percentage amount is based on the total 
space between the two lines.

A non-Latin typeface is one that uses 2-byte 
and 4-byte characters. Japanese, Korean, and 
Chinese are examples of non-Latin typefaces. 
If you work with non-Latin typefaces, you 
may need to use features in the operating 
system to enter characters instead of the 
keyboard  B .

To use the operating system to enter non-
Latin text:

Select the option Use Inline Input For 
Non-Latin Text to allow you to input text 
using the electronic keyboards built into 
the computer operating system.

 A  The  Advanced Type settings  of 
the Preferences dialog box.

 B  The  non-Latin input controls  for the 
Macintosh and Windows operating systems.
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Composition Preferences

The Highlight settings let you control which 
parts of the text are highlighted to indicate 
composition or typographic violations or 
substitutions  C .

To set the highlight options:

Set the Highlight options as follows  D :
 • Keep Violations displays lines that 

have been broken in violation of the 
Keep With settings that you chose for 
the paragraph settings.

 • H&J Violations highlights those 
areas that violate the hyphenation or 
justification settings.

TIPTIP H&J Violations occur when InDesign has no 
other way to set the text except to break the 
H&J controls.

 • Custom Tracking/Kerning highlights 
the text with tracking or kerning 
applied to it.

 • Substituted Fonts highlights 
characters that are substituted for 
a font that is not installed in the 
computer system.

TIPTIP This is the famous pink highlight for a missing 
font that many people see when they import 
text or change typefaces.

TIPTIP If the shape of the uninstalled font exists in 
the Adobe Type Manager database, the shape 
of the font is approximated. If not, a default 
font is used.

 • Substituted Glyphs highlights 
OpenType characters that have been 
substituted with alternate glyphs.

 C  The  Composition settings  of 
the Preferences dialog box.

 D  An example of text with a  highlight  applied.



520 Chapter 21 Customizing

You can also control the eff ect of the Text 
Wrap settings and how text wraps around 
objects.

To set the text wrap options:

Choose one of the following from the Text 
Wrap options:
 • Justify Text Next to an Object forces 

text next to an object to be justified if 
it wraps around an object inside the 
frame  A .

 • Skip by Leading forces text that has 
wrapped around an object to move to 
the next available leading increment. 
This avoids problems where text may 
not line up across columns or frames  B .

 • Text Wrap Only Affects Text Beneath 
causes InDesign text wrap to work only 
on text below the object, rather than 
text above and below the object.

Units & Increments 

Preferences

Units and Increments refer to the units of 
measurements and how much things change 
when you apply keyboard shortcuts  C .

To set where the ruler starts:

Use the Origin menu to select one of the 
following  D :
 • Spread sets the horizontal ruler to 

stretch across the pages in a spread.
 • Page sets the horizontal ruler to reset 

for each individual page in a spread.
 • Spine sets the horizontal ruler 

to stretch across the spine of the 
document.

 A  The eff ect of setting the  Justify 
Text Next to an Object  option.

Off

On

 B  When  Skip By Leading  is turned off , the 
text does not line up across columns. When 
it is turned on, the text does line up.

Unaligned text

Aligned text

 C  The  Units & Increments settings  
of the Preferences dialog box.

 D  The  Origin menu  lets you choose how 
the rulers stretch across the page.
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To set the ruler units:

Use the Horizontal and Vertical menus to 
select the unit of measurement for each 
of the rulers  E .

TIPTIP Set an amount, in points, for a custom unit of 
measurement.

To set the units for text sizes:

Use the Text Size menu to choose points 
or pixels for how text is measured  F .

To set the units for stroke sizes:

Use the Stroke menu to choose Points, 
Millimeters, or Pixels for how text is 
measured  G .

To set the number of points per inch:

Use the Points/Inch field to choose 
between the PostScript or the Traditional 
numbers of points per inch  H .

The keyboard increments control how much 
the objects move or the text changes  I . 

To set the keyboard increments:

Enter an amount in the fields as follows:
 • Cursor Key lets you choose the amount 

that the arrow keys move objects.
 • Size/Leading controls the amount that 

the type size and leading change.
 • Baseline Shift lets you set the amount 

that the baseline shift changes.
 • Kerning/Tracking controls the amount 

that the kerning or tracking changes.

 E  The units of measurement for the 
 horizontal and vertical rulers.

 F  The units of measurement for  text sizes .

 G  The units of measurement for  stroke sizes .

 H  Use the  Points/Inch fi eld  to 
choose between the PostScript 
measurement for points per inch or 
the Traditional measurement.

 I  The  Keyboard Increments  area lets 
you choose how the arrow keys move 
objects and change text controls.
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Grids Preferences

Designers just love to set up lines that stretch 
up and down and across their pages to help 
keep text and graphics lined up correctly. The 
Grids preferences control those lines  A .

To set the baseline grid options:

1. Use the Color menu to choose a color for 
the baseline grid.

2. Use the Start field to position where the 
grid should start on the page.

3. Use the Relative To menu to position the 
start of the grid relative to the top of the 
page or the top margin.

4. Use the Increment Every field to set the 
distance between the lines of the grid.

5. Use the View Threshold field to set the 
lowest magnification at which the grid is 
visible.

TIP Set this for something like 75% to make it 
easier to see the entire page when you 
zoom out.

To set the document grid preferences:

1. Use the Color menu to choose a color for 
the document grid.

2. Enter a value for the Horizontal and 
Vertical fields as follows:
 • Gridline Every sets the distance 

between the major lines of the grid.
 • Subdivisions sets the number of 

secondary lines of the grid.

To set the positioning of the grids:

Select Grids in Back to position the grids 
behind graphics and text  B .

 A  The  Grids settings  of the 
Preferences dialog box.

 B  An example of setting the  Grids in 
Back option  in the Grids category.
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Guides & Pasteboard 

Preferences

You can customize the appearance and size of 
your ruler guides and the pasteboard.
The Color area is a rainbow of choices for how 
to color onscreen guides and areas  C .

To set the onscreen elements colors:

Use the menus to set the colors for the 
margins, columns, bleed, slug, Smart 
Guides, and the area that surrounds the 
page in the Preview Mode.

To set the Guide Options:

1. Use the Snap to Zone field to set how 
close the objects should be when they 
snap to guides. This amount is set in 
pixels.

2. Select Guides in Back to hide the guides 
when they appear behind objects.

To set the Smart Guide Options:

Select each of the display settings to 
indicate whether Smart Guides should 
appear at the object centers, object 
edges, similar sizes, or spacing.

To set the Pasteboard Options:

1. Enter an amount in the Horizontal 
Margins field to increase or decrease the 
amount of pasteboard space to the left 
and right sides of the page.

2. Enter an amount in the Vertical Margins 
field to increase or decrease the amount 
of pasteboard space above and below the 
page  D .

 C  The  Guides & Pasteboard settings  
in the Preferences dialog box.

 D  The eff ect of increasing the 
minimum vertical off set.

6p

24p
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Dictionary Preferences

The Dictionary preferences work with which-
ever languages and dictionaries are used for 
InDesign documents  A .
The Language setting is used to choose which 
language dictionary should be used to check 
whether words are correctly spelled. Consider 
that the word cinema is correctly spelled if 
English is the chosen language. However, the 
word is incorrectly spelled if French is chosen 
as the language. In that case the word should 
be cinéma.

To set the dictionary preferences:

1. Use the Language menu to set the default 
language.

2. Select the dictionaries in the User 
Dictionary area. (See the next exercise for 
how to add a user dictionary.)

3. Choose a preference from the 
Hyphenation menu.

4. Choose a preference from the Spelling 
menu.

5. Use the Double Quotes menu to choose 
the characters for double quotation 
marks  B .

6. Use the Single Quotes menu to choose 
the characters for single quotation 
marks  B .

TIP The Quotes menus list the marks used for 
different languages, such as Spanish and 
French. Or you can enter your own characters 
in the field.

 A  The  Dictionary settings  in the 
Preferences dialog box.

 B  The  Quote menus  in the 
Dictionary preferences.

Double quote choices

Single quote choices

Sharing Dictionaries

You may want to create a single dictionary that everyone in your workgroup can share. When a user dictionary 
is stored on a server, the first user to load the dictionary locks the file; all subsequent users see that the 
dictionary is locked. Files can also be locked through the operating system, which makes the file read-only. 
If you share a user dictionary over the network server, you may want to lock the file so that it’s read-only for 
all users, allowing only the administrator to add words.
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You use the dictionary management tools 
to create, link to, add, and delete new user 
dictionaries. This allows you to create several 
dictionaries for InDesign.

To create a new user dictionary:

1. Click the New Dictionary button in the 
Dictionary preferences  C .

2. Name and save the dictionary file (UDCUDC) to 
a location. The new dictionary appears in 
the Dictionary list  D .

You don’t have to create your own new dic-
tionary. You can use the dictionary manage-
ment tools to add someone else’s dictionary 
to your version of InDesign.

To add a dictionary:

1. Click the Add Dictionary button in the 
Dictionary preferences.

2. Navigate to select the new dictionary. The 
dictionary appears in the Dictionary list.

To delete a dictionary:

1. Select the dictionary that you want to 
delete in the Dictionary list.

2. Click the Delete Dictionary button in the 
Dictionary preferences.

To relink a dictionary:

1. Select the dictionary that has a Missing 
or Modified icon next to its name in the 
Dictionary list  E .

2. Click the Relink Dictionary button in the 
Dictionary preferences.

3. Navigate to find the missing dictionary.

 C  The  Dictionary buttons  in the 
Dictionary preferences.

Relink Dictionary

New Dictionary

Add Dictionary

Delete Dictionary

 D  The  Dictionary list  displays the 
list of dictionaries installed in 
the Dictionary preferences.

 E  The  Missing icon in the Dictionary 
list  indicates that you need to 
relink to the dictionary.
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The hyphenation exceptions let you choose 
whether to apply the hyphenations created 
by editing the Dictionary or those built into 
the application.

To set the hyphenation exceptions:

Choose one of the following from the 
Compose Using menu  A :
 • User Dictionary uses only the 

hyphenation exceptions set by editing 
the Dictionary.

 • Document uses the hyphenation 
exceptions list stored inside the docu-
ment. (See the next exercise for how to 
add the user dictionary hyphenation 
exceptions to a document.)

 • User Dictionary and Document 
merges the exceptions in both the 
document and the user dictionary. This 
is the default setting.

The User Dictionary options let you merge 
hyphenation exceptions into a document 
and create new hyphenation exceptions that 
aff ect the document  B .

To set the user dictionary preferences:

1. Merge User Dictionary into Document 
adds the hyphenation exceptions in the 
user dictionary to the document. This is 
on by default.

TIP This is especially useful if you send the native 
InDesign document to a service bureau for 
output.

2. Recompose All Stories When Modified 
applies the new exceptions in the 
user dictionary to all the stories in the 
document.

 A  The  Compose Using menu  in 
the Dictionary category.

 B  The  User Dictionary options  in 
the Dictionary category.
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Spelling Preferences

The Find section of the Spelling preferences 
controls what types of problems the spelling 
checker fl ags during a spelling check  C .

To set the Find options for Spelling:

1. Select Misspelled Words to find words 
that are not known in the spelling 
dictionary.

2. Select Repeated Words to find instances 
of words that are repeated, such as “the 
the spelling checker.”

3. Select Uncapitalized Words to find 
words that are listed in the dictionary as 
capitalized. For instance, proper names of 
countries are capitalized in the dictionary.

4. Select Uncapitalized Sentences to flag 
uncapitalized words that begin sentences. 

Dynamic spelling highlights errors right on 
your page. If you want to work with dynamic 
spelling, you have a choice as to which colors 
the errors are underlined with.

To set the Dynamic Spelling options:

1. Select Enable Dynamic Spelling in the 
Spelling preferences  D .

2. Use the Underline Color menus to specify 
the color used to highlight misspelled 
words, repeated words, uncapitalized 
words, and uncapitalized sentences.

 C  The  Spelling settings  in the 
Preferences dialog box.

 D  Use the  Dynamic Spelling controls  to 
turn on dynamic spelling and specify 
colors for each of the error categories.
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Autocorrect Preferences

The Autocorrect preferences not only turn 
on the Autocorrect feature, they allow you to 
add or remove those words that you want to 
have automatically corrected.

To turn on autocorrection:

1. Choose Enable Autocorrect to turn on the 
basic correction for words  A .

2. Choose Autocorrect Capitalization Errors 
to also automatically correct errors in 
uppercase and lowercase words.

The Autocorrect list contains the words that 
are commonly mistyped. In addition to the 
words the Adobe engineers felt you would 
mistype, you can easily add your own.

To add words to the Autocorrect list:

1. Use the Language menu to choose the 
language for the autocorrection  B .

2. Click the Add button at the bottom of the 
Autocorrect Preferences. This opens the 
Add to Autocorrect List dialog box.

3. Type the typical misspelling in the 
Misspelled Word field  C .

4. Type the correct spelling in the Correction 
field.

5. Click OK to add the word to the list.

To delete words from the Autocorrect list:

1. Select the word in the list that you want 
to delete.

2. Click the Remove button.

 A  The  Autocorrect settings  in the 
Preferences dialog box.

 B  Use the  Autocorrect Options controls  
to turn on autocorrection for word 
errors and for capitalization errors. 

 C  The  Add to Autocorrect List dialog 
box  lets you enter the misspelling 
for a word and its correction.
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Notes Preferences

Notes are primarily used in an InDesign/
InCopy workfl ow. The Notes preferences 
control how the notes appear in the InDesign 
or InCopy stories  D .

To set the Notes options:

1. Use the Note Color list to set a color for 
the user. This color should be unique.

2. Select Show Note Tooltips to display the 
text for the note when the user hovers 
over the note display  E .

You can also set the preferences for how 
notes are handled when working in the Story 
Editor.

To set the options for notes in the Story 
Editor:

Select the following as desired:
 • Include Note Content When Checking 

Spelling to apply a spelling check to 
the note text.

 • Include Note Content in Find/Change 
Operations to include the note text in 
the results of a Find/Change routine.

To set the background color for the note:

Use the Inline Background Color list to 
choose a color for the area behind the 
note when viewed in the Story Editor  F .

 D  The  Notes settings  in the 
Preferences dialog box.

 E  A  note tooltip  that is revealed when 
the cursor pauses over the note.

 F  The  note background color  as 
displayed in the Story Editor.
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Track Changes Preferences

You can customize how the changes for Track 
Changes are displayed. There are three types 
of text changes that are displayed as the 
tracked changes. Each one can be turned on 
or off  individually.

To select which text changes are displayed:

Select or deselect one of the following 
from the Show area of the Track Changes 
preferences  A :
 • Added Text displays text that has been 

inserted.
 • Deleted Text displays text that has 

been cut.
 • Moved Text displays text that has been 

moved from one location to another.

Each type of tracked text change can have its 
own display.

To set the display for the types of changes:

1. Use the Text menu to set the color for the 
changed text  B .

2. Use the Background menu to set the color 
behind the changed text  B .

3. Use the Marking menu to choose one of 
the indicators for the changed text  C .
 • None applies no indicator to the 

changed text.
 • Strikethrough adds a line through the 

changed text  D .
 • Underline adds a line under the 

changed text  D .
 • Outline draws a rectangle around the 

changed text  D .

 A  The  Track Changes settings  in 
the Preferences dialog box.

 B  The  three menu controls  for the 
display of changed text.

 C  The  marking choices menu  for 
the display of changed text.

 D  The  strikethrough, outline, and underline 
markings  for the display of changed text.
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The user color, defi ned in the User dialog box, 
allows each person to have his or her own 
color for the tracked changes. But it is pos-
sible that two people will pick the same user 
color. So you may want to ensure that two 
people don’t have the same user color.

To prevent changes appearing with the 
same user colors:

Select Prevent Duplicate User Colors.

If you have a lot of text, it is helpful to display 
the change bars. These are vertical lines on 
the side of the Story Editor text that indicate 
that a tracked change has been applied to 
the text.

To set the display for the types of changes:

1. Select the Change Bars option to display 
the change bars  E .

2. Use the Change Bar Color menu to choose 
a color.

3. Use the Location menu to choose where 
the change bar appears  F . Your choices 
are Left Margin or Right Margin.

One of the most common reasons for chang-
ing text is for spelling errors. If you run a 
spelling check on a document, you might not 
want to go through all the deleted text with 
the original spelling errors.

To prevent the spelling check from going 
through deleted text:

Deselect Include Deleted Text When 
Spellchecking  G .

 E  The  menu controls  for the change bars that 
run along the side of the tracked changes.

 G  The command  Include Deleted 
Text When Spellchecking  controls 
whether deleted text is included 
when the spelling check runs.

 F  The  change bar  positioned on the 
left margin of the Story Editor.

Change bar
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Story Editor Display 

Preferences

If you work in the Story Editor, you can choose 
the preferences for its display  A .

TIP None of these settings affect the appearance 
of the text in the layout.

To set the preferences for text display:

1. Use the Font menu to set the typeface.
2. Use the point size menu to set the size.
3. Use the Line Spacing menu to choose the 

leading between the lines  B .
4. Use the Text Color menu to set the color 

of the text.
5. Use the Background menu to set the color 

of the Story Editor window background.
or
Use the Theme menu to select a preset 
text and background color scheme  C .

6. Choose Enable Anti-aliasing to soften the 
edges of the text.

7. If you choose Enable Anti-aliasing, choose 
an anti-aliasing Type option.
 • Default is the typical anti-aliasing.
 • LCD Optimized works best on light-

colored backgrounds with black text.
 • Soft produces a lighter, fuzzier 

appearance than Default.

You can also change how the cursor, or inser-
tion point, is displayed within the Story Editor. 

To set the preferences for cursor display:

1. Choose Edit > Preferences > Story 
Editor Display (Win) or InDesign >
Preferences > Story Editor Display (Mac).

2. Choose one of the Cursor Options  D .
3. Select Blink to make the cursor turn on 

and off within the text.

 A  The  Story Editor Display settings  
of the Preferences dialog box.

 B  The  Line Spacing menu  of the Story 
Editor preferences controls the 
space between the lines of text.

 C  The  Theme menu  lets you quickly change 
the text and background colors.

 D  The  Cursor Options  change the display 
of the cursor within the text.
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Display Performance 

Preferences

The default view is the view that is used when 
documents are fi rst opened.

To set the default view:

1. Use the Default View menu to choose 
which of the display performance 
settings is automatically applied to new 
documents  E .

2. Select Preserve Object-Level Display 
Settings to maintain any individual 
settings applied to graphics.

The Adjust View Settings control how images 
appear onscreen for each of the three view 
choices.

To choose the options for Adjust View 
Settings:

1. Choose one of the options from the 
Adjust View Settings menu.

2. Drag the slider controls to set the quality 
for raster images, vector graphics, and the 
transparency effects.

3. Repeat for the other two view settings.

TIPTIP It takes longer for the screen to redraw if you 
choose the highest-quality previews.

Anti-aliasing is the term used to describe the 
soft edge applied to either text or graphics.

To control the anti-aliasing of text and 
graphics:

Select Enable Anti-aliasing to add a soft 
edge to the type and graphics displayed 
on the monitor  F .

 E  The  Display Performance settings  
in the Preferences dialog box.

 F  The eff ect of applying  anti-aliasing  to type.

On

Off
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Greeking is the term used to describe the 
gray band that is substituted for text charac-
ters  A . 

To set text to be greeked:

Enter an amount in the Greek Type Below 
field. This sets the size below which the 
text characters will be replaced with gray 
bands onscreen.

When you use the Hand tool to scroll around 
a document, InDesign needs to determine 
how text and images that were not originally 
in the window appear when you move them 
into view. You use the Hand Tool preferences 
to control how the images appear or how fast 
you can move while scrolling.

To set the scrolling preferences:

Drag the Hand Tool slider to one of the 
following:
 • The left position greeks both text and 

images. This is the fastest setting but 
it loses the appearance of the page as 
text and images come into view  B .

 • The middle position greeks images but 
maintains text visibility  B .

 • The right position turns off all greeking 
of text and images. This is the slowest 
setting but it maintains the appearance 
of the page as text and images come 
into view  B .

 A  The eff ect of applying  greeking  to type.

On

Off

B  The appearance of text and images for 
each of the Hand Tool slider settings.

Left position Middle position Right position



InDesign CS5 Visual Quickstart Guide 535

Appearance of Black 

Preferences

As many designers have discovered, when 
a color-corrected black is displayed on a 
computer screen, 100% black ink winds up 
looking very washed out. The Appearance of 
Black preferences allow you to choose how 
100% black ink is displayed and printed  C .

To control the appearance of black 
onscreen:

Choose one of the following from the On 
Screen menu:
 • Display All Blacks Accurately displays 

100%K as dark gray. This setting allows 
you to see the difference between pure 
black and rich black.

 • Display All Blacks As Rich Black 
displays 100%K as jet black (RGBRGB=000). 
This setting makes pure black and rich 
black appear the same onscreen. 

You can also control how 100%K appears 
when printing to a non-PostScript desktop 
printer or exporting to an RGB format. This 
helps control the appearance of blacks in PDF 
and JPEGJPEG fi les.

To control the appearance of black when 
printing or exporting to an RGB format:

Choose one of the following from the 
Printing/Exporting menu:
 • Output All Blacks Accurately outputs 

100%K using the color numbers in the 
document. This setting allows you 
to see the difference between pure 
black and rich black in the finished 
document.

 • Output All Blacks As Rich Black 
outputs 100%K as jet black. This setting 
makes pure black and rich black appear 
the same.

 C  The  Appearance of Black settings  
in the Preferences dialog box.
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File Handling Preferences

If InDesign crashes or the computer is shut 
down before you can save the InDesign 
documents, a fi le is created that contains the 
recovered document. The Document Recov-
ery Data area lets you choose where that 
recovered document is located.

TIP Although most people will use the same drive 
that contains the application, this option lets 
you specify a folder on a drive that has more 
space than the one that contains the InDesign 
application folder.

To set the temporary folder:

1. Click the Browse (Win) or Choose (Mac) 
button in the Document Recovery Data 
area  A .

2. Use the dialog box to choose the location 
of the recovered documents.

The Saving InDesign Files area lets you set 
how many fi les appear in the Open Recent 
menu. You can also add a thumbnail preview 
to the fi le as well as control the size of the 
preview.

To set the number of fi les in the Open 
Recent menu:

Enter a number in the Number of Recent 
Items to Display field.

To create a preview with saved documents:

1. In the Saving InDesign Files area, choose 
Always Save Preview Images with 
Documents.

2. Use the Pages menu to choose how many 
pages will be displayed in the preview  B .

3. Choose one of the sizes from the Preview 
Size menu  C .

TIP More pages and larger previews increase 
the file size and the time it takes to save the 
document.

 A  The  File Handling settings  in 
the Preferences dialog box.

 B  The  Pages menu  of the Always Save 
Preview Images with Documents area 
lets you choose how many pages are 
displayed as part of the preview.

 C  The  Preview Size menu  lets you 
choose the size for the preview 
image that is saved with the fi le.
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You can control the position where snippets 
appear when you drag them onto a page.

To control the location of snippets:

Select the Snippet Import options as 
follows:
 • Position at Original Location places 

the snippet at its original coordinates. 
 • Position at Cursor Location ignores 

the original coordinates and places the 
snippet where the cursor is located 
when the mouse button is released on 
the page.

Use the Links options to control how placed 
graphics and other links are handled  D.

To set the Links options:

Choose the Links options as follows:
 • Choose Check Links Before Opening 

Document to have InDesign look at the 
links in the document.

 • Choose Find Missing Links Before 
Opening Document to have InDesign 
try to relink any missing links in the 
previously linked folder.

 • Select the option Create Links When 
Placing Text and Spreadsheet Files to 
link those styles back to the original 
files.

TIPTIP All local formatting you have applied will be 
discarded when the text is updated. 

 • Choose Preserve Image Dimensions 
When Relinking if you want images to 
appear at the same size as the images 
they’re replacing; deselect this option 
to have relinked images appear at their 
actual size.

 • Use the Default Relink Folder to choose 
what folder should be used when 
automatically relinking missing links.

 D  The  Links options  for placed 
graphics and other fi les.

Working with Previews

You may not see a document preview if you open 
the file using the Macintosh Finder or Windows 
Explorer. That’s why I recommend using Adobe 
Bridge to open InDesign documents.

If you save a document with a preview, you will 
only see a preview of the first spread. However, 
you will be able to see a preview of all the pages 
of a template.

A Suggestion for an Editorial Workflow

Many people I know want to turn on the option 
to create links when placing text and spreadsheet 
files because they need editors to make changes 
to their document.

The problem with that workflow is that any 
formatting applied to the text in InDesign will 
be lost when the text is updated.

A better solution would be to work with InCopy, 
which allows InDesign stories to be edited 
without InDesign running. Then the text can 
be updated in InDesign without losing any 
formatting.
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Clipboard Handling

You may need to change the options for 
what type of information is included in the 
clipboard  A .

To set the clipboard format:

Select the Clipboard options as follows:
 • Prefer PDF When Pasting adds graphics 

as self-contained PDFPDF files that retain 
effects.

 • Copy PDFPDF to Clipboard copies data as 
PDF files. Select this in order to paste 
paths into Illustrator or Photoshop.

 • Preserve PDF Data at Quit maintains 
any copied PDF information on the 
clipboard for use in other applications.

To set the attributes for pasting text:

Select When Pasting Text and Tables from 
Other Applications as follows:
 • All Information maintains formatting.
 • Text Only strips out all formatting.

Trashing Preferences

Sometimes InDesign may start to act 
strangely. This may mean that the fi les that 
hold all your preferences and settings have 
become corrupt. In that case you need to 
trash those fi les and let InDesign start over 
with the factory settings.

To restore all preferences and default 
settings:

1. As you launch InDesign, immediately 
press Ctrl-Alt-Shift (Win) or Cmd-Opt-
Shift-Control (Mac).

2. Click Yes when asked if you want to delete 
your preference files  B .

 B  The  Delete InDesign Preference fi les 
dialog box  lets you start from scratch 
with factory-fresh default settings.

 A  The  Clipboard Handling settings  
in the Preferences dialog box.
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Index
A
Above Line anchored objects, 253–254
absolute numbering

applying, 285
choosing, 512–513

absolute offset, 221
Accept Change icon, 376
active pages, 261
Actual Size, keyboard shortcuts, 42
Add Anchor Point tool, 196, 202
Add Bullets dialog box, 378
Add Items on Page [number] command, 317
Add to Autocorrect List dialog box, 528
Added Text, in Track Changes, 529
Adjust View Settings, 533
Adobe (ACEACE) conversion options, 443
Adobe Bridge. see Bridge
Adobe Illustrator. see Illustrator
Adobe InDesign Tagged Text Import 

Options dialog box, 384
Adobe Paragraph Composer, 425
Adobe PDFPDF Presets dialog box, 499
Adobe Photoshop. see Photoshop
Adobe Single-Line Composer, 425
Adobe XMP dialog box, 292
Advanced category options, 467
Advanced PDFPDF options, 496
Advanced section, in Export EPSEPS dialog box, 501
Advanced Type preferences, 518
alert dialog box, 307
Alert icon, 296
Align Left Edge option, 75
Align menu, 246
Align panel

aligning objects with, 109
features of, 2

Align Stroke control, 162
Align to Baseline Grid, 432–433
alignment

justified vertical, 83
setting anchor object for, 111
setting paragraph, 71
vertical, 110, 246, 348

Alignment list, 254
Alignment menu, 109
Alignment options, for caption frame, 372
All Caps effects, 64–65
All Printer’s Marks, 458
Allow Document Pages to Shuffle, 264
alternate glyphs, 436

Alternating controls
for column strokes, 354
for row strokes, 353

Alternating Pattern menu
for fills, 355
for table columns, 354
for table rows, 353

alternative characters, 77
Analogous color harmony rule, 150
anchor points

modifying, 196–197
in paths, 190

anchored objects
Above Line and Inline positions, 253–254
creating/setting Object Options, 252
custom, 255
editing/releasing, 256
setting, for alignment, 111
tips for using, 256

Angle field, 461
angles, measuring, 119
animating objects, 450
Animation panel, 2
animations, timing of, 450
anti-aliasing, of text/graphics, 533
Appearance of Black preferences, 535
Apple CMMCMM (Mac) conversion options, 443
AppleScripts, 389
Application bar

in document setup, 48–49
features of, 2
magnification list in, 42
view controls in, 43

Apply Master dialog box, 279
Apply Style menu, 414
applying colors, 129
applying swatch colors, 134
Arrange Documents menu, 49
arrowhead styles, 170
artboard, 266
artwork

Bridge/Mini Bridge for, 208
converting to frames, 211
placing, 204–207

ASCIIASCII file import options, 271
Assignments panel, 2
attributes

cell, 418
character, 62
object style, 415–416
paragraph, 70, 85, 425
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for pasting text, 538
stroke, 160–164
table, 419

Attributes panel
features of, 2
overprinting colors and, 151

Auto-Collapse Icon Panels, 515
auto justified tiling, 456
auto leading, 66
Auto Leading percentage, 429
Auto Rename, 401
Auto-Show Hidden Panels, 514
Autocorrect feature, 363
Autocorrect preferences, 528
autoflow pages with text, 275
automatic bullets and numbering, 377–379
automatic drop cap styling, 409
automatic hyphenation, 430
automatic leading, 429
automatic OpenType alternate characters, 435
automatic page numbering, 284
automatic resolution of style conflicts, 402
automatic table of contents, 303
automatic tiling, 456
Automatically Adjust to Fit Marks and Bleeds, 475
automation features

adding captions to images, 371–373
bullets and numbering, 377–379
changing case, 360
checking spelling, 360–363
creating tagged text, 383–384
Eyedropper tool on text, 387–388
Find/Change, 364–365
Find Font, 385
footnotes, 380–382
Glyph Find/Change, 369
GREPGREP Find/Change, 368
keeping lines together, 386
Object Find/Change, 370
overview, 359
running scripts, 389
saving searches, 370
Story Editor, 374
text Find/Change, 366–367
tracking text changes, 375–376

B
background color, for notes, 529
Balance Ragged Lines command, 435
Bar arrowhead style, 170
Barbed arrowhead style, 170
baseline grid

aligning text to, 433
creating custom, 434
preferences, 522

setting, 432
in View Options menu, 48

baseline shift controls, 67
basic feather effect, 180
Basic Paragraph style, 392
basic shapes, 89–90
basic text

applying text distortions, 68
Character panel in, 62
Control panel for, 85
creating text frames, 54–56
Glyphs panel in, 77–79
hidden characters, 76
inserting manual indents, 73
moving/deleting text, 60–61
overview, 53
paragraph formatting, 70
selecting text, 58–59
setting alignment/indents, 71–72
setting language, 69
setting line/character spacing, 66–67
setting paragraph effects, 74–75
setting text frame controls, 81–83
setting typeface/point size, 63
spanning/splitting columns, 84
special characters, 86
styling text, 64–65
text flow in, 80
typing text, 57

basing styles, 397
behaviors, applying to buttons, 449
Besier curves, 190
bevel and emboss effect, 179
Binary format, for EPSEPS files, 503
bitmaps, 492–493
Black color

Appearance of Black preferences and, 535
in Color panel, 126
defining new swatches and, 133

black point, in images, 443
black precision eyedropper, 186
blank pages, 259–260
blank printer spreads, 475
bleed area

in document setup, 24
for EPSEPS files, 503
setting, 459

Bleed Guides, 35
Bleed Marks setting, 458
Bleed mode, 43
blend mode effects, 173–175
blinking insertion point, 57
body table cells, 345
book files, electronic. see also pages and books

creating, 294
creating table of contents, 299–303
documents in, 294–295
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files in, 295–296
numbering of, 297–298
page/chapter numbering in, 297–298
updating/replacing, 296

Book Page Numbering Options dialog box, 297
Book panel, 3, 294–298
Booklet Type menu, 475
bookmarks, 449
Bookmarks panel, 3
Bottom positions, in vertical justification, 83
bounding box handles, 96
Bounding Box option, 238, 239
break characters, 276
Break Link to Style, 397, 406
Bridge

adding information to files in, 371
Library icons in, 318
multiple PDF pages and, 215
placing artwork from, 208
previewing snippets in, 322
Suite Color Settings in, 445

Bridge icon, in Application bar, 48
Bring All To Front command, 47
Bring Forward command, 108
Bring to Front command, 108
built-in object styles, 415
Bullet Character glyph display, 377
bullets

adding/custom formatting, 377
setting position of, 379

Bunting, Fred, 439, 466
Butt Cap setting, 161
button(s)

applying/modifying behaviors, 449–450
creating, 449
Dictionary, 525
properties, 449
setting states, 449

Buttons panel, 3

C
Cap settings, 161
capitalized words, hyphenation and, 431
Caption Setup dialog box, 372
captions

adding to images, 371–373
applying to graphics, 292–293

Cascade command, 47
case controls, for text Find/Change, 366
case sensitivity, 400
categories

Cell Styles, 418
Find/Change, 364
OpenType, 437–438
preferences, 512
preflight profiles, 480–481

Print dialog box, 452
specialized glyph, 436
Table Styles, 419

category controls, 416
Category list, 511
cell fills, 352
Cell Insets, 348
Cell Options controls, 348, 351
cell preview area, 351
cell strokes, 351, 352
cell styles

defining, 418
tables and, 329

Cell Styles panel, 3
Cell Styles pop-up lists, 419
cells, table

customizing, 347–349
deleting content, 339
inserting graphics, 346
inserting tables, 333
inserting text, 334
selecting text, 335

Center alignment option, 162
Center Content command, 219
center point indicator, 244
Center positions, in vertical justification, 83
Change Bars option, 530–531
Changes Allowed menu, 498
chapter numbers

for book files, 298
specifying/adding, 286

character attributes, 388
character formatting, 405
Character icon, 85
Character panel

features of, 3, 62
setting language and, 69
setting line/character spacing, 66–67
setting typeface/point size, 63
styling text and, 64–65
text distortions and, 68

Character Settings preferences, 518
character spacing, 66–67
Character Style Conflicts menu, 402
Character Style menu

choosing character style, 411
formatting drop cap character and, 409

character styles
applying, 404
deleting, 408
with nested styles, 410–411
overriding, 406

Character Styles panel, 4, 396, 400–401
characters

in glyph sets, 78–79
hidden, 76
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inserting/accessing, 77
special text, 86

Check Spelling dialog box, 360
checkerboard grid, 259
Circle arrowhead style, 170
CircleSolid arrowhead style, 170
Clear All, from Tabs panel menu, 327
Clear All Transparency icon, 176
Clear Overrides button, 405
Clear Overrides icon, 417
Clear Overrides Not Defined in the Style icon, 417
clearing overrides, 405
Clip Contents to Cell option, 346
clipboard, 60
Clipboard Handling preferences, 538
clipping paths, 231–232
Close Path command, 195, 202
Cmd/Ctrl+Shift keys

for scaling within frames, 104
for selecting text, 59

CMYKCMYK Color Management Policy, 442
CMYKCMYK color model

Color Picker and, 144
defining/understanding, 126–127
features of, 124

CMYKCMYK working space, 441
Color area, in Guides & Pasteboard, 523
Color Bars setting, 458
Color Conversion menu, 494
Color list

for layer highlights, 308
for paragraph rules, 248

color management
choosing color settings, 440–443
overview, 439
saving/loading color settings, 444–445
working with profiles, 446

Color menu
in Export EPSEPS dialog box, 502
to highlight commands, 511
in Print dialog box, 460

Color panel
features of, 4
tinting swatches with, 142
for working in color, 126–129

Color Picker, 144
color profiles, 494
color ramp, 129
color settings choice, 440–443
color stops, 145–147
color swatches

applying/deleting, 134–135
defining new, 132–133
importing from documents, 137
merging, 135
modifying, 133
moving/duplicating/saving, 136

Swatches panel and, 130–131
unused, 135, 136

Color tab, in Image Import Options, 446
color, working in

basics of, 124–125
Color panel usage, 126–129
creating gradient swatches, 145–147
creating mixed inks, 139–141
creating tints, 142–143
defining/storing swatches. see color swatches
Eyedropper tool for, 148
Kuler panel for, 149–150
overprinting colors, 151
overview, 123
swatch libraries for, 138
using Color Picker, 144

color(s)
applying/transferring, 129
changing Ruler Guide, 38
compression, 491–492
downsampling, 491
for grayscale images, 223
of hidden characters, 76
printing of, 460–461
stroke gap, 163
unnamed, 129, 131, 137

Column Guides, 35–36
Column Strokes control, 354
Column Width control, 341
columns

adding, 339
automatically distributing, 341
changing, 28
changing number of, 337
changing width visually/numerically, 341
creating with guides, 37
inserting in tables, 338
setting, 27
spanning/splitting, 84
text frame, 81–82

Columns settings, in Text Frame Options, 81
columns, table

alternating repeating strokes, 354
deleting, 339
selecting, 335

commands, keyboard shortcuts for, 510
commas, for noncontiguous pages, 264
Community area, 22
Compatibility menu, 488
Complimentary color harmony rule, 150
Compose Using menu, 526
Composition preferences, 519–520
Compound color harmony rule, 150
compound paths

creating, 157
releasing, 182

compound shapes, 209
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compression controls, 491, 492
Compression menu, 492, 493
computer clipboard, 60
conditional text

creating/modifying, 288
sets, 291
setting indicator/applying, 289
showing/hiding, 290

Conditional Text panel, 4
Conflict With Existing Style menu, 401
container object, 116
content grabber, 216
content object, 116
content offset, 221
Context menu, 510
contextual menus

applying Next Style, 395
in document rulers, 31
features of, 20

contiguous pages, 264
Contour Options Type menu, 240
control buttons

Find/Change, 365
Glyph Find/Change, 369

control handles
moving, 194
in paths, 190
retracting/extending, 193

Control panel
features of, 4, 357–358
options for objects, 117
Page tool in, 33
for paragraph/character settings, 85
paragraph formatting and, 70
styling text and, 62

Conversion Options, 443
Convert Direction Point tool, 197
Convert Table to Text dialog box, 333
Convert Tables To list, 270
Convert Text to Table dialog box, 330
converting shapes, 90
copies, document, 51
Copies field, 453
Copy command, 94
copying objects

dragging and, 93
scaling/rotating/shearing and, 98

copying text, 60–61
corner curves, 192
corner options, 170–171
corner points, 193
Create Guides dialog box, 37
Create New commands, 22
Create Package Folder, 484
Crop Marks, 458
Crop To Menu, 214
cross-references, 448

Cross-References panel, 4
CS5CS5 files, 503
current document defaults, 187
Currently Assigned To area, 510
Cursor Options, in Story Editor Display, 532
cursor(s)

Drag-and-Drop Text, 61
fixed-page autoflow, 275
image, 204, 205
load text/link text, 80
loaded text, 268
overflow, 343
Padlock, 121
Place, 514
semi-autoflow, 274
Type tool, 54

Curved arrowhead style, 170
curved loaded image cursor, 204
curves, 192, 193
custom alignment character, 327
custom anchored objects, 255
custom bleed controls, 459
custom bullet characters, 378
custom frame grid, 434
custom glyph set, 78
custom PDFPDF presets, 500
custom Quick Apply settings, 421
custom-sized frame, 205
custom-sized pages, 33–34
Custom Spread Flattener Settings, 470
custom stroke styles

dashed stroke, 164, 167
dotted stroke, 168
editing, 168
overview, 165
saving/transferring/deleting, 169
stripe stroke, 166

custom text wrap, 242
custom transparency flattener preset, 468
custom underlines/strikethroughs, 65
custom workspaces, 17
Customize Style Import, 403
customizing

Advanced Type preferences, 518
Appearance of Black preferences, 535
Autocorrect preferences, 528
choosing preferences categories, 512
Clipboard Handling preferences, 538
Composition preferences, 519–520
Dictionary preferences, 524–526
Display Performance preferences, 533–534
File Handling preferences, 536–537
General preferences controls, 512–513
Grids preferences, 522
Guides & Pasteboard preferences, 523
Interface preferences, 514–515
modifying keyboard shortcuts, 508–510
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modifying menu commands, 511
Notes preferences, 529
overview, 507
Spelling preferences, 527
Story Editor Display preferences, 532
Track Changes preferences, 530–531
Trashing preferences, 538
Type Preferences, 516–517
Units & Increments preferences, 520–521

Cut command, 94
cutting text, 60

D
dashed stroke style, 164, 167
Data Format menu, 503
Data Merge panel, 5
Decimal Tab icon, 327
Default Fill and Stroke icon, 187
Default View, 533
default(s)

colors, 134, 137
current document, 187
object styles, 415, 417
setting, 27
setting object, 187
tab stops, 325
text, 62
view settings, 233–234
workspaces, 17

Delete Anchor Point tool, 196, 202
Delete Character Style alert box, 408
Delete Effect icon, 176
Delete InDesign Preference files, 538
Delete Item(s), from Library panel menu, 317
Delete Layer icon, 307
Delete Paragraph Style alert box, 408
Delete Swatch dialog box, 134
Delete Unused Layers, 307, 312
Delete Workspace dialog box, 16
Deleted Text, in Track Changes, 530
deleting text, 60–61
destination insertion point, 61
destinations, hyperlink, 448
Detach All Objects From Master, 281
Detach Selection From Master, 281
device-independent PostScript files, 477
diagonal lines, 88
Diagonal Lines controls, 356
Dictionary dialog box, 362
Dictionary preferences, 524–526
dictionary(ies)

buttons, 525
editing hyphenation in, 432
hyphenation exceptions in, 526
sharing, 524

Direct Selection tool
changing text wrap path, 242
grouping/pasting into objects, 114–116
modifying clipping path, 232
modifying paths, 194–195
modifying points, 197
selecting frames and, 122
selecting objects, 91

direction controls, 356
directional feather effect, 180
disc icon, 402
discretionary hyphen, 431
display, library, 319
display options

for changed text, 530–531
Story Editor, 532

Display Performance context-sensitive menu, 234
Display Performance preferences, 533–534
Display Performance Preferences dialog box, 233
distances, Measure tool for, 118
distortions

letter, 428
object, 100
text, 68

Distribute Columns/Rows Evenly commands, 341
distributing objects, 110–111
docked panels, 515
Document Chapter Numbering, 286
Document Chapter Numbering options, 298
document grids

setting preferences/positioning, 522
working with, 40

document information, 120
Document Numbering Options dialog box, 297
Document Open Password area, 497
document pages

converting to master pages, 278
defined, 259
document setup and, 23
modifying master page elements, 280

document presets, 29–30
Document Recovery Data area, 536
document rulers, 31–32
document sections, 284
document setup

Application bar in, 48–49
basic steps for, 23–24
changing layout options, 28
changing magnification, 41–42
controlling windows, 47
document grids in, 40
document presets in, 29–30
document rulers in, 31–32
file maintenance, 50–52
guides in, 33–34
overview, 21
Page tools in, 33–34
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setting layout options, 25–27
Smart Guides in, 39
view/pasteboard controls in, 43–44
viewing Transformation Values, 39
Welcome Screen, 22
Zoom/Hand tools in, 45–46

Document Setup dialog box, 28
document trim, 24
document(s)

adding library items to, 318
changing appearance of new, 515
in creating books, 294–295
importing swatches from, 137, 138
loading styles into, 400–401
multipage, 258
numbering of, 297
opening saved, 52
packaging, 484
preflighting, 478
printing, 452
seeing changes in, 376
setting options for exporting, 486–487

dotted stroke style, 168
Download menu, in Graphics category, 466
Download PPD Fonts option, 466
drag and drop text, 516
Draw menu settings, 352
drop caps, 74–75
Drop Caps and Nested Styles dialog box, 413
Drop Caps dialog box, 409
drop shadow effect, 177
Duplicate command

for moving text, 61
replicating objects and, 94

Duration menu, 411
dynamic spelling checker, 363
Dynamic Spelling options, 527

E
Edit Document Preset dialog box, 30
Edit Glyph Set dialog box, 79
editing stroke styles, 168
Edit>Undo command, 365
effect settings, for text, 245
Effects panel

features of, 5
opacity/blend mode effects, 172–175
working with effects in, 176

effects, styling. see also styling techniques
adding arrowheads, 170
bevel and emboss/satin, 179
corner options, 170–171
feather, 180–181
glow, 178
opacity/blend mode, 172–175
overview, 153

setting Global Light, 181
shadow, 177
for viewing images, 235
working with, 176

effects, text
inline/anchored objects, 251–256
overview, 237
paragraph rules, 247–250
for text on paths, 244–246
wrapping text. see text wrap

electronic book files. see also pages and books
creating, 294
creating table of contents, 299–303
documents in, 294–295
files in, 295–296
numbering of, 297–298
page/chapter numbering in, 297–298
updating/replacing, 296

electronic styles
applying, 64–65
myths/realities, 69

elements, predictable, 410
Ellipse tool, 54, 56
elliptical graphic frames, 89
em space, 86
Embed Fonts menu, 502
Embed icon, 228
Embed profile icon, 482
emboss effect, 179
en space, 86
Enable Floating Document Window Docking, 515
Enable Layout Adjustment, 33, 283
Enable Multi-Touch Gestures, 514
Encoding menu, 383
End Nested Style Here character, 412
Engine menu (Win/Mac), 443
Entire Pasteboard command, 41
entire table

deleting, 339
selecting, 336

Entry Style menu, 301
EPSEPS files, 501–503
Erase Tool, 201, 202
errors

for preflight profiles, 480–481
spelling, 361

Errors list, in Preflight panel, 478
Export dialog box, 322
Export EPS dialog box, 501–503
Export JPEG dialog box, 504
Export Options dialog box, 383
Export PDFPDF categories list, 488
exporting

creating EPSEPS files, 501–503
creating PDFPDF files, 488
as InCopy file, 505
overview, 485
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setting Advanced PDF options, 496
setting export file options, 486–487
setting JPEGJPEG options, 504
setting Output PDFPDF options, 494–495
setting PDF compression options, 491–493
setting PDF General controls, 488–490
setting security PDF options, 497–498
text, 506
using IDMLIDML files, 503
working with PDFPDF presets, 499–500

Eyedropper tool
for sampling colors, 148
on text, 387–388
usage of, 185–186

F
facing pages, 25–26
false italic, 68
feather effects, 180–181
Fewer Options button, 24
figure space, 86
file formats

for artwork, 205
for export options, 486–487

File Handling preferences, 536–537
File Info dialog box, 371
file(s)

book. see book files, electronic
maintenance, 50–52
opening within InDesign, 52
text. see text file(s)

fill and stroke defaults, 187
Fill Frame Proportionally command, 218–219
fills. see also styling techniques

applying to frames, 223
applying to objects, 154
applying to text, 155
gradient, 155–156
of None, 157
overview, 153
swapping stroke settings, 158

Fills control, 355
Find/Change control panel, 364–365
Find Font dialog box, 385
Find Format Setting, 367
Find options, 527
Find What list, 366–367
First Baseline controls, 349
first baseline, of footnotes, 382
First Line Left Indent field, 72
Fit Content Proportionally command, 218–219
Fit Content to Frame command, 219
Fit Frame to Content command, 218–219
Fit Guides to Margin/Page commands, 37
Fit Page in Window command, 41–42
Fit Spread in Window command, 41–42

Fitting controls list, 220
Fixed Column Width option, 82
fixed-page autoflow cursors, 275
flattener preset

applying to individual spreads, 470
creating, 468
previewing settings, 471
setting, 467
working with, 469

Flattener Preview panel, 5, 471
flattening rules, 470
Flip menu, 460
flipping objects, with transform commands, 106
flowing text

automatically, 275
manually, 273
master text frames and, 272
with semi-autoflow command, 274

flush space, 86
fly-out panels, 18
Font Downloading and Embedding area, 513
font information, 466
fonts

choosing, 63
embedding in EPSEPS files, 502
making global changes to, 385
previewing sizes, 516
subsetting, 495, 513

footers, 344
footnotes, 380–382
Forced Line Break, 57
Format menu, 504
Formatting controls, 381
formatting, local, 404–406, 417
formatting options

for Excel cells, 332
for text Find/Change, 367

Formatting Table list, 271
Frame Edges, in View Options, 48
Frame Fitting Options dialog box, 220
frames

as compound shapes, 209
converting clipping paths into, 232
converting text to, 210
filling with placeholder text, 276
fitting graphics in, 218–221
graphic. see graphic frames
placing artwork in, 204–207
star, 55
star graphic, 90
types of, 88
working with images inside, 216–217

frames, text
adjusting tables within, 343
for captions, 293
choosing default for, 417
creating, 54–56
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creating tables in, 329
custom grids for, 434
features of, 88
importing/creating master, 272
selecting, 122
setting general controls, 81–83
text flow and, 80

frames, unassigned
creating text frames and, 55, 56
features of, 88
selecting, 122

Fraser, Bruce, 439, 466
Free Transform tool, 101
Frequency field, 461
fx icon, 176

G
Gap Color list, 248
gap color, stroke, 163
Gap Tint control, 248
Gap tool, 113
General category

of Export PDF dialog box, 488–490
of Preferences dialog box, 512–513

General print options, 453–454
getting started

contextual menus and, 20
overview, 1
panel choice. see panels
Tool Hints panel and, 19
Tools panel and, 18
working with panels, 14–15
workspaces and, 16–17

Getting Started with Transparency Using 
Adobe Creative Suite Software, 471

global changes, to fonts, 385
global defaults, 187
Global Light, 181
glow effects, 178
Glyph Find/Change search, 369
glyph(s)

choosing alternate, 436
scaling, 428

Glyphs panel
features of, 5, 77–79
viewing categories in, 436

Go to Row dialog box, 334
Grabber tool, 46
gradient feather effect, 181
gradient fills, 155–156
Gradient panel, 5, 147
gradient strokes, 159
gradient swatches, 145–147
graphic file format list, 205
graphic frames

choosing default for, 417

features of, 88
selecting, 122

graphics, imported
anti-aliasing in, 533
applying captions to, 292–293
Bridge/Mini Bridge in, 208
clipping paths for, 231–232
embedding, 228
fitting in frames, 218–221
importing as inline objects, 251
importing transparent images, 230
inserting into table cells, 346
linking, 224–227
nesting graphic elements, 222
overview, 203
placing artwork, 204–207
setting Image Import Options, 212–215
setting layer visibility, 229
specialty frames, 209–211
styling placed images, 223
viewing, 233–236
working with, 216–217

Graphics options, 466
Gray Out view setting, 235
grayscale compression, 492
grayscale downsampling, 491
grayscale images

colorizing, 223
Ink Limit view and, 463

greeking text, 534
GREPGREP Find/Change search, 368
GREPGREP styles, 414
grid of frames, 207
gridify feature, 95
grids, document, 40
Grids in Back option, 522
Grids Preference dialog box, 40
Grids preferences, 522
Group Selection tools, 97
grouping objects, 114
Guide Options, in Guides & Pasteboard, 523
Guides & Pasteboard preferences, 35, 523
Guides in Back command, 35
Guides, in View Options, 48
guides, working with, 35–38
gutters

changing, 28
in Columns settings, 81
setting, 27

H
hair space, 86
Hand tool

in document setup, 45–46
for scrolling, 534

hanging bullet, 72
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headers, 344
Headers and Footers area, 344
hidden characters (invisibles), 48, 76, 324
hidden layers, 309–310
hidden objects, 314
hidden panels, 515
Hide Master Items, 281
High Resolution view setting, 235
Highlight options, 519
Highlights menu, 471
highlights, underlines as, 65
horizontal alignment icons, 110
horizontal distribute icons, 110
horizontal rulers

in document setup, 31, 37
units of measurement for, 521

horizontal scaling, 68
hyperlinks, 448
Hyperlinks panel, 6
hyphenation

controlling application of, 430
designating contiguous pages, 264
editing in dictionary, 432
No Break command/discretionary hyphen, 431
in paragraphs, 75
setting exceptions, 526

I
IDMLIDML (InDesign Markup) files, 503
Ignore Text Wrap checkbox, 243
Illustrator

best file format from, 212
transparent images and, 230

Image Import Options
choosing clipping paths, 231
Layer Comp list, 229
setting for PSD/EPSEPS images, 213
setting for TIFF/JPEG images, 212
setting options for PDFPDF files, 214–215
specific profiles and, 446

Image Quality menu
for color/grayscale bitmap images, 492
in Export JPEG dialog box, 504

images. see graphics, imported
import options

for ASCII text files, 271
for Microsoft Excel files, 270–271
for Microsoft Word files, 269–270
tagged text, 384

imported graphics
anti-aliasing in, 533
applying captions to, 292–293
Bridge/Mini Bridge in, 208
clipping paths for, 231–232
embedding, 228
fitting in frames, 218–221

importing as inline objects, 251
importing transparent images, 230
inserting into table cells, 346
linking, 224–227
nesting graphic elements, 222
overview, 203
placing artwork, 204–207
setting Image Import Options, 212–215
setting layer visibility, 229
specialty frames, 209–211
styling placed images, 223
viewing, 233–236
working with, 216–217

importing swatches, 137, 138
imposing pages in position, 474–476
In-RIPRIP Separations, 460–461
Include Deleted Text When Spell-

checking command, 531
Include Paragraph Styles list, 300
Include settings, 490
InCopy files, 505
Indent to Here character, 73
indents, 72
InDesign CS4CS4, 503
InDesign Markup (IDMLIDML) files, 503
Index panel, 6
indicators

for conditional text, 289–290
for custom anchored objects, 255

Info area/panel
for document/text/object information, 120
features of, 6
of Find Font dialog box, 385
in Preflight panel, 478

Ink Alias menu, 465
Ink Limit controls, 463
Ink Manager, 464–465
ink percentages, in Separations Preview panel, 463
Inline Background Color, 529
inline graphics, 346
Inline Input For Non-Latin Text, 518
inline objects, 251
inner glow effect, 178
inner shadow effect, 177
Insert Anchored Object dialog box, 252
Insert Column(s) dialog box, 338
Insert Order list, 78
Insert Pages dialog box, 260
Insert Row(s) dialog box, 338
Insert Table dialog box, 330
insertion point

inserting manual indents and, 73
moving text and, 60–61
typing text and, 57

inset spacing, 82
Inside alignment option, 162
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Intent menu
choosing final color display, 443
setting layout options and, 25

interactive and multimedia
adding movies, 449
adding sounds, 449
animating objects, 450
applying/modifying button behaviors, 449–450
applying zoom settings, 448
button properties, 449
creating buttons, 449
creating cross-references, 448
creating page transitions, 450
defining hyperlinks, 448
editing/working with hyperlinks, 448
exporting interactive PDFPDF/SWFSWF files, 450
formatting hyperlinks, 448
multistate objects, 450
overview, 447
setting button states, 449
setting up Interactive workspace, 448
timing animations, 450
types of interactive elements, 448
working with bookmarks, 449
working with preview controls, 450

interactive color wheel, 150
interactive elements

PDF export and, 490
types of, 448

interactive PDF/SWFSWF files, 450
Interactive workspace, 448
Interface preferences, 514–515
International Color Consortium, 494
invert text wrap, 238
invisible objects, 242
invisibles (hidden characters), 76, 324
island spreads, 267
ISO (International Organization for Stan-

dardization) standards, 489
Isolate Blending command, 175
Item Information dialog box, 319

J
JavaScript, 389
JDFJDF (Job Definition Format) file, 496
Join settings, 161
JPEG options, 504
Jump Object option, 238, 239
Jump to Next Column option, 238, 239
justification

automatic leading/single word justification, 429
glyph scaling for, 428
letter spacing for, 427
understanding, 426
vertical, 349
word spacing for, 426

justified vertical alignment, 83
Justify positions, in vertical justification, 83
Justify Text Next to an Object option, 520

K
Keep Lines Together controls, 386
keep options, 342
Keep Options dialog box, 386
Keep with Next Row option, 342
kerning controls, 66
Keyboard Increments area, 521
keyboard shortcuts

accessing Hand tool, 46
creating, 509
for dragging text, 61
for drawing frames, 56
for magnification, 42
modifying, 508–510
for moving insertion point, 57
quick guide, 59
for running scripts, 389
for selecting text, 59
for styles, 398
tool, 18

knockout group, 174
Kuler panel, 6, 149–150

L
LABLAB color model

Color Picker and, 144
features of, 124
mixing colors in, 128

Landscape orientation, 26
Language menu, 69
layer comps

in Photoshop, 213
setting layer visibility, 229

Layer Options dialog box, 308–310
layer visibility, 229
layers

contents of, 313–314
creating, 306–307
deleting, 307
overview, 305
setting options, 308–310
working with, 311–312

Layers panel. see also layers, 7, 306–307
layout adjustment, 283
Layout controls, 381
Layout menu, 262
layout options, document

changing, 28
setting, 25–27

Leader field, 328
leading controls, 66
letter commands, with Quick Apply, 422
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letter spacing, 427
libraries

applying library items to page, 318
displaying/sorting entries, 321
overview, 315
searching, 320
setting display, 319
snippets vs., 321
storing items, 316–317
strategies for using, 317

Library panel, 316
Ligatures effects, 64–65
limits of security, 498
Line Spacing menu, 532
Line tool, 90
linear gradients, 145, 147
line(s)

breaks, 435
drawing, 191
in a paragraph, 413
spacing, 66–67

Link icon, 104
link indicators, 80
Link Info items, 227
link text cursor, 80
linked file icon, 505
linked graphics, 226, 227
Links options, 537
Links panel

embedding graphics and, 228
features of, 7
Layer Overrides in, 229
placed images and, 224–227

list, of keyboard shortcuts, 509
List View, 319
live captions, 293, 373
Live Corner Option controls, 171
Load Styles, 400–401
loaded image cursor, 204, 206
loaded text cursor, 268, 272, 274
local formatting

applying, 404
clearing, 405, 417
overriding, 406

local overrides
defined, 259
of master page elements, 280

Lock Position command, 121
locking objects

on layers, 314
with Lock Position command, 121
selecting, 513

M
Macintosh

magnification shortcuts, 42

non-Latin input controls for, 518
notebooks, Quick Apply on, 421
panel controls, 14
saving/naming files in, 50
Zoom/Hand tools shortcuts in, 46

magnification
with Application bar, 48
keyboard shortcuts, 42
list, 42
with View commands, 41
with Zoom/Hand tools, 45–46

Make Same Size icon, 24, 26
manual indents, 73
manual method, for flow text, 273
Manual Page Breaks list, 269
manual tiling, 457
Margin Guides, 35–36
margin(s)

changing, 28
importing text within, 272
indents, 72
setting booklet, 475
setting for facing/nonfacing pages, 25–27

Margins and Columns dialog box
changing gutter space in, 36
changing layout options and, 28

Marking choices, 530
Marks and Bleeds category, 493
Marks settings, 458
marquee(s)

selecting multiple points with, 194
selecting objects with, 91
zoom, 45

master frames, 272
master page(s)

adding objects/importing, 277
applying new/base on existing, 279
creating new, 278
defined, 259
detaching/hiding items, 281
overlay, 265
overriding master elements, 280
setting text wrap for, 243
uses for, 277

Master Text Frame option, 272
match criteria, 320
maximum pages, in InDesign documents, 263
Measure tool, 118–119
measuring lines, 119
Media panel, 7
menu commands

modifying, 511
for selecting objects, 91
for selecting text, 59

Menu Customization dialog box, 511
menu icons, 15
menus
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Alignment, 109
Character panel, 62
contextual, 20, 31
font/style, 63
Intent, 25
Language, 69
Page Size, 26
Paragraph panel, 70, 74–75
Swatches panel, 130, 132, 133, 134, 135
Vertical Justification Align menu, 83
workspace, 17

Merge Cells command, 347
Merge Layers command, 312
merging swatches, 135
Messages area, 476
metacharacters, 367
metadata, 292–293
Metadata Caption, 372
Microsoft Excel cells, 332
Microsoft Excel files, 270–271
Microsoft Excel Import Options dialog box, 331
Microsoft ICMICM (Win) conversion options, 443
Microsoft Word

importing files, 269–270
importing footnotes, 382

Microsoft Word Import Options dialog box
importing styles and, 402–403
importing tables and, 331
setting formatting for Word tables, 333

Mini Bridge
placing artwork from, 208
previewing snippets in, 322

Mini Bridge panel, 7
minimized panels, 14
Minimum Vertical Offset field, 44
missing fonts, 385
Missing icon

in Book panel, 296
in Dictionary list, 525

missing links, 224–225
Miter Limit field, 161
mixed ink swatches

creating Mixed Ink Group, 140
creating single, 139
modifying, 141
uses of, 139

Mixed inks, 125
modified color swatches, 133
modified links, 224, 226
Monochromatic color harmony rule, 150
monochrome bitmap downsampling, 492
monochrome bitmap resolution, 493
monochrome image compression, 493
mouse

advantages of, 59
creating polygon frame, 90
for moving text, 61

for selecting text, 58
Move command, 93
Move Pages dialog box, 264
Moved Text, in Track Changes, 530
movies, 449
moving objects

content/container only, 116
methods of, 92–93
with Transform panel, 103

moving swatches, 136
moving text, 60–61
multimedia. see interactive and multimedia
multiple character styles, 410–411
multiple images, 206–207
multiple nested styles, 412
multiple pages, 215
multiple paragraphs, 395
multiple presets, 473
multiple table cells, 335
multiple windows, 47
multistate objects, 450
Murphy, Chris, 439, 466
myths, 69

N
names, in style groups, 399
navigation controls, 262
Navigation icon, 376
navigation of pages, 261–264
nested styles

applying Nested Styles command, 411
line styles, 413
multiple nested styles, 412
preparing to use, 410

Nested Styles dialog box
paragraph effects and, 75
from Paragraph panel menu, 409

nesting graphic elements, 222
nesting groups, 114
nesting panels, 15
New Cell Style dialog box, 418
New Character Style dialog box, 396
New Color Swatch dialog box, 132
New Condition dialog box, 288
New Document dialog box, 23, 29
New Glyph Set dialog box, 78
New Gradient Swatch dialog box, 145
New Layer icon, 306–307
New Master dialog box, 278
New Nested Style button, 411
New Object Style dialog box, 416
New Paragraph Style dialog box, 393
New Section dialog box, 284
New Set dialog box, 509
New Style Group, 399
New Table Style dialog box, 419
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New Tint Swatch dialog box, 143
New Window command, 47
New Workspace dialog box, 16
Next Page Number character, 287
Next Style command, 394–395
Nigels, 430
No Break command, 431
No Wrap option, 238, 239
non-Latin input controls, 518
noncontiguous pages, 264
None

arrowhead style, 170
fill, 157
marking choice, 530
object style, 415

nonexisting items, TOCTOC of, 300
nonfacing pages, 25–26
Normal View mode, 43
Notes panel, 8
Notes preferences, 529
Number fields, 37
Number, in Columns setting, 81
Number of Pages field, 25
Number of Recent Items to Display field, 536
numbered list, 72
numbered loaded image cursor, 206
Numbered Paragraphs list, 300
numbering

absolute, 285, 512–513
controls, 380
page, 284–285, 297, 512

numbers
applying/formatting, 378
setting position of, 379

numerical moving, 103
numerical positioning, 221
numerical resizing, 98
numerical rotation, 100
numerical scaling, 99
numerical settings, 54, 56
numerical shearing, 101

O
Object Find/Change search, 370
Object Format Options dialog box, 370
Object Options, 252
Object Shape option, 238, 239
Object States panel, 8
object styles, 415–417
Object Styles panel, 8
Object Type list, 319
objects

adding to master pages, 277
aligning/centering to, 39
animating, 450
applying corner options, 170–171

applying fills to, 154
applying opacity/blend mode, 172–175
applying to layers, 311
changing shape of, 183
copying, 93, 98
distorting, 100
inline, 251
invisible, 242
moving, 92–93, 103, 116
multistate, 450
replicating, 94–95
resizing, 96
rotating, 99, 105–106
scaling, 96, 98, 104
shearing, 100, 105

objects, anchored
Above Line and Inline positions, 253–254
creating/setting Object Options, 252
custom, 255
editing/releasing, 256
setting, for alignment, 111
tips for using, 256

objects, locking
on layers, 314
with Lock Position command, 121
selecting, 513

Objects Move with Page, 33
objects, working with

aligning, 109–111
Arrange commands in, 108
Control panel in, 117
creating basic shapes, 89–90
frame types, 88
Gap tool in, 113
grouping/pasting into, 114–116
Info panel in, 120
locking, 121
Measure tool in, 118–119
moving objects, 92–93
overview, 87
replicating, 94–95
resizing, 96
selecting, 91
selecting frames, 122
Smart Dimensions/Smart Spacing, 112
transform commands in, 106–107
Transform panel in, 102–105
transform tool and, 97–101

offset, of paragraph rules, 249
100% black ink, 535
Only Align First Line to Grid command, 433
opacity effect, 172–175
Open a Recent Items, 22
Open Documents as Tabs, 515
Open Path command, 195, 202
OpenType fonts, 435–436
OPIOPI Image Replacement options, 467
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Opt/Alt-click
creating style groups, 398
defining new color swatch, 132
defining paragraph style, 392
deleting layers, 307
hiding layers, 309
locking layers, 308
overriding local formatting, 405
removing local formatting, 406

Opt/Alt key
adding columns/rows to tables, 339
creating copies of layer items, 314
creating polygon frame, 90
deleting library items, 317
drawing frames with, 56
moving/copying text, 61
moving layer objects, 311

Opt/Alt-Shift-click, 406
Opt/Alt-Tab keys, 334
optical kerning, 66
optical margin alignment, 424
options

Advanced PDF, 496
export, 486–487
security PDF, 497–498
setting preflight, 483
table of contents, 303

Options area
of General controls for printing, 454
in Transparency Flattener Preset 

Options dialog box, 468
Options controls

Autocorrect, 528
in Export PDF dialog box, 489
in Print dialog box, 455

orientation, 26
Origin menu, 520
out-of gamut colors, 128
outer glow effect, 178
Outline, marking choice, 530
output

Advanced options in, 467
choosing setup controls, 455
color separations/Ink Manager, 464–465
creating PostScript files, 477
creating preflight profiles, 479–482
creating print summary, 473
creating printer’s spreads, 474–476
flattener presets/preview, 468–471
overview, 451
packaging documents, 484
preflighting documents, 478
printing documents, 452
Separations Preview for, 462–463
setting bleed area, 459
setting color controls, 460–461
setting Graphics options, 466

setting page marks, 458
setting preflight options, 483
setting print options, 453–454
tiling pages, 456–457
working with print presets, 472–473

output commands, 298
output intent, 25
Outside alignment option, 162
overflow cursor, 343
overhang, 424
overprinting colors, 151
Override All Master Page Items, 280
overset symbol, 57
Overset Text indicator, 374

P
Package command, 484
Padlock cursor, 121
Page Information setting, 458
page links, 448
page marks, 458
Page Number menu, 302
page numbering

automatic/document section, 284
options, 297
preferences, 512
section markers and, 285

Page Position menu, 455
Page Size menu, 26
Page tool

in document setup, 33–34
modifying page size, 265–266

Page Transitions panel, 8
PageMaker files, 52
page(s)

adding to libraries, 317
aligning/centering to, 39
changing size, 33
document, 23
dragging snippets onto, 322
marks/information, 458
moving, 34
preview imposed, 476
setting layout of, 25–27
transitions, 450

pages and books
adding blank pages, 259–260
adjusting layouts, 283
applying captions, 292–293
changing Pages panel, 258
conditional text, 288–290
conditional text sets, 291
creating/separating spreads, 267
creating table of contents, 299–303
creating text breaks, 276
flowing text, 272–276
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importing text, 268–271
making books, 294–298
master pages, 277–281
modifying page sizes, 265–266
navigating/moving pages, 261–264
overview, 257
page numbers/text variables, 284–287
rotating spreads, 282

Pages area, of General controls, 453
pages, document

converting to master pages, 278
defined, 259
document setup and, 23
modifying master page elements, 280

Pages option, 501
Pages panel

applying master pages, 279
changing, 258
duplicating/deleting pages, 263
in Export PDF dialog box, 489
features of, 9
moving to pages with, 261
rearranging/moving pages, 264
using Page tool and, 33–34

Panel Options
for Links panel, 227
for Pages panel, 258

panels. see also specific panels
working with, 14–15
workspaces for, 16–17

Paper color
as background color, 130
opacity effects of, 172

Paper Size and Orientation controls, 455
Paragraph Composer, 425
Paragraph icon, 85
Paragraph panel

features of, 9
formatting with, 70

paragraph rules
applying, 247
controlling width/offset, 249
reversing text with, 250
styling appearance, 248

Paragraph Space controls, 74
Paragraph Style Conflicts menu, 402
paragraph styles

applying, 404
applying to TOCTOC, 299
Basic, 392
defining by example, 394
defining manually, 393
deleting, 408
drop cap styling, 409
setting next, 394–395

Paragraph Styles panel
features of, 9

loading styles and, 400–401
paragraph symbol, 330
paragraph(s)

attributes, 388
effects, 74–75
formatting, 70, 406
formatting bullets in, 377
formatting numbers in, 378
margin indents in, 72
selecting, 58
setting alignment of, 71
setting keep options for, 386
spacing limit, 83

Parameters menu, 320
Paste command, 94
Paste in Place command, 94
Paste Into command, 115
Paste Remembers Layers command, 307
Paste Without Formatting command, 60
pasteboard

document setup and, 23
increasing size of, 44

Pasteboard Options, 523
pasting text, 60–61
Path list, 232
Path Type Options dialog box, 245
Path Type tool, 244
Pathfinder commands, 182

changing object shapes, 183
path modification in, 184

Pathfinder panel, 9
paths. see also points and paths

closing, 191, 192, 195
deleting, 201
elements of, 190
importing vector, 211
modifying, 194–195
smoothing, 200
text on, 244–246

PDFPDF compression options, 491–493
PDFPDF export options, 488
PDFPDF presets, 499–500
PDFPDF/X profile controls, 495
pen points, 190
Pen tool

creating frame shapes, 205
for drawing points/paths. see points and paths
overview, 190
rules, 193
for text wrap path points, 242

pencil icon, 505
Pencil tool

drawing/editing with, 198
setting preferences for, 199

Permissions area, 497
Photoshop

adding information in, 371
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Image Import Options, 213
Paths panel, 231
transparency grid, 230

Place command, 204
Place cursor preview, 514
Place Item(s) command, 318
Place PDF dialog box

Crop To Menu in, 214
Layer controls, 229

placed image(s)
color management control, 446
information, 120

placement options, for footnotes, 382
plain corner points, 191
plus sign (+)

adding point to text wrap indicator, 242
adding text to paths indicator, 244
image position indicator, 221
local formatting indicator, 392, 417
local overrides indicator, 404
multiple PDF pages indicator, 215

point size, 63
points and paths

adding/deleting points, 202
changing curves/corner points, 193
drawing curves, 192
drawing lines, 191
Erase Tool, 201
modifying paths, 194–195
modifying points, 196–197
overview, 189
Pen tool, 190
Pencil tool, 198–199
Smooth tool, 200

Points/Inch field, 521
policies, color management, 442
Polygon tool, 55, 56
polygraph graphic frames, 90
Portrait orientation, 26
Position and Style option, 372
Position controls, 379
Position List, 253
PostScript files, 477
PostScript menu, 501
power zoom, 46
precision eyedropper, 186
preferences

Advanced Type, 518
Appearance of Black, 535
Autocorrect, 528
choosing categories, 512
Clipboard Handling, 538
Composition, 519–520
Dictionary, 524–526
Display Performance, 533–534
File Handling, 536–537
guides, 35

Guides & Pasteboard, 523
hyphenation, 432
justification setting, 427
Notes, 529
Pencil tool, 199
Smooth tool, 200
Spelling, 527
Story Editor Display, 532
Track Changes, 530–531
Trashing, 538
Type Options, 516–517
for viewing images, 233

Preflight Options, 483
Preflight panel

for documents, 478
features of, 10

preflight profiles
categories/errors for, 480–481
creating, 479
exporting/adding/embedding, 482

Presentation mode, 43
Preserve Local Formatting option

alternating repeating strokes, 354
applying to cells, 350

Preset menu
applying PDF presets, 499
in Transparency Flattener, 467

Preset Settings area, 468
Prevent Duplicate User Colors, 531
Prevent Selection of Locked Objects option

deselecting, 513
locking objects with, 121

Preview area, 456–457
preview controls, 450
Preview menu, 502
Preview mode, 43
Preview panel, 10
Preview size controls, 77
Preview Size menu, 536
Preview window, 476
Previous Page Number character, 287
Print Bland Printer Spreads, 475
Print Booklet command, 474
Print dialog box, 452
Print Layers menu, 454
Print Presets dialog box, 472–473
Print Presets menu, 474
printer icon, 464
Printer list, 453
printer’s marks, 458
printer’s spreads, 474–476
Printing Allowed menu, 497
printing to disk, 477
Process colors

benefits of, 133
defining new swatches and, 132
features of, 124
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in gradients, 147
Ink Manager and, 464–465

Product Area menu, 510
Profile Inclusion Policy menu, 494
Profile Mismatches and Missing Profiles options, 442
profiles

color management with, 446
preflight, 479–482

Projecting Cap setting, 161
proxy lines, 351
proxy square

for deleting/selecting layer items, 313
for moving layer objects, 311

Proxy view setting, 235
punctuation characters, 424
punctuation space, 86

Q
QuarkXPress files, 52
quarter space, 86
Query controls list, 370
Quick Apply feature

applying letter commands, 422
applying styles, 420
editing styles/customizing, 421

quick guide, to keyboard shortcuts, 59
Quote menus, 524

R
radial gradients, 145, 147
raster image processing (RIPRIP), 460
raster images, 235
reader’s spreads, 474
Real World Color Management (Fraser, 

Bunting & Murphy), 439, 466
realities, electronic styling, 69
Recent Items area, 22
recovering files, 52
Rectangle tool, 56
rectangular graphic frames, 89
red dot, text overflow and, 340
redefining styles, 407
reference point

object transformation and, 97
setting Transform panel, 102
shearing objects around, 100

Registration color, 131
Registration Marks setting, 458
regular text wrap, 238
Reject Change icon, 376
Relative to menu, 432
Remove Existing Ruler Guides option, 37
Repeat command, 412
Repeat Header/Footer menus, 344
Repeat Tab command, 325
Repeating Element menu, 411

repeating elements, 410–412
repeating nested line styles, 413
repeating nested styles, 412
replicating objects, 94–95
Reset All Warning Dialogs, 513
resizing objects

bounding box handles for, 96
with Gap tool, 113
with Transform panel, 103

Resolution fields
for color/grayscale bitmap images, 491
for monochrome images, 493

Resolve Text Style Conflicts Using menu, 384
reversing text, 250
RGBRGB Color Management Policy, 442
RGBRGB color model

Color Picker and, 144
features of, 124
mixing colors in, 127

RGBRGB working space, 441
Right Indent, 72
right indent tab, 324
RIPRIP (raster image processing), 460
Rotate tool/command, 99
rotating objects

Rotate tool and, 99
with transform commands, 106
with Transform panel, 105

Rotation icon, 282
Round Cap setting, 161
row separator, 330
rows

changing height visually, 340
changing number in tables, 337
creating with guides, 37
distributing/setting keep options, 342
dragging table edge to add, 339
inserting in tables, 338
setting height numerically, 341

Rows and Columns category, 341
Rule Above controls, 382
Ruler Guides, 35–38
Ruler Units Origin menu, 32
rulers, document, 31–32
Rulers, in View Options, 48
rules, paragraph

applying, 247
controlling width/offset, 249
reversing text with, 250
styling appearance, 248

S
Same Style command, 394
Sample Buttons panel, 10
Sampling menu

for color/grayscale downsampling, 491
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for monochrome images, 492
satin effect, 179
Save A Copy command, 51
Save As command, 51–52
Save As dialog box, 50–51
Save Color Settings dialog box, 444
Save command, 51
Save Preset button

for PDF documents, 499
saving print setting, 472

Save Style dialog box, 299
Saving InDesign Files, 536
saving stroke styles, 169
saving swatches, 136
Scale command, 98
Scale for Descenders command, 409
Scale for Descenders option, 75
Scale tool, 98
Scale X and Y fields, 104
scaling objects

resizing or, 96
Scale tool/command for, 98
with Transform panel, 104

scaling preferences, 513
Scissors tool, 195, 202
Screen Mode menu, 49
Screening menu, 461
Script Label panel, 10
Scripts panel

features of, 11
for running scripts, 389

scrolling preferences, 534
search areas, Find/Change, 364
search criteria, for spelling checker, 361
Search Currently Shown Items, 320
Search Entire Library, 320
Search field, 49
Search for Missing Links in This Folder option, 225
Search list, 366
searches, saving, 370
section marker character, 285
section numbering, 512–513
security PDFPDF options, 497–498
segments, pat, 190
Select Rule menu, 150
Select Same-Sized Pages icons, 454
selecting text, 58–59
Selection tool

grouping/pasting into objects, 115–116
for images inside frames, 216–217
moving objects, 92
object transformation, 97
selecting frames, 122
selecting objects, 91
selecting ruler guides, 38

semi-autoflow text, 274
Send Backward command, 108

Send Data menu, 466
Send to Back command, 108
Separations Preview panel

features of, 11
working with, 462–463

separator character, in TOCTOC, 302
serifs, 424
Set menu

for Conditional Text panel, 291
for keyboard preferences, 508

setting the user, Track Changes and, 375
setting up documents. see document setup
Settings menu, 440
Setup category, 455
Setup controls, 474
setup, document

Application bar in, 48–49
basic steps for, 23–24
changing layout options, 28
changing magnification, 41–42
controlling windows, 47
document grids in, 40
document presets in, 29–30
document rulers in, 31–32
file maintenance, 50–52
guides in, 33–34
overview, 21
Page tools in, 33–34
setting layout options, 25–27
Smart Guides in, 39
view/pasteboard controls in, 43–44
viewing Transformation Values, 39
Welcome Screen, 22
Zoom/Hand tools in, 45–46

Shades color harmony rule, 150
shadow effects, 177
shapes, basic, 89–90
Shear tool/command, 100
shearing objects

with Shear tool/command, 100
with Transform panel, 105

Shift key
creating polygon frame, 90
drawing frames with, 56
for moving text, 61
for selecting text, 59

Shift-Return/Enter, for Quick Apply entry, 420
Shift-Tab

changing hidden panel display, 515
inserting right indent tab, 324
moving backwards, 334

shortcuts, keyboard
accessing Hand tool, 46
creating, 509
for dragging text, 61
for drawing frames, 56
for magnification, 42
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modifying, 508–510
for moving insertion point, 57
for running scripts, 389
for selecting text, 59
for styles, 398
Tools panel use and, 18

Show All option, 321
Show area, of Track Changes, 530
Show Document Grid, 40
Show/Hide icon, 462
Show list, 436
Show Master Page Overlay, 33
Show Transformation Values, 514
Show Vertically option, 258
Simple arrowhead style, 170
SimpleWide arrowhead style, 170
single line selection, 58
single word

justification, 429
selecting, 58

sixth space, 86
size

bleed, 503
changing object, 98
changing page, 33, 265
font, 516
frame, 54, 56
measuring text/stroke, 521
overhang, 424
Preview area, 77
preview image, 536
selecting page, 454
setting page, 26
Small Caps/Subscript/Superscript, 64

skewing text, 68
Skip By Leading option, 520
Skip First/Last options, 344
slug area

in document setup, 24
setting, 459

Slug Guides, 35
Slug mode, 43
Small Caps effects, 64–65
Smart Dimensions, 112
Smart Guide Options, 523
Smart Guides, 35, 39, 48
Smart Spacing, 112
Smart Text Flow options, 517
smooth curves, 192
Smooth tool, 200
Snap to Document Grid, 40
Snap to Guides command, 36
Snap to Zone field, 35
Snippet Import setting

controlling location with, 537
dragging snippets and, 322

snippets
creating/using, 322
libraries vs., 321
overview, 315

Sort Items options, 321
sounds, adding, 449
source, hyperlink, 448
spaces

separating tab leader, 328
width of, 86

spacing
around tables, 343
controls, 426
for footnotes, 381
between objects, 111

spanning columns, 84
special characters

to/from characters, 287
forcing text breaks, 276
inserting, 86

specialty frames, 209–211
spelling check

adding/editing words, 362
importing/exporting entries, 363
limitations of, 361
search criteria/correcting errors, 361
usage of, 360

Spelling preferences, 527
spines, book/magazine, 32
Split Cell Horizontally/Vertically commands, 347
splitting columns, 84
Spot colors

benefits of, 133
defining new swatches and, 132
features of, 125
in gradients, 147
Ink Manager and, 464–465

spreads
applying flattener presets to, 470
creating printer’s, 474–476
rotating, 282
setting layout options and, 25
using document rulers and, 32

spreadsheets, 332
Square arrowhead style, 170
SquareSolid arrowhead style, 170
stacking order, 108
Standard menu, 488
star frames, 55
star graphic frames, 90
start page, 25
Start Page field, 24
Start Paragraph menu, 386
Start Row menu, 342
states, button, 449
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static captions
applying, 373
creating, 293

Step and Repeat command, 95
storing tint swatches, 143
Story Editor

displaying tracked changes, 376
setting notes options for, 529
usage of, 374

Story Editor Display preferences, 532
Story panel

features of, 11
for optical margin alignment, 424

straight lines, 90, 191
strategies for character style, 404
Strikethrough

effects, 64–65
marking choice, 530

stripe stroke style, 166
Stroke menu, 521
Stroke panel

features of, 11
working with, 160–164

stroke styles, custom
dashed stroke, 164, 167
dotted stroke, 168
editing, 168
overview, 165
saving/transferring/deleting, 169
stripe stroke, 166

strokes
applying attributes, 160–164
applying effects, 158
applying to frames, 223
applying to text, 159
creating custom styles, 165–169
overview, 153
units of measurement for, 521

style choices list, 403
style conflicts, 401, 402
style groups, 399
Style Mapping dialog box, 403
style menu

choosing character style for lines, 413
for setting typeface, 63

Style options
for footnote references, 380
in Table of Contents dialog box, 302

style overrides
applying, 404
clearing, 405–406

Style Settings
for cell style attributes, 418
controls, 415
for table style attributes, 419

style source file, 295–296
styles

applying stroke, 163
applying styles/overrides, 404
automatic drop cap, 409
basing, 397
Character, 396
clearing overrides, 405–406
creating GREPGREP, 414
creating nested line, 413
creating style groups, 399
defining cell, 418
defining object, 415–416
defining table, 419
duplicating/sorting, 398
guidelines/keyboard shortcuts, 398
importing from Word, 402–403
loading/importing, 400–401
nested, 410–412
overview, 391
paragraph, 392–395
Quick Apply feature for, 420–422
redefining/deleting, 407–408
unused, 407
working with object, 417

styling paragraph rules, 248
styling techniques

adding arrowheads, 170
applying fills, 154–157
applying strokes. see strokes
bevel and emboss/satin effects, 179
corner options, 170–171
creating compound paths, 157
creating custom stroke styles, 165–169
Eyedropper tool, 185–186
feather effects, 180–181
glow effects, 178
opacity/blend mode effects, 172–175
overview, 153
Pathfinder commands for, 182–184
placed images and, 223
setting Global Light, 181
setting object defaults, 187
shadow effects, 177
working with effects, 176

styling text, 64–65
Subscript effects, 64–65
Subset dialog box, 320
Suite Color Settings dialog box, 445
Summary area, in Print dialog box, 473
Superscript effects, 64–65
Suppress Text Wrap When Layer Is Hidden option, 310
swatch libraries, 138
Swatch Options dialog box

modifying color swatches, 133
modifying tint swatches, 143

swatches
applying/deleting, 134–135
defining new, 132–133
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importing from documents, 137
merging, 135
mixed ink, 139–141
modifying, 133
moving/duplicating/saving, 136
Swatches panel and, 130–131
unused, 135, 136

Swatches panel
adding colors to, 129
adding/dragging colors to, 131
features of, 11
storing tint swatches, 143
working with, 130

Synchronize Options dialog box, 296
synchronized color settings, 444–445

T
tab alignment icons, 325
tab characters

inserting, 324
inserting into tables, 334

tab leaders, 328
tab stops

changing, 326
removing, 327
setting, 325

Table Border controls, 350
table borders

adding, 350
setting stacking order, 352

table cells
copy and paste content, 340
customizing, 347–349
deleting content, 339
inserting graphics, 346
inserting tables, 333
inserting text, 334
selecting text, 335

table columns
alternating repeating strokes, 354
deleting, 339
selecting, 335

Table control triangle, 374
Table Dimensions area

header and footer rows in, 344
rows and columns in, 337

table fills, 355
table headers/footers, 345
Table menu, 332
Table of Contents dialog box

advanced options in, 301
formatting TOCTOC listings, 299

table of contents (TOCTOC)
creating, 299–303
of nonexisting items, 300
other uses for, 302

Table Options for Row Strokes, 353
Table panel, 12, 357–358
table rows

alternating repeating strokes for, 353
deleting, 339
selecting, 336

table selection commands, 336
Table Setup dialog box

for applying borders, 350
table appearance and, 337

Table Spacing controls, 343
Table Styles

defining, 418
panel, 12

tables
adding diagonal lines in cells, 356
adding images, 346
adjusting within text frame, 343
alternating strokes/fills, 353–355
cell styles and, 329
converting text into, 330
converting to text, 333
creating in text frame, 329
customizing cells, 347–349
importing/pasting text into, 331
navigating through, 334
overview, 323
rows and columns in, 337–342
selecting, 335–336
setting borders/strokes/fills, 350–352
setting formatting for tables, 332–333
tabs vs., 328
working with headers and footers, 344–345
working with Table/Control panels, 357–358

tabs
creating leaders, 328
inserting characters, 324
overview, 323
setting stops, 325–327
tables vs., 328

Tabs panel
features of, 12
menu commands, 325

tagged text, 383–384
Tags panel, 12
targeted pages, 261
template format, 50
temporary folder, 536
text

anti-aliasing in, 533
applying character style to, 414
applying fills to, 155
applying Nested Line Style command to, 413
applying Nested Styles command to, 411
changing case, 360
conditional, 288–291
converting into tables, 330
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converting tables to, 333
converting to frames, 210
drag and drop, 516–517
dragging, 61
exporting, 506
Eyedropper tool on, 387–388
flowing, 272–275
inserting footnotes, 380
inserting into table cells, 334
inserting tabs in, 324
pasting into tables, 331
setting cell options for, 348
setting defaults, 62
tagged, 383–384
typography in. see typography

Text as Black command, 460
text attributes, 388
text basics

applying text distortions, 68
Character panel in, 62
Control panel for, 85
creating text frames, 54–56
Glyphs panel in, 77–79
hidden characters, 76
inserting manual indents, 73
moving/deleting text, 60–61
overview, 53
paragraph formatting, 70
selecting text, 58–59
setting alignment/indents, 71–72
setting language, 69
setting line/character spacing, 66–67
setting paragraph effects, 74–75
setting text frame controls, 81–83
setting typeface/point size, 63
spanning/splitting columns, 84
special characters, 86
styling text, 64–65
text flow in, 80
typing text, 57

text effects
inline/anchored objects, 251–256
overview, 237
paragraph rules, 247–250
for text on paths, 244–246
wrapping text. see text wrap

text file(s)
importing, 268–271
of keyboard shortcuts, 509
links for, 226

text Find/Change
metacharacters/formatting options, 367
setting text strings, 366

text flow, 80
Text Frame Options dialog box

Baseline Grid settings in, 434
Ignore Text Wrap checkbox, 243

setting text frame controls, 81
text frames

adjusting tables within, 343
for captions, 293
choosing default for, 417
creating, 54–56
creating tables in, 329
custom grids for, 434
features of, 88
importing/creating master, 272
selecting, 122
setting general controls, 81–83
text flow and, 80

Text Import Options dialog box, 271
text information, 120
Text Size menu, 521
text threads, 80
text variables

chapter numbers, 286
to/from characters, 287

text wrap
applying, 238
contour options, 240
controlling for hidden layers, 310
custom text wrap, 242
ignoring, 243
of master page item, 280
options, 239, 520
Wrap To option, 241

Text Wrap panel, 12
Theme menu, 532
thickness, stroke, 160
thin space, 86
third space, 86
threshold, for font subsetting, 513
thumbnail preview, Place cursor, 514
Thumbnail View, 319
Thumbnails menu, 455
Tile command, 47
Tile menu, 456
tile options, 49
tiling pages, 456–457
Timing panel, 13
Tint control, 248
tint swatches, 142–143
Tints, 125
title bar, Tools panel, 18
Title field, 300
To Path menu, 246
To Text field, 414
TOCTOC. see table of contents (TOCTOC)
Toggle Lock space, 308
Toggle Visibility space, 309
Tool Hints panel, 13, 19
tool tips

controlling display of, 514
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note, 529
Tools panel use and, 18

Tools panel
changing display, 515
Ellipse tool in, 54, 89
Eyedropper tool in, 148
features of, 18
Free Transform tool in, 101
Gap tool in, 113
Hand tool in, 46
Measure tool in, 118
Page tool in, 33–34
Polygon tool in, 55, 90
Rectangle tool in, 56, 89
Rotate tool in, 99
Scale tool in, 98
Selection tools in, 91, 92
Shear tool in, 100
Type tool in, 54
Zoom tool in, 45–46

Top positions, in vertical justification, 83
Track Changes commands, 376
Track Changes panel, 375–376
Track Changes preferences, 530–531
tracking controls, 67
trackpad, 514
transferring colors, 129
transferring stroke styles, 169
Transform Again command, 107
Transform Again Individually command, 107
transform commands, 106–107
Transform menu, 93
Transform panel

features of, 13
for positioning/transforming objects, 102–105

transform tools, 97–101
Transformation Values

changing preview, 514
creating frames and, 54, 89
viewing, 39

transparency
effects, 235
resources, 471

Transparency Flattener Presets
applying to individual spreads, 470
creating, 468
previewing settings, 471
working with, 469

Transparent Background, 214
transparent images, 230
Trap Presets panel, 13
Trapping menu, 461
Trashing preferences, 538
Triad color harmony rule, 150
Triangle arrowhead style, 170
TriangleWide arrowhead style, 170
trim, document, 24

triple-click, for selecting text, 58
two-column documents, 27
Type list

Object Find/Change and, 370
for paragraph rules, 248

Type Options preferences, 516–517
Type tool, 54–56
typeface, 63
typing text, 57
Typographer’s Quotes, 516
typography

Adobe Paragraph Composer, 425
balancing ragged lines, 435
baseline grid, 432–434
hyphenation control, 430–432
justification controls, 426–429
OpenType categories, 437–438
OpenType fonts, 435–436
optical margin alignment, 424
overview, 423

U
unassigned frames

creating text frames and, 55, 56
features of, 88
selecting, 122

Underline
effects, 64–65
marking choice, 530

Unembed alert box, 228
uneven line breaks, 435
ungrouping objects, 115
Units & Increments preferences

for document rulers, 31–32
setting, 520–521

units of measurement, in document rulers, 31
unnamed colors

avoiding, 129, 131, 137
naming, 137

unnamed gradients, 147
unnested panels, 15
unused styles, 407
unused swatches, 135, 136
Up/Down arrow

changing nest styles order, 412
row height adjustment and, 340

Update Library Item command, 318
Use Document Bleed Settings, 459
Use Incoming Style Definition, 401
Use Spacing option, 111
User dialog box, 505
User Dictionary options, 526

V
variables, text

chapter numbers, 286
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to/from characters, 287
vector graphics, 235
vector program, 211
vertical alignment

icons, 110
of text in cells, 348
of text on paths, 246

vertical distribute icons, 110
vertical justification

positioning text in cells, 349
text frame controls and, 83

vertical rulers
in document setup, 31, 37
units of measurement for, 521

vertical scaling, 68
View commands, 41–42
View menu, 462
view modes

changing, in Application bar, 49
of documents, 43–44

View Options menu, 48
View Threshold, 38
Visibility icon, 511
visibility of layer guides, 310
VisualBasic scripts, 389

W
Warning area, 476
warning dialog boxes, 513
Weight control, 248
Welcome Screen, 22
When Pasting Text and Tables from 

Other Applications area, 538
When Scaling options, 513
white point, 443
white precision eyedropper, 186
white space characters, 86
whole word controls, 366
width

in Columns settings, 81–82
of paragraph rules, 249

window commands, 47
window page menu, 262
Windows

magnification shortcuts, 42
non-Latin input controls for, 518
panel controls, 14
saving/naming files in, 50
Zoom/Hand tools shortcuts, 46

word spacing, 426
workflow

for captions, 292
editorial, 537

working in color
basics of, 124–125
Color panel usage, 126–129

creating gradient swatches, 145–147
creating mixed inks, 139–141
creating tints, 142–143
defining/storing swatches. see color swatches
Eyedropper tool for, 148
Kuler panel for, 149–150
overprinting colors, 151
overview, 123
swatch libraries for, 138
using Color Picker, 144

Working Space RGBRGB/CMYKCMYK menus, 441
working with objects

frame types, 88
Gap tool in, 113
grouping/pasting into, 114–116
Info panel in, 120
locking, 121
Measure tool in, 118–119
moving objects, 92–93
overview, 87
replicating, 94–95
resizing, 96
selecting, 91
selecting frames, 122
Smart Dimensions/Smart Spacing, 112
transform commands in, 106–107
Transform panel in, 102–105
transform tool and, 97–101

workspace(s)
menu, 17, 49
panel arrangement and, 16–17

wrap options, 238, 239
wrap, text

applying, 238
contour options, 240
controlling for hidden layers, 310
custom text wrap, 242
ignoring, 243
of master page item, 280
options, 239, 520
Wrap To option, 241

Wrap To menu, 241

X
X coordinate

in positioning graphics, 221
in positioning graphs, 221

X field
moving objects horizontally, 103
in scaling objects, 98

X Relative To list, 255

Y
Y coordinate

in positioning graphics, 221
in positioning graphs, 221
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Y field
moving objects vertically, 103
in scaling objects, 98

Y Relative To list, 255

Z
zero point

crosshairs, 457
of document rulers, 32
Number fields set to, 37

Zoom In/Out, keyboard shortcuts, 42
Zoom tool

in document setup, 45–46
modifying, 508

zooming, 41, 42



WATCH
READ

CREATE
Meet Creative Edge. 
A new resource of unlimited 

books, videos and tutorials for 

creatives from the world’s 

leading experts.

Creative Edge is your one 

stop for inspiration, answers to 

technical questions and ways to 

stay at the top of your game so 

you can focus on what you do 

best—being creative. 

All for only $24.99 per month 

for access—any day any time 

you need it.

creativeedge.com


	Table of Contents
	Chapter 1 Getting Started
	Choosing Panels
	Working with Panels
	Using Workspaces
	Using the Tools Panel
	Using the Tools Hints Panel
	Using Contextual Menus

	Chapter 2 Document Setup
	The Welcome Screen
	Setting Up Documents
	Setting the Layout Options
	Changing Layout Options
	Using the Document Presets
	Using Document Rulers
	Using the Page Tool
	Working with Guides
	Using Smart Guides
	Viewing Transformation Values
	Working with Document Grids
	Changing the Magnification
	View and Pasteboard Controls
	Using the Zoom and Hand Tools
	Controlling Windows
	Using the Application bar
	File Maintenance

	Chapter 3 Basic Text
	Creating Text Frames
	Typing Text
	Selecting Text
	Moving and Deleting Text
	Using the Character Panel
	Setting the Typeface and Point Size
	Styling Text
	Setting Line and Character Spacing
	Applying Text Distortions
	Setting the Language
	Applying Paragraph Formatting
	Setting Alignment and Indents
	Inserting a Manual Indent
	Setting Paragraph Effects
	Working with Hidden Characters
	Using the Glyphs Panel
	Working with Text Flow
	Setting Text Frame General Controls
	Spanning and Splitting Columns
	Using the Control Panel for Text
	Using Special Text Characters

	Chapter 4 Working With Objects
	Types of Frames
	Creating Basic Shapes
	Selecting Objects
	Moving Objects
	Replicating Objects
	Resizing Objects
	Using the Transform Tools
	Using the Transform Panel
	Using the Transform Commands
	Using the Arrange Commands
	Aligning Objects
	Smart Dimensions; Smart Spacing
	Using the Gap Tool
	Grouping and Pasting Into Objects
	Using the Control Panel for Objects
	Using the Measure Tool
	Using the Info Panel with Objects
	Locking Objects
	Selecting Frames

	Chapter 5 Working in Color
	The Basics of Color
	Using the Color Panel
	Defining and Storing Swatches
	Using Swatch Libraries
	Creating Mixed Inks
	Creating Tints
	Using the Color Picker
	Creating Gradient Swatches
	Using the Eyedropper
	Using the Kuler Panel
	Overprinting Colors

	Chapter 6 Fills, Strokes, and Effects
	Applying Fills
	Applying Stroke Effects
	Creating Custom Stroke Styles
	Adding Arrows
	Corner Options
	Opacity and Blend Mode Effects
	Working with Effects
	Shadow Effects
	Glow Effects
	Bevel and Emboss Effects
	Satin Effect
	Feather Effects
	Setting the Global Light
	Using the Pathfinder Commands
	Using the Eyedropper
	Setting Object Defaults

	Chapter 7 Points and Paths
	Pen Points
	Drawing Lines
	Drawing Curves
	Changing Curves and Corner Points
	Modifying Paths
	Modifying Points
	Using the Pencil Tool
	Using the Smooth Tool
	Using the Erase Tool
	Adding or Deleting Points on Paths

	Chapter 8 Imported Graphics
	Placing Artwork
	Using Bridge and Mini Bridge
	Specialty Frames
	Setting the Image Import Options
	Working with Images Inside Frames
	Fitting Graphics in Frames
	Nesting Graphic Elements
	Styling Placed Images
	Linking Graphics
	Embedding Graphics
	Setting Layer Visibility
	Importing Transparent Images
	Using Clipping Paths
	Viewing Images

	Chapter 9 Text Effects
	Wrapping Text
	Text on a Path
	Working with Paragraph Rules
	Inline and Anchored Objects

	Chapter 10 Pages and Books
	Changing the Pages Panel
	Adding Blank Pages
	Navigating and Moving Pages
	Modifying Page Sizes
	Creating and Separating Spreads
	Importing Text
	Flowing Text
	Creating Text Breaks
	Working with Master Pages
	Rotating Spreads
	Adjusting Layouts
	Page Numbers and Text Variables
	Conditional Text
	Conditional Text Sets
	Applying Captions to Graphics
	Making Books
	Creating a Table of Contents

	Chapter 11 Layers
	Creating and Deleting Layers
	Setting the Layer Options
	Working with Layers
	Layer Contents

	Chapter 12 Libraries and Snippets
	Storing Items in a Library
	Applying Library Items to a Page
	Setting the Library Display
	Searching and Sorting Libraries
	Creating and Using Snippets

	Chapter 13 Tabs and Tables
	Inserting Tab Characters
	Setting Tab Stops
	Creating Tab Leaders
	Creating and Using Tables
	Navigating Through Tables
	Selecting Tables
	Working with Rows and Columns
	Adjusting Tables Within a Text Frame
	Working with Headers and Footers
	Adding Images to Tables
	Customizing Cells
	Setting Borders, Strokes, and Fills
	Alternating Strokes and Fills
	Adding Diagonal Lines in Cells
	Using the Table or Control Panels

	Chapter 14 Automating Your Work
	Changing Case
	Checking Spelling
	Using Find/Change
	Using the Text Find/Change
	Using the GREP Find/Change
	Using the Glyph Find/Change
	Using the Object Find/Change
	Saving Searches
	Adding Captions to Images
	Using the Story Editor
	Tracking Text Changes
	Bullets and Numbering
	Footnotes
	Creating Tagged Text
	Using Find Font
	Keeping Lines Together
	Using the Eyedropper on Text
	Using Scripts

	Chapter 15 Styles
	Working with Paragraph Styles
	Working with Character Styles
	Working with Styles
	Creating Style Groups
	Loading and Importing Styles
	Importing Text Styles from Word
	Applying Styles and Style Overrides
	Clearing Style Overrides
	Redefining and Deleting Styles
	Automatic Drop Cap Styling
	Using Nested Styles
	Creating Nested Line Styles
	Creating GREP Styles
	Defining Object Styles
	Working with Object Styles
	Defining Table and Cell Styles
	Using the Quick Apply Feature

	Chapter 16 Typography
	Optical Margin Alignment
	Using Adobe Paragraph Composer
	Applying Justification Controls
	Controlling Hyphenation
	Baseline Grid
	Balancing Ragged Lines
	Using OpenType
	Open Type Categories

	Chapter 17 Color Management
	Choosing Color Settings
	Saving and Loading Color Settings
	Working with Profiles

	Chapter 18 Interactive and Multimedia
	Setting Up the Interactive Workspace
	Types of Interactive Elements
	Defining Hyperlinks
	Setting the Hyperlink Destinations
	Applying Zoom Settings to Page Links
	Formatting Hyperlinks
	Editing and working with Hyperlinks
	Creating Cross-References
	Working with Bookmarks
	Adding Sounds
	Adding Movies
	Movie Display Options
	Creating Buttons
	General Button Properties
	Setting the Button States
	Applying Behaviors
	Modifying Behaviors
	Multistate Objects
	Animating Objects
	Timing Animations
	Working with the Preview Controls
	Creating Page Transitions
	Exporting Interactive PDF Files
	Exporting Interactive SWF Files

	Chapter 19 Output
	Printing a Document
	Setting the General Print Options
	Choosing the Setup Controls
	Tiling Pages
	Setting Marks and Bleed
	Setting the Output Controls
	Working with Separations Preview
	Color Separations and Ink Manager
	Setting the Graphics Options
	Setting the Advanced Options
	Flattener Presets and Preview
	Working with Print Presets
	Creating a Print Summary
	Creating Printer’s Spreads
	Creating PostScript Files
	Preflighting Documents
	Creating Preflight Profiles
	Setting the Preflight Options
	Packaging a Document

	Chapter 20 Exporting
	Setting the Export File Options
	Creating PDF Files
	Setting the PDF General Controls
	Setting the PDF Compression Options
	Setting the Output PDF Options
	Setting the Advanced PDF Options
	Setting the Security PDF Options
	Working with PDF Presets
	Creating EPS Files
	Using InDesign Markup Files
	Setting the JPEG Options
	Exporting for InCopy
	Exporting Text

	Chapter 21 Customizing
	Modifying Keyboard Shortcuts
	Modifying the Menu Commands
	Choosing the Preferences Categories
	General Preferences Controls
	Interface Preferences
	Type Preferences
	Advanced Type Preferences
	Composition Preferences
	Units & Increments Preferences
	Grids Preferences
	Guides & Pasteboard Preferences
	Dictionary Preferences
	Spelling Preferences
	Autocorrect Preferences
	Notes Preferences
	Track Changes Preferences
	Story Editor Display Preferences
	Display Performance Preferences
	Appearance of Black Preferences
	File Handling Preferences
	Clipboard Handling
	Trashing Preferences

	Index
	A
	B
	C
	D
	E
	F
	G
	H
	I
	J
	K
	L
	M
	N
	O
	P
	Q
	R
	S
	T
	U
	V
	W
	X
	Y
	Z




